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11 Assembly and Single Part 
Drawings 

 

We will introduce the creation of assembly and single-part drawings in Tekla 
Structures. 

We will first create single-part and assembly drawings by using predefined drawing 
wizards (drawing wizards are an automatic way of creating single, assembly and 
multi-drawings). 

We will then edit the drawing properties and create a new drawing wizard. The 
Drawing Wizard will use the edited drawing properties and the select filters that we 
defined in an earlier lesson. Then we will show how the same drawings can be 
created manually. We will also demonstrate how updating effects the drawings. 

Revision control of all drawing types is presented in Lesson 10 Principles of 
working with drawings. 

In this lesson 
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11.1 Integration between Drawings and the Model 

Assembly and single-part drawings 
Single-part drawings are workshop drawings of each of the individual steel parts in 
the model. Assembly drawings are workshop drawings, in which details of an 
assembly consisting of the steel parts are presented for fabrication. 

All of the views in single-part or assembly drawings are current views of the 
members as they are in the model. 

When the model contains any identical members, the drawing is a view of one of 
these members. The drawing, however, contains information about the quantity of 
all of the identical members. If the "host" member of the drawing is modified or 
deleted, it will get a new position mark at the next numbering. Tekla Structures will 
then automatically assign the original drawing to another member with the original 
position mark. 

Tekla Structures integrates the drawings and reports with the model. This means 
that, for example, dimensions and marks in the drawings are always correct. 
Because the information in the drawings and reports comes directly from the model, 
you cannot delete any of the parts or bolts from the drawings. You can, however, 
filter out parts and bolts in the drawings, or make them invisible. 

You can create drawings and reports at any stage of the project. If you change the 
model, Tekla Structures updates the related drawings the next time you perform 
numbering. 

For more information, see Help: Drawing > Introduction to drawings > Basics. 
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11.2 Create Drawings Using Drawing Wizards 
Once you have numbered the model, you can create assembly and single-part 
drawings from the model. Drawing wizards are the most effective way to create 
drawings in Tekla Structures. 

Wizards automatically produce different types of drawings of different parts, such as 
beams, columns, and braces. You can use wizards to create single-part, assembly, or 
multi-drawings using the settings defined in the wizard files. 

You can use the predefined wizard files, edit them, or create your own drawing 
wizards. The Wizard dialog box lists the available wizard files. 

 
For more information on drawing wizards, see: 
Help: Drawing > Getting started with drawings > Creating drawings > Using drawing 
wizards 

Help: Drawing > Getting started with drawings > Drawing reference > File>Wizard… 

 

Drawing wizards cannot be used to create General 
Arrangement (GA) drawings or cast unit (CU) drawings of 
concrete structures. 

 

Functionality of drawing wizards 
For each member type in the model, drawing wizards automatically perform the 
following steps: 

1. Define the drawing type to be created (single, assembly or multi) 

2. Select the predefined drawing properties to be used 

3. With the given select filter, select the parts from which to create drawings 

4. Create drawings 
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When you apply a wizard, you can choose whether the wizard creates drawings from 
all parts of the model, or just from the selected parts. 

 

By creating wizards that match the select filters and drawing 
properties in the project you can automatically create all 
single and assembly drawings of the parts using suitable 
predefined properties. 

 

 

Preconditions of using a drawing wizard: 

• Numbering of the model must be up to date 

• The appropriate wizard file must exist 

• The saved drawing properties listed in the wizard file 
must exist 

• The saved select filters listed in the wizard file must exist 

• Model members which will be selected by the select filter 
must exist 

 

Create single-part drawings of selected parts 
We will now use a drawing wizard to create single-part drawings of selected steel 
beams and plates. 

1. Open the BasicModelCombined model. 

2. Select the BEAM_STEEL filter from the drop-down list of available Select 
filters 

 
3. Select the whole model with an area selection 

4. To see the creation of the drawings, open the drawing list by clicking the Open 
drawing list icon. 

 
5. Select File > Wizard… from the menu or click on the Wizard icon on the Standard 

toolbar to open the Wizard dialog box. 

 
6. Select Single Drawings on the Wizards tab. 

Create single-part 
drawings of steel 
beams 
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7. Click the Create from selected button. 

8. In the drawing list check that single-part drawings with the title BEAM were 
created. 

 
9. Open a few single-part drawings for viewing 

 

 

You can view the next drawing on the list by clicking 
Next or using the shortcut Ctrl + Page Down 
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Following the procedure above, now create single part drawings of all plates. 

1. Select the PLATE select filter. 

2. Select the whole model with an area selection. 

3. Select Single Drawings on the Wizards tab in the wizard dialog box. 

4. Click on the Create from selected button. 

5. In the drawings list check that single-part drawings with the title PLATE were 
created. 

6. Open a few single-part drawings for viewing 

 

 

Create single-part 
drawings from 
plates 
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Using the procedure outlined above, you could create single-part drawings from any 
other selected steel parts in the model (columns, braces, angles, etc.). 

 

It is advisable to create all the single and assembly drawings 
with the wizard, even for a single part. 

Tekla Structures displays a Cancel dialog box during the 
creation of drawings. Click OK in the dialog box to stop 
creating the drawings. 

Create assembly drawings of all steel parts 
Next, we will create assembly drawings of all the steel parts by using another 
drawing wizard. 

To create all assembly drawings at once: 

 

1. Define a select filter to filter away the concrete parts, click OK. 

 
2. Drag an area through the whole model to select all the steel parts 

3. Click on the Wizard icon to open the Wizard dialog box 

 
4. Select Assembly Drawings on the Wizards tab 

Create assembly 
drawings 
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5. Click Create from selected 

 

 

Use the Create from all button to create drawings from the 
whole model at once.  

 

6. In the drawings list check that the assembly drawings were created correctly 
(sort the drawing list by Title). 

 
7. Open a few assembly drawings (which are not named STANDARD) for viewing 
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For parts that don't match with the drawing properties or 
filters listed in the wizard file, the predefined wizards create 
drawings using STANDARD properties. 

 

1. Select drawings with the title STANDARD in the drawing list. 

2. Click the Filter - Select parts button 

 

 
The parts associated with the selected drawings are now highlighted in the model. 
You will find, e.g., that objects that don't have a request in the default wizard are 
highlighted in the model. 

1. Select one vertical brace on gridline A. 

2. Click the Display - All button to ensure that all drawings are shown in the list. 

3. Click the Filter - By parts button. 

 

Select parts with 
drawing title 
STANDARD 

Open brace 
drawing 
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The drawing list shows now only the assembly drawing created from the brace 
selected in the model. The brace drawing was created with bracing properties. 

 

4. Open the drawing 

 

 
 

 

A drawing wizard will not create a duplicate drawing for any 
member already having, e.g., a single-part or assembly 
drawing. 
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11.3 Edit Drawing Properties 
We will now define specific drawing properties for both horizontal and vertical 
bracing and save the properties to be used later in the drawing wizard. 

As an example we will open one vertical brace drawing for editing. Using this 
drawing we will save the properties for the horizontal bracing. We will then edit 
some more properties and save them for the vertical bracing. 

The editing actions we will do are just examples of using the drawing properties. 
The final drawing you get depends on the environment you are using and may not be 
identical to this example. 

Study the Online help for information on each of the separate fields available in the 
drawing properties. 
Help: Drawing > Dimensioning 

Help: Drawing > Drawing Properties 

 

The drawings are created with the applied drawing properties 
(wizard applies the correct predefined properties 
automatically to parts). 

The quality of the automatically created drawings depends on 
the drawing properties used 

Whenever there is a need to edit the drawings, you should 
check if the result can be achieved by editing the drawing 
properties. 

As long as you can manage to create complete drawings by 
using predefined drawing properties the creation / updating of 
drawings will be automatic 

 

 

Properties for horizontal bracing 
 

1. Right-click on the drawing and select Properties… to open the Assembly 
drawing properties 

2. Load the predefined properties no_dimensions 

3. Click Modify 

 

Load properties 
no_dimension 
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The drawing was regenerated with no_dimension properties. It appears now without 
any dimensions and only the main view is visible. 

 

By default, Tekla Structures creates the additional views only if it is 
necessary in order to show the dimensions in the drawing. 

 

For our purposes, we want to have both the front and top views in the brace 
drawings regardless of the dimensions that may be needed. 

 

1. In the Assembly drawing properties dialog box click the View… button. 

2. Choose the option on for the Front and Top views. 

3. Click Modify and then OK 

 

Display both front 
and top views 
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The first dimension we will add is the main part overall dimension. 

1. In the Assembly drawing properties dialog box click Dimensioning… > Part 
dimensions. 

2. Select Once for Main part overall dimensions. 

3. Click Modify and then Apply 

 

Main part overall 
dimension 
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The main part overall dimension appears. 

We will next add the dimension between the extreme bolts. 

1. On the Bolt dimensions tab select Assembly for Extreme bolts. 

2. Click Modify and then Apply 

 

Extreme bolts 
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The distance between the extreme bolts appears. 

We then continue by dimensioning the main part cuts. 

To dimension the cuts in the main part: 

1. On the Part dimensions tab turn Main part shape: to On 

2. Click Modify and then Apply 

 

Main part shape 
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The dimensions of the cuts appear in absolute dimensions. This is due to the 
dimension type defined in the Assembly – Dimension properties tab.  

We will next change the dimension type to relative. 

1. In the Assembly drawing properties dialog box, click Dimension… 

2. Change the Dimension types / In X direction to relative (see fig below). 

Change 
dimension type 
from absolute to 
relative 



 Copyright © 2005 Tekla Corporation TEKLA STRUCTURES BASIC TRAINING  19 
  Assembly and Single Part Drawings  
 

 
3. Click Modify and then OK 

 

 
The dimensions of main part cuts now appear as relative dimensions. 

 

 

By commenting environment variable, 
XS_NO_RELATIVE_SHAPE_DIMENSIONS, out the shape 
dimensions would always be relative despite the option 
chosen in the Dimension properties dialog box. 
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By editing dimension planes table You can define how Tekla Structures 
dimensions different profiles in drawings. For example, you can have 
Tekla Structures always dimension rectangular hollow sections to the 
middle of the profile or to the top. 
See Help: Drawing > Dimensioning > Dimension planes 

 
An example of dimensioning according the prof. type 8 (=rectangular 
hollow sections) is set in dimension plane table by default so that Tekla 
Structures dimension sections to the middle of the profile 

8,        -1.0,   TRUE*, TRUE, TRUE,        TRUE*,   TRUE,   TRUE 

 
To change Tekla Structures to dimension rectangular hollow sections to 
the left / top of  the profile, set the dimensioning of prof. type 8 as shown 
below: 

8,        -1.0,   FALSE, TRUE*, TRUE,        FALSE,   TRUE,   TRUE* 

 
 

 

You can protect areas in drawings to prevent text or dimensions being placed there. 
This way you can e.g. prevent the part mark (1014 in the fig. above) overlapping 
with the part. 

 

In cases where Tekla Structures can not find a free place for 
an object the objects will overlap with each others despite the 
switches in the protection dialog box. 

 

1. In the Assembly drawing properties dialog box click Protection. 

2. Select the checkboxes shown below. These options define that dimension lines 
may not overlap parts. 

Protection 
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3. Click Modify and then Apply 

 

 

We will now save the properties that we have applied so far for horizontal bracing. 
We will then continue to edit the drawing a little and save the properties for vertical 
bracing. 

 

1. Type bracing_H in the Name: field of Assembly drawing properties dialog box 

2. Type bracing_H_TR in the Save as field, click the Save as button 

 

Save as 
properties for 
bracing_H 
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Properties for vertical bracing 
 

For vertical bracing we want to see the secondary part bolt internal dimensions and 
change the part mark frame a little as well as include the single part views of the 
plates. 

We will first add bolt dimensions to the vertical bracing. 

 

1. On the Assembly - Dimensioning properties dialog, on the Bolt dimensions tab, 
select Internal for Secondary part bolt internal dimensions. 

2. Click Modify and then Apply 

 

Secondary part 
bolt internal 
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The bolt distance dimensions of the gusset plates appear. 

 

We will next change the part mark frame to be rectangular. 

 

On the Assembly - part mark properties / General tab: 

1. Change the Frame around mark to rectangular. 

Change the frame 
of part marks 
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2. Click Modify and then Apply 

 

 
The frames of part marks change to rectangular. 

 

 

We will now include single-part views of the individual part components that form 
the assembly. 
 

1. In the Assembly drawing properties dialog box, click Layout > Other. 

2. Set Include single parts to Yes. This activates also the Single part attributes field 
allowing you to choose any predefined single part attributes. 

Include single 
parts to the 
brace_V drawings 
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3. Click Modify and then Apply 

 

 
The single part views for plates appear. 

 

Tekla Structures has several environment variables to customize the single part 
presentation in assembly drawings. For example, you can choose to exclude some 
single-part views from assembly drawings. 

Help: System > Appendix A: Variables > List of variables > S > 
XS_SINGLE_EXCLUDE 

Or you can, for example, set the scale of single-part views included in assembly 
drawings. 

Help: System > Appendix A: Variables > List of variables > S > 
XS_SINGLE_SCALE 
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We will now save the properties for vertical bracing 

1. Type bracing_V in the Name: field of the Assembly drawing properties dialog 
box. 

2. Type bracing_V_TR in the Save as field, click the Save as button 

 

 
 

Save as 
properties for 
bracing_V 
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11.4 Create a New Drawing Wizard 
We will next create a new assembly drawing wizard that matches the part properties 
and select filters defined in lesson 5. We will use the available drawing properties 
added with the bracing_H_TR and bracing_V_TR properties defined in this lesson. 

We start by creating properties for the parts not matching with the wizard requests 

We will then edit existing drawing requests to suit horizontal and vertical braces and 
use the new properties defined for them. We will delete all those requests that are 
not needed and finally edit a request for those parts that don't match our wizard to be 
shown as INCOMPLETE in the drawing list. 

 

1. Load standard drawing properties 

2. Edit the Name: field to INCOMPLETE 

3. Save the properties with the name INCOMPLETE 

 

 
We will now use an existing wizard as the basis for constructing our own wizard. 

To create a new drawing wizard, we will perform the following steps: 

1. Open an existing wizard file. 

2. Save it with another name. 

3. Modify the new file. 

4. Test the functionality of the new wizard 

 

Create properties 
INCOMPLETE 
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The following links present more information on customizing the wizard settings 
and the contents of a wizard file. 
Help: System > Files and folders > Customizing Tekla Structures > Creating wizard 
files  

Help: System > Files and folders > Log files > Wizard log 

To create the new wizard file: 

1. Click the Wizard icon to open the Wizard dialog box. 

 
2. Select Assembly Drawings on the Wizards tab. 

3. Click Edit to open the wizard file in a text editor 

 

 

 
 

1. Select Save as… from the File menu of the text editor to save the wizard file with 
another name. 

2. Browse to the attributes folder under your model folder, enter 
ASSEMBLY_TR.dproc as the file name and click Save. Note that the file 
extension has to be dproc. 

Open existing 
wizard file 

Save wizard file 
with another 
name 
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3. Check that the ASSEMBLY_TR.dproc file was created in the attributes 
subfolder by selecting Open model folder from the Tools menu 

 

The predefined wizard files are located in the folder 
..\countries\*environment*\system. In the system folder, the wizard files 
are available for use in all models. Modified and saved wizard files are 
saved in the same folder, unless you define another destination folder 
(such as the model folder). 

 

1. Save and Reopen the model. 

 

To have the new wizard file shown in the Wizard dialog box, 
you need to close and reopen the model. 

 

2. Open the Wizard dialog box. 

3. Select ASSEMBLY_TR on the Wizards tab and click Edit. 

4. Find the requests for chs bracings and shs bracings. 

 
5. Edit the requests to match the criteria for vertical and horizontal bracing shown 

highlighted in yellow below. 

Edit the wizard file  
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6. Delete all extra requests. Only keep the following: 

• Beams 

• Vertical braces 

• Horizontal braces 

• Rafters 

• Purlins 

• Columns 

Delete the extra 
requests 
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Change the remaining requests to use the select filters that we defined earlier, for 
this project. 

7. Change the select filters defined for steel parts in this project: 

• column_filter to COLUMN_STEEL 

• beam_filter to BEAM_STEEL 

• purlin_filter to PURLIN 

• etc. 

 
 

Change the select 
filters 
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8. Edit the last request to be as shown: 
/* Create rest of assembly drawings */ 
 
set_drawing_type(assembly) 
set_drawing_attributes(INCOMPLETE) 
set_filter(standard) 
create_drawings() 
 
9. Click Save to save the changes and to close the text editor 

 

 

A wizard file is comprised of several sets of drawing 
requests. The order of these requests is important, since Tekla 
Structures creates only one drawing for each selected object. 
The first request that matches the criteria of select filters is 
applied. 

 

Now we want to ensure that the new wizard file functions correctly. 

1. Delete all of the assembly drawings in the drawing list. 

2. Open the Wizard dialog box, select the ASSEMBLY_TR wizard and click 
Create from all. 

 
3. Check the drawing list to see that correct drawing properties were used: 

• The titles of the created assembly drawings 

• INCOMPLETE 

• bracing_V, bracing_H 

Request for the 
rest of the 
assembly 
drawings 

Save the wizard 
file 

Apply own wizard 
file 
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11.5 Edit Drawings Manually 
It is easy to manually add, delete and edit drawing objects (i.e. dimensions, lines, 
text, symbols, graphics and marks) in Tekla Structures drawings. 

 

 

Most drawing objects (both automatically and manually created) are 
associative and automatically update if the model changes. However 
some manually created drawing objects such as lines, polygons, and 
circles are yet not associative. 

 

We will now edit one brace_H drawing manually to include the same editing that we 
defined for the vertical brace_V drawing properties (the bolt distance dimensions the 
rectangular part mark frame, and single part views). 

 

1. Open the first bracing_H drawing in the drawing list 

2. Click on the Create Y dimension icon 

 
3. Pick the center points of bolts to be dimensioned 

4. Move the cursor to where you want the dimension to appear and click on the 
middle mouse button 

 

 
 

 
 

The associative symbols indicates which drawing objects are associated 
to the model and will be updated if the model is changed  

        
Click SHIFT+A in the keyboard to display/hide the associative symbols 

 

Add bolt distance 
dimensions 
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To move the dimension: select it and drag it to the desired position 

 

Add the bolt dimension to the other end in the same way. 

1. Double-click one of the part marks to open the Part mark properties dialog box. 

2. On the General tab, change the Frame around mark to rectangular and tick only 
this check box. 

3. Select all the part marks in the drawing. 

(You can use the Select part mark select switch.) 

 
4. Modify 

 

 
Now all the part marks in the drawing have rectangular frames. 
 

1. Using the CTRL key select each plate part in the drawing. 

2. Right-click and select Create single part views from the popup menu. 

Change the frame 
of part marks 

Include single 
part views 
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3. Close the drawing, click Save and Freeze in the confirmation dialog box 

 

 
 

 

When you close a drawing that has been changed, Tekla Structures 
prompts you to save the drawing. 

Whenever you have manually edited the drawing it is recommended to 
select Save and Freeze. This way you will systematically freeze edited 
drawings and only them. 

 

An F appears in the drawing list to show this drawing is frozen. 

Now this one horizontal brace drawing has roughly the same editing as all the 
vertical brace drawings. The difference is that part of this horizontal brace drawing 
editing was done manually.  

If we wanted the rest of the horizontal brace drawings to have the same editing, we 
could repeat the manual editing to them one by one. However, changing the 
bracing_H_TR drawing properties is a better solution. 

 

 

To get the creation of drawings as automatic as possible, you 
should find good enough predefined drawing properties to 
create the drawings with, instead of editing them manually. 

Whenever there is a need to edit the drawings, you should 
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first check if the result can be achieved by changing the 
drawing properties. 

As long as you can manage to create complete drawings by 
using predefined drawing properties the creation and 
updating off the drawings will be more automatic. 
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11.6 Update Drawings 
We will now modify our model by changing the bolt spacing of all of the gusset 
plate connections. Changes in the model will result in some of the drawings no 
longer be up-to-date. To be able to open the drawings you will need to run 
numbering and update them. 

We will study how updating effects the edited drawings. 

Updating will: 

• Switch the P flag on a frozen drawing to an *. This indicates that the drawing 
has been updated (also manual editing, such as extra marks or dimensions). 

• Regenerate any drawings with a P flag that are unfrozen, with the originally 
used drawing properties. The updating deletes all the manual editing (added 
dimensions, texts etc.). 

• Update the quantities on a drawing with an N flag. 

Change the model 
 

1. Select all the connections in the model. 

2. Find the Tube gusset (20) connection (Ctrl+F), and double-click on it to open it. 

3. Check that Ignore other types is selected in the connection dialog box. 

4. On the Bracebolts1, Bracebolts2 and Bracebolts3 tab pages, edit the vertical bolt 
spacing to 80 as shown below. 

 

 

Change gusset 
plate bolt spacing 
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5. Click Modify 

 

Now the model has changed and some of the drawings are no longer up to date. To 
be able to open the drawings you need to run numbering and update them. 

 

 

It is not possible to open earlier revisions of the drawings. Due to the 
integration between drawings and the model a drawing that is not up-to-
date cannot be opened. 

 

 

Select Tools > Numbering > Modified. 

Once the numbering is carried out, the flags in the Drawing list show all those 
affected drawings that need to be updated. 
Help: Drawing > Getting started with drawings > Drawing status flags 

 

 

 

You can filter up-to-date drawings with Filter > Up to date button. To get 
non up to date drawings listed press Display > Invert button after Filter > 
Up to date. 

 

 

The vertical brace drawings were created with only the predefined drawing 
attributes. They will be complete right after updating, since they are simply 
recreated using their own attributes. 

To update drawings: 

1. Select all the bracing_V drawings from the list. 

2. Click Update. 

3. Open the drawings to see that they are ok 

 

Run numbering 

Update vertical 
brace drawings 
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We will next update all the horizontal brace drawings including the manually edited 
one. 

 

Before updating drawings Make sure that all the drawings having 
manual editing are Frozen. 

Updating will regenerate any drawings with a P flag that are unfrozen, 
the updating deletes all the manual editing (added dimensions, texts 
etc.). 

There is no Undo for the updating the drawings command. 

 

1. Select all the bracing_H drawing from the list except the frozen one.  

2. Click Update. 

 

 

Because a lot of time can be spent editing drawings, it is 
advisable to always freeze manually edited drawings. If 
major modifications in the model create problems with a 
drawing you can always regenerate the drawing with the 
predefined drawing properties. 

To consciously override manual modifications in a drawing 
and regenerate the drawing with predefined drawing 
properties, you can: 

3. Unfreeze the drawing. 

4. Update the drawing  

Or in case the drawing is already up to date: 

1. Unfreeze the drawing. 

2. Modify it first, using other drawing properties (e.g. 
No_dimensions)  

3. Modify it with the original properties (e.g. bracing_H) 

 

Since the drawing is not frozen, the updating regenerates the drawing but deletes all 
the manual editing (in this case the added bolt dimensions and part mark frame 
change).  

 

Update horizontal 
brace drawing 
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To update frozen drawings: 

1. Select the frozen bracing_H drawing from the list. 

2. Click Update. 

3. The P gets replaced by an * 

 

 

 

1. Open the drawing with an *. 

The dimensions should be correct. 

 

2. Save the drawing, and the * flag is removed 

Update frozen 
horizontal brace 
drawing 

Check and save 
the drawing 
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11.7 Create Drawings Manually 
In Tekla Structures, you can create single-part and assembly drawings by loading 
and applying predefined drawing properties for layout, dimensions, marks, etc. for 
selected parts. This process is called the manual creation of drawings, in contrast to 
the drawing creation with wizards. 

The steps for the manual creation of drawings are basically the same as the steps 
automatically dine by the drawing wizard: 

1. Select the model objects. 

2. Load and Apply the predefined drawing properties. 

3. Click Drawing > Assembly drawing to create assembly drawings or Drawing > 
Single-part drawing to create single-part drawingsCreate assembly 

drawings 

As an example, we will create assembly drawings of the columns. 

To manually create assembly drawings of all columns: 

1. Open the drawing list and delete all assembly drawings with the title 
COLUMN. 

2. Select the column_filter on the Select switches toolbar and select the whole 
model. 

3. Select Properties > Assembly drawing… in the menu to open the Assembly 
drawing properties dialog box. 

4. Select column properties in the drop-down box next to the Load button. 

 

Create assembly 
drawings from 
columns 
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5. Click Load and OK. 

6. Select Drawing > Assembly drawing in the menu to create the assembly drawings. 

7. Open the drawing list and check that the correct drawings were created. 

 

You can also use the view filters in the View filter dialog box 
(opened from the View properties dialog box) to help 
selecting members in the model for drawing creation. 

 


