
 

Applied Precast Concrete 
Detailing 

 

Tekla Structures 11.0 
August 30, 2005 

Copyright © 2005 Tekla Corporation 

 Copyright © 2005 Tekla Corporation Applied Precast Concrete Detailing  i 
  TEKLA STRUCTURES BASIC TRAINING  
 



 

 

 Copyright © 2005 Tekla Corporation Applied Precast Concrete Detailing  ii 
  TEKLA STRUCTURES BASIC TRAINING  
 



 

Contents 

8 Concrete Detailing....................................................................................................... 2 

8.1 Connecting Concrete Members Using Connections and Macros...............................................3 
8.2 Creating Stairwell ....................................................................................................................12 
8.3 Using Pre-cast Concrete Custom Components .......................................................................23 

 

 Copyright © 2005 Tekla Corporation Applied Precast Concrete Detailing  i 
  TEKLA STRUCTURES BASIC TRAINING  
 



 Copyright © 2005 Tekla Corporation Applied Precast Concrete Detailing  i 
  TEKLA STRUCTURES BASIC TRAINING  
 



7 Applied Precast Concrete 
Detailing 

This lesson explains how to modify and finalize concrete members in Tekla Structures. You 
will also learn how to use custom components to create concrete members and to connect 
them. 

Concrete detailing can be done manually or by using system connections or custom 
components, which help you to automate the detailing. See more about concrete detailing in 
Tekla Structures Help: Detailing > Reinforcement > Concrete detailing and about 
connections in Help: Detailing > Getting Started > Basics > Connection concepts.

For fully automatic connection creation, you can use the AutoConnection functionality to 
select and apply connections with predefined properties to selected parts. Use 
AutoConnection to have Tekla Structures automatically create similar connections for 
similar framing conditions. See more about AutoConnections in Tekla Structures Help: 
Detailing > Getting Started > AutoConnection > Using AutoConnection. 

 

 

 

 

In this lesson 

Introduction 
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7.1 Connecting Concrete Members Using 
Connections and Macros 

In this exercise we will use system connections to connect the concrete beams and columns 
and to fit the hollow-core slabs to the steel beams. You can create connection macros either 
by using AutoConnections or manually. See more about connections in Tekla Structures 
Help: Detailing > Getting Started > Basics > Connection concepts and about 
AutoConnections in Help: Detailing > Getting Started > AutoConnection > Using 
AutoConnection. 

AutoConnections is the recommended way to create connections. Use AutoConnections to 
automatically select and apply connections with predefined properties to selected parts. 

Create corbels using AutoConnections and AutoDefaults 
With AutoConnection you can define groups of rules which Tekla Structures automatically 
applies when you use AutoConnection to create connections in a model. 

There are six basic cases for AutoConnections: Define conditions 
for 
AutoConnections 

 

For each of these it is possible to define several framing conditions. We will now define two 
different conditions, which check the material and number of secondaries for corbel 
connections. The first condition will use the Corbel connection (14), if only one beam is to 
be connected. For two beams we will use the Two sided seating with dowel (76) 
connection. 

1. Open the AutoConnection setup dialog by selecting AutoConnection… from 
Setup pull down menu. 

2. Right-click on the Beam to column web rule group and select Create 
additional rule sets. Tekla Structures creates a New rule set under the Beam 
to column web rule group. 

3. Open the Beam to column web rule group and right-click on the New rule set 
and select Edit rule set… from the popup list. 

4. Change the Rule set name to describe the use (Concrete Column). 

5. Select Primary material name and Secondary 1 material name from the 
Available rules list and move them to the right by clicking the arrow in the 
middle of the dialog. 
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6. Write K* in the Exact value field for both rules. 

7. Add a new rule Number of secondaries by selecting it from the Available 
rules list and clicking the arrow. 

8. Set the Exact value to 1. 

 

9. Click OK to close the dialog and save the rule settings. 

10. We will next define which connection this rule will use. Open the Concrete 
Column rule set and right-click on the No connection icon to select the Corbel 
connection (14). Now pick Select connection type…, which opens the Select 
component dialog. 

11. In the Select component dialog select Corbel connection (14). Close the 
dialog by clicking OK. 
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12. You have now completed one rule definition. Next, copy the rule set to apply 
also for the Beam to column flange condition by right-clicking on the 
Concrete Column rule set and selecting Copy rule set from the popup menu. 

13. Open the Beam to column flange rule group and right-click on any rule set 
and select Paste rule set from the popup menu. 

 
You have now defined the beam to column connection for concrete members always to be 
Corbel connection (14) if the number of secondaries is 1. 

14. Next, create another rule set for the Two sided seating with dowel (76) 
connection in case there are two beams to be connected to a column. Repeat 
steps 2 – 8. Rule name is: Concrete column (2 sec) 

15. Set the Exact value of "Number of secondaries" to 2. 

16. Add a new rule Secondary 2 material name by selecting it from the Available 
rules list and clicking the arrow. 

17. Write K* to Exact value field. 
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18. Click OK to close the dialog and save the rule settings. 

19. Move the rule set above the Concrete column rule set using right button 
command Move up. The rules are read from the list in appearance order and the 
first valid rule will be used. 

20. Open the Concrete column (2 sec) rule set and right-click on the No 
connection icon to select the Two sided seating with dowel (76). Now pick 
Select connection type…, which opens Select component dialog. 

21. In Select component dialog select Two sided seating with dowel (76). Close 
the dialog by clicking OK. 

22. Next copy the rule set to apply also in Beam to column flange condition by 
right-clicking on Concrete column (2 sec) rule set and selecting Copy rule set 
from popup menu. 

23. Open the Beam to column flange rule group and right-click on any rule set 
and select Paste rule set from popup menu. 

 
24. Click OK to close the dialog and save the rule settings. 
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With AutoDefaults you can create rules defining when to use different pre-defined 
connection properties. When the connections need to be modified (for example changing the 
beam size), Tekla Structures automatically redefines the connection properties using the 
AutoDefaults rules defined by you. See more in Help: System > AutoConnection > 
AutoDefaults setup > AutoDefaults setup.  

Define 
AutoDefaults  

We will now create a new AutoDefaults rule group named Industrial building rules. This 
rule group could include all the rules needed to define when to use certain pre-defined 
connection properties for the entire project. 

 

1. Click Setup > AutoDefaults… to open the AutoDefaults setup dialog box. Create new rule 
group: Industrial 
building rules 2. Right-click in the dialog and select New rule group, and a rule group named New 

appears. 

3. Select the New rule group, press the F2 key and type: Industrial building rules.  

 
4. Press OK to save the settings.  

 

We will now create an AutoDefault rule for Two sided seating with dowel (76) and use it in 
the Industrial building rule group. 

Create new rule 
sets for Two sided 
seating with dowel 
(76) 1. Open the AutoDefaults setup dialog from Setup > AutoDefaults… pull down menu. 

2. Browse to Two sided seating with dowel (76) under Industrial building rules group. 

 
3. Right-click to create an additional rule set. 

4. Select the New rule set under Two sided seating with dowel (76) and select Edit rule 
set… from the right-click popup menu. 
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5. Write a new name for the rule set: Corbels400-800. 

6. Select Primary depth from Available rules list and move it to the right using arrow 
button in the middle of the dialog. 

7. Set Minimum value to 400 and Maximum value to 800. 

 

 
8. Click OK to save the settings and close the dialog. 

9. Select connection parameters Standard.j30000076 under the Corbels400-800 rule set and 
right-click > Additional connection parameters... 

10. Select the new connection parameters and right-click > Edit connection parameters. 
The connection properties dialog opens. 

11. On the General tab, select the Industrial building rules for the AutoDefault rule group; 
it can also be None.  

 
12. On all the tabs, set the fields that you want AutoDefaults to override to Default by 

selecting the options marked with the arrow symbol. Set all needed options, values and 
dimensions on all tab pages as shown below:  
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13. Save the settings using Save as field, define the name Corbels400-800. 

14. Close the dialog with OK. 

15. Right-click on the connection parameters and pick Select connection parameters… 

 Copyright © 2005 Tekla Corporation Applied Precast Concrete Detailing  9 
  TEKLA STRUCTURES BASIC TRAINING  
 



 
16. Select Corbels400-800.j30000076 from Attribute File List.  

 
17. Close the Attribute File List with OK. 

18. Close the AutoDefaults setup dialog with OK. 

 

We will now use the AutoConnections and apply the AutoDefault rules which we just 
defined. 

Create 
connections 

1. Select all concrete beams and columns between grid lines C and F.  

 
2. From the Detailing pull down menu select AutoConnection… 

3. Select the Industrial building rules group for connection parameters.  
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4. Click the Create connections button. Tekla Structures creates connections between 

concrete beams and columns using Corbel connection (14), which creates corbels and 
connects beams to columns if only one beam is to be connected. For two beams, Tekla 
Structures uses the Two sided seating with dowel (76) connection. 
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7.2 Create a Stairwell 
In this exercise we will create a stairwell and footings for it using a system macro and a 
custom component. 

Create stairwell footings with the help of a custom component 
First, we need to import the needed custom component into the model. Import the custom 

component 
1. Open the Component catalog by pressing Ctrl + F or from the Tools > Find a 

component… drop down menu. 

2. Right-click > Import… 

3. Select CastInPlaceCustomComponents300605.uel file in the browser. 

4. Click OK. The custom components are imported into the model and are ready for use. 

 

The custom component will create a footing and supporting walls for the stairwell. Define 
first the values for the footing and the walls, then place them in the model.  

Create the 
footings 

1. In the Component catalog, double-click on the CIP_FO_002 custom component to open 
the dialog. 

2. On the Footing tab, insert the values as shown below. 
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3. Set the values on the Walls tab. Note that the 2.2 walls will not be created and therefore 

the profile size is set to zero. 
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4. On the Position tab, set the Rotation to Back and the On plane and At depth fields to 

Middle position. 

 
5. Close the dialog with OK. 

6. In the PLAN +0 view, zoom in to gridline A between lines 5 and 6. 
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7. Delete the 1800*1800 size footings below the columns on grid lines 5 and 6. 

8. Select the CIP_FO_002 custom component in the Component catalog. 

9. Pick the middle point between grid lines 5 and 6 on the line A. 

 
The footing and the walls are created. 
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We will next insert supporting wall panels on gridlines 5 and 6 between the columns and the 
side walls. 

1. Double-click on the Create concrete panel icon to open the dialog. 

2. Fill in the values as shown below: 

Insert additional 
walls 

 
3. Close the dialog by clicking the OK button. 

4. Pick the start and end points for each wall and close them with the middle mouse button. 
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Insert a slab Before creating the stairwell, we will insert a slab above the walls we just created. 

1. Double-click on the Create concrete slab icon to open the dialog. 

2. Set the slab height to be 300 mm, select K30-2 as the material and position it to be Front  
in depth with value 700. 

 
3. Close the dialog with the OK button. 

4. In the PLAN +0 view, pick the polygon position by clicking at the corner points. 

5. Close the polygon with the middle mouse button. 
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Create the stairwell using a macro 
We will create the stairwell using the Stairwells and elevator shafts (90) component. First 
we need to find the needed component. 

Define the 
stairwell settings 

2. Open the Component catalog by pressing Ctrl + F or from the Tools > Find a 
component… drop down menu. 

3. Type "stair" in the search field. 

4. Click the Search button. All components having a word "stair" are listed. 

5. Double click the Stairwells and elevator shafts (90) component. 

 
6. Fill in the tab pages as shown below: 
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On the Plan View tab, define the levels and wall dimensions for 1st, typical and top floors. 
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On the Openings tab, set the dimensions for doors. 

 Copyright © 2005 Tekla Corporation Applied Precast Concrete Detailing  20 
  TEKLA STRUCTURES BASIC TRAINING  
 



 
On the Stairs and landings tab, define the placement and dimensions for stairs. 

7. Close the dialog with the OK button. 

8. In the PLAN +0 view, pick, first, the intersection of gridline A and the column inner 
side on line 5, then the intersection of line A and the column inner side on line 6. The 
stairwell is created. 
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7.3 Using Pre-cast Concrete Custom 
Components 

In this exercise we will use pre-cast custom components for creating and connecting concrete 
members. 

Insert a column shoe connection 
First, we need to import the needed custom component into the model. Import the custom 

component 
1. Open the Component catalog by pressing Ctrl + F or from the Tools > Find a 

component… drop down menu. 

2. Right-click > Import… 

3. Select the file PrecastCustomComponents310505.uel in the browser. 

4. Click OK. The custom components are imported into the model and are ready for use. 

5. Double-click on the CO_CO_GR_02 custom component to open the dialog. 

 
6. Use the default the values as shown below. 

 
7. Close the dialog with the OK button. 

8. Pick the footing of the stairwell. 
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9. Pick the column on gridline 5. The column shoes and anchor bolts are created. 

10. Repeat for the column on line 6. 

 

Create plinth walls and wall panels 
For the plinth wall insulation we need first create a new material named "Stonewool" Non-bearing 

plinth walls 
1. Open the Modify material catalog from File > Catalog > Materials > Modify…  

2. Right-click over the Miscellaneous branch and select Add grade.  

3. Select the new material and press F2, then type Stonewool 

4. Set the profile and plate density values to be 250 kg/m3 

5. Close the dialog with OK.  

6. Close also the Save confirmation dialog with OK. 

 

We will now create non-bearing plinth walls on gridline A. First, we need to find the needed 
custom component in the component catalog. The component was imported together with the 
column – footing connection (CO_CO_GR_02). 

1. Open the Component catalog by pressing Ctrl + F or from the Tools > Find a 
component… drop down menu. 

2. Open the "Custom" folder 

3. Double-click on the EW_003 custom component to open the dialog. 

 
4. Fill in the fields on each tab page as shown below. 
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On the Main part tab set the dimensions and materials. 

 
Define the dimensions and spacing of the insulation boxes. 
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Set the position to be Left on plane, Rotation to Top and Middle at depth. 

5. Click OK to close the dialog and apply the settings. 

6. Pick the start point at the columns outer side mid point at line 7. 

7.  Pick the end point at the columns outer side mid point at line 6. A plinth wall is created. 

 
8. Create similar plinth walls between gridlines 5 and 1 on gridline A, one wall between 

each column. 

 
9. Create similar plinth walls on gridline F, one wall between each column. 

 
Next, we will create bearing plinth walls on gridlines 1 and 7. Bearing plinth 

walls 
1. Open the Component catalog by pressing Ctrl + F or from the Tools > Find a 

component… drop down menu. 

2. In the Custom folder, double-click on the EW_004 custom component to open the 
dialog. 

3. Fill in the fields on each tab page as shown below. 
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On the Main part tab set the dimensions and materials. 
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Define the dimensions and spacing of the insulation boxes. 

 
Set the position to be Left on plane, Rotation to Top and Middle at depth. 

4. Close the dialog with the OK button. 

5. Pick the start point on gridline C at the 900*600 column's long side mid point. 

 
6. Pick the end point on gridline A, perpendicular to the start point. 

 
7. Create similar plinth walls between gridlines C and F. 

8. Repeat with reverse picking order at gridline 1. Note that you need to use reference pick 
with Ctrl button on grid line C at the 900*600 column's long side mid point, then pick 
the actual start point on gridline A, perpendicular to it. 

 
Panels around the 
stairwell 

Next, we will create outer panel with insulation around the outer part of the stairwell. 

1. Open the Component catalog by pressing Ctrl + F or from the Tools > Find a 
component… drop down menu. 

2. In the Custom folder, double-click on the EW_002 custom component. 

3. Fill in the fields on each tab page as shown below. 

 Copyright © 2005 Tekla Corporation Applied Precast Concrete Detailing  28 
  TEKLA STRUCTURES BASIC TRAINING  
 



 
On the Picture tab, define the dimensions and materials. Note that the thickness of the inner 
panel is zero. 

Set the position to be Left on plane, Rotation to Top and Middle at depth. 

4. Close the dialog with the OK button. 

5. Pick the start and end points at the corners around the stairwell's bearing walls. 

 
We should now have plinth walls and wall panels around the whole building. Next, we will 
connect the walls to each other. 
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Connect the walls using custom components 
We will now create corner connections between the walls on the outer corners. Outer corners 

1. Open the Component catalog by pressing Ctrl + F or from the Tools > Find a 
component… drop down menu. 

2. Open the "Custom" folder 

3. Double-click on the EW_EW_GR_04 custom component to open the dialog. 

 
4. Fill in the fields as shown below. 

 
5. Close the dialog by clicking the OK button. 

6. Zoom into the intersection of gridlines F and 7. 

7. Pick the parts of the walls as shown on the dialog's Picture tab. End with the middle 
mouse button. 
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The connection is created. 

 
8. Use the component EW_EW_GR_06 for the corner at the intersection of gridlines 1 and 

F. 

9. Set the values on the Picture tab as in previous connection and put the up direction to –z. 

 
10. Repeat for gridline A outer corners. Use EW_EW_GR_04 at grid line 1 and 

EW_EW_GR_06 at grid line 7. 

Next we will connect the walls around the stairwell. Corners around 
the stairwell 
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1. Open the Component catalog by pressing Ctrl + F or from the Tools > Find a 
component… drop down menu. 

2. Open the "Custom" folder 

3. Double click the EW_EW_GR_11 custom component to open the dialog. 

 
4. Fill in the fields as shown below. 

 
5. Close the dialog with the OK button. 

6. Zoom in to stairwell's inner corner on gridline 5 and pick the parts in order shown on the 
dialog, end with the middle mouse button. 
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A connection is created. 

7. Then go to the stairwell's inner corner on grid line 6 and make the connection using 
EW_EW_GR_12 custom component with Picture tab page values shown below. Use –z 
up direction on General tab. Picking order is the same as in previous connection. 

 
8. Use the manual fitting tool to adjust the stairwell's outer corners on gridlines 5 and 6. 

Before fitting, switch the "Select objects in components" on. 

a. Select the "Create fitting" icon. 

b. Pick the panel to be fitted between grid lines 5 and 6. 

c. Point the fitting line with two points along joining parts' sides as shown in the 
first picture below. 
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d. Repeat for the insulation. 

 
e. Continue with the panel on grid line 5 by picking it, then make a reference pick 

with Ctrl button down at the corner of the panel we just fitted. Point direction at 
the selected panel's corner and give a numerical value 15, then press Enter to 
get the start point for fitting line 15 mms from the panel's side. 

 
f. Pick the fitting line end point at the side of the insulation, perpendicular to the 

start point. 

 
g. Repeat for the opposite corner at grid line 6. 

 

Now we will connect the parallel walls to each other. Connections on 
straight sides 

1. Open the Component catalog by pressing Ctrl + F or from the Tools > Find a 
component… drop down menu. 

2. Open the "Custom" folder 

3. Double click the EW_EW_GR_15 custom component to open the dialog. 

 
4. Fill in the fields as shown below. 
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5. Close the dialog with the OK button. 

6. Zoom in to column in the intersection of gridlines A and 2. 

7. Pick, first, the panels in the order shown on the dialog, then the column, and end with 
the middle mouse button. 

 
The connection is created between the walls and the column. 

8. Repeat to all similar cases around the building at concrete columns. 

9. On gridline F, use the component EW_EW_GR_14 for connecting the walls beside the 
steel columns with settings shown below. 
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Connect double-T slabs using custom components 
We will now connect the double-T slabs to each other using a seam-type custom component. 

1. Open the Component catalog by pressing Ctrl + F or from the Tools > Find a 
component… drop down menu. 

2. Open the "Custom" folder 

3. Double-click on the DT_DT_GR_01 custom component to open the dialog. 

 
4. Fill in the fields as shown below. 
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5. Click OK to close the dialog and apply the settings. 

6. In the PLAN +7175 view, zoom in to the top right corner at gridline F between lines 5 
and 7. 

7. Select the 50 mm thick slabs and hide them using right-click > Shift + hide.  

8. Pick the top most DT-slab (main part) then the next slab aside it (sec. part). 

9. Pick start and end points as shown below. 

 
The connection is created. 
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10. Select the connection in the model and copy it 8 times to y direction -2400 mm. 

 
11. Then select all the double-T slab seam connections and copy them 2 times to x direction 

-12000 mms. 

 
Now all the double-T slabs should be connected to each other. 
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Create seam ring reinforcements using custom components 
Next we will create seam ring reinforcements around the hollow core-slabs using custom 
components. 

1. Open the Component catalog by pressing Ctrl + F or from the Tools > Find a 
component… drop down menu. 

2. Open the "Custom" folder. 

3. Double-click on the BE_D_004_SeamRing custom component to open the dialog. 

  
4. Fill in the fields as shown below. 

 
Set the dimensions of the in-situ concrete and the placing of the rebars. 
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Define the seam ring reinforcement properties and placing. 

5. Close the dialog with the OK button. 

6. Pick the beam on gridline 7 at level +3850. 

7. Pick the intersection point of gridlines B and 7 at the end of the beam. 

 
The reinforcements and the in-situ beam are created. 

8. Select the component and copy it to the upper levels (3500 and 95500 mms up). 

9. Create similar reinforcement to grid line 4 at two lowest levels putting the first seam 
rebar at 800 mms from the start. 
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