Contents

5 Basic Modeling 2 ................................................................................................................................................. 3
  5.1 Start a New Model - BasicModel2 .................................................................................................................. 4
  5.2 Setting Up Job Specific Information ................................................................................................................. 7
  5.3 Create Concrete Members .............................................................................................................................. 11
  5.4 Create Steel Members ...................................................................................................................................... 23
  5.5 Combine Models 1 and 2 .............................................................................................................................. 41
  5.6 Define Your Own Select Filters ...................................................................................................................... 45
In this lesson we will cover some preliminary tasks that you need to do before starting to model in a real project. We will create a new model and recap the basic functions introduced in lesson 1. After that, you will learn some more about the basic functions.

You will learn how to:

- Set up project information
- Define part properties and numbering series
- Work in true planes (sloped, skewed)
- Use phases
- Combine separate models
- Create your own select filters
5.1 Start a New Model - BasicModel2

Start a new model and name it BasicModel2.

Create new model

1. Pick the New icon.

2. Save in C:\TeklaStructuresModels, type Model name "BasicModel2".
3. Click the OK button and the model will be created.

Create grid

We will now create a grid for the model. In order to combine Basic Model 1 and Basic Model 2 later, we will take into account the positioning of Basic Model 1 and define the origin of Basic Model 2 grid to be 0,13900,0 in the global coordinates.

The grid is created according to the work plane, the current local coordinate system, of the model. So before creating the grid we will temporarily position the work plane to the global coordinates 0,13900,0.

The red coordinate arrow symbol indicates the work plane, which is the current local coordinate system of the model. Most of the commands dependent on the coordinate system use work plane coordinates.

You can create a skew grid by first setting the work plane to the desired skew position.
Set Work plane to a new position

1. On the menu, select View > Work plane > With one point.
2. Type 0,13900, click Enter or OK.

![Enter a numeric location](image)

The work plane is positioned in global 0,13900,0

You can also create a grid and then move the grid with the Move command.

You can use the command Work plane > With one point to set the work plane exactly to the desired position. This command keeps the work plane parallel to the current work plane, but moves it to a new position using a single picked point.

Create the grid

1. Delete the default grid (if there exists one).
2. Double-click on the Create grid line icon.

![Create grid line](image)

3. Edit the grid, in the Grid properties dialog box, according to the grids shown in the figure above (coordinates and text).
4. Click Create.
5. Enter GRID2 in the Save as field and click the Save as button to save the grid values.

Fit work area

1. Click anywhere in the view.
2. Right-click and select Fit work area.

The view should now look like the one below.
Create plane views along gridlines

We will now create **Elevation** and **Plan** views along the gridlines.

**Create grid views**

1. Select the grid.
2. Right-click and select **Create view > Grid views** from the pop-up menu.
3. Click the **Show…** button on each view plane to open the **View properties** dialog box, set the view properties the way you want and click **OK**.
4. Click **Create** in the **Creation of views along grid lines** dialog box.
5.2 Setting Up Job Specific Information

Prior to adding any parts we will setup the model with the necessary job specific information:

- Project properties
- Preferences
- Part properties and numbering series

Project properties

Project properties are common to all drawings and can be used to fill in typical information in the title blocks.

1. Open the Project properties dialog box by selecting Properties-> Project…
2. Fill in the information as shown in the dialog box below.
3. Press OK.

Check preferences

Before starting the modeling we will check that preferences are set up correctly.

Help: System > Using Tekla Structures effectively > General > Preferences
Check that your preferences are set up correctly before you start modeling. If you change settings on the Preferences tab, Tekla Structures only applies the new settings to connections you subsequently create. Connections you created prior to changing the preferences are not affected.

1. Open Setup > Options…
2. On the Preferences tab check the values are as below, click OK.

Part properties and numbering series

You use a numbering series (numbering prefixes and start numbers) to divide parts, assemblies (steel detailing) and cast units (concrete detailing) into groups. For example, you can allocate separate numbering series to different phases or part types.

You can name the numbering series to which a part, assembly or cast unit belongs, by using the part properties dialog box. The numbering series name consists of a prefix and a starting number.

If you already know in the beginning of the project how the members should be numbered it is a good idea to create the parts right from the start with the correct numbering series.
Help: Modeling > Parts > Numbering parts > Defining numbers to be used for parts

In a later lesson you will learn the basics of numbering parts in Tekla Structures; how numbering series result in different part / assembly /cast unit numbers, numbering settings etc.

Go through each of the part properties dialog box (Beam properties, Column properties, Contour plate properties, etc.) and set them up with the information shown in the tables below and save each of them with a specific name. See the Adjust Beam properties example below the tables.

### Steel members

<table>
<thead>
<tr>
<th>Parts/command</th>
<th>Part prefix</th>
<th>Part start no.</th>
<th>Assembly prefix</th>
<th>Assembly start no.</th>
<th>Part name</th>
<th>Material</th>
<th>Class</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beam command:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Beams</td>
<td>PB</td>
<td>1</td>
<td>AB</td>
<td>1</td>
<td>BEAM</td>
<td>S355JR</td>
<td>6</td>
</tr>
<tr>
<td>Vertical braces</td>
<td>PV</td>
<td>1</td>
<td>AV</td>
<td>1</td>
<td>BRACING_V</td>
<td>S355JR</td>
<td>3</td>
</tr>
<tr>
<td>Horizontal braces</td>
<td>PH</td>
<td>1</td>
<td>AH</td>
<td>1</td>
<td>BRACING_H</td>
<td>S355JR</td>
<td>3</td>
</tr>
<tr>
<td>Rafters</td>
<td>PR</td>
<td>1</td>
<td>AR</td>
<td>1</td>
<td>RAFTER</td>
<td>S355JR</td>
<td>9</td>
</tr>
<tr>
<td>Purlins</td>
<td>PP</td>
<td>1</td>
<td>AP</td>
<td>1</td>
<td>PURLIN</td>
<td>S355JR</td>
<td>8</td>
</tr>
<tr>
<td>Column command:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Columns</td>
<td>PC</td>
<td>1</td>
<td>AC</td>
<td>1</td>
<td>COLUMN</td>
<td>S355JR</td>
<td>7</td>
</tr>
<tr>
<td>Silos</td>
<td>PX</td>
<td>1</td>
<td>AX</td>
<td>1</td>
<td>SILO</td>
<td>S355JR</td>
<td>1</td>
</tr>
<tr>
<td>Contour plate command:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Plates</td>
<td></td>
<td>1001</td>
<td>A</td>
<td>1</td>
<td>PLATE</td>
<td>S355JR</td>
<td>99</td>
</tr>
</tbody>
</table>

### Concrete members

<table>
<thead>
<tr>
<th>Parts/command</th>
<th>Cast unit prefix</th>
<th>Cast unit start no.</th>
<th>Part name</th>
<th>Material</th>
<th>Class</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concrete beam command:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Beams</td>
<td>CB</td>
<td>1</td>
<td>BEAM</td>
<td>K40-1</td>
<td>6</td>
</tr>
<tr>
<td>Hollow-core slabs</td>
<td>CH</td>
<td>1</td>
<td>HCSLAB</td>
<td>K40-1</td>
<td>1</td>
</tr>
<tr>
<td>Concrete column command:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Columns</td>
<td>CC</td>
<td>1</td>
<td>COLUMN</td>
<td>K40-1</td>
<td>3</td>
</tr>
<tr>
<td>Pad footing command:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pad footings</td>
<td>CP</td>
<td>1</td>
<td>FOOTING</td>
<td>K40-1</td>
<td>2</td>
</tr>
<tr>
<td>Concrete slab</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Example: Adjust beam properties

1. Open the **Beam properties** dialog.
2. Match the highlighted fields in the dialog box below.

Type the part name **BEAM** in the save as field and click the **Save as** button.

---

**Save defaults**

After you have set up the properties, you must save the **Project properties** and **Preferences** for this model with the **Save defaults** command.

The **Save defaults** command creates a set of standard files which also include the part properties files. These standard properties are loaded when you open the model.

In other words, when you want specific properties to be loaded by default when you open a model, set up and load the properties before using the **Save defaults** command.

**Help: System > Files and Folders > Customizing Tekla Structures > Save defaults**

Save Defaults: Click **Setup > Save defaults**.
5.3 Create Concrete Members

First we will create pad footings and columns on gridline 1 and then copy them to the other gridlines.

We will then create beams on gridlines 1 and 3 and mirror them to the other side of the structure. With a slab generation macro, we will then create TT slabs on top of the beams at level 7175.

Finally we will create a sloped grouting on top of the TT slabs.

Pre-cast footings

We will now create foundations on gridline 1.

2700*2700 footing

1. Double-click on the Create pad footing icon.
2. Load the saved **FOOTING** properties.

3. Enter the pad footing information in the dialog box for a 2700*2700 footing as shown in the drawing.

4. Click **Apply**.

5. Pick grid intersections C-1 and F-1.

6. Enter the pad footing information in the dialog box for a 2100*2100 footing as shown in the drawing.

7. Click **Apply**.


The footings should now look like those shown below:

---

### Pre-cast columns

Now we will create the columns on gridline 1.

1. Double-click on the **Create Concrete column** icon.

2. Load the **COLUMN** properties that you saved earlier.

3. According to the drawing shown above, enter the information in the **Concrete column properties** dialog box for a 900*600 column, and click **Apply**.

4. Pick the intersections of grids C-1 and then F-1. While still in the command:

5. Complete the dialog for 600*600 columns and create them on grid intersections D-1 and E-1.
Copy the members

We will now copy the footings and columns to other gridlines.

1. Select the footings and columns on gridlines C and F.
2. Right-click and select Copy > Translate… on the pop-up menu.
3. Pick two points to show the translation vector (6000 in x direction).
4. Type in the number of copies (6).
5. Click Copy.

1. Select the footings and columns on gridlines D and E.
2. Right-click and select Copy > Translate… on the pop-up menu.
3. Pick two points to show the translation vector (12000 in x direction).
4. Type in the number of copies (3).
5. Click Copy.
Pre-cast ledger beams

We will now create the beams on gridlines 1 and 3 at level +7175.
1. Double-click on the Create concrete beam icon.

2. Load the BEAM properties that you’ve saved.

3. Enter the information in the Concrete beam properties dialog box for gridline 1 beams according to the drawing above, click Apply.

4. In the 3D view pick the reference point of the column at C-7175.

5. Still having the cursor snapping to the picked point, type z to lock the z coordinate and then pick the top point of the column at D-7175.
6. End the command by clicking the middle mouse button.

7. Still having the z coordinate locked, create the other two beams on gridline 1 in the same way.

8. Enter the information for the beams on gridline 3 in the **Concrete beam properties** dialog box, click **Apply**.

9. Create the gridline 3 beams.

10. Type z to unlock the z coordinate
    
    The model should now look as shown below.

---

**Mirror the beams to gridlines 5 and 7**

1. Select the beams just created on gridlines 1 and 3.

2. **Copy special > Mirror** the beams to the other end of the structure indicating two points on gridline 4 as the mirror line.
The model now looks as shown below.

Pre-cast TT slabs

We will now create precast TT slabs on top of the framework by using the **Modeling of Slab Area** macro (88).

**Create the TT slabs**

3. Find the **Modeling of Slab Area** macro (88) in the Component catalog.
4. Double-click on the component to open the component dialog box.
5. Complete the dialog box as shown and **Apply**.
6. In the PLAN +7175 view, pick positions 1 and 2 (the intersections of gridlines and the column edges) as shown, click the middle mouse button.

7. Pick positions 3 and 4 as shown, click the middle mouse button.

8. Pick positions 5 and 6, click the middle mouse button.

The slabs are created.

10. Select the macro symbol and copy it to the other spans.
Second stage concrete / grouting

We will create grouting out of four symmetrical slabs. First, we create one slab, edit the sloping for the slab, and then copy-mirror the rest of the slabs.

Create the grouting

1. Double-click on the Create concrete slab icon.
2. Load the SLAB properties that you saved earlier.
3. Set the profile to 50 and the position in depth to Front and Apply.
4. In the PLAN +7175 view, pick the four corners for the slab as shown.
   (1) Outer corner of the column
   (2) Intersection of the gridline and the column edge
   (3) Mid point of the gridline
   (4) Outer edge of the beam (Perpendicular snap)
5. Click the middle mouse button to create the slab.
We will next set the sloping for the grouting by editing the $dz$ values of the three chamfers shown below.

**Create the rest of the slabs**

1. Create the rest of the slabs (with Copy-Translate).
Set the sloping for the grouting

2. Double-click on the chamfer.
3. Set the Dz1 value to 150, **Modify**.
4. Repeat this for the other two chamfers.
5.4 Create Steel Members

First, we will create two columns on gridline 1 and then a rafter between them. After that we will create the construction points needed to create the horizontal bracing and purlins. We will copy-translate the completed portal frame and points.

We will then replace the concrete columns on gridlines 2, 4 and 6, combining them with the upper steel columns so that they are turned into full-length steel columns.

Utilizing a sloping work plane and view planes, we will model the horizontal bracing and purlins.

Finally, we will create vertical bracing on gridlines C and F.

Steel columns

We first create two columns on gridline 1.

1. Double-click on the Create column icon.

2. Load the COLUMN properties.
3. Complete the **Column properties** (profile and levels) for the column at grid intersection C-1 as shown in the figure above and click **Apply**.

4. Pick grid intersection C-1 to create the column.

5. Complete the **Column properties** for the column at grid F-1, and click **Apply**.

6. Pick the grid intersection F-1 to create the second column.

Since the profile depth of the concrete and steel columns are different (900*600 => h=900 while HEA 800 => h=790), middle positioning causes a gap in the outer face.

Use the **Measure** tool to measure the distance from the edge of the column to the edge of the slab.

**Measure the gap**

1. Click on the **Create y measure** icon.

2. In the GRID 1 view pick the point in the slab corner, then the point in the column corner.

3. Pick a position to place the dimension.
The measure tools measure distances between two points in the view plane.
Measures are visible in the rendered view window until you update or redraw the window.

**Adjust the vertical position**

Adjust the column edge to the slab (and concrete column) by using the vertical position offset in the **Column properties** dialog.

1. Open the **Column properties** dialog box.
2. **Modify** the column on gridline C using a vertical offset of -55.

3. **Modify** the column on gridline F using a vertical offset of 55.

**Steel rafter**

Now we will create a rafter between the two columns that we just created.
Create rafter

1. Double-click on the Create beam icon.
2. Load the RAFTER properties.
3. Enter the rafter information in the dialog according to the drawing above (Profile: IPE750*160) and click Apply.
4. In the GRID 1 view pick grid C-20200 and then F-18200.

Work points for horizontal bracing and purlins

After inputting the two columns and the rafter, we will layout points for modeling the purlins, and the vertical and horizontal braces.

Bracing work points

First, we need to create points at the intersection of grid C and the rafter centerline and the intersection of grid F and the rafter centerline. Then, using those points, we will create work points for the braces.

To create a point at the intersection (indicated with a red arrow) of grid C and the rafter centerline:
1. Double-click on the **Create divided line points** icon.

2. Type 1 (1 point) and pick the positions shown below.

To create the point in the intersection of grid F and the rafter centerline on the other end of the rafter, we simply copy the first point.

1. Select the point just created, right-click and select **Copy – Translate**…
2. Pick the start point of the rafter, then the end point of the rafter, then click **Copy**.

We will now create the work points for the first and the last brace.

1. Double-click on the **Create extension point** icon.

2. Type -800, click **OK**.
3. Pick one of the points just created, and then the other.
4. Repeat, picking the points in the reverse order.

Using the **Create divided line points** command to divide the space between the work points that you just created into ten equal spaces (9 points).

1. Double-click on the **Create divided line points** icon.

2. Enter 9 as the number of dividing points, click **OK**.

3. Pick one of the work points that you just created, and then the other.

**Purlins work points**

We can now use the grid intersections C-20200 and F-18200 to create the work points for the first and last purlins.

1. Double-click on the **Create extension point** icon.

2. Type -600, click **OK**.

3. Pick grid intersection C-20200, and then F-18200.

4. Repeat, picking the points in the reverse order.

Using the **Create divided line points** command, divide the space between the work points that you just created into 12 equal spaces (11 points).

**Copy the portal frame and the points**

We will now copy the columns, the rafter and the points to gridlines 2-7.
1. Select the columns, the rafter and the points.

2. Right-click and select **Copy > Translate**.

3. Pick two points to show the translation vector (6000 in x direction).

4. Type the number of copies (6).

5. Click **Copy**.

---

**Combine columns**

We modeled concrete columns also on gridlines 2, 4 and 6 even though they are not needed to support the concrete beams. We will now replace them with full length steel columns by combining them with the steel columns on top of them.
1. Select **Edit > Combine** from the menu.
2. Pick the steel column at grid C-2.
3. Pick the concrete column at grid C-2.
4. Reply **OK** to both questions.

   ![Image of combining columns](image1)

The columns are now combined. The combined column has inherited the properties of the steel column (the first picked part).

![Image of combined column](image2)

5. Repeat the combining for the rest of the columns on gridlines 2, 4 and 6.
Set sloping work plane for bracing and purlins

The next step is to model the horizontal bracing and purlins of the sloped roof. To place the parts in the correct plane we will first change the work plane (which currently is the local coordinate system of the model) to the roof slope.

**Help: Modeling > Getting Started > Basics > Defining the work area and shifting the work plane**

**Help: Modeling > Getting Started > View reference > View > Work plane > To part plane**

To set the work plane to the roof slope:

1. Pick the **Set Work plane to part top** icon.

2. Pick the rafter on gridline 1.

The work plane is now positioned in a plane parallel to the top plane of the rafter.
The **Set work plane to part plane** command sets the work plane parallel to the part plane (front, top, back, bottom) on the center line of the part.

You can use the command **Work plane > With one point** to set the work plane exactly to the desired position. This command keeps the work plane parallel to the current work plane, but moves it to a new position using a single picked point.

### True plan view

To make it easier to add the roof bracing we will now make a true plan view of the roof bracing by creating a view perpendicular to the work plane. We can also use the true plan view in drawings.

Working in a true plan view makes it easier to model e.g. sloped objects since the grids are also shown in the true plan and points in the view plane are presented as yellow crosses. The part positioning, copying, etc, however, always comply with the work plane coordinate system no matter in which view you perform the commands.

1. Pick **Properties > View...**
2. Complete the properties as shown below, click **OK**.

![View properties dialog]

3. Select **View > Create view > To workplane**.

The new view is created. The work points created for braces appear in yellow since they are now on the view plane. The grid is also shown in the true plan view plane.
Create horizontal bracing

Working in the true plan view, we will next create the horizontal bracing members using the Create beam tool.

1. Double-click on the Create beam icon.
2. Load the BRACING_H properties.

3. Complete the dialog box according to the information shown in the drawing above and change the Position at depth to Middle and Apply.

3. In the true plan view create the braces shown in the drawing by snapping to the yellow points.
Check the position of the braces in the 3D view and elevation view on grid 1.

We will now copy-mirror the braces to the other end of the building (between gridlines 4 and 5). Since the work plane is now at the same slope with the TRUE PLAN view, it is easy to pick the points for the mirror line.

The **Copy special > Mirror** command copies and mirrors objects through a plane that is perpendicular to the work plane and passes through a line you specify.

**Mirror the braces**

1. Select the braces.
2. **Copy special > Mirror**.

3. In the **True plan** view pick two points on gridline 4 to set the mirror line and click **Copy**.
Create purlins

While still working in the true plan view we will create the purlins by using the Create beam tool.

1. Double-click on the Create beam icon.
2. Load the PURLIN properties.
3. Select a Z300/3.0 profile for the purlin.
4. Change the Position / At depth to: Front with 5 mm offset and Apply.

5. Pick the purlin work point near grid intersection F-1 at the command Pick first position. The point that you pick for the purlin is red since it is not in the view plane.
6. At the command: Pick second point, pick the work point near grid intersection F-2.

7. Check the elevation view on grid 1 to ensure that the purlin is orientated and positioned correctly.
With asymmetric profiles (Z, L, etc) the picking order of the first and second position determines the orientation. It is not possible to change the orientation using the beam properties.

8. Create the rest of the purlins by using the Copy > Translate command.

Now we must switch the work plane back to the global origin to carry on modeling outside of the roof plane.

1. Select View > Work plane > Work plane…
2. Select Plane: XY and set the depth coordinate to 0 and click Change.

The work plane is now set back to the global origin.

Vertical bracing

Working in the elevation on the GRID C view we will create vertical bracing using the Create beam tool.

Create brace

1. Double-click on the Create beam icon.
2. Load the BRACING_V properties.
3. Enter RHS200*120*8 as the profile.
4. Change the Position / At depth to: Front and add a 5 mm offset, click Apply.
5. Create one brace using the column top positions at C-1 and C-2.

6. Move the brace 1300 mm downwards and to the middle of the column.
Copy the brace along grid C
1. Select the brace and use **Copy special > Translate...** to copy the brace five times at 6000 mm intervals along gridline C.

Copy the braces to gridline F
2. Select all the braces on gridline C and select **Copy special > Translate...**
3. In the GRID 1 view, pick the outer corner of the column on gridline C as the first position.

4. Pick the inner corner of the column on gridline F as the second position, click **Copy**.

Crane girders

Create girder
1. Double-click on the **Create beam** icon.
2. Load the **BEAM** properties.
3. Enter IPE450 for the profile size.

Next we will add crane girders to the framing.
4. In the GRID 1 view, pick the grid intersection C-15500.
5. Use the cursor to snap (do not pick!!) in the y direction.
6. With the keyboard type 930 for the numeric location and press **Enter**.

**Copy girders**

1. Copy the girder that you created to the other columns on gridline C.
2. Use the **Copy – mirror** command to copy the girders from gridline C to gridline F.
The BasicModel2 model is now complete.

Save the model.

1. Click *File > Save as*...

2. Check the path *C:\TeklaStructuresModels*, in the Save in field and type Model name *BasicModelCombined*.

3. Press the *OK* button. The model has now been saved with the new name.
5.5 Combine Models 1 and 2

Next we will combine BasicModel1 and BasicModelCombined by copying the objects in phase 1 from BasicModel1. To copy the objects from another model we will use the command; Copy from model. This command copies objects from specified phase(s) from another model.

To be able to manage the objects from the two models after we have combined them we will first transfer the model 2 parts to a different phase.

Help: Modeling > Settings and tools > Settings > Phases

Change the phase of BasicModel2 members, preparation

Check objects by phases

1. Click Properties > Phase number... to open the Phase manager dialog box.
2. By default only Phase 1 appears in the dialog box.
3. Select Phase 1.
4. Click Objects by phases.

All the parts in the model become highlighted, indicating that they belong to Phase 1.

Add a new phase – Model2

4. Click on the Add button to add a new phase.
5. Edit the name of the new phase to Model 2.
6. Also edit the name of the Phase 1 to Model 1.
7. See that all of the parts are still highlighted in the Model 2 phase.
8. Click Modify phase.
9. Now all of the parts in the model have changed to Phase number 2.

In BasicModel1 the column footings on gridline B were dimensioned both for steel columns on gridline B and concrete columns on gridline C. After combining the models the footings on gridline C will no longer be needed and you can delete them.

Remove pad footings
Delete the pad footings on gridline C.

**Edit > Copy from model**

Since we did not edit the phases in BasicModel1 they all belong to phase number 1.

**Copy from model**

1. Click Edit > Copy special > From model...
2. Select BasicModel1 as the model to copy from in the Model directories list.
3. Enter 1 as the phase number from which to copy the objects.
4. Click Copy.

The model 1 parts are now in the combined model.
With the **Copy special > From model** command you are not able to import drawings with the model.

**Change the Model 1 part properties and numbering series**

The Model 1 parts were created without paying attention to part properties and they are not consistent with the Model 2 parts (color, name, numbering series, and material).

The different numbering series and material would result in otherwise equal parts getting different numbers when numbering.

In this combined model we want all of the parts to be numbered according to the numbering series shown in the table in the beginning of the lesson. To achieve this we will need to modify the Model 1 part properties so that they are consistent with the Model 2 parts.

The properties of the connection parts to be created in the new model will be consistent with the existing ones since we used the same default Preferences in both models.

1. Select the Model 1 pad footings.
   You can try the available select filters for selecting the footings.
2. Load the **FOOTING** properties.
3. Remove the modify switches and check only **Name, Material, Class** and **Numbering series** switches.
4. Click **Modify**.

By following the procedure above change the properties for:

- Beams
- Concrete beams
- Columns
- Concrete columns
- Slabs
- Hollow-core slabs
- Horizontal bracing
- Vertical bracing
- Silos.
5.6 Define Your Own Select Filters

To make the selecting of parts easier in the future we will now define select filters for each part type. We will use the names of the part as filtering criteria.

For steel/concrete beams and columns we will use the materials as additional filtering criteria to be able to filter them separately.

**Help: Modeling > Settings and tools > Filter > Select filter**

1. Click on the Display select filter dialog icon to open the Select filter dialog box.

2. Load the standard filter to turn out all the possible filtering.
3. Enter the name FOOTING in the Name field of the Parts tab.
4. Enter the name FOOTING in the Save as field and click Save as.

You can now select the new filter on the drop-down list.

By following the procedure above, define select filters for:

- Slabs
- Hollow-core slabs
- Horizontal bracing
- Vertical bracing
- Silos
- Rafters
Define select filter for plates

To define select filters for plates created both manually and by the connections:

1. Enter the name *PLATE* in the Name field of the Parts tab. (*PLATE* matches every part whose name includes the word PLATE)
2. Enter the name PLATE in the Save as field and click Save as.

Define select filter for steel beams

To define select filters for steel beams:

1. Enter the name BEAM in the Name field of the Parts tab.
2. Enter S* in the Material field of the Parts tab. (S* matches every material whose material name begins with the character S)
3. Enter the name BEAM_STEEL in the Save as field and click Save as.

By following the procedure above define select filters for:

- Concrete beams
- Steel columns
- Concrete columns.

Create your own select filters to use both for modeling and for automating drawing creation with the help of wizards.

The Copy from model command only copies the objects from another model (not e.g. attributes from the model folder). We will now bring the attributes created in BasicModel1 to BasicModelCombined.

1. Tools > Open model folder.
2. Browse to model BasicModel1 > Attributes.
3. Copy the files.
4. Browse to **BasicModelCombined > Attributes.**
5. **Paste.**

![Image showing a list of names]

**Save the model**

Finally save the model.