Basic Modeling 1
## Contents

1. **Basic Modeling 1**  
   1.1 Start Tekla Structures  
   1.2 Create a New Model – BasicModel1  
   1.3 Create Grids  
   1.4 Create Plane Views along Gridlines  
   1.5 Create Foundations  
   1.6 Create Columns  
   1.7 Create Beams  
   1.8 Create Slabs

Copyright © 2006 Tekla Corporation
We will go through the basic functions of Tekla Structures: How to create a new structural 3D model, and how to create grids (i.e. module lines), grid views and structural members in the model. As a result of this lesson the model will look as shown below.
1.1 Start Tekla Structures

To start Tekla Structures, click the Windows Start button. Navigate through Programs > Tekla Structures > Tekla Structures enu Europe. This will start Tekla Structures in European environment using English language.

The modeling user interface is now opened. At first, most of the menu options and all the icons are gray indicating that they are inactive. When you open an existing model or create a new model, the icons and available menu options become active.
1.2 Create a New Model – BasicModel1

To start a new model, you first need to create an empty model database with a unique name. In this lesson use the name BasicModel1.

Start a new model

1. Select File > New… from the pull-down menu or click the New model icon in the Standard toolbar to open the New model dialog box.

2. At the center of the dialog box, Tekla Structures suggests the name "New Model" for the model. The full path of the model folder is shown in the first field.

3. Replace the name "New Model" by BasicModel1.

4. Click the OK button (or Enter) to create the new model.

The menus and icons become activated and the model name appears in the title bar of the Tekla Structures window.

Every model must have a unique name. Tekla Structures does not allow duplicate model names. Do not use special marks ( / \ ; : | ) in model names.

You can only have one model open at a time. If you already have a model open, Tekla Structures prompts you to save that model.

Tekla Structures automatically created a grid and a view according to the saved standard view properties. The default 3D view and grid are shown below.
Cyan dash-and-dot lines show the projections of the grids which are visible on the view plane. Tekla Structures indicates the work area of a view using green, dashed lines. For more information, see: Help: Modeling > Getting started > Basics.

To save the model:

5. Select **File > Save** from the pull-down menu or click the **Save** icon in the **Standard** toolbar.

Remember to save your model every now and then, and always when opening another model or exiting Tekla Structures.

Tekla Structures includes also an auto save feature that backs up and saves your work automatically at set intervals. These are set in the **Autosave properties** dialog box obtained from the **Setup > Autosave…** pull-down menu.

For more information on saving and auto saving, see:

**Help: Modeling > Getting started > Basics > Saving a model and exiting Tekla Structures**

Most commands of Tekla Structures are found both in menus (main or pop-up) and in toolbars (icons). In this training manual we will mainly use the pop-up menu to activate commands.
There are several ways to execute commands in Tekla Structures:

- Icons
- Commands in main pull-down menu
- Commands in pop-up menu

By default, all the commands are found in the pull-down menu, and most of them in the icons. A pop-up menu appears when you click the right mouse button (right-click). If you have an object selected, the commands on the pop-up menu relate to that object.

For more information on Tekla Structures screen layout and toolbars, see:

- Help: Modeling > Introduction > Screen layout
- Help: Modeling > Introduction > Toolbars
1.3 Create Grids

To create the appropriate grid for BasicModel1 as shown above, you can delete the existing grid and create a new one from the Points > Grid… pull-down menu. Alternatively you can modify the existing grid.

To modify the existing grid:

1. Double-click on the gridline.
2. Complete the appearing Grid dialog box as shown below by filling in the X, Y and Z coordinates and the labels for the gridlines.
3. Click **Modify** to apply the new grid values.

4. Enter the grid file name, GRID1, and click the **Save as** button to save the grid values for later use. The settings are saved in the file GRID1.grd, which is stored in the **attributes** subfolder of your model folder.

For more information on grids and dialog box buttons, see:

*Help: Modeling > Introduction > Inputting information > Common buttons*

---

When the grid was modified, the work area of the view, shown with the green dashed line, was not updated.

To fit the work area according to the modified grid:

1. Click the view to activate it.
2. Right-click and select **Fit work area** from the pop-up menu.

---

<table>
<thead>
<tr>
<th>Interrupt</th>
<th>Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move</td>
<td></td>
</tr>
<tr>
<td><strong>Fit work area</strong></td>
<td></td>
</tr>
<tr>
<td>Redraw window</td>
<td></td>
</tr>
<tr>
<td>Zoom</td>
<td></td>
</tr>
<tr>
<td>Update window</td>
<td></td>
</tr>
<tr>
<td>Next window</td>
<td></td>
</tr>
<tr>
<td>Create GA drawing</td>
<td></td>
</tr>
<tr>
<td>Create clip plane</td>
<td></td>
</tr>
</tbody>
</table>

The view should now look as shown below:
### 1.4 Create Plane Views along Gridlines

We will now create Elevation and Plan views along the gridlines created in the previous section.

A view is a representation of a model from a specific location. Each view is displayed in its own window inside the Tekla Structures window. Each view has a view plane on which the grids are visible and points are represented as yellow crosses. Points outside the view plane appear as red dots.

For more information, see: Help: Modeling > Getting started > Views.

**Create grid views**

To create views along gridlines,

1. Select one gridline.
2. Right-click and select **Create view > Grid views** from the pop-up menu to open the **Creation of views along grid lines** dialog box.

3. Change the View properties as shown above and click the **Show…** button of the XY view plane to open the **View properties** dialog box.

4. Change the **View depth** values as shown below and click **OK** to close the dialog box.
5. Select the number of views as **All** and click **Create** in the **Creation of views along grid lines** dialog box.

The **Views** dialog box appears presenting all the created views. All invisible named views are listed on the left, and all visible views on the right.

For more information on view properties, see:

**Help: Modeling > Getting started > Views > View properties**

To display or hide views:

1. Click the **Open named view list** icon to open the **Views** dialog box (which is now already open).
2. Select the view(s) you want to display or hide.
3. Use the arrows to move view(s) from left to right (visible) or vice versa (invisible).

Do not keep too many views open at the same time. Nine is the maximum number of open views. You can open or close named views by clicking the Open named view list icon. Delete unnecessary views from the view list.

To switch between views, press **Ctrl+Tab**.
**Rotate the model**

You can rotate the model in a 3D view with rendered view type.

1. Press the key v.
2. In the view, pick a center of rotation.
3. Hold down the **Ctrl** key, and click and drag with the middle mouse button.

**Change between 3D / Plane**

With the shortcut **Ctrl+P** you can change the view angle between 3D and Plane, which is very useful.
1.5 Create Foundations

We will now create foundations for the BasicModel1.

Column footing

1800*1800 footing

To create footings for columns:

1. Double-click on the Create pad footing icon. This will open Pad footing properties dialog box.

2. Complete the Pad footing properties dialog box as shown below and click Apply.
3. In the 3d view, pick the grid intersection A-1 to create the footing.
4. Create the rest of the 1800*1800 footings at other intersections of gridline A by picking each position.
   
   **Help: Modeling > Parts > Part location > Position on work plane**
   
   **Help: Modeling > Parts > Part location > Position depth**
   
   **Help: Modeling > Parts > Part properties > Profile**

   ![Warning Icon] You can undo (and redo) previous commands one by one since the last save by clicking the icons or typing **Ctrl + Z** (Undo) and **Ctrl + Y** (Redo).

2700*2700 footing

5. Complete the **Pad footing properties** dialog box for a 2700*2700 footing as shown below and **Apply** this.

   The footings on gridline B need offsetting from the gridline because there will be additional columns modeled afterwards. This offset will be accomplished by adjusting the **Vertical Position** value in the **Pad footing properties** dialog box.

   ![Pad footing properties dialog box]

6. Create the footings at intersections of the gridline B.

7. Right click and select **Interrupt** to end the command.
The commands will stay active until you interrupt them.

To end commands, right-click and select **Interrupt** from the pop-up menu, or press the **Esc** key.

To restart the last command used, press **Enter**.

---

**Foundations for silos – parametric profiles**

We will create two identical circular foundations for the silos. At first, one foundation will be created at the coordinate 4500,4500,0 and then the other foundation will be created as a copy of the first one.

Tekla Structures contains standard (library), parametric, and user-defined profiles. For the foundation, we will use parametric profiles.

*Help: Modeling > Parts > Part properties > Profile*

*Help: Modeling > Settings and tools > Appendix A: Parametric Profiles*

---

![Diagram of foundations](image)

**Create footing**

1. Double-click on the **Create pad footing** icon.

2. Complete the Pad footing properties dialog box as shown below and click **Apply**.

   You can select the profile for a part from the **Select profile** dialog box that opens next to the **Profile** field in the part properties dialog box.

   You can as well enter a profile name in the **Profile** field in the part properties dialog box.
3. Type 4500,4500 to define the position for the footing (typing the numbers automatically displays the Enter a numeric location dialog box).

4. Press Enter (or click OK) and the foundation is created.

Help: Modeling > Settings and tools > Tools > Snapping

Copy the footing
1. Click the footing once to select it.
2. Right click and select Copy special > Translate from the pop-up menu.
3. Click copy.
Now the footings should look as shown below:
1.6 Create Columns

We will first create two of the columns and then use the Copy command to create the other columns.

You can create your columns and beams either in steel or concrete! Follow the left side of the instruction for steel and the right side for concrete.

To create the first two columns.

Create steel columns
1. Double-click on the Create column icon.

2. Complete the Column properties dialog box as shown below.

3. Complete the dialog's Position tab as shown below, and then click Apply.

Create concrete columns
1. Double-click on the Create concrete column icon.

2. Complete the Concrete column properties dialog box as shown below.

3. Complete the dialog's Position tab as shown below, and then click Apply.
4. Pick the intersection of gridlines A-1 to create one column, and then pick grid B-1 to create the second column.

**Copy columns**

1. Select the columns that you just created by dragging a window across them.
2. Right click and select **Copy special > Translate...** from the pop-up menu. Complete the dialog box as shown below and click **Copy**.
Now all the columns appear in the model.

When you want to model identical structures, you can alternatively create one footing (and its reinforcement), the steel column on top of it and the base plate connection between the footing and the column, and copy this structural entity to all other positions of similar structures.

You can select multiple parts in the model by holding down the Ctrl-key when selecting objects in the model.

Help: Modeling > Introduction > Selecting model objects > How to select objects

Silos

We will now model the steel silos by using solid parametric profiles. A more precise alternative would be to create the silo as a circular hollow section with a contour plate welded on top of it.

Create silos

1. To create the silos, double-click on the Create column icon.

2. Complete the Column properties dialog box as shown below, and then click Apply.
3. Pick the top point of the first silo footing and then the other.

Now the silos appear in the model.
The visibility of objects in views depends on the work area, view depth, view setup, and view filter. You can also temporarily hide parts in a view by using the Hide tool (on the pop-up menu).

In the pictures hereafter all the model objects created may not always be visible.

Help: Modeling > Getting started > Views > Displaying and hiding objects in views
1.7 Create Beams

Level 3850 beams

We will first create the beams at the +3850 level and then copy them (using the select filter) to the two upper levels. Again, you can create the beams either in steel or in concrete.

1. Open the PLAN +3850 view.

Create steel/concrete beams

Create steel beams

2. Double-click on the Create beam icon.

3. Complete the Beam properties dialog box as shown and Apply.

Create concrete beams

2. Double-click on the Create concrete beam icon.

3. Complete the Concrete beam properties dialog box as shown.
4. Complete the dialog’s Position tab as shown below, and Apply.

5. In the PLAN +3850 view pick the intersection of gridlines A-4 and then B-4.

6. Continue at gridlines 5, 6, and 7.
When inputting horizontal members always pick from left to right or from bottom to top for consistency purposes.

Copy beams to upper levels

1. Open the Grid 7 view, right-click and select **Copy** from the pop-up menu.

   ![Diagram of Grid 7 view showing copy beams]

2. Pick the gridline intersection B-3850 and then B-7350.
3. Copy beams to level +13400 by repeating steps 1-2.
4. Change the select filter option back to **standard** to enable also the selection of other objects than beams.
Level 13400 beams

Next we will create beams at the view +13400 level.

Create grid beams

By using the same beam properties that we applied earlier, create the missing beams at the gridline intersections shown in the figure below.
Next we will create beams in locations where no gridlines intersect. The snapping tools help you pick points to position objects precisely without having to know the coordinates or layout additional lines or points.

Help: Modeling > Settings and tools > Tools > Snapping

Create beam A

1. Double-click one of the existing beams in the model and press Apply.
2. Start the beam command.

Create the rest of the beams

2. Start the concrete beam command.
3. Make sure only the **Snap to reference lines / points** icon of the two main snap switches on the right is pressed down.

4. Make sure the **Snap to mid points** and **Snap to end points** icons are pressed down.

5. Pick a midpoint of the beam between A-2 and A-3 and then the midpoint of the beam between B-2 and B-3.

5. Pick a midpoint of the beam between A-2 and A-3 and then the midpoint of the beam between B-2 and B-3.

---

**Create beam B**

We will pick the start position of beam B by using the gridline intersection A-1 as a temporary reference point and tracking along gridline 1 in the direction of intersection B-1 for 9000 mm.

We will then pick the second position of beam B using the temporary snap switch **Perpendicular**.

**Pick the first position of beam B**

1. Start the beam command.

2. Hold down the **Ctrl** key and pick gridline intersection A-1 as the origin to show the “From” location coordinates.

3. Then use the cursor to snap (do not pick!!) in the correct direction (e.g. to gridline intersection B-1).
4. Type 9000 for the numeric location. (The **Enter a numeric location** dialog box will open automatically.)

![Enter a numeric location dialog box]

5. Press **OK** or **Enter** and the cursor snaps to the correct position. (=9000 mm from A-1 in the direction of B-1).

6. Right click and select **Perpendicular**.

![Pick second position of beam B]

7. Pick the second position on beam A (see below).

---

7. Pick the second position on beam A (see below).
Create beam C

While still in the beam command,

8. Right click and select **Intersection** for snap override.

9. Pick the intersection of beam B and gridline 2 and then the intersection of gridlines B-2.

Create beam D

We will first create one of the beams that frame around the silo and then by using the **Copy > Rotate** command create the other three.
Help: Modeling > Settings and tools > Settings and tools reference > Edit > Copy > Rotate…

1. Hold down the Ctrl key and pick gridline intersection A-1 to show the “From” location coordinates, use the cursor to snap (do not pick!!) in the correct direction. (E.g. grid intersection B-1).

2. Type 4000 for the numeric location and press Enter, the cursor snaps to the correct position.

3. Type the letter O on the keyboard to snap to positions in orthogonal directions on the work plane (0, 45, 90, 135, and 180 degrees).

4. Let the cursor snap to the midpoint as shown below and pick.

5. Type the letter O to turn the ortho off.

Copy rotate the beam

1. Select the beam that you just created.

2. Right click and select Copy special > Rotate… from the pop-up menu.
3. Pick the center point of the silo as the point to define the rotation (select a view in which the silos are visible and pick near the circumference to snap to the center point). The origin X0 and Y0 values will appear in the dialog box.

4. Complete the other fields in the dialog.

5. Click **Copy**.

   We will now copy the beams to the other silo.

1. Select the beams shown highlighted in the picture below (press the **Ctrl** key to add parts to the selection).

2. **Copy special > translate…** them 9000 mm in the x direction.

---

**Bracing**

Working in the **Grid A** elevation view, we will input the vertical steel bracing members using the **Create beam** tool.
Create braces a and b

1. Double-click on the Create beam icon.
2. Complete the Beam properties dialog box as shown below and Apply.
3. In the 3d view create brace a by first picking the gridline intersection A-2 and then the midpoint of column A-3.
4. Create brace b by picking the top position of column A-2 and then midpoint of column A-3.

Use handle to move brace end

We can see from the drawing above that the lower end of the brace needs 200 mm offsetting from the grid level. Now we will use handles to move the part end.

Help: Modeling > Parts > Part location

1. Select brace a to display the handles.
2. Select the yellow handle (Tekla Structures then highlights the handle).
3. Right click and select **Move special > Translate...** to move the handle 200 mm upwards.
4. Click **Move**.
5. Repeat the procedure to move brace b’s top handle 1000 mm downwards.

Help: Modeling > Settings and tools > Settings and tools reference > Edit>Copy >Mirror...

Now we have modeled all the steel and concrete members in Model1. The model should look like in the picture below.
1.8 Create Slabs

Concrete hollow-core slabs

We will now create concrete hollow-core slabs. Instead of positioning the slabs to the gridline intersection we will model the slabs to the face of the steel columns.

In the PLAN +13400 view:

1. Double-click on the Create concrete beam icon.

2. Complete the Concrete beam properties dialog box as shown and Apply.
If you have modeled steel columns and beams:

3. Pick the intersection of the column flange outer face and gridline 4 and then the intersection of the column flange outer face and gridline 5 (make sure that **Snap to geometry lines/points** is active).

If you have modeled concrete columns and beams:

3. Pick the intersection of the column outer border and gridline 4 and then the intersection of the column outer border and gridline 5 (make sure that **Snap to geometry lines/points** is active).
1. Select the slab that you just created.

2. Right click and select **Copy special > Translate**... from the pop-up menu.

3. Type 1200 in the \( \text{dY} \) field of the **Copy – translate** dialog box and 10 as the number of copies.

4. Click **Copy**.

**Copy the slabs in y direction**

**Copy the slabs in x direction**

1. Drag an area select, selecting all the concrete slabs.

2. Right click and select **Copy > Translate**... from the pop-up menu.

3. Type 6000 in the \( \text{dX} \) field of the **Copy - translate** dialog box.
Copy hollow-core slabs to levels 7350 and 3850

Copy the slabs

1. Hold down the Ctrl key and select all the hollow-core slabs by dragging 3 areas through the slabs.

2. Still holding down the Ctrl key, pick the two slabs shown in the picture below to unselect them.

3. Right click and select Copy special > Translate... from the pop-up menu.

4. Enter -6050 in the dZ field of the Copy special > Translate dialog box, click Copy.

5. Enter -9550 in the dZ field of the Copy special > Translate dialog box, click Copy.
Concrete slab

1. Double-click on the **Create concrete slab** icon.
2. Complete the **Concrete slab properties** dialog box as shown and **Apply**.
3. In the PLAN +13400 view pick point A (intersection of column flange outer face and gridline 1, shown in the drawing above).
4. Let the cursor snap to the position just picked (do not pick!) and press y to lock the y coordinate.

5. Let the cursor now snap to the end point of the beam near point B and pick.

6. Press y to release the coordinate lock.

7. Pick point C.
8. Pick point D.

9. Click the middle mouse button to create the slab.

**Copy concrete slab**

1. Select the slab that you just created.
2. **Copy – translate** the slab 9000 mm in x direction.
Create in-situ slabs

Before we add reinforcements to concrete members we need to create additional 600 mm wide in-situ slabs beside the hollow-core slab area in first and second floors. For this, zoom in to first floor in gridlines A and 5 – 6.

1. Double-click on the **Create concrete slab** icon.
2. Set the profile height to 175 mm.
3. Press **OK** to close the dialog.
4. Start picking the polygon shape at the middle of the hollow-core slab in gridline 5.
5. Write: \texttt{R} then add 0, 600, to the \textit{Enter a numeric location} dialog and press \texttt{OK}.

6. Write: \texttt{R} then add 6050, 0, to the \textit{Enter a numeric location} dialog and press \texttt{OK}.

7. Write: \texttt{R} then add 0, -600, to the \textit{Enter a numeric location} dialog and press \texttt{OK}.

8. Close the polygon with middle button.

Now select the slab and copy it 3500.00 mm in z-direction using \textit{Copy special} > \textit{Translate...} right button command.

Now the Model1 framework is finished.

\section*{Links to additional information}

\texttt{Help: Modeling > Introduction > General information > Single user mode vs multiuser mode}

\texttt{Help: Modeling > Introduction > General information > Languages and environments}