toc

Team LiB
Next Section

Effective Project Management, Third Edition
Effective Project Management, Third Edition
by Robert K. Wysocki and Rudd McGary ISBN:0471432210
John Wiley & Sons © 2003

This text provides a guide to project management, reflecting significant changes in project management practices over the last few years. It covers tradition methods of project management as well as adaptive and extreme approaches.

Table of Contents
 | Effective Project Management—Traditional, Adaptive, Extreme, Third Edition
 | Preface
 | Introduction to Effective Project Management
 | Part One - Traditional Project Management
 | Chapter 1 | - | What Is a Project?
 | Chapter 2 | - | What Is Traditional Project Management?
 | Chapter 3 | - | Scoping the Project
 | Chapter 4 | - | Identifying Project Activities
 | Chapter 5 | - | Estimating Duration, Resource Requirements, and Cost
 | Chapter 6 | - | Constructing and Analyzing the Project Network Diagram
 | Chapter 7 | - | Finalizing the Schedule and Cost Based on Resource Availability
 | Chapter 8 | - | Organizing and Conducting the Joint Project Planning Session
 | Chapter 9 | - | Recruiting, Organizing, and Managing the Project Team
 | Chapter 10 | - | Monitoring and Controlling Progress
 | Chapter 11 | - | Closing Out the Projects
 | Chapter 12 | - | Critical Chain Project Management
 | Part Two - Adaptive Project Framework
 | Chapter 13 | - | Introduction to the Adaptive Project Framework
 | Chapter 14 | - | Version Scope
 | Chapter 15 | - | Cycle Plan
 | Chapter 16 | - | Cycle Build
 | Chapter 17 | - | Client Checkpoint
 | Chapter 18 | - | Post-Version Review
 | Chapter 19 | - | Variations to APF
 | Part Three - Organizational Considerations
 | Chapter 20 | - | Project Portfolio Management
 | Chapter 21 | - | Project Support Office
 | Epilogue | - | Putting It All Together Finally
 | Appendix A | - | What’s on the CD-ROM
 | Appendix B | - | Bibliography
 | Index
 | List of Figures
 | List of Tables
 | List of Sidebars

Team LiB
Next Section


backcover

Team LiB

Back Cover

In previous editions, this book has established itself as the definitive guide to effective project management. Now, with this major revision, it’s updated to reflect significant changes in project management practices over the last few years. Written again by Robert K. Wysocki and a new coauthor, Rudd McGary, this book covers traditional methods of project management as well as adaptive and extreme approaches. Unlike other project management books that simply give abstract advice, this timely book mentors you though a series of real-world exercises and adheres to the Project Management Institute’s (PMI) Body of Knowledge, 2000 Edition.

Effective Project Management is packed with thought-provoking discussion questions related to the chapter materials and case study as well as an abundance of exercises. The material covers:

  • Traditional project management, including risk assessment and control
  • Generating, building, and representing the Work Breakdown Structure
  • Estimating duration, resource requirements, and cost
  • Constructing and analyzing the project network diagram
  • Organizing and conducting the Joint Project Planning session
  • Recruiting and managing a project team
  • Adaptive Project Framework, Extreme Project Management, and their core values
  • Project portfolio management, including prioritizing projects

About the Authors

Robert K. Wysocki, Ph.D., has more than 38 years of experience as a project management consultant and trainer, information systems manager, systems and management consultant, author, and training developer and provider. Effective Project Management, Second Edition, is a bestseller and is essential for the library of every project manager.

Rudd McGary, Ph.D., PMP, has been practicing and teaching project management for more than 25 years. McGary has taught at the Ohio State University, Indiana University, and the University of Iowa and has been CEO of two operating companies. As the current central Ohio VP of Certification for PMI, he has worked with hundreds of candidates to help them become certified.

Team LiB


Effective Project Management - Traditional, Adaptive, Extreme, Third Edition

Team LiB

Effective Project Management—Traditional, Adaptive, Extreme, Third Edition

Robert K. Wysocki, Ph.D. with contributions by
Rudd McGary, Ph.D.,PMP

Executive Publisher: Robert Ipsen
Vice President and Publisher: Joe Wikert
Executive Editor: Robert M. Elliott
Developmental Editor: Kevin Kent
Editorial Manager: Kathryn A. Malm
Production Editor: Felicia Robinson
Media Development Specialists: Megan Decraene and Kit Malone
Text Design & Composition: Wiley Composition Services

Copyright © 2003 by Robert Wysocki, Rudd McGary. All rights reserved.

Published by Wiley Publishing, Inc., Indianapolis, Indiana
Published simultaneously in Canada

No part of this publication may be reproduced, stored in a retrieval system, or transmitted in any form or by any means, electronic, mechanical, photocopying, recording, scanning, or otherwise, except as permitted under Section 107 or 108 of the 1976 United States Copyright Act, without either the prior written permission of the Publisher, or authorization through payment of the appropriate per-copy fee to the Copyright Clearance Center, Inc., 222 Rosewood Drive, Danvers, MA 01923, (978) 750-8400, fax (978) 646-8700. Requests to the Publisher for permission should be addressed to the Legal Department, Wiley Publishing, Inc., 10475 Crosspoint Blvd., Indianapolis, IN 46256, (317) 572-3447, fax (317) 572-4447, E-mail: permcoordinator@wiley.com.

Limit of Liability/Disclaimer of Warranty: While the publisher and author have used their best efforts in preparing this book, they make no representations or warranties with respect to the accuracy or completeness of the contents of this book and specifically disclaim any implied warranties of merchantability or fitness for a particular purpose. No warranty may be created or extended by sales representatives or written sales materials. The advice and strategies contained herein may not be suitable for your situation. You should consult with a professional where appropriate. Neither the publisher nor author shall be liable for any loss of profit or any other commercial damages, including but not limited to special, incidental, consequential, or other damages.

For general information on our other products and services please contact our Customer Care Department within the United States at (800) 762-2974, outside the United States at (317) 572-3993 or fax (317) 572-4002.

Trademarks: Wiley, the Wiley Publishing logo and related trade dress are trademarks or registered trademarks of Wiley Publishing, Inc., in the United States and other countries, and may not be used without written permission. All other trademarks are the property of their respective owners. Wiley Publishing, Inc., is not associated with any product or vendor mentioned in this book.

Wiley also publishes its books in a variety of electronic formats. Some content that appears in print may not be available in electronic books.

Library of Congress Cataloging-in-Publication Data:

ISBN: 0-471-43221-0

Printed in the United States of America

10 9 8 7 6 5 4 3 2 1

Acknowledgments

This acknowledgment is really a special acknowledgment to two people who played a key role in getting this whole project started. First, Dave Crane and I had co-facilitated a three-day project management course for Boston University Corporate Education Center clients. Dave and I honed the course materials over a three-year period and then decided to turn it into a book. At that time, Bob Beck, who was recently retired after 25 years with IBM, was my business partner and volunteered to create the CD-ROM that would house the O’Neill & Preigh Church Equipment Manufacturers case study. Dave and Bob devoted most of their efforts to the case study and the CD-ROM, while I focused on the contents of the book. Our three-person team worked very well together and produced the first edition. In time, and after healthy sales of the first edition, we decided to do a second edition. That has been even more successful than the first edition. Bob has retired now and spends most of his time fishing and helping his missionary church build facilities in South America. Dave is fully occupied delivering training for Boston University. I’m still actively involved in project management consulting and writing. We’ve kind of gone our separate ways. I owe both of these friends and colleagues my heartfelt thanks for giving so freely of their time and energies. All three of us can look back with no regrets and know that we have done great work together.

Now it’s time for the third edition. I’ve decided to retire O’Neill & Preigh; that case served us well. In its place there is a new case, the Jack Neift Trucking Company, and a new team member, Rudd McGary. I’ve learned a lot working with Dave and Bob and would like to think that that learning is reflected in this third edition.

About the Authors

Robert K. Wysocki, Ph.D., has over 38 years’ experience as a project management consultant and trainer, information systems manager, systems and management consultant, author, and training developer and provider. He has written 10 books on project management and information systems management. One of his books, Effective Project Management, 2nd Edition, has been a best-seller and is recommended by the Project Management Institute for the library of every project manager. He has over 30 publications and presentations in professional and trade journals and has made more than 100 presentations at professional and trade conferences and meetings. He has developed more than 20 project management courses and trained over 10,000 project managers.

In 1990 he founded Enterprise Information Insights, Inc. (EII), a project management consulting and training practice specializing in project management methodology design and integration, Project Support Office establishment, the development of training curriculum, and the development of a portfolio of assessment tools focused on organizations, project teams, and individuals. His clients include AT&T, Aetna, Babbage Simmel, British Computer Society, Boston University Corporate Education Center, Computerworld, Converse Shoes, the Czechoslovakian Government, Data General, Digital, Eli Lilly, Harvard Community Health Plan, IBM, J. Walter Thompson, Peoples Bank, Sapient, The Limited, The State of Ohio, Travelers Insurance, and several others.

He is a member of the ProjectWorld Executive Advisory Board, the Project Management Institute, the American Society of Training & Development, and the Society of Human Resource Management. He is past Association Vice President of AITP (formerly DPMA). He earned a B.A. in Mathematics from the University of Dallas, and an M.S. and Ph.D. in Mathematical Statistics from Southern Methodist University.

Rudd McGary, Ph.D., PMP, has worked in the project management arena both as an educator and a practitioner. Dr. McGary brings more than 25 years of experience in the area to this book. In addition to teaching at Ohio State, the University of Iowa, and Indiana University, he has been a guest lecturer at numerous other nationally known schools.

He has worked with major international companies on their business and project management systems. These companies have included DOW Chemical, ITT, and McDonald’s. He has also been the author of columns in various business magazines with readerships of over 100,000. Currently the VP Certification for the Central Ohio Project Management Institute chapter, McGary has helped more than 200 people obtain their PMP certification. Additionally, he has been the CEO of two operating companies and consulted with the CEOs of over 800 privately held organizations. McGary is also coauthor of Project Management Best Practices A-Z.

He lives with his wife, Sharon, sons Clayton and Carter, and the great white dog, Picasso.


Preface

Preface to the Third Edition

Someone once said, “If it ain’t broke, fix it.” The second edition has been very successful, and for that we are grateful. It ain’t broke. But so much is happening in the world of projects and project management that it is time to fix it. The third edition represents a major updating of a very successful second edition. Comments from our readers and the significant changes taking place in the project management landscape are what prompted the writing of the third edition. For those who have followed this book through the previous editions and have become our loyal readers, we are offering a fresh and greatly expanded third edition. You will find that a few totally new topics are introduced here for the first time, that a number of contemporary topics have also been added, and that a number of continuing topics have had a fresh coat of paint applied. We hope that you will be pleased with the results.

There are two significant changes on the cover:

  • First, note the title change. We have added Traditional, Adaptive, Extreme as a subtitle. The material from the second edition of this title is mostly contained in the part devoted to the traditional approach to project management. There are now discussions in the book devoted to the adaptive and extreme approaches to project management. These discussions are new in the third edition. The part devoted to the adaptive approach is totally new. It has not been published elsewhere.

  • Second, note the change in authors. Bob Beck and Dave Crane are no longer listed as authors and have moved on to other adventures and have been replaced by Rudd McGary. Rudd is a veteran and brings years of project management consulting and training experience to the team. Welcome aboard, Rudd!

Rudd’s major contribution is the replacement of the O’Neill & Preigh case study from the second edition with a fresh new case, Jack Neift Trucking Company. The CD-ROM that accompanies this book still contains the exercises much like the second edition, but the text itself also contains a number of discussion questions related to the chapter materials and to the case study as well.

This material is also new with the third edition. Much to our surprise the book has been widely adopted in undergraduate, graduate, and continuing education programs. The second edition was not written as a college text, but because of the numerous college adoptions, we have decided to write the third edition as both a reference and as a text. Many college faculty have written and asked for our support. We were cognizant of that need as we prepared this edition. That is why we’ve added more exercises and thought-provoking discussion questions that should add a bit of excitement to class lectures. Additionally, many of the requests for help asked for copies of the figures, so the CD-ROM contains PowerPoint slides of every figure and table in the book.

We would like to think that this edition offers you a complete view of effective project management as it is now practiced and how it should be practiced in the very near future.

Thank you again for adding our book to your project management library. If you have any questions or would just like to comment, you may contact me at rkw@eiicorp.com and Rudd at rmcgary@hotmail.com.

Enjoy!
Robert K. Wysocki, Ph.D.


Introduction to Effective Project Management

Changes in the Business Environment

Change is constant! We hope that does not come as a surprise to you. Change is always with us and seems to be happening at an increasing rate. Every day we face new challenges and the need to improve yesterday’s practices. As John Naisbett says in The Third Wave, “Change or die.” For experienced project managers as well as “wannabe” project managers, the road to breakthrough performance is paved with uncertainty and with the need to be courageous, creative, and flexible. If we simply rely on a routine application of someone else’s methodology, we are sure to fall short of the mark. As you will see in the pages that follow, we are not afraid to step outside the box and outside our comfort zone. Nowhere is there more of a need for change than in the approach we take to managing projects.

Organizational Structures

The familiar command and control structures introduced at the turn of the century are rapidly disappearing. In their place are task forces, self-directed work teams, and various forms of projectized organizations. In all cases, empowerment of the worker lies at the foundation of these new structures. With structural changes and worker empowerment comes the need for all of us to have solid project management skills. One of our clients is often heard saying: “We hire smart people, and we depend on them. If the project is particularly difficult and complex, we can put five smart people together in a room and know that they will find an acceptable solution.” While there is merit to this line of reasoning, we think project management should be based more on wisely chosen and repeatable approaches than on the creativity and heroic actions of a room full of smart people.

Software Applications

Many of you may remember the days when a computer application had to meet the needs of just a single department. If there was a corporate database, it was accessed to retrieve the required date, which was passed to an applications program that produced the requested report. If there was no data or if we did not know of its existence, we created our own database or file and proceeded accordingly. In retrospect, our professional life as systems developers was relatively simple. Not so any more. To be competitive, we now develop applications that cross departmental lines, applications that span organizations, applications that are not clearly defined, and applications that will change because the business climate is changing. All of this means that we must anticipate changes that will affect our projects and be skilled at managing those changes. Many of the flavors of project management approaches in use in corporations are fundamentally intolerant of change. Barriers to change run rampant through many of these approaches. If your process has that property, bury it quickly; that is not the way to be a contemporary project manager.

Cycle Time

The window of opportunity is narrowing and constantly moving. Organizations that can take advantage of opportunities are organizations that have found a way to reduce cycle times. Taking too long to roll out a new or revamped product can result in a missed business opportunity. Project managers must know how and when to introduce multiple release strategies and compress project schedules to help meet these requirements. Even more importantly, the project management approach must support these aggressive schedules. That means that these processes must protect the schedule by eliminating all non-value-added work. We simply cannot afford to layer our project management processes with a lot of overhead activities that do not add value to the final deliverables. We will spend considerable time on these strategies in later chapters.

Right-Sizing

With the reduction in management layers, a common practice in many organizations, the professional staff needs to find ways to work smarter, not harder. Project management includes a number of tools and techniques that help the professional manage increased workloads. Our staffs need to have more room to do their work in the most productive ways possible. Burdening them with overhead activities for which they see little value is a sure way to failure.

In a landmark paper “The Coming of the New Organization” (Harvard Business Review, January/February 1988), Peter Drucker depicts middle managers as either those who receive information from above, reinterpret it, and pass it down or those who receive information from below, reinterpret it, and pass it up the line. Not only is quality suspect because of personal biases and political overtones, but also the computer is perfectly capable of delivering that information to the desk of any manager who has a need to know. Given these factors, plus the politics and power struggles at play, why employ middle managers? As technology advances and acceptance of these ideas grows, we have seen the thinning of the layers of middle management. Do not expect them to come back; they are gone forever. The effect on project managers is predictable and significant. Hierarchical structures are being replaced by organizations that have a greater dependence on project teams, resulting in more opportunities for project managers.


Changes in the Project Environment

Traditional project management (TPM) practices were defined and matured in the world of the engineer and construction professional where the team expected (and got) a clear statement from clients as to what they wanted, when they wanted it, and how much they were willing to pay for it. All of this was delivered to the project manager wrapped in a neat package. The i’s were all dotted, and the t’s were all crossed. All the correct forms were filed, and all the boxes were filled with the information requested. Everyone was satisfied that the request was well documented and that the deliverables were sure to be delivered as requested. The project team clearly understood the solution they would be expected to provide, and they could clearly plan for its delivery. That describes the world of the project manager until the 1950s. By the mid-1950s the computer was well on its way to becoming a viable commercial resource, but it was still the province of the engineer. Project management continued as it had under the management of the engineers.

The first sign that change was in the wind for the project manager arose in the early 1960s. The use of computers to run businesses was now a reality, and we began to see position titles like programmer, programmer/analyst, systems analyst, and primitive types of database architects emerging. These professionals were really engineers in disguise, and somehow, they were expected to interact with the business and management professionals (who were totally mystified by the computer and the mystics that could communicate with it) to design and implement business applications systems to replace manual processes. This change represented a total metamorphosis of the business world and the project world, and we would never look back.

In the face of this transformation into an information society, TPM wasn’t showing any signs of change. To the engineers, every IT project management problem looked like a nail, and they had the hammer. In other words, they had one solution, and it fit every problem. One of the major problems that TPM faced, and still faces, is the difference between wants and needs. If you remember anything from this introduction, remember that what the client wants is probably not what the client needs. If the project manager blindly accepts what the clients say they want and proceeds with the project on that basis, the project manager is in for a rude awakening. Often in the process of building the solution, the client learns that what they need is not the same as what they requested. Here we have the basis for rolling deadlines, scope creep, and an endless trail of changes and reworks. It’s no wonder that 70-plus percent of projects fail. That cycle has to stop. We need an approach that is built around change—one that embraces learning and discovery throughout the project life cycle. It must have built-in processes to accommodate the changes that result from this learning and discovery.

We have talked with numerous project managers over the past several years about the problem of a lack of clarity and what they do about it. Most would say that they deliver according to the original requirements and then iterate one or more times before they satisfy the client’s current requirements. We asked them: “If you know you are going to iterate, why don’t you use an approach that has that feature built in?” The silence in response to that question is deafening. All of the adaptive and agile approaches to project management that are currently coming into fashion are built on the assumption that there will be changing requirements as the client gains better focus on what they actually need. Sometimes those needs can be very different than the original wants.

Obviously, this is no longer your father’s project management. The Internet and an ever-changing array of new and dazzling technologies have made a permanent mark on the business landscape. Technology has put most businesses in a state of confusion. How should a company proceed to utilize the Internet and extract the greatest business value? Even the more basic questions—”What business are we in?” “How do we reach and service our customers?” “What do our customers expect?”—had no answers in the face of ever-changing technology. The dot.com era began quickly with a great deal of hyperbole and faded just as quickly. A lot of companies came into existence on the shoulders of highly speculative venture capital in the 1990s and went belly up by the end of the century. Only a few remain, and even their existence is tenuous. The current buzzwords e-commerce and e-business have replaced B2B and B2C, and businesses seem to be settling down. But we are still a long way from recovery. As we write this book, few forecasters would say that the precipitous drop in the business world has bottomed out.

The question on the table is this: “What impact should this have on our approach to project management?”

Where Are We Going?—A New Mind-set

We are not in Kansas anymore! The discipline of project management has morphed to a new state, and as this book is being written, that state is not yet a steady one. It may never be. What does all of this mean to the struggling project manager?

To us the answer is obvious. We must open our minds to the basic principles on which project management is based so as to accommodate change and avoid wasted dollars and wasted time. For as long as we can remember, we and our colleagues have been preaching that one size does not fit all. The characteristics of the project suggest what subset of the traditional approach should be used on the project. This concept has to be extended to also encompass choosing the project management approach that we employ based on the characteristics of the project at hand.

Introducing Extreme Project Management

Something new was needed, and along came extreme project management (xPM). This approach embraced high change and highly complex situations where speed was a critical success factor. B2B and B2C applications clearly fall into the extreme category. New product development and R&D projects are also typical extreme projects. More recently, the whole school of thought around these types of approaches to project management has been titled agile project management. Under the title of agile project management, you find extreme programming, SCRUM (named after a term used in rugby), Dynamic Systems Development Method (DSDM), Feature Driven Development (FDD), Adaptive Systems Development (ASD), Crystal Light, and others. These hybrids all focus on extreme software development projects, which are at the opposite end of the spectrum from traditional projects. Even with all of these hybrids, there is still something missing.

For several years now we and other project management authors have suggested “one size does not fit all.” We are, of course, talking about how the characteristics of the project should inform the project manager as to what pieces and parts of the traditional approach should be used on a given project. As the project went from high risk to low risk, from high cost to low cost, from critical mission to routine maintenance, and from groundbreaking technology to well-established technology, the project management approach appropriately went from the full methodology to a subset of the methodology. That was fine for making adjustments to the traditional approach, but now we have another factor to consider that has led to a very basic consideration of how a project should be managed. This factor can be posed as a question that goes to the very heart of project management: “What basic approach makes sense for this type of project?”

This new approach represents a radical shift away from trying to adapt TPM to fit the project toward one that is based on a very different set of assumptions and principles than before.

We contend that the traditional world of project management belongs to yesterday. There will continue to be applications for which it is appropriate, but there is a whole new set of applications for which it is totally inappropriate. The paradigm must shift, and any company that doesn’t make that shift is sure to be lost in the rush. “Change or die” was never a truer statement than it is today.

Introducing the Adaptive Project Framework

All of this discussion of the traditional and new approaches is fine, but we see a wide gap between the traditional approach and these newer agile approaches, a gap occupied by a whole class of projects that cannot totally use the methodology of either approach and for which there is no acceptable project management methodology. To deal with projects that fall in the gap, a new approach is needed.

We call this new approach Adaptive Project Framework (APF). It is new. It is exciting. It works. We urge you to step outside the comfort zone of the traditional project management box and try APF. Be assured that we have not abandoned TPM. There are many projects for which it is a good fit. It has several tools and processes that make sense even with the type of project for which APF was designed. Many of those tools and processes have been incorporated into APF.

Developing a Taxonomy of Approaches

Why do we need yet another way of managing projects? Don’t we have enough choices already? There certainly are plenty of choices, but projects still fail at a high rate. We believe that part of the reason is that we haven’t yet completely defined, at a practical and effective level, how to manage the types of projects that we are being asked to manage in today’s business environment. Figure I.1 illustrates our point very effectively.

We’ve had the traditional approach for almost 50 years now. It was developed for engineers and the construction industry during a time when what was needed and how to get it were clearly defined. Over the years TPM has worked very well in that situation and still serves us well today when applied to those situations for which it was developed. Unfortunately, the world has not stood still. There is a whole new environment with which project managers have been trying to contend for the past few years. What do we do if what is needed is not clearly defined? What if it isn’t defined at all? Many have tried to force fit the traditional approach into these situations, and it flat out doesn’t work.

And what about those cases where what is needed is clearly defined but how to produce it isn’t as obvious. These types of projects lie on a scale between the traditional and the extreme. Clearly, the traditional approach won’t work. For the traditional approach to work, you need a detailed plan, and if you don’t know how you will get what is needed, how can you generate a detailed plan? What about the extreme approach? We’re guessing that the agilists would argue that any one of the agile approaches would do just fine. We would agree that you could use one of them and probably do quite well. Unfortunately, you would be ignoring the fact that you know what is needed. It’s a given. Then why not use an approach that has designed in the fact that you know what is needed? Makes sense to us. Enter what we are calling APF, an adaptive approach that can fill the gap between TPM and xPM.

Click To expand
Figure I.1: Approaches to managing a project.

APF is an approach that spans the gap between TPM and xPM. At the same time, we want you to appreciate the traditional and extreme approaches and know when and how to use them. If we are successful in developing an appreciation for all three methods, we will have a taxonomy consisting of approaches that will meet the need for a sound approach to project management regardless of the nature of the project. The appropriate approach can be chosen once the type of project is known. Specifically:

  • Figure I.1 shows that TPM works when the goal and the solution are clearly defined. If any one of the goal or solution is not clearly defined, we need another approach.

  • When the solution is not clear, the appropriate approach is APF. This is discussed in detail in Part II, “Adaptive Project Framework.”

  • When the goal is not clear, the appropriate approach is xPM, which is discussed in detail in Chapter 19.

Examples of all three approaches abound:

  • A project to install an intranet system in a field office is clearly a traditional project. This project will have been done several times, and the steps to complete it are documented.

  • A good example of an adaptive project is taken from history: John F. Kennedy’s challenge to put a man on the moon and return him safely by the end of the decade. The goal statement could not be clearer. How it was to be accomplished was anybody’s guess. There certainly were some ideas floating around NASA, but the detail was not there.

  • There are hundreds of examples of extreme project from the brief dot.com era of the late 1990s. Executives, in an attempt to maintain parity with their competition, got wrapped up in a feeding frenzy over the Internet. They challenged their technical staffs to build them a Web site ASAP where they could conduct either B2B or B2C activities. They had no ideas what it would look like or perhaps even what it would do, but they would know it when they saw it. The goal was very vague, and how it would be reached was anybody’s guess.

One more concept differentiates these three approaches—the way the project converges on the solution. It is important that you understand these differences, because they explain much of what is done in the course of using each approach. This concept is illustrated in Figure I.2 and the differences are as follows:

  • TPM projects follow a very detailed plan that is built before any work is done on the project. The plan is based on the assumption that the goal (that is, the solution) is clearly specified at the outset. Apart from minor aberrations caused by change requests, the plan is followed and the goal achieved. The success of this approach is based on a correct specification of the goal during project definition and the initial scoping activities.

  • APF projects follow a detailed plan, but the plan is not built at the beginning of the project. Instead, the plan is built in stages at the completion of each cycle that defines the APF project life cycle. The budget and the timebox (that is, the window of time within which the project must be completed) of the APF project are specified at the outset. At the completion of each cycle, the team and the client review what has been done and adjust the plan going forward. Using this approach the solution emerges piecemeal. Because planning has been done just-in-time and because little time and effort was spent on planning and scheduling solution components that never ended up in the final solution, an APF project finishes in less time and less cost than a TPM project.

  • xPM projects do not follow a plan in the sense of TPM or APF projects. Instead, an xPM project makes informed guesses as to what the final goal (or solution) will be. The guess is not very specific, as Figure I.2 conveys. A cycle of work is planned based on the assumption that the guess is reasonable. At the completion of the cycle, just as in the case of an APF project, a review of what was learned and discovered is factored into the specification of the goal and a new goal definition is produced. This new definition is probably a little more accurate than the original guess. Figure I.2 would interpret this by having the ellipse shrink in volume and move up or down. The next cycle of work is planned based on the new goal. This process continues for some number of cycles and results either in an acceptable solution or in the project being abandoned at the completion of some intermediate cycle. In most cases there is not a specified timebox or budget for an xPM project. Instead, the project ends when a solution has been delivered or the client has killed the project because the cycle deliverables did not seem to be converging on an acceptable solution.

    Click To expand
    Figure I.2: Plan-to-goal comparison.


Why We Wrote This Book

We believe a number of professionals are looking for some help. We can fill their needs with this book. When scheduled training is not available or practical, our book can help. It is written to be studied. It is written to guide you as you learn project management. It is written to be a self-paced resource, one that will immerse you in managing a project for a simulated company. Let it work with you through the entire project life cycle.

On a more altruistic level, we have three reasons for writing this third edition:

  • To come to the rescue of the discipline of project management. We believe that it is seriously out of alignment with the needs of our businesses. The high failure rates of projects are evidence of that misalignment. The problem is that project management is the hammer and all projects are seen as nails. This is a one-size-fits-all approach to project management, and it simply doesn’t work. The nature and characteristics of the project must dictate the type of management approach to be taken. Anything short of that will fail. As we have already shown, projects have fundamentally changed but our approach to managing them has not. We need a more robust approach to project management—one that recognizes the project environment and adapts accordingly.

  • To introduce APF. APF is really a hybrid that takes the best from TPM and xPM. It breaches the gap between projects with clearly defined goals and solutions and projects where the goal and the solution are not. The work that we report here is a work in progress. By putting it before our colleagues, we expect that others will contribute to its further maturation.

  • Our continual challenge to offer a practical how-to guide for project managers in the management of their projects. Our style is applications-oriented. While the book is based on sound concepts and principles of project management, it is by no means a theoretical treatise. It is written to be your companion.


How This Book Is Structured

The book consists of three parts organized into 21 chapters, an epilogue, and two appendices. We have followed the Project Management Body of Knowledge (PMBOK) standards advocated by the Project Management Institute (PMI). As far as we are able to tell, what we have done is entirely compatible with PMBOK in the sense that we have described approaches that do not contradict PMBOK. Once you have completed this book, you will have covered all nine knowledge areas of the PMBOK. PMI has recommended our book as one that every project manager should have in his or her library.

Part I: Traditional Project Management

Part I includes the entire second edition with a few notable exceptions. After two appearances by the O’Neill & Preigh Church Equipment Manufacturers, we have decided to retire the company from active duty. The new case is the Jack Neift Trucking Company.

The new case takes on a much different flavor than the one it replaces. It gives us a chance to introduce and have you practice some of the contemporary nuances of projects. We have also added or expanded the discussion of quality management, risk management, procurement management, estimation, and communications management. This brings the third edition into better alignment with PMBOK.

For the college and university faculty who are using our book in their courses, we have also added a few discussion questions at the end of each chapter. These are designed to actively engage the class in a sharing of ideas about how they would handle the situations presented.

Part II: Adaptive Project Framework

Part II is entirely new and the topic it introduces, Adaptive Project Framework, is also new. We leave the world of the traditional project manager behind in this part of the book. We have already introduced the idea that contemporary projects are very different from those that the engineering profession and construction industry used as their models for developing the traditional approach to project management. The world that we enter in this part of the book is the world of fast-paced, high-change, and complex projects. Traditionalists have tried unsuccessfully to adapt their ideas to these types of projects. The failure rates that have been reported are testimony to their inability to adapt traditional thinking to a nontraditional environment. In this part we take the initial step toward defining our new approach.

APF is the middle ground between TPM and xPM. In Chapter 19 we take our second step by considering projects whose goal is not or cannot be clearly stated. While APF may work for some of these projects, these projects tend to be exploratory in nature and do not fit well with the types of projects for which APF is best suited. In this part we introduce the extreme project and its management. The APF project is one in which requirements are reasonably well-known, whereas the extreme project’s requirements become known as part of the process of discovery that takes results from the iterative nature of the project. Another way of looking at the difference is that an APF project has a reasonably well-defined goal; an extreme project has a fuzzily defined goal at best.

Part III: Organizational Considerations

In Parts I and II we developed the project management approaches that we feel span the entire landscape of project types. In this part we develop two topics that treat the environment in which project management takes place: the project portfolio and its management and the Project Support Office. Projects are thus viewed in the larger context of the organization that they support.

Chapter 20 discusses project portfolio management. The focus in many organizations is shifting away from the management and control of single projects to a focus on a portfolio of projects. Accompanying this shift in focus is a shift toward considering the portfolio from an investment perspective just as the organization’s investment portfolio has been considered for many years. At the time we were researching new materials for this book, the only published book on project portfolio management was a collection of journal articles assembled by Lowell D. Dye and James S. Pennypacker (Project Portfolio Management, Center for Business Practices, 1999). There were no how-to books on project portfolio management. Chapter 20 is the first attempt to begin to explore the topic. We are not giving you a tome on project portfolio management, only a starter kit. By institutionalizing the approach we give you, you will be able to enhance these basic concepts.

Chapter 21 discusses the Project Support Office (PSO). The PSO is a popular and fast-growing entity in organizations that wish to provide proactive project support. A notable addition to this third edition is a complete treatment of the PSO, which is a much expanded treatment compared to the second edition.

Epilogue: Putting It All Together Finally

This is new with the third edition. As we suggest at the outset, project management is at a significant crossroads. The discipline has to adapt to the changing nature of projects. Some of the old has to give way to the new. For example, Rudd McGary is new to the team that produced this edition. He and I have agreed to use this epilogue to make our personal statements about where project management is as a discipline, where it needs to be as a discipline, and how it might get there.

Appendices

There are two appendices:

  • Appendix A tells you everything you need to know about the CD-ROM and how to access and use it. Of particular interest to the university and college faculty is that the CD-ROM contains reproducible slides of every figure and table in the book. The CD-ROM also contains all of the case study exercises.

  • Appendix B is an updated version of the bibliography from the second edition.


How to Use This Book

The original target audience for this book was the practicing project manager. However, as we discovered, many of the second edition sales were to university and college faculty. We certainly want to encourage their use of our book, so in this third edition we have expanded the target market to include both practicing project managers and faculty. We have added discussion questions to each chapter, and to assist in lecture preparation, we have put copies of all figures and tables on the CD-ROM.

Using This Book as a Guide for Project Managers

This book adapts very well to whatever your current knowledge of or experience with project management might be:

  • If you are unfamiliar with project management, you can learn the basics by simply reading and reflecting.

  • If you wish to advance to the next level, we offer a wealth of practice opportunities through the case exercises.

  • If you are more experienced, we offer several advanced topics, including APF and xPM in Parts II and III.

In all cases, the best way to read the book is front to back. If you are an experienced project manager, feel free to skip around and read the sections as a refresher course.

The seasoned professional project manager will find value in the book as well. We have gathered a number of tools and techniques that appeared in the first edition of this book. The Joint Project Planning session, the use of Post-It notes and whiteboards for building the project network, the completeness criteria for generating the Work Breakdown Structure, the use of work packages for professional staff development, and milestone trend charts are a few of our more noteworthy and original contributions.

Using This Book as a Textbook for a Project Management Course

This book also works well as a text for a management course. The general method of usage should be to assign specific reading from the book on topics to be discussed in the class. In addition, use the case study to tie the disparate range of topics together into a cohesive discussion. The case study presents an opportunity for discussion among the students and represents a platform from which to work that gives the students a chance to discuss project management theories and techniques in a real-world setting. Discussion questions are already given in this book, but it is suggested that the teacher of the course take his or her own topics and work them into the case.


Who Should Read This Book

Even though our industry experience in information technology is clearly evident, we have tried to write this book to be industry-independent. Whether you are the seasoned project manager professional or a first-time project manager, you will find useful information in this book. We have incorporated a healthy mix of introductory and advanced topics. Much of what we have written comes from our own experiences as project managers, project management consultants, and trainers.

In all cases the material is presented in how-to mode. We expect you to use our tools and processes and firmly believe that this is the way to make that possible.


Jack Neift Trucking Company Case Study

This case is be used throughout the book to give examples of various project management ideas and techniques. It is both a project management case and a business case and is constructed to give a view of a case that is possible and in a real-world environment.

Purpose of the Case Study

The purpose of the case study is to tie abstract concepts and real-world activity together. The topics in this book are most useful to you if you can use them in your own setting. By presenting this case, we have tried to give you a realistic framework on which you can see many possible opportunities to use project management techniques. These ideas and techniques are found throughout the book, and the case helps show how to make the theoretical underpinnings of the book a useful real-world practice.

Using the Case Study

Almost all of the chapters have case study questions. Those questions map to a specific instance in the case that we are using to help you understand the concept better. The best thing to do is to work with the questions immediately after having read the text. That way, you will be getting reinforcement of the text in a real-world setting.

To prepare you for those questions, we introduce the case in some detail. As you read the case overview, keep in mind that the discussion questions are significant questions. They aren’t list-the-10-causes-of-the-Civil-War-type questions, but rather are questions that will test your understanding of the material you have just read. You must understand the case study to be able to answer the discussion questions. Rest easy, however, because many of the questions do not have a single right answer. Many will depend on your interpretation of the case setting.

Overview of the Business Situation

The management of Jack Neift Trucking was facing difficult times and decisions. The trucking industry was depressed, and it was getting harder and harder to stay afloat in a down economy and with major competition able to weather the financial storms. Jack Neift Trucking was a family-owned company, founded in 1937. In that year the father, Jack Neift, had started a trucking company with one truck and one client. The company control remained within the family generation after generation down to its present president, Bea Stoveburden.

The company had seen both strong and weak financial times, but because of its ability to adapt quickly to marketing conditions, it remained one of the strongest family-owned companies in the United States. The company was medium-sized, averaging just over 500 trailer units. Jack Neift Trucking serviced mostly states east of the Mississippi but also had corridors into Texas and Oklahoma. Routes into the New York City area generated the major part of the company’s income.

The problem Bea was facing as the president was an old one. Deadheading had been a term used by everyone on the trucking industry, and it was a cause for concern for Jack Neift Trucking. (Deadheading occurs when a truck goes from point to point without a load of cargo.) Rick Shaw, the operations director, saw a trend occurring that had more and more deadheading happening as the company concentrated on the Northeast corridor. While it was fairly easy to get loads going from the Midwest to the Northeast, the opposite was not true. As the deadheading increased, it meant that the assets of the company were underutilized more and more, making the company profit margin dangerously slim.

Bea convened a retreat of her top management team and challenged them all by saying, “What we’ve been doing won’t get us through this time. We need to think of new ways to service our customers and to make us a modern company at the same time.” (Happily she did not say, “Think outside of the box.”) “What is it that we need to control to make us more successful?”

Dee Livery, the national sales manager, started off the discussion by saying, “My salespeople need to get shipping information faster. We could help the deadheading situation by knowing quickly if a load was going to a certain point.”

Dusty Rhodes, the head dispatcher, suggested, “We could save a lot of time if we could get better information on our destinations and how they handle unloading. We have trucks sitting in lots for five or six hours because we didn’t know what the best time was to offload our cargo.”

Otto Entruck, the chief mechanic, chimed in, “We can get better preventive maintenance if we know where the rigs are going to go and how much mileage we are expecting to put on the tractors.”

Finally, Hy Rowler, the CFO, said, “If we can get control of our deadheading, we can remain competitive and begin to build a much better balance sheet for the company. But we have to respond faster, because the value of money is greater if we can turn it over more quickly than we are doing currently.”

The discussion went on long into the night with a variety of answers being suggested. Bea asked everyone to meet early next morning, at which time she would offer some ideas for further thought and then action.

Morning came and the group ate breakfast together while talking over the problems the company was having. After the plates were cleared, Bea began to describe a vision for the company. “We’re basically an old-time type of company. But we need to think like a modern one now. We aren’t going to get much relief from our problems with engineering or mechanical help. Our equipment is good, we keep our drivers a little longer than the industry average, and our customers keep coming back. But we need to be more responsive to our customers and, in turn, help our people be competitive in a highly competitive marketplace.”

“The one aspect that flows through all our needs is information. We need to get information passed between our people. We need to get information from our customers to our people and vice versa. We need to be able to link everyone in the company with others that can help them do their jobs. And we need to link everyone fast, so that information becomes a competitive tool. Here are some points to consider.”

“We’re still an old mainframe company, and our old machines are maxed out with only our accounting needs. We don’t have a system to deal with today’s trucking world and deal with it fast. So I’m going to ask all of you to take today and tomorrow to specify what you want in the way of information, and when we meet next, an IT consultant will be with us listening to our needs. The better we are at requirements, the better we’ll be at getting this project on the road.” With that, the meeting was ended.

The next two days were hectic for everyone concerned. Not only did they have their regular jobs to do, but also each of them was thinking of how to articulate the requirements they would have from the standpoint of information. The other part of the puzzle dealt with how the information was to be passed. The future of the company would depend in large part on framing the scope of the information technology project and beginning to articulate the requirements needed to satisfy current market needs. And it was going to depend on running the project efficiently.

The day came and the IT consultant met with the management team. Bea introduced Laurie Driver, a brilliant designer and consultant. With her was Sal Vation, introduced by Laurie as “One of the best project managers I’ve worked with. He’s certified and comes to the table with 20 years of project management experience.”

Bea began the meeting by outlining the needs. Then each of the management team, and their assistants, described the requirements needed to help Jack Neift Trucking back to the position it was used to. Dee Livery started. “I’ve talked this over with my second-in-command, Crash de Van, and we both agree that to get the maximum out of the sales force, we need to know specific loads as they are sold and their destinations. We need to know when the loads will arrive and what time they will be unloaded. If we know this, we can make a concerted effort to sell return loads in the locations to which we’re going. This information is our major need at first. I’ll work on an incentive plan for the sales staff to make sure we concentrate on cutting down deadheading. To do that I’ll need input from you, Hy.”

Hy Rowler said, “I’ll be happy to work with you on that problem, and we should look at exactly how we’re going to incentivize the sales force. We’ll need to give them information on loads as quickly as possible. Without that information getting to them, we’re not going to be able to make this all work.”

Rick Shaw suggested, “We also need to know what type of equipment we are going to use and to plan out its use over a period of time. We may want to look at a GPS system to get information about loads. Is this possible, Hy?”

The response was what Bea wanted to hear. “We can justify the cost only if we can see a scenario that will give us a fast repayment. The costs are possible, but we need to link them to the increased sales effort to counter deadheading. But yes, it’s possible. I haven’t run the numbers yet though, and this meeting will help me focus on the cost side of the equation. Since we’re talking about a major IT system, we need to get input from Laurie on how she views the cost.”

Laurie said, “This project will probably cost up to one million dollars just based on the small amount of requirements I’ve heard. What do you think, Sal?”

“You’re better at that type of cost estimate than I am, but I think an order-of-magnitude estimate at one million gives us somewhere to shoot at,” said Sal. “We can start with that as an assumption and back up the numbers better after we have a first project meeting.”

Laurie suggested, “I need to get each of you to gather requirements. Sal will start putting together a project plan. Bea, the charge for this will be our hourly rate, and we won’t exceed 80 hours of billing time to get to the next step where we show you our suggestions. If we go over 80 hours, we’ll eat the cost. Should we start?”

Bea knew that this was coming and had already made the decision. “Go,” she said. “Ladies, Gentlemen, your priority over the next two weeks is to work with Laurie and Sal to get the requirements we need. Let’s make this work.”

Turning to Sal, Bea asked, “Can you have a time line for the next two weeks to me before end of business today?”

“I’ll give you first cut by then,” said Sal.

Laurie said, “Let’s meet right after this meeting to go over our prospective needs.”

Laurie and Sal went to work immediately to get a schedule for the next two weeks. Since the sponsor was completely supportive, they both knew that access to key people would be easily arranged. Sal set up the schedule, Laurie checked off on it, and the first phase of the project began. Because of the sponsor involvement, Laurie was able to gather requirements very efficiently. The trick with the project was going to be to make sure that the needs of all the stakeholders were met. Eighty working hours later, Laurie and Sal were prepared to make the presentation to the sponsor and stakeholders. And Bea led the management team into the room.

Description of the Project

“Laurie, Sal, we’re all listening,” Bea began. “One request, please don’t get too IT-technical during this presentation. We want you to take care of that. It’s how well your solution fits our business needs that matters most to us. Not the inner workings of the system.”

With that Laurie and Sal began to explain the IT project they were proposing. “There are several major areas to be considered. But the overriding consideration is getting information passed between people working in one location to people working in others. And the information has to come in real time, without delay, or the value of the information is lost. So we’re suggesting a Web-based solution that uses a client/server configuration behind it. The sales force in the Northeast locations has to know as sales are made in the Midwest. This information will be input through laptops that the entire sales force will have. As a sale is made, the information will be posted to a server that can either push the information down-line or store it. The information will be immediately available to several users. The sales department will get the information; the operations department also. In addition, the head dispatcher and mechanic operations will get the information.

“As sales information comes in, it will also be sent to an application that will determine sales salary as part of an entirely new focus for the compensation plan. This information will also be tracked for the president, and total sales by geographical area will be updated to the minute. All of this will be available on a secure Web site that will have passwords for each of the major users.

“A major consideration for the project will be the decision of whether to build this system or try to find something off the shelf to use for this project.”

“Please explain,” asked Bea.

Sal responded, “Off the shelf means an application or system that has already been made and tested by others. The risk factors are usually lower, since it has already been out in the marketplace and others have a had a chance to work with it.”

“What is the downside?” asked Bea.

“Well,” said Sal, “if you don’t make it yourself, you can’t control what goes into it. So the final application may not fit exactly. And that little bit of difference can be a huge problem. And don’t believe anyone who says it’s easy to customize a current system or application. So there has to be some type of decision on both the cost involved with the two choices, the risks involved with the two choices, and the ease of use of the two choices.”

“We have run a cost/benefit analysis and determined that in this case it will be more efficient financially to code this in-house. We will contract the coding out to a company that has experience with this type of application, so while it will be specific to Jack Neift Trucking, the production people will have gone through similar projects recently. We couldn’t find anything that fit what you wanted to do without major rewriting in any case.”

“Any downside?” asked Bea.

Sal said, “While we believe the cost benefit is significant, we also realize a set of risks by writing it in-house. These risks, which I’ll give to you in a printed report, can raise the costs. So we’ll have to manage them.”

“A second major part of the project is the installing of a GPS tracking system. This is actually a lot easier, since there are currently several over-the-counter models that we can use.”

“As you can see, the project will cost approximately $850,000. We can give you a project schedule as soon as you say go.”

“We have several questions,” said Bea. And for the next two hours the management team asked everything they could think of so that they could clarify the scope of the project and how they were going to be involved. When that finished, Bea asked Laurie and Sal to step outside, and she polled the management team. “Are you satisfied you understand the scope of what we’re about to do? It’s important that everyone on the team give his or her complete support if we go ahead. Do we need more time for this decision?” She asked everyone on the team what he or she thought, and the reaction was unanimous. It was a cautious go. Bea called Laurie and Sal back in and gave them the news. The project was about to start.

Summary

Now you have the relevant background and details of the case that we use throughout the book. The Work Breakdown Structure begins with the high-level Waterfall model, which Winston Royce first suggested be used for IT projects in 1970. Using these high-level tasks, you are going to walk through the planning of a case from the top down.

There is no correct Work Breakdown Structure that fits every IT project. So as you go, you will find some latitude as to the tasks you place within the high-level tasks. If you are already in IT, you’ll recognize the sequence of major tasks. Use these as your guideposts to do the rest of the case study throughout the first part of this book.

The CD-ROM included in this book has a copy of Microsoft Project on it. The very high-level WBS, which is included, is only a start. Each time you go further into detail in the WBS, save your work as a new version. That way, you will be able to track the progress of the planning in the WBS and also be able to see at what point in the process you can consider resourcing, risk management, and all the other topics discussed in Part I.

The key to any WBS is getting the first major topics correct. We’ve already done that for you; now you need to consider how to do the rest. You may wish to find experts in each of the major task areas and ask them how long they think a project like the one described would take. You have been given some cost constraints, and it’s necessary to get this project done as soon as possible, but aside from that, you need to put your WBS together based either on your own experience or by talking to others.

An interesting exercise might be to form a work group and do the WBS together as you would with a project team. Each person on the team could have a specific area to break down, and in the process working together, you would get good information about putting a WBS together with a project team.

Good luck with this practical application of what the book discusses!


Putting It All Together

We have given you our assessment of the project management environment and how it has led us to propose a taxonomy of approaches—traditional project management (TPM), Adaptive Project Framework (APF), and extreme project management (xPM). Based on what we know about the types of projects that the project manager encounters, we believe that TPM, APF, and xPM represent a rich enough taxonomy to handle these very diverse project types.


Part One: Traditional Project Management

Chapter List

Chapter 1: What Is a Project?
Chapter 2: What Is Traditional Project Management?
Chapter 3: Scoping the Project
Chapter 4: Identifying Project Activities
Chapter 5: Estimating Duration, Resource Requirements, and Cost
Chapter 6: Constructing and Analyzing the Project Network Diagram
Chapter 7: Finalizing the Schedule and Cost Based on Resource Availability
Chapter 8: Organizing and Conducting the Joint Project Planning Session
Chapter 9: Recruiting, Organizing, and Managing the Project Team
Chapter 10: Monitoring and Controlling Progress
Chapter 11: Closing Out the Projects
Chapter 12: Critical Chain Project Management

We think you will find our treatment of traditional project management (TPM) a refreshing change from the usual fare you have been subjected to. In keeping with the format of the second edition, there will be plenty of

opportunity to practice the tools and techniques that we have used successfully for many years and are now sharing with you. In all of the chapters throughout the book, we close with a Discussion Questions section. These questions are thought-provoking and should give those reading this book food for thought and the faculty teaching from this book ample opportunity to engage the class in lively discussion. The questions will often set up a situation and ask for a recommended action. There are no right answers. The short, practical exercises; thought-provoking discussion questions; and comprehensive simulated problems reinforce your practice of newly acquired knowledge. You’ll also find a rich source of practice-oriented materials, such as the use of Post-It notes and whiteboards for project planning, many of which are not to be found in other books on the subject.

For those who are familiar with the second edition, you will note that Part I in this edition contains essentially the entire second edition. In other words, it covers all of traditional project management. We have not deleted any material on traditional project management but have actually added some new material. In Part I, you will find new or expanded discussions of the project management environment, risk management, procurement management, managing client expectation, estimating cost, organizing the project team, establishing team operating rules, communications management, change management, project status meetings, and critical chain project management.

Good luck!


Chapter 1: What Is a Project?

Things are not always what they seem.

—Phaedrus, Roman writer and fabulist

Defining a Project

To put projects into perspective, you need a definition—a common starting point. All too often people call any work they have to do a “project.” Projects actually have a very specific definition. If a set of tasks or work to be done does not meet the strict definition, then it cannot be called a project. To use the project management techniques presented in this book, you must first have a project.

A project is a sequence of unique, complex, and connected activities having one goal or purpose and that must be completed by a specific time, within budget, and according to specification.

Start Sidebar
Chapter Learning Objectives

After reading this chapter you will be able to:

  • Define a project

  • List a project’s characteristics

  • Distinguish a project from a program, activity, and task

  • Understand the three parameters that constrain a project

  • Know the importance of defining and using a project classification rule

  • Understand the issues around scope creep, hope creep, effort creep, and feature creep

End Sidebar

This definition tells us quite a bit about a project. To appreciate just what constitutes a project let’s look at each part of the definition.

Sequence of Activities

A project comprises a number of activities that must be completed in some specified order, or sequence. An activity is a defined chunk of work.

Cross-Reference

We expand on this informal definition of an activity later in Chapter 4.

The sequence of the activities is based on technical requirements, not on management prerogatives. To determine the sequence, it is helpful to think in terms of inputs and outputs.

  • What is needed as input in order to begin working on this activity?

  • What activities produce those as output?

The output of one activity or set of activities becomes the input to another activity or set of activities.

Specifying sequence based on resource constraints or statements such as “Pete will work on activity B as soon as he finishes working on activity A” should be avoided because they establish an artificial relationship between activities. What if Pete wasn’t available at all? Resource constraints aren’t ignored when we actually schedule activities. The decision of what resources to use and when to use them comes later in the project planning activities.

Unique Activities

The activities in a project must be unique. A project has never happened before, and it will never happen again under the same conditions. Something is always different each time the activities of a project are repeated. Usually the variations are random in nature—for example, a part is delayed, someone is sick, a power failure occurs. These are random events that can happen, but we never are sure of when, how, and with what impact on the schedule. These random variations are the challenge for the project manager.

Complex Activities

The activities that make up the project are not simple, repetitive acts, such as mowing the lawn, painting the house, washing the car, or loading the delivery truck. They are complex. For example, designing an intuitive user interface to an application system is a complex activity.

Connected Activities

Connectedness implies that there is a logical or technical relationship between pairs of activities. There is an order to the sequence in which the activities that make up the project must be completed. They are considered connected because the output from one activity is the input to another. For example, we must design the computer program before we can program it.

You could have a list of unconnected activities that must all be complete in order to complete the project. For example, consider painting the interior rooms of a house. With some exceptions, the rooms can be painted in any order. The interior of a house is not completely painted until all its rooms have been painted, but they may be painted in any order. Painting the house is a collection of activities, but it is not considered a project according to the definition.

One Goal

Projects must have a single goal, for example, to design an inner-city playground for ADC (Aid to Dependent Children) families. However, very large or complex projects may be divided into several subprojects, each of which is a project in its own right. This division makes for better management control. For example, subprojects can be defined at the department, division, or geographic level. This artificial decomposition of a complex project into subprojects often simplifies the scheduling of resources and reduces the need for interdepartmental communications while a specific activity is worked on. The downside is that the projects are now interdependent. Even though interdependency adds another layer of complexity and communication, it can be handled.

Specified Time

Projects have a specified completion date. This date can be self-imposed by management or externally specified by a customer or government agency. The deadline is beyond the control of anyone working on the project. The project is over on the specified completion date whether or not the project work has been completed.

Within Budget

Projects also have resource limits, such as a limited amount of people, money, or machines that are dedicated to the project. While these resources can be adjusted up or down by management, they are considered fixed resources to the project manager. For example, suppose a company has only one Web designer at the moment. That is the fixed resource that is available to project managers. Senior management can change the number of resources, but that luxury is not available to the project manager. If the one Web designer is fully scheduled, the project manager has a resource conflict that he or she cannot resolve.

Cross-Reference

We cover resource limits in more detail in Chapter 7.

According to Specification

The customer, or the recipient of the project’s deliverables, expects a certain level of functionality and quality from the project. These expectations can be self-imposed, such as the specification of the project completion date, or customer-specified, such as producing the sales report on a weekly basis.

Although the project manager treats the specification as fixed, the reality of the situation is that any number of factors can cause the specification to change. For example, the customer may not have defined the requirements completely, or the business situation may have changed (this happens in long projects). It is unrealistic to expect the specification to remain fixed through the life of the project. Systems specification can and will change, thereby presenting special challenges to the project manager.

Cross-Reference

We show you how to handle changing client requirements effectively in Chapter 10.


What Is a Program?

A program is a collection of projects. The projects must be completed in a specific order for the program to be considered complete. Because programs comprise multiple projects, they are larger in scope than a single project. For example, the United States government has a space program that includes several projects such as the Challenger project. A construction company contracts a program to build an industrial technology park with several separate projects.

Unlike projects, programs can have many goals. The NASA space program is such that every launch of a new mission includes several dozen projects in the form of scientific experiments. Except for the fact that they are all aboard the same spacecraft, the experiments are independent of one another and together define a program.


Project Parameters

Five constraints operate on every project:

  • Scope

  • Quality

  • Cost

  • Time

  • Resources

These constraints are an interdependent set; a change in one can cause a change in another constraint to restore the equilibrium of the project. In this context, the set of five parameters form a system that must remain in balance for the project to be in balance. Because they are so important to the success or failure of the project, let’s discuss them individually.

Scope

Scope is a statement that defines the boundaries of the project. It tells not only what will be done but also what will not be done. In the information systems industry, scope is often referred to as a functional specification. In the engineering profession, it is generally called a statement of work. Scope may also be referred to as a document of understanding, a scoping statement, a project initiation document, and a project request form. Whatever its name, this document is the foundation for all project work to follow. It is critical that scope be correct. We spend considerable time discussing exactly how that should happen in Chapter 3 where we talk about Conditions of Satisfaction.

Beginning a project on the right foot is important, and so is staying on the right foot. It is no secret that scope can change. We do not know how or when, but it will change. Detecting that change and deciding how to accommodate it in the project plan are major challenges for the project manager.

Cross-Reference

Chapter 3 is devoted to defining project scope, and scope management is discussed in Chapter 10 in the section Managing Change.

Quality

Two types of quality are part of every project:

  • The first is product quality. This refers to the quality of the deliverable from the project. The traditional tools of quality control, discussed in Chapter 2, are used to ensure product quality.

  • The second type of quality is process quality, which is the quality of the project management process itself. The focus is on how well the project management process works and how can it be improved. Continuous quality improvement and process quality management are the tools used to measure process quality. These are discussed in Chapter 5.

A sound quality management program with processes in place that monitor the work in a project is a good investment. Not only does it contribute to customer satisfaction, it helps organizations use their resources more effectively and efficiently by reducing waste and rework. Quality management is one area that should not be compromised. The payoff is a higher probability of successfully completing the project and satisfying the customer.

Cost

The dollar cost of doing the project is another variable that defines the project. It is best thought of as the budget that has been established for the project. This is particularly important for projects that create deliverables that are sold either commercially or to an external customer.

Cost is a major consideration throughout the project management life cycle. The first consideration occurs at an early and informal stage in the life of a project. The customer can simply offer a figure about equal to what he or she had in mind for the project. Depending on how much thought the customer put into it, the number could be fairly close to or wide of the actual cost for the project. Consultants often encounter situations in which the customer is willing to spend only a certain amount for the work. In these situations, you do what you can with what you have. In more formal situations, the project manager prepares a proposal for the projected work. That proposal includes an estimate (perhaps even a quote) of the total cost of the project. Even if a preliminary figure had been supplied by the project manager, the proposal allows the customer to base his or her go/no-go decision on better estimates.

Time

The customer specifies a timeframe or deadline date within which the project must be completed. To a certain extent, cost and time are inversely related to one another. The time a project takes to be completed can be reduced, but cost increases as a result.

Time is an interesting resource. It can’t be inventoried. It is consumed whether we use it or not. The objective for the project manager is to use the future time allotted to the project in the most effective and productive ways possible. Future time (time that has not yet occurred) can be a resource to be traded within a project or across projects. Once a project has begun, the prime resource available to the project manager to keep the project on schedule or get it back on schedule is time. A good project manager realizes this and protects the future time resource jealously.

Cross-Reference

We cover this topic in more detail in Chapter 5, Chapter 7 (where we talk about scheduling project activities), and Chapter 9.

Resources

Resources are assets, such as people, equipment, physical facilities, or inventory, that have limited availabilities, can be scheduled, or can be leased from an outside party. Some are fixed; others are variable only in the long term. In any case, they are central to the scheduling of project activities and the orderly completion of the project.

For systems development projects, people are the major resource. Another valuable resource for systems projects is the availability of computer processing time (mostly for testing purposes), which can present significant problems to the project manager with regard to project scheduling.


The Scope Triangle

Projects are dynamic systems that must be kept in equilibrium. Not an easy task, as we shall see! Figure 1.1 illustrates the dynamics of the situation.

The geographic area inside the triangle represents the scope and quality of the project. Lines representing time, cost, and resource availability bound scope and quality. Time is the window of time within which the project must be completed. Cost is the dollar budget available to complete the project. Resources are any consumables used on the project. People, equipment availability, and facilities are examples.

Click To expand
Figure 1.1: The scope triangle.
Note

While the accountants will tell us that everything can be reduced to dollars, and they are right, we will separate resources as defined here. They are controllable by the project manager and need to be separately identified for that reason.

The project plan will have identified the time, cost, and resource availability needed to deliver the scope and quality of a project. In other words, the project is in equilibrium at the completion of the project planning session and approval of the commitment of resources and dollars to the project. That will not last too long, however. Change is waiting around the corner.

The scope triangle offers a number of insights into the changes that can occur in the life of the project. For example, the triangle represents a system in balance before any project work has been done. The sides are long enough to encompass the area generated by the scope and quality statements. Not long after work begins, something is sure to change. Perhaps the customer calls with an additional requirement for a feature that was not envisioned during the planning sessions. Perhaps the market opportunities have changed, and it is necessary to reschedule the deliverables to an earlier date, or a key team member leaves the company and is difficult to replace. Any one of these changes throws the system out of balance.

The project manager controls resource utilization and work schedules. Management controls cost and resource level. The customer controls scope, quality, and delivery dates. These points suggest a hierarchy for the project manager as solutions to accommodate the changes are sought. We return to this topic in greater detail in Chapter 10.

Scope Creep

Scope creep is the term that has come to mean any change in the project that was not in the original plan. Change is constant. To expect otherwise is simply unrealistic. Changes occur for several reasons that have nothing to do with the ability or foresight of the customer or the project manager. Market conditions are dynamic. The competition can introduce or announce an upcoming new version of its product. Your management might decide that getting to the market before the competition is necessary.

Your job as project manager is to figure out how these changes can be accommodated. Tough job, but somebody has to do it! Regardless of how the scope change occurs, it is your job as project manager to figure out how, if at all, you can accommodate the change.

Hope Creep

Hope creep is the result of a project team member’s getting behind schedule, reporting that he or she is on schedule, but hoping to get back on schedule by the next report date. Hope creep is a real problem for the project manager. There will be several activity managers within your project, team members who manage a hunk of work. They do not want to give you bad news, so they are prone to tell you that their work is proceeding according to schedule when, in fact, it is not. It is their hope that they will catch up by the next report period, so they mislead you into thinking that they are on schedule. The activity managers hope that they will catch up by completing some work ahead of schedule to make up the slippage. The project manager must be able to verify the accuracy of the status reports received from the team members. This does not mean that the project manager has to check into the details of every status report. Random checks can be used effectively.

Effort Creep

Effort creep is the result of the team member’s working but not making progress proportionate to the work expended. Every one of us has worked on a project that always seems to be 95 percent complete no matter how much effort is expended to complete it. Each week the status report records progress, but the amount of work remaining doesn’t seem to decrease proportionately. Other than random checks, the only effective thing that the project manager can do is to increase the frequency of status reporting by those team members who seem to suffer from effort creep.

Feature Creep

Closely related to scope creep is feature creep. Feature creep results when the team members arbitrarily add features and functions to the deliverable that they think the customer would want to have. The problem is that the customer didn’t specify the feature, probably for good reason. If the team member has strong feelings about the need for this new feature, formal change management procedures can be employed.

Cross-Reference

The change management process is discussed in Chapter 10.

An example illustrates the point. The programmer is busy coding a particular module in the system. He or she gets an idea that the customer might appreciate having another option included. The systems requirements document does not mention this option. It seems so trivial that the programmer decides to include it rather than go through the lengthy change process.

While this approach may seem rather innocent, let’s look at some possible consequences. First of all, because the feature is not in the system requirements document, it is also not in the acceptance test procedure, the systems documentation, the user documentation, and the user training program. What will happen if something goes wrong with the new option? How will another programmer know what to do? What will happen when the user discovers the option and asks for some modification of it? You can see the consequences of such an innocent attempt to please. The message here is that a formal change request must be filed, and if it is approved, the project plan and all related activities will be appropriately modified.


Project Classifications

In this section, we characterize projects in terms of a detailed set of variables. The value of these variables is used to determine which parts of the project management methodology must be used and which parts are left to the discretion of the project manager to use as he or she sees fit.

Classification by Project Characteristics

Many organizations have chosen to define a classification of projects based on such project characteristics as these:

  • Risk—Establish levels of risk (high, medium, low)

  • Business value—Establish levels (high, medium, low)

  • Length—Establish several categories (i.e., 3 months, 3 to 6 months, 6 to 12 months, etc.)

  • Complexity—Establish categories (high, medium, low)

  • Technology used—Establish several categories (well-established, used somewhat, basic familiarity, unknown, etc.)

  • Number of departments affected—Establish some categories (one, few, several, all)

  • Cost

The project profile determines the classification of the project. The classification defines the extent to which the project management methodology is to be used.

We strongly advocate this approach because it adapts the methodology to the project. “One size fits all” does not work in project management. In the final analysis, we defer to the judgment of the project manager. Apart from the parts required by the organization, the project manager should adopt whatever parts of the methodology he or she feels improves his or her ability to help successfully manage the project. Period.

Project types are as follows:

Type A projects. Projects of Type A are the high-business-value, high- complexity projects. They are the most challenging projects the organization undertakes. Type A projects use the latest technology, which, when coupled with high complexity, causes risk to be high also. To maximize the probability of success, the organization requires that these projects utilize all the methods and tools available in their project management methodology. An example of a Type A project is the introduction of a new technology into an existing product that has been very profitable for the company.

Type B projects. Projects of Type B are shorter in length, yet they still are significant projects for the organization. All of the methods and tools in the project management process are probably required. The projects generally have good business value and are technologically challenging. Many product development projects fall in this category.

Type C projects. Projects of Type C are the projects occurring most frequently in an organization. They are short by comparison and use established technology. Many are projects that deal with the infrastructure of the organization. A typical project team consists of five people, the project lasts six months, and the project is based on a less-than-adequate scope statement. Many of the methods and tools are not required for these projects. The project manager uses those tools, which are optional, if he or she sees value in their use.

Type D projects. Projects of Type D just meet the definition of a project and may require only a scope statement and a few scheduling pieces of information. A typical Type D project involves making a minor change in an existing process or procedure or revising a course in the training curriculum.

Table 1.1 gives a hypothetical example of a classification rule.

Table 1.1: Example Project Classes and Definitions
CLASS | DURATION | RISK | COMPLEXITY | TECHNOLOGY | LIKELIHOOD OF PROBLEMs
Type A | > 18 months | High | High | Breakthrough | Certain
Type B | 9–18 months | Medium | Medium | Current | Likely
Type C | 3–9 months | Low | Low | Best of breed | Some
Type D | < 3 months | Very low | Very low | Practical | None

These four types of projects might use the parts of the methodology shown in Figure 1.2. The figure lists the methods and tools that are required and optional given the type of project.

Click To expand
Figure 1.2: The use of required and optional parts of the methodology by type of project.

Classification by Project Type

There are many situations where an organization repeats projects that are of the same type. Following are some examples of project types:

  • Installing software

  • Recruiting and hiring

  • Setting up hardware in a field office

  • Soliciting, evaluating, and selecting vendors

  • Updating a corporate procedure

  • Developing application systems

These projects may be repeated several times each year and probably will follow a similar set of steps each time they are done.

Cross-Reference

We look at the ramifications of that repetition when we discuss Work Breakdown Structure templates in Chapter 4.

It is important to note then that we can classify project by type of project. The value in doing this is that each type of project utilizes a specific subset of the project management methodology. For example, projects that involve updating a corporate procedure are far less risky than application systems development projects. Therefore, the risk management aspects of each are very different. Risk management processes will be less important in the corporate procedure project; conversely, they will be very important in the applications development project.


Putting It All Together

You now should know that we advocate a very specific definition of a project. If a collection of work is to be called a project, it must meet the definition. Once we know that it is a project, it will be subjected to a specific set of requirements as to its management. That is the topic of the next chapter.


Discussion Questions

  1. Suppose the scope triangle were modified as follows: Resource Availability occupies the center. The three sides are Scope, Cost, and Schedule. Interpret this triangle as if it were a system in balance. What is likely to happen when a specific resource on your project is concurrently allocated to more and more projects? As project manager, how would you deal with these situations? Be specific.

  2. Where would you be able to bring about cost savings as a program manager for a company? Discuss these using the standard project constraints.

  3. Discuss ways that scope creep occurred on projects with which you have been associated. Was the project manager able to reverse scope creep? Is it possible to reverse scope creep? Defend either your yes or no answer.


Chapter 2: What Is Traditional Project Management?

A manager...sets objectives,...organizes,...motivates,... communicates,...measures,...and develops people. Every manager does these things—knowingly or not. A manager may do them well or may do them wretchedly but always does them.

—Peter Drucker

Principles of Traditional Project Management

When we think of the principles of management, we usually associate them with the management of people. The management of people includes defining what the business unit will do, planning for the number and type of staff who will do it, organizing the staff, monitoring their performance of the tasks assigned them, and finally bringing a close to their efforts. Those same principles also apply to projects.

Start Sidebar
Chapter Learning Objectives

After reading this chapter you will be able to:

  • Understand the relationship between people management and project management

  • Appreciate the importance of project planning

  • Recognize the characteristics of projects that fail

  • Understand the five phases of the traditional project management life cycle

  • See how the project plan is a model

  • Use the tools of quality management as they apply to improving the process of traditional project management

  • Understand how risk management can be applied to the steps that describe the traditional project management process

  • Understand the procurement process

  • Explain the relationship between traditional project management and the systems development life cycle

  • Explain the relationship between traditional project management and the new product development life cycle

  • Appreciate the significance of the project pain curve

End Sidebar

Project management is a method and a set of techniques based on the accepted principles of management used for planning, estimating, and controlling work activities to reach a desired end result on time—within budget and according to specification. The following sections investigate how these management principles apply to the phases of a project.

Defining

One of the first tasks for project managers is to define the work that needs to be done in their area of responsibility. Exactly the same task applies to people management. In project management, however, the defining phase is very formal, while in people management it can often be informal.

There is a parallel in traditional project management (TPM). For the project manager, defining the tasks to do is a preliminary phase of the project life cycle and an important one. In this phase, the requestor (also known as the customer) and the project manager come to an agreement about several important aspects of the project. Regardless of the format used, every good defining phase answers five basic questions:

  • What is the problem or opportunity to be addressed?

  • What is the goal of the project?

  • What objectives must be met to accomplish the goal?

  • How will we determine if the project has been successful?

  • Are there any assumptions, risks, or obstacles that may affect project success?

The defining phase sets the scope of the project. It forms the basis for deciding if a particular function or feature is within the scope of the project.

Remember, even the best of intentions to define project scope will fall short of the mark. The scope of the project can change for a variety of reasons, which we investigate in Chapter 10 in the section titled Managing Change—sometimes far more frequently than the project manager would prefer. As mentioned in the previous chapter, these changes are called scope creep; they are a way of life in today’s organizations. Scope creep can be the bane of the project manager if it is not dealt with effectively. Scope creep occurs for a variety of reasons, from something the client forgot to include in the business requirements document to a change in business priorities that must be reflected in the project.

The project manager must respond to scope creep by documenting the alternative courses of action and their respective consequences on the project plan. A good project manager will have a formal change management process in place to address scope creep. We have much more to say on this topic in Chapter 10.

Planning

How often have you heard it said that planning is a waste of time? No sooner is the plan completed than someone comes along to change it. These same naysayers would also argue that the plan, once completed, is disregarded and merely put on the shelf so the team can get down to doing some real work. In people management, the planning activity involves deciding on the types of people resources that will be needed to discharge the responsibilities of the department. That means identifying the types of skills needed and the number of people possessing those skills.

In TPM the project plan is indispensable. Not only is it a roadmap to how the work will be performed, but it is also a tool for decision making. The plan suggests alternative approaches, schedules, and resource requirements from which the project manager can select the best alternative.

Note

Understand that a project plan is dynamic. We expect it to change. A complete plan will clearly state the tasks that need to be done, why they are necessary, who will do what, when it will be completed, what resources will be needed, and what crite- ria must be met in order for the project to be declared complete and successful. However, TPM is not designed for change, even though it is expected. In Part II of the book, we discuss project management approaches that are designed for change. One of the many advantages of these approaches is that change is accommodated within the process itself. Change in the TPM world is something the project manager would rather not deal with. Change to the project manager who is using the approaches discussed in Part II is a necessary ingredient of a successful project.

There are three benefits to developing a project plan:

Planning reduces uncertainty. Even though we would never expect the project work to occur exactly as planned, planning the work allows us to consider the likely outcomes and to put the necessary corrective measures in place.

Planning increases understanding. The mere act of planning gives us a better understanding of the goals and objectives of the project. Even if we were to discard the plan, we would still benefit from having done the exercise.

Planning improves efficiency. Once we have defined the project plan and the necessary resources to carry out the plan, we can schedule the work to take advantage of resource availability. We also can schedule work in parallel; that is, we can do tasks concurrently, rather than in series. By doing tasks concurrently, we can shorten the total duration of the project. We can maximize our use of resources and complete the project work in less time than by taking other approaches.

Just as Alice needed to know where in Wonderland she was going, so does the project manager. Not knowing the parameters of a project prevents measurement of progress and results in never knowing when the project is complete. The plan also provides a basis for measuring work planned against work performed.

Executing

Executing the project plan is equivalent to authorizing your staff to perform the tasks that define their respective jobs. Each staff member knows what is expected of him or her, how to accomplish the work, and when to have it completed.

Executing the project plan involves four steps. In addition to organizing the people who will work on the project, a project manager also needs to do the following:

  1. Identify the specific resources (person power, materials, and money) that will be required to accomplish the work defined in the plan.

  2. Assign workers to activities.

  3. Schedule activities with specific start and end dates.

  4. Launch the plan.

The final specification of the project schedule brings together all the variables associated with the project. To facilitate this exercise, we introduce a number of tools and techniques that we have developed and religiously use in our consulting practice. These are explained and illustrated in Chapters 6 through 11.

Controlling

As part of the planning process, an initial schedule is created. The schedule lists the following:

  • What must be accomplished in the project

  • When each task must be accomplished

  • Who is responsible for completing each task

  • What deliverables are expected as a result of completing the project

No matter how attentive the team is when creating the plan, the project work will not go according to plan. Schedules slip—this is the reality of project management. The project manager must have a system in place that constantly monitors the project progress, or lack thereof. The monitoring system summarizes the completed work measured against the plan and also looks ahead to forewarn of potential problems.

Cross-Reference

Problem-escalation procedures and a formal change management process, which we discuss in Chapter 10, are essential to effective project control.

Closing

Closing a project is a formal means of signaling the completion of the project work and the delivery of the results to the customer. In managing people, the equivalent action is to signal the end of a task with some sign of completion and assign the individual to another task.

The closing phase evaluates what occurred during the project and provides historical information for use in planning and executing later projects. This historical information is best kept in a document called a project notebook. To be useful, the notebook should be in an electronic form so that it is easy to retrieve and summarize project information for use in projects currently being planned. Every good closing provides answers to the following questions:

  • Do the project deliverables meet the expectations of the requestor?

  • Do the project deliverables meet the expectations of the project manager?

  • Did the project team complete the project according to plan?

  • What information was collected that will help with later projects?

  • How well did the project management methodology work and how well did the project team follow it?

  • What lessons have we learned from this project?

The closing phase is very important to TPM, but unfortunately it is the part that is most often neglected or omitted by management. Rather than spending time in the closing phase of this project, the project manager is under pressure to get started on the next project. Often the next project is already behind schedule and work hasn’t yet begun. It is easy for management to skip the closing phase because it is perceived as an overhead expense, is easily overlooked, and delays getting the next project underway.


Traditional Project Management Life Cycle

Over the years that we have consulted and offered training in TPM, we observed a number of project management methodologies that, on first look, seem to differ from one another. On closer examination, we actually found that there are a number of underlying principles that are present in the more successful methodologies. From them, we fashioned a TPM life cycle that was first published by Weiss and Wysocki.1

Since that publication, we continue to compare this life cycle with client methodologies. The results confirm our assumptions that features reoccur in successful methodologies. More recently the Project Management Institute published its Project Management Body of Knowledge (PMBOK), which has an underlying life cycle that is remarkably similar to the one we adopted in our consulting practice. The one we present in this book parallels PMBOK. If your organization has a methodology in place, compare it to the model given here. If you map your methodology to this life cycle, you may discover that you already do bits and pieces of TPM without realizing it. You may not be referring to each phase by the same names as we do, but the actions in that phase are probably what you’ve been doing all these years. Take comfort, for TPM can be defined as nothing more than organized common sense. In fact, if it were not common sense, we would have a difficult time gaining any converts!

[1] 1Joseph W. Weiss and Robert K. Wysocki, 5-Phase Project Management: A Practical Planning and Implementation Guide (Reading, Mass.: Perseus Books, 1992), ISBN 0-201-56316-9.

Phases of Traditional Project Management

There are five phases to the TPM life cycle, each of which contains five steps:

  1. Scope the project.

    • State the problem/opportunity.

    • Establish the project goal.

    • Define the project objectives.

    • Identify the success criteria.

    • List assumptions, risks, and obstacles.

  2. Develop the project plan.

    • Identify project activities.

    • Estimate activity duration.

    • Determine resource requirements.

    • Construct/analyze the project network.

    • Prepare the project proposal.

  3. Launch the plan.

    • Recruit and organize the project team.

    • Establish team operating rules.

    • Level project resources.

    • Schedule work packages.

    • Document work packages.

  4. Monitor/control project progress.

    • Establish progress reporting system.

    • Install change control tools/process.

    • Define problem-escalation process.

    • Monitor project progress versus plan.

    • Revise project plans.

  5. Close out the project.

    • Obtain client acceptance.

    • Install project deliverables.

    • Complete project documentation.

    • Complete post-implementation audit.

    • Issue final project report.

The five phases are performed in sequence, with one feedback loop from the monitor/control progress phase to the develop detailed plan phase. This model is adapted from the PMI PMBOK and from an earlier work of one of the authors (Weiss and Wysocki).2

Figure 2.1 shows the TPM life cycle. The following sections walk you through the five phases of the TPM life cycle. Please refer to this figure as you read the following sections.

Scope the Project

The first phase of the TPM life cycle is the scoping phase. This phase is the one most often given the least attention. The scoping phase plans the project.

Planning—or rather, effective planning—is painful. For many people, planning doesn’t seem like real work. Projects are always behind schedule, so we are tempted to skip planning so that we can get down to the real work of the project. Experience has shown that good planning can actually decrease the time required to complete a project, even taking the planning time into account. Planning reduces risk and, in our experience, can increase productivity by as much as 50 percent. We find it interesting that project teams do not have time to plan, but they do have time to do work over again. What insanity!

Every project has one goal. The goal is an agreement between the requestor and the project manager about the deliverable—what is to be accomplished in the project. The goal tells the project developers where they are going so that, when the project is completed, they know it. Ideally, the scoping phase begins with an exchange of information between a requestor and a provider (usually the project manager). The information exchange usually involves a conversation between the two parties to assure one another that the request is clearly understood and the response, in the form of deliverables, is also clearly understood.

In our TPM life cycle, the goal is bounded by a number of objective statements. These objective statements clarify the fuzziness of the goal statement. Taken as a pair, the goal and objective statements scope the project. They are the framework within which the entire project planning process can be successfully conducted.

[2] 2Joseph W. Weiss and Robert K. Wysocki, 5-Phase Project Management: A Practical Planning and Implementation Guide (Reading, Mass.: Perseus Books, 1992), ISBN 0-201-56316-9.

Click To expand
Figure 2.1: The TPM life cycle.

Once the scope is complete, it is documented in the form of the Project Overview Statement (POS). The POS is a brief document (usually one page) that describes, in the language of the business, the following:

  • What problem or opportunity is addressed by the project?

  • What are the project’s goal and objectives?

  • How will success be measured?

  • What assumptions, risks, and obstacles may affect the project that you wish to call to the attention of senior management?

The POS, or some form of it, is in wide use. We can trace the early history of the POS back to Texas Instruments in the early 1960s. TI used the POS to allow anyone in the organization to submit an idea for a project. It was the company’s version of a project initiation form. The POS is also referred to as a document of understanding, scope statement, initial project definition, and statement of work. In our consulting practice, we have encountered organizations that require risk analysis, cost/benefit analysis, return on investment calculations, internal rate of return estimates, and break-even analysis as attachments to the POS. This information is used to decide whether the project should go forward to the detailed planning phase. If the project, as described in the POS, is approved, it moves to the detailed plan phase.

Develop the Detailed Plan

The second phase of the TPM life cycle is to develop the project plan. In this phase, the details about the project are determined. This may be an exercise for one or two individuals, but it often takes place in a formal planning session attended by those who will impact or be impacted by the project.

Cross-Reference

We cover this planning session in more detail in Chapter 8.

The deliverable from this planning session is the project proposal. This document includes the following:

  • A detailed description of each work activity

  • The resources required to complete the activity

  • The scheduled start and end date of each activity

  • The estimated cost and completion date of the project

In some organizations there can be any number of attachments, such as feasibility studies, environmental impact statements, or best-of-breed analysis.

The project plan is a description of the events to come. In that sense, it is a model of the project. As events occur in the project, the model is affected and can change to describe how future events in the project are likely to occur.

Because the project plan is a model, we can use it to test alternative strategies for redirecting future events. As project work begins, the nature of the project changes—sometimes radically. Activities can get behind or ahead of schedule; team members can be reassigned, leave the company, or get sick. Market situations can change, rendering all or some of the project objectives obsolete. These events can occur one at a time or in clumps, and the project manager must be ready to analyze, decide, and act. You should already have an appreciation for the complexity of the project plan and work. There are, in fact, several dimensions to consider when trying to formulate a going-forward strategy. Here are just a few:

  • If a project activity finishes earlier or later than the schedule date, can the resource schedule for later activities be adjusted accordingly?

  • If one or more project activities finish late, can other resources assigned to the project be reallocated to restore the project to its original schedule?

  • How can the project manager simultaneously compress the project schedule while avoiding unresolvable resource scheduling conflicts?

  • What resources can be reallocated from one project to another without adversely affecting each project’s schedule?

Any one of these decision situations involves a number of interdependent variables. It is unlikely that any project manager could process these variables and all of the possible variations without the aid of a computer-based project model and the supporting software, such as Microsoft Project 2002, ABT Workbench, Open Plan, or any one of several other software packages.

Once the project proposal is approved, the project enters the next phase of the TPM life cycle, in which the final details of the work schedule are completed and project work begins.

Launch the Plan

The third phase of the TPM life cycle is to launch the plan. In this phase, the project team is specified. It is important to eliminate the notion that an individual is solely responsible for the success (or failure) of the project. It is true that you can point to examples in which the efforts of an individual brought the project to successful completion, but these events are rare. Although some of the specific team members could have been identified earlier in the life cycle, additional members are identified during this stage. In contemporary organizations, the project team is often cross-functional and can span other organizational boundaries.

In addition to identifying the team at this time:

  • The exact work schedules are determined.

  • Detailed descriptions of the tasks in the project are developed.

  • Team operating rules, reporting requirements, and project status meetings are established.

The completion of this final planning activity signals the beginning of the monitoring phase.

Monitor/Control Project Progress

As soon as project work commences, the project enters the monitoring phase. A number of project status reports will have been defined in the previous phase and are used to monitor the project’s progress. Some of these reports are used only by the project team, while others are distributed to management and the customer.

Change management is a big part of this phase, and procedures will have been installed as part of the launch phase to process change requests. Change requests will always cause some amount of project replanning. When the requests are received, the feedback loop is activated, and the project manager revisits the project plan to identify ways to accommodate the change request. Problems also can occur as work finishes ahead of or behind schedule. A problem-escalation procedure will have been defined during the launch phase to handle these situations.

Close Out the Project

The final phase of the TPM life cycle begins when the customer says the project is finished. The “doneness criteria” will have been specified and agreed to by the customer as part of the project plan. A number of activities occur to close out the project:

  • Install the deliverables.

  • File final reports and documentation.

  • Perform a post-implementation audit.

  • Celebrate!

Levels of Traditional Project Management

There are three variations to the TPM life cycle. Which cycle you use in a given project depends on what management needs you are trying to meet.

Defining, planning, organizing. This first and simplest of the three cycles is concerned with getting the project going. There is no follow-up on performance against plan. We have encountered a number of situations in which one person will be solely responsible for completing all project activities. In such cases there is value in planning the project, but limited value in implementing the control and close phases. Here the project manager and client are often the same person and the interest is only in laying out a strategy for doing the work. Often the project following this cycle will have to be planned in conjunction with one or more other projects. The intent is to set a time line for completing the project in conjunction with others underway. This cycle is closely related to good time-management practices. If you keep a to-do list, you will find your habits are quite comparable to this three-part cycle.

Defining, planning, organizing, controlling. The second cycle is most often thought of as project management. Getting the project started is only half (or actually much less than half) of the effort. The more people, the more activities, and the more resources involved, the more likely the project manager will need to follow with the control function. Things will go wrong—you can bet on it. A mechanism needs to be in place to identify problems early on and do something to keep the project moving ahead as planned.

Defining, planning, organizing, controlling, closing. The astute project manager will want to learn from the project that follows this cycle. Several questions can be answered from an audit of the records from completed projects.

Cross-Reference

Chapter 11 focuses on the closing activities.


Quality Management

In order to meet customer requirements, and do so on time and within budget, the project manager must incorporate sound quality management practices. He or she will be concerned with the quality of the following:

  • The product/service/process that is the deliverable from the project

  • The project management process itself

Countless books have been written on the product side of quality; we will not repeat those presentations here. Others have done a far better job than we could hope to achieve in this book. The bibliography in Appendix B lists some publications that may be of interest to you.

In this section we focus on the process of TPM. Our emphasis is on the two tools and techniques that we have successfully integrated and used in our consulting practice to improve the process of TPM: the Continuous Quality Management Model and the Process Quality Management Model.

Continuous quality management is a procedure that a company can use to improve its business processes. It is a way of life in those organizations that want to attain and sustain a competitive position in fast-paced information age industries. As shown in Figure 2.2, continuous quality management begins with a definition of vision, mission-critical success factors, and business processes.

A second tool is integrated after the definition steps. This tool, process quality management, is used to relate critical success factors to business processes. This establishes the foundation on which the Continuous Quality Management Model proceeds to conduct a gap analysis that identifies processes and steps within processes where improvement opportunities might be made. Any number of improvement projects can be undertaken, and the resulting improvements are checked against targeted improvements and further projects commissioned. Because new improvement opportunities always present themselves, a series of feedback loops, shown in Figure 2.2, continues the process.

Continuous Quality Management Model

Continuous quality management is most evident in those organizations that are customer-driven. Levi Strauss, Motorola, and Xerox are but a few. The companies that have applied for or won the coveted Baldrige Award, an award recognizing exemplary quality management within the company, are also on the list.

The Continuous Quality Management Model shown in Figure 2.2 is cyclical, as depicted by the feedback loops. Feedback loop A occurs when there have been significant process changes and the relationship between critical success factors (CSF) and process may have changed. Feedback loop B occurs when a business process may have changed and affected the gap analysis. Feedback loop C simply continues the priority scheme defined earlier and selects another business process for improvement. Feedback loop D usually involves continued improvement efforts on the same business process. The results of the current project may not have been as expected, or new improvement ideas may have arisen while the current project was being conducted. That is, the TPM phase of the model is adaptive. Scope changes will often result from lessons learned during project execution.

Process Quality Management Model

Figure 2.3 is a schematic of the Process Quality Management Model (PQMM). We have used this model successfully in our project management engagements that involve quality improvement programs. The model is based on the assumption that the enterprise has documented its mission, vision, and CSFs. With these in place, the processes that drive the business are identified and related to the CSFs using a grading system in which each business process is assigned a grade of A (excellent) through E (embryonic).

Click To expand
Figure 2.2: Continuous Quality Management Model.
Click To expand
Figure 2.3: The process quality management matrix.

The next step is to identify which business processes affect which CSFs and mark each with an X, as shown in Figure 2.3. The number of CSFs that have been related to each business process is counted, and the results are tabulated into the zone map. For example, in Figure 2.3 there are two business processes (P7 and P14) that were given a grade of C and that are related to 5 CSFs. That is reflected by the 2 in the cell that lies at the intersection of the column labeled C and the row labeled 5 in the zone map.

By taking into account the process grade and the number of CSFs affected by the process, business processes can be ranked according to the priority needs for improvement programs. Those cells that lie in Zone 1 will contain data points that identify business processes that are strong candidates for improvement. In this example, P2, P4, P5, P6, P12, and P16 are business processes whose combination of grade and number of related CSFs identify them as processes where improvement efforts should be focused. The results are analyzed to identify and prioritize improvement opportunities for a given process. A project idea emerges out of this analysis, and the TPM life cycle begins.


Risk Management

In project management a risk is some future happening that results in a change, either positive or negative, to the project. For the most part, risk is associated with loss, at least in the traditional sense. Loss can be estimated. The estimate is a combination of two factors:

  • The probability that the event will occur

  • The severity of the loss if the event occurs

This estimate forces a choice on the project manager’s part regarding what to do, if anything, to mitigate the risk and reduce the loss that will occur.

Note

Newer risk theories deal with entrepreneurial risk where there is not only a probability of loss, but a possibility of gain. This is common in business where capital is put at risk in order to fund a new business venture. For the most part, in this book we deal with risk in the traditional sense where risk is the possibility of loss.

Risk management is a broad and deep topic, and we are only able to brush the surface in this book. A number of reference books on the topic are available. The bibliography in Appendix B lists some specific titles you can use as a reference. The risk analysis and management process that we briefly describe answers the following questions:

  • What are the risks?

  • What is the probability of loss that results from them?

  • How much are the losses likely to cost?

  • What might the losses be if the worst happens?

  • What are the alternatives?

  • How can the losses be reduced or eliminated?

  • Will the alternatives produce other risks?

The business decision is to assess how the expected loss compares to the cost of defraying all or some of the loss and then taking the appropriate action.

With project management, the risks that need to be managed are those that will hurt the project itself. While the project may impact the total business, the total business isn’t the domain of the project manager.

Throughout the project management life cycle, several issues give rise to increased risk of project failure. In a 2000 study, the Standish Group surveyed more than 1000 IT managers on reasons why projects fail. The top 10 reasons why projects succeed, according to this survey, are these:

  1. Executive management support

  2. User involvement

  3. Experienced project manager

  4. Clear business objectives

  5. Minimized scope

  6. Standard infrastructure

  7. Firm basic requirements

  8. Formal methodology

  9. Reliable estimates

  10. Skilled staff

Obviously, the lack of any of theses reasons would be a reason for projects to fail.

Identifying Risk

To establish the risk management for the project, the project manager and project team must go through several processes. The first is identifying risk.

In this part of the process the entire team is brought together to discuss and identify the risks that are specific to the current project. We recommend that the meeting focus solely on risk. A meeting with such a single focus lets the entire project team know how important risk management is and gets everyone thinking about the various risks involved in the project.

Note

Don’t assume that you have identical risks on projects that look alike. Take some time to identify the risks specific to the current project so that any new risks can be identified and managed. While the experienced project manager certainly knows what general type of risks there are on each project, the professional project manager takes nothing for granted and always identifies risks for the project at the outset.

Assessing Risk

As mentioned, there are two major factors in assessing risk. The first one is the probability that the risk event will occur. For instance, if a project involves migrating legacy systems to new systems, the interface points between the two are often where problems occur. The professional project manager will have a good sense of these types of risks and the chances they will occur.

Note

If you are certain that an event will occur, it’s not a risk; it’s a certainty. This type of event isn’t handled by risk management. Because you are sure that it will occur, no probability is involved. No probability, no risk.

When the team puts together the risk identification list, nothing should be ruled out at first. Let the team brainstorm risk without being judgmental. The team will put up some risks with small probabilities. Those risks are so small that you can ignore them. For instance, the risk that a meteor will destroy the building in which you work is miniscule. If you’re worrying about things like that meteor, you won’t be much of a project manager. It’s the risks that actually might occur that you manage.

The second part of risk assessment is the impact the risk will have on the project. If a risk has a probability of 50 percent that it will occur, you need to assess what the impact will be, because a 50-50 chance of something happening is fairly high. If, however, the risk event has a low impact rating, you won’t need to manage it. This information should also be discussed at the first risk meeting.

To give a numerical score for a risk event, you simply multiply the probability of the risk occurring times the impact that the event’s occurrence would have. While at first glance this seems to be a rigorous mathematical process, it’s not. The probability of an occurrence is subjective to a great extent, as is the impact of the event. You should get advice from the team on both the probability of occurrence and the impact risks will have on the project, but in the end your experience and a good dose of common sense will give you a good start on handling the risk.

Planning Risk Response

The next step in risk management is to plan, as much as possible, the responses that will be used in the event that the identified risks occur. For instance, you may want to include a clause in your hardware contract with the vendor that if the servers don’t get to you by a certain date, they will pay a penalty. This penalty gives the vendor an incentive to perform and mitigate the risks involved in late delivery of key equipment. For all the risks listed in the risk identification that you choose to act upon, you should have some type of action in mind. It’s not enough simply to list the risks; you need to plan to do something about the risk events if they occur.

Another example of risk planning is the planning for key personnel. What will you do if one of the key developers leaves the company before finishing the coding? This risk will impact the project severely if it occurs. Having someone capture code as it is written and debriefing with the developer each day are two ways of dealing with the risk of key personnel loss. How many others can you come up with? Coming up with contingency plans such as this is risk response planning.

Risk Monitoring and Control

Once you’ve identified the risk, assessed the probability and impact of the risks, and planned what to do if the risk event occurs, you need to monitor and control the project risks. The process of writing down the risks and assessing them makes everyone on the project team aware of their existence and is a good place to start. You need to put together a risk log. This document lists all risks that you want to manage, identifies who is supposed to manage the risk, and specifies what should be done to manage the risk event. A risk log is a simple template that can be done in MS Word. Table 2.1 gives an example, and the following bulleted list explains each column.

Table 2.1: Risk Log Example
ID Number | Risk Description | Risk Owner | Action to Be Taken | Outcome

  • The ID Number always remains the same, even if the risk event has occurred and been managed. If you take the risk off of the list and file it elsewhere, don’t assign the old number to a new risk. Leave the number the same or there will be a great deal of confusion.

  • The Risk Description is a short statement of the risk event.

  • The Risk Owner is the person who has to manage the listed risk.

  • The Action to Be Taken lists what the owner is going to do to deal with the risk event.

  • The Outcome tells you what happened.

Use this form to keep track of risk in the project and you’ll have control over it. When you go to status meetings, you should always talk about risks and their management by the team. Keep the risks in front of the team so that the various members will be aware of what risks are coming up and what is to be done about the risk event. It’s good project management.

Risk Assessment Example

You can use several tools to conduct risk assessment and perform risk management. They range from the very mathematical to more paper-and-pencil-type tools. The tool described in the example that follows is the one we use in our consulting practice. We chose it because of its ease of use and versatility.

The first step is to identify the risk drivers that may be operative on a given project. These are the conditions or situations that may unfavorably affect project success. These conditions represent a candidate list from which the list of risk drivers that are appropriate for a given project is chosen. The list we start with is shown in Figure 2.4. You can also tell the team that if they don’t see one of their major risks listed, they should add it.

Click To expand
Figure 2.4: Candidate list of risk drivers.

The second step is to pick the 10 top risk drivers for your project and rank them from most likely to impact the project to least likely to impact the project. Label them A (most likely) through J (least likely), and array the data as shown in Figure 2.5.

Click To expand
Figure 2.5: Risk analysis worksheet.

The data given in the worksheet is from a hypothetical project. The columns are the top 10 risk drivers that were identified from the candidate list. The column entries are 1 = low risk, 2 = medium risk, and 3 = high risk. Actually, any metric can be used as long as the lower numbers are at the low-risk end and the higher numbers are at the high-risk end. The rows are steps in a process. For the sake of an example, we chose steps from a hypothetical systems development life cycle. Any collection of process steps may be used, and so the tool has broad application to a variety of contexts. The row and column totals are evaluated relative to one another and to scores from similar projects. These totals tell the story. High column totals suggest a risk driver that is operative across a number of steps in the process. High row totals suggest a process step that is affected by several risk drivers. Finally, the total for the whole worksheet gives us a percentage figure that can be used to compare this project against similar completed projects. The percentage is relative, but it may suggest a rule that gives an early warning of projects that are high risk overall.

To analyze the resulting scores, first examine column totals that are large relative to other column totals. In the example, we should focus on the risk drivers associated with columns C, D, E, and F. Because their column totals are high, they can potentially affect several process steps. The project team should identify strategies for either reducing the probability of the risk occurring or mitigating its impact, or both, should the event associated with that risk occur. The row totals can be analyzed in the same fashion. In the example, integration has the highest row total (27). That indicates that several risk drivers are related to integration. The project team should pay attention to the work associated with integration and look for ways to improve or better manage it. For example, the team might choose to have more skilled personnel work on integration than would otherwise be the practice.


Procurement Management

As a project manager, you will always have projects for which you must procure hardware, software, or services from outside sources. This process is procurement, and the professional project manager must have a basic understanding of the procedure so that he or she can make sure that the organization is getting the right materials at the best cost. To manage procurement, you need to go through a few processes, which are discussed in the next few sections.

Planning Procurement

Planning procurement involves both what you’re going to procure and the time that you’re going to procure it. Also included in this planning is your addressing of the make or buy decision. Let’s talk about this decision first.

The standard IT organization usually has an opportunity to decide between building the needed software or buying the off-the-shelf variety:

Buying. If no software is available, the decision is easy. You make the software yourself. But most of the time, you’re not doing something so unique that someone hasn’t already done it once before. If you buy the software off the shelf, you’re getting software that has already been tested, and you can contact users to see how it has worked. Buying off the shelf mitigates the risk level, because you’re not the first one using the application. While this sounds nice, there is another factor to consider. By buying already-written applications, you may not be getting something that exactly fits your needs. So you have to balance the ease of getting an existing application with the problem of not having something that fits exactly.

Making. The make decision for procurement means that you will be working with new code, testing it yourself, and then installing something completely new in the system. Actually, very few applications are completely new; rather, some parts of them are.

From a procurement standpoint, you have to factor in which strategy is the most efficient and cost-effective for the organization. Don’t just take a short-term look. If you use an off-the-shelf application and everyone is unhappy with it, it’s going to cost you in the long run. Consider everything before making your choice to procure.

After you’ve gone through the make-versus-buy decision, you need to look at all the things you need to procure and when you need to procure them. What you need will be made clearer by going through requirements gathering. This process is a major part of the procurement process and can’t be overemphasized. When you’re gathering requirements, talk to all the potential users and get their requirements. Write down the list of requirements and circulate it to everyone who contributed. You may need to negotiate some of the requirements because they may add too much cost to the project. Almost certainly, the requirements you get the first day you ask for them will change by the time you’re ready to solicit bids for the project.

Warning

Make sure that as the requirements list changes during this period, you keep the document containing the requirements under version control. Failure to do this will result in major confusion.

The “when” question is just as important as the “what.” If you need servers four months from now, you don’t want to tie up the organization’s money today. Look through all your needs, whether services or materials, to determine why you need them. This information gives you a way to manage your budget, and good procurement helps keep the organization’s cash under control. You will get much of this information after you’ve defined the work needed to complete the project. The sequence in which this work will be done will give you some idea of when you need various items. When you procure is a big part of procurement control and needs to be closely managed.

Soliciting Requests for Proposals

Once you’ve done your requirements gathering, you can begin to prepare procurement documents for solicitation. These documents, called Requests for Proposals (RFPs), are what the vendors use to determine how they should respond to your needs. The clearer the RFP, the better off you and the vendor are, because you will be giving basic information on what you want. The more specific you are, the better the chance that the vendor will be able to respond to you quickly and efficiently.

Many organizations have a procurement office. In this case, you need to give them a document with your requirements and let them do their work. If you don’t have a procurement office, you need to prepare a document to send to the vendors. You’ll want to have a lead writer, probably not you, and someone from legal to make sure that what you’ve asked for in the document is clear and forms the basis for a contract between you and the vendor.

Note

Remember that a contract always implies some type of adversarial relationship. Both parties to the contract wish to get the best-possible terms for their sides. So, as you put out an RFP, keep in mind that although you definitely want to get the best-possible terms for your side, you must make sure the terms aren’t so difficult that they prohibit many people from responding. You must encourage as much participation in your RFP as possible. Don’t get into a draconian mode where the RFP almost punishes those people that are responding to it.

You need to state the time conditions for response, which means that you state how many days you will give people to respond, as well as how long you will review the responses before making a choice. By putting a time line on both the vendor and your organization, the process goes faster, and expectations are clear at the beginning of the process.

Managing RFP Questions and Responses

You need to have some mechanism where you can answer questions concerning the RFP. There are a couple key ways to do this.

  • You can call a vendor meeting at which you answer all questions posed by the vendors that are present. However, after the meeting, you must also publish, in some form, your responses to the questions so that all vendors, including those who were not present at the meeting, are given a fair chance to see your response

  • A more modern approach is to put your RFP online and to respond to questions online. This arrangement gives everyone interested in responding to your RFP a chance to see other organization’s questions and to have a permanent record of your responses to questions posed. This process works only if you have someone constantly monitoring the Web site for questions and then someone who is responsible for answering the questions. This process also eliminates the burden of vendors traveling to a company that may be far away geographically. By going online, you level the playing field for all vendors.

Selecting Vendors

Before you even start reading the responses to your proposal, set the standards for choosing a given vendor. These criteria may be technically based, experience based, or cost based, but whatever basis you use for choosing a vendor, it must remain the same for all of the vendors. If you are a public company, every vendor you’ve turned down will ask for a copy of the winning bid. If they think they have a better bid, all sorts of nasty things may occur (read: legal action). If, however, you have a standards chart, you can point out that everyone was rated with the same criteria and that the winner had the best overall number. By determining your criteria for choice early in the process, it is easier to make a decision and then to defend it if need be.

Managing Contracts

Specifically, in the case where the application is to be written solely by the vendor, the project manager’s primary job is contract management. Contract management involves the following:

  • The vendor must supply you with deliverable dates so that you can tell if the project is on time.

  • The vendor should also supply a Work Breakdown Structure detailing how the vendor decomposes the scope of the project and showing the tasks that make up the completion of a deliverable.

  • You need to have regular status meetings to track progress. This meeting should be formal and should occur on specified dates. The status meetings should occur at least once a week, although in the early stages of the project, you may choose to have them more often. The weekly status meetings give you an idea of how the vendor is proceeding in fulfilling the contract, and by having them at the weekly intervals, you won’t allow the project to get very far off course. You can correct a week’s worth of problems; anything longer than that starts making problems unmanageable.

In your contract, state who the contract manager will be for your organization. If you are project managing the project, it will probably be you, but in some organizations, contract management functions are handled by a specific department or team. We prefer the contract management to be in the hands of the project manager, or at least to have the project manager as part of the contract management team.

Note

If the contract is run on a deliverable basis—that is the vendor agrees to given deliverables on certain dates—it is extremely important to state the payment mechanism. The person who signs off on each deliverable is extremely important to the vendor and should be specifically assigned in the RFP.

Closing Out the Contract

Closing out the contract is often an overlooked function of the project manager. It both certifies what has been done and gives all parties a chance to deal with open issues and final payments. The professional project manager will be aware of all of the steps that must be followed in the procurement process even though he or she may not be the person directly responsible for managing them. This is just another part of being a project management professional. Consider the following as you bring a contract to a close:

  • Lack of a clear understanding when the project is finished is a plague that permeates IT. When you write your RFP, state clearly how the project finishes and what the final deliverable is. Failure to do this will almost always lead to cost overruns in the form of maintenance activities under the heading of project work. State what the final product of the project is to be, who is to determine if it has been delivered, and what is to be done with any open issues. Make this information as clear as possible and you will save the company thousands of dollars.

  • After the contract is closed, make sure you file all of the materials used during the project. These materials include the original RFP, the project baseline, the scope statement, the WBS, the various plans used to manage the project, and all changes, including those that were requested but turned down. You also need to show all payments and make sure that any subcontractors on the project were paid. Confirming that subcontractors have been paid is done through the vendor, who must show that all payables to subcontracts have been made.

  • Put all this information into a large file and keep it. How long? We have seen instances of disputes coming up years after a project is finished. Keep it as long as the project product is in use. As a matter of fact, keep these records permanently.


Relationship between Traditional Project Management and Other Methodologies

TPM methods are very robust. They can be applied to a variety of situations. We can use the methods to plan a picnic or a trip to Mars. Regardless of the application, the same steps apply. To illustrate exactly what we mean, let’s look at the relationship between the typical TPM methodology and two other methodologies.

Systems development life cycle. Those of you who are software development professionals will have recognized many similarities between the TPM life cycle and the systems development life cycle. The two do, in fact, have many things in common. Many organizations that claim to be practicing project management have basically adapted their systems development methodology to a pseudo-project management methodology. Although this may work, in our experience several problems arise because of the lack of specificity in some parts of the systems development methodology. We also find that most systems development methodologies do not give enough how-to details to support good TPM practices. Figure 2.6 shows the commonality that exists between the project management life cycle and a typical systems development life cycle. For each phase of the TPM methodology, note the corresponding phase in the systems development life cycle.

New product development life cycle. New product development can benefit from a well-defined project management methodology. Just as there is a similarity between systems development and TPM, there also is a similarity between the product development life cycle and TPM. To see this, consider Figure 2.7, which shows the parallelism between the two. Note that each phase of the TPM methodology has a corresponding phase in new product development. Much of what we have taught you about TPM works very comfortably in the product development arena.

Cross-Reference

Time to market is a critical success factor in new product development. In Chapters 6 and 7, we explain several TPM tools and techniques that can be used to reduce time to market. For the project manager, that means that the time side of the triangle is fixed and resource efficiency is not a binding constraint.


The Pain Curve

This chapter has given you a high-level overview of what we mean by TPM. We introduced you to the life cycle of the project and discussed quality management and risk management as integral parts of TPM. Beginning with Chapter 3 and extending through Chapter 11, we explore the five phases of the TPM methodology in great detail. Our goal is to give you enough practical examples and case exercises to get you started on the road to world-class project management.

Click To expand
Figure 2.6: Traditional project management and systems development.
Click To expand
Figure 2.7: Product development life cycle and TPM.

We would be remiss, however, if we did not warn you of what lies ahead. It is easy to talk about the benefits of practicing sound TPM, but difficult to actually do it. The pressures of the job and the seemingly unrealistic deadlines we all face tempt us to get on with the work and not spend the necessary time preparing for work.

“Pay me now or pay me later” applies equally well to project planning. When the team and your management are anxious for work to begin, it is difficult to focus on developing a solid plan of action before you are pressed into service. At times it would seem that the level of detail in the plan is overkill, but it is not. You will have to accept that on faith at this point. The project manager must resist the pressure to start project work and instead spend the time up front generating a detailed project plan. It has been demonstrated that a poor planning effort takes its toll later in the project as schedules slip, quality suffers, and expectations are not met.

The pain curve (see Figure 2.8) tells us that proper planning is painful but pays off in less pain later in the project. To not plan is to expose yourself to significant pain as the project commences. In fact, that pain usually continues to increase. It would continue to increase indefinitely except that someone usually pulls the plug on the project once the pain reaches unbearable levels. The next chapters give you the skills you need to make project planning less painful.

Click To expand
Figure 2.8: The project management life cycle pain curve.


Putting It All Together

You now have all of the fundamentals to begin a TPM project. In this chapter we presented a high-level overview of the TPM life cycle. In the ensuing chapters we dig deeper into the life cycle and show you step-by-step how to plan and execute a traditional project.


Discussion Questions

  1. Identify the points in the project management life cycle where client involvement is needed. What specific action would you take as the project manager to ensure that involvement?

  2. The post-implementation audit is vitally important in improving the practice of project management and the process of project management, yet it is always so difficult to get senior management and the client to allocate the time to authorize and participate in these audits. Knowing that, what would you as project manager do to help alleviate this problem?

  3. Where in the five-phase life cycle of a project do you think the most failures occur? Defend your answer.

  4. You are the project manager of a caveman group going out to hunt mastodons. Describe your efforts at risk mitigation.

Start Sidebar
Case Study

Even though you are early in the process, determine for the case how you are going to perform user acceptance testing and who are going to be the testers. In your answer, be sure to include all functions that will be users of the product.

End Sidebar


Chapter 3: Scoping the Project

Prediction is very difficult, especially about the future.

—Neils Bohr

Define the problem before you pursue a solution.

—John Williams, CEO, Spence Corp.

Defining the Project

If you don’t know where you are going, how will you know when and if you ever get there? So many times we have seen projects get off to a terrible start simply because there never was a clear understanding of exactly what was to be done. This chapter gets you started on the right foot with a series of activities that lead to a clearly defined and understood definition of what the project is all about. We begin with a communications tool called Conditions of Satisfaction.

Start Sidebar
Chapter Learning Objectives

After reading this chapter, you will be able to:

  • Understand what managing client expectations really means

  • Explain the Conditions of Satisfaction development process

  • Develop the Conditions of Satisfaction document

  • Recognize the importance of maintaining the Conditions of Satisfaction throughout the entire project life cycle

  • Define the basic parts and function of the Project Overview Statement

  • Write a saleable Project Overview Statement for your project idea using the language of your business

  • Understand the role of the Project Overview Statement in the project management life cycle

  • Write clear goal and objective statements

  • Establish measurable criteria for project success

  • Identify relevant assumptions, risks, and obstacles

  • Discuss attachments to the Project Overview Statement and their role in project approval

  • Create a Project Definition Statement

  • Understand the approval process for the Project Overview Statement

    Note

    The TPM approach assumes you have that clear understanding of what is to be done. In Part II of this book, where we deal with extreme project management, we relax that requirement and deal with situations where the goal is not clearly, or cannot be clearly, defined.
End Sidebar

If you look behind the list of the top 10 reasons why projects succeed, outlined in Chapter 2, you will find that communications is a key to that success in seven of the 10 reasons. Our assurance of effective communications is the Conditions of Satisfaction (COS).

The deliverable from the Conditions of Satisfaction will be a one-page document (with attachments) called the Project Overview Statement (POS). The Project Overview Statement clearly states what is to be done. It is signed by the parties who completed the Conditions of Satisfaction exercise. Once the POS is approved, the scoping phase is complete.


Managing Client Expectations

Somehow clients always seem to expect more than we are prepared to deliver. This expectation gap is more the result of a failure to communicate than it is of anything else, and this lack of communications starts at the beginning of a project and extends all the way to the end. We believe that it does not have to happen. In this section we share a tool that we have used successfully for many years. Understand at the outset that the tool is easy to explain and understand, but difficult to put into practice.

Sorting Wants versus Needs

We believe that the root cause of many problems that come up in the course of a project originate in a disconnect between what the client says they want and what they really need. The disconnect may come about because the client is swept up in a euphoria over the technology and is so enamored with what they see on the Web, for example, that they have convinced themselves they have to have it without any further thought of exactly what it is they really need. The disconnect can also come about because the client does not really know what they need. TPM forces them into specifying what they want when that is the absolute wrong thing to do. If there is any reason to believe that what the client says they want is different from what they need, the project manager has the responsibility of sifting and sorting this out ASAP. It would be a mistake to proceed without having the assurance that wants and needs are in alignment. You don’t want to start the project not knowing that the solution is in fact what will satisfy the client. That is one of the reasons for the Conditions of Satisfaction, discussed in the next section.

Developing Conditions of Satisfaction

If we had to pick one area where a project runs into trouble, we would pick the very beginning. For some reason, people have a difficult time understanding what they are saying to one another. How often do you find yourself thinking about what you are going to say while the other party is talking? If you are going to be a successful project manager, you must stop that kind of behavior. An essential skill that project managers need to cultivate is good listening skills.

Good listening skills are important in the project planning phase for two different project situations:

  • The first situation, and the ideal one, occurs when a client makes a request for a project. At this point, two parties are brought together to define exactly what the request is and what kind of response is appropriate. The deliverable from this conversation is a COS.

  • The second, and more likely, situation, occurs when you inherit what we call the “water cooler project.” As the name suggests, these are the projects that are assigned to you when you accidentally meet your manager at the water cooler. Up to that point, you probably had not heard of such a project, but you now need to find out all about it ASAP. The COS document is the result of your investigation.

This section describes the process for developing the COS.

The conversations and negotiations that eventually lead to an agreed-on COS have several dimensions. The process of developing the COS involves four parts:

Request. A request is made.

Clarification. The provider explains what he or she heard as the request. This conversation continues until the requestor is satisfied that the provider clearly understands the request. Both parties have now established a clear understanding of the request.

Response. The provider states what he or she is capable of doing to satisfy the request.

Agreement. The requestor restates what he or she understands that the provider will provide. The conversation continues until the provider is satisfied that the requestor clearly understands what is being provided. At this point both parties have established a clear understanding of what is being provided.

Let’s walk through an example. Suppose you want a certain model of widgets in forest green to ship to your warehouse by December 1, 2003. You decide to visit the manufacturer to make this request. The conversation would go something like this:

Requestor: I would like you to build five prototypes of the new forest green widgets and ship them to my warehouse on December 1, 2003.

Provider: You are asking if we can get five green widget prototypes into your warehouse by December 1, 2003?

Requestor: Actually, if you can get them shipped by December 1, 2003, that will be acceptable. But remember, they have to be forest green.

Provider: So if on December 1, 2003, I can ship five forest green widgets to your warehouse, you will be satisfied.

Requestor: Yes, but they must be the new model, not the old model.

Provider: The new model?

Requestor: The new model.

Provider: I believe I understand what you have asked for.

Requestor: Yes, I believe you do.

Provider: Because of my current production schedule and the fact that I have to change paint colors, I can ship two forest green widgets on November 25, 2003 and the remaining three on December 8, 2003.

Requestor: If I understand you correctly, I will get five prototypes of the new forest green widgets in two shipments—two prototypes on November 25 and three on December 8. Is that correct?

Provider: Not exactly. You won’t receive them on those dates. I will ship them to your warehouse on those dates.

Requestor: So, let me summarize to make sure I understand what you are able to do for me. You will build a total of five prototypes of the new forest green widgets for me and ship two of them on November 25 and the remaining three on December 8?

Provider: That is correct.

Establishing Clarity of Purpose

By the time you leave, both you and the manufacturer have stated your positions and know that the other party understands your position. While the example is simple, it does establish a language between you and the provider, and both of you understand the situation. The seeds have been planted for a continuing dialog. As the project work progresses, there will be changes that can be dealt with effectively because the effort has been made up front to understand each other.

The next step in the COS process is to negotiate to closure on exactly what will be done to meet the request. Obviously, some type of compromise will be negotiated. The final agreement is documented in the POS.

Our example was fairly simple. More than likely, the parties will not come to an agreement on the first pass. This process repeats itself, as shown in Fig- ure 3.1, until there is an agreed-to request that is satisfied by an agreed-to response. As part of this agreement there will be a statement, called success criteria, in the POS that specifies when and how the request will be satisfied. It is important that this statement be very specific. Do not leave whether or not the conditions have been met up to interpretation. An ideal statement will have only two results—the criteria were met or the criteria were not met. There can be no in-between answer here. The success criteria (aka doneness criteria) will become part of the POS. The result is documented as the COS and becomes input to the POS.

Click To expand
Figure 3.1: Establishing the Conditions of Satisfaction.

This early step of establishing and agreeing to what will be done is very important to the success of the project. It is difficult to do a thorough job, especially when everyone is anxious to get to work on the project. It is also a painful process. People can be impatient; tempers may flare. You may be inclined to skip this step. Remember, pain me now or pain me later. You choose what you are willing to live with. Even if the request seems straightforward, do not assume that you understand what the requestor has asked or that the requestor understands what you will provide, even if the request seems straightforward. Always use the COS to ensure that you both understand what is expected.

Specifying Business Outcomes

As indicated in the previous section, it is a good idea to specify within the COS what exactly the outcomes are that demonstrate the COS has been met. The outcomes have been called success criteria, explicit business outcomes, and objectives, among other names. Whatever term you use, you are referring to a quantitative metric that signals success. We discuss that metric in more detail later in the chapter. For now all we need say is that it is a quantitative measure (profit, cost avoidance, improved service levels) that defines success.

Conducting Milestone Reviews

The COS is not a static agreement. It is a dynamic agreement that becomes part of the continual project monitoring process. Situations change throughout the project life cycle and so will the needs of the customer. That means that COS will change. At every major project status review and project milestone, review the COS. Do they still make sense? If not, change them and adjust the project plan accordingly.


Creating the Project Overview Statement

The Conditions of Satisfaction statement provides the input you need to generate the POS. The POS is a short document (ideally one page) that concisely states what is to be done in the project, why it is to be done, and what business value it will provide to the enterprise when completed.

The main purpose of the POS is to secure senior management approval and the resources needed to develop a detailed project plan. It will be reviewed by the managers who are responsible for setting priorities and deciding what projects to support. It is also a general statement that can be read by any interested party in the enterprise. For this reason, the POS cannot contain any technical jargon that generally would not be used across the enterprise. Once approved, the POS becomes the foundation for future planning and execution of the project. It becomes the reference document for questions or conflicts regarding project scope and purpose.

The POS serves other purposes, as well, including use in the following situations:

Inherited project. There will be situations where you will inherit the project. In these instances, the project has been defined and scoped; a budget, staff resources, and completion date also have been determined. In this scenario, do you write a POS? Yes!

There are several reasons to write a POS when you inherit a project. The first is to become familiar with and understand the project and the customer’s and management’s expectations. We can’t stress enough how important it is for requestor and provider to ensure that what will be delivered is what the customer expects.

The second reason is that the POS will become the referent for the planning team. It is the foundation on which the project plan will be built. The project team can use the POS as the tiebreaker or referent, to resolve any misunderstandings. In this case, the project scope has been determined, and it is up to the planning team to ensure that the resulting project plan is within the scope of the project, as defined in the POS.

Unsolicited individual initiative. Many organizations use the POS as a method for anyone in the organization to suggest an idea for increasing efficiency, improving productivity, or seizing a business opportunity. Because the POS can be drafted rather quickly by one person, it acts as a way to capture a brief statement of the nature of the idea. Senior management can react to the proposed idea without spending too much time. If the idea has merit, the proposer will be asked to provide a detailed plan.

The idea may be conditionally accepted, pending a little more justification by the proposer. Again, the idea is pursued further if it has merit. Otherwise, it is rejected at this early stage, before too much time and too many resources are spent on needless planning.

A reference for the team. An equally important reason for writing a POS is to give your team briefing information on the project. Besides reaching a consensus with your customer on what will be done, the team members need to have an understanding of the project at their level of involvement. Think of this as a Conditions of Satisfaction for the team. Here the focus is on ensuring that the project manager and the team have a common understanding of the project. The POS serves as a good briefing tool for staff members who are added after the project commences. It helps them get up to speed with their understanding of the project.

Parts of the POS

The POS has five component parts:

  • Problem/opportunity

  • Project goal

  • Project objectives

  • Success criteria

  • Assumptions, risks, obstacles

Its structure is designed to lead senior managers from a statement of fact (problem/opportunity) to a statement of what this project will address (project goal). Given that senior management is interested in the project goal and that it addresses a concern of sufficiently high priority, they will read more detail on exactly what the project includes (project objectives). The business value is expressed as quantitative business outcomes (success criteria). Finally, a summary of conditions that may hinder project success are identified (assumptions, risks, obstacles). Let’s take a look at each of these sections more closely. An example POS is shown in Figure 3.2.

Click To expand
Figure 3.2: An example POS.

Stating the Problem/Opportunity

The first part of the POS is a statement of the problem or opportunity that the project addresses. This statement is fact—it does not need to be defined or defended. Everyone in the organization will accept it as true. This is critical because it provides a basis for the rest of the document. The POS may not have the benefit of the project manager’s being present to explain what is written or to defend the reason for proposing the project to the management. A problem or opportunity statement that is known and accepted by the organization is the foundation on which to build a rationale for the project. It also sets the priority with which management will view what follows. If you are addressing a high-priority area or high-business-value area, your idea will get more attention and senior management will read on.

There are several examples of situations that will lead to a statement of the problem or opportunity that has given rise to this POS:

Known problem/opportunity area. Every organization has a collection of known problems. Several attempts to alleviate part of or the entire problem may have already been made. The POS gives proposers a way to relate their idea to a known problem and to offer a full or partial solution. If the problem is serious enough and if the proposed solution is feasible, further action will be taken. In this case, senior managers will request a more detailed solution plan from the requestor.

With the business world changing and redefining itself continuously, opportunities for new or enhanced products and services present themselves constantly. Organizations must be able to take advantage of them quickly because the window of opportunity is not wide and is itself constantly moving. The POS offers an easy way to seize these opportunities.

Customer request. Internal or external customers make requests for products or services, and their requests are represented in the COS. The POS is an excellent vehicle for capturing the request and forwarding it to senior management for resolution. More recently, with the empowerment of the worker, workers not only receive the request but also have the authority to act on the request. The POS, coupled with the COS, establishes an excellent and well-defined starting point for any project.

Corporate initiative. Proposals to address new corporate initiatives should begin with the POS. There will be several ideas coming from the employees, and the POS provides a standardized approach and document from which senior management can prioritize proposals and select those that merit further planning. A standard documentation method for corporate initiatives simplifies senior management’s decision-making process for authorizing new projects.

Mandated requirements. There will be several instances in which a project must be undertaken because of a mandated requirement. These could arise from market changes, customer requirements, and federal legislation, as well as other sources. The POS is a vehicle for establishing an agreement between the provider and the decision maker about the result of the project. The POS clarifies for all interested parties exactly how the organization has decided to respond to the mandate.

Establishing the Project Goal

The second section of the POS states the goal of the project—what you intend to do to address the problem or opportunity identified in the problem/opportunity section. The purpose of the goal statement is to get senior management to value the idea enough to read on. In other words, they should think enough of the idea to conclude that it warrants further attention and consideration. Several submissions may propose the same issue. Because yours will not be the only one submitted, you want it to stand out among the crowd.

A project has one goal. The goal gives purpose and direction to the project. It defines the final deliverable or outcome of the project so that everyone understands what is to be accomplished in clear terms. The goal statement will be used as a continual point of reference for any questions that arise regarding scope or purpose.

The goal statement must not contain any language or terminology that might not be understandable to anyone having occasion to read it. In other words, no techie talk allowed. It is written in the language of the business so that anyone who reads it will understand it without further explanation from the proposer. Under all circumstances avoid jargon.

Just like the problem or opportunity statement, the goal statement is short and to the point. Keep in mind that the more you write, the more you increase the risk that someone will find fault with something you have said. The goal statement does not include any information that might commit the project to dates or deliverables that are not practical. Remember, you do not have much detail about the project at this point.

Unfortunately, we have a habit of accepting as cast in stone any number that we see in writing, regardless of the origin of the number. The goal statement should not include a specific completion date. (Easier said than done, we realize.) If you expect management to ask for a date, estimate the date to the nearest quarter, month, or week as appropriate, but with the caveat that the estimated delivery date will become more specific as you learn more about project specifics. It is important that management understand just how some of the early numbers are estimated, and that there is a great deal of variability in those early estimates. Assure them that better estimates will be provided as the project plan is built and as the project work is undertaken. Leave the specific dates for the detailed planning session when a more informed decision can be made.

Doran’s S.M.A.R.T. characteristics provide the criteria for a goal statement:1

Specific. Be specific in targeting an objective.

Measurable. Establish a measurable indicator(s) of progress.

Assignable. Make the object assignable to one person for completion.

Realistic. State what can realistically be done with available resources.

Time-related. State when the objective can be achieved—that is, duration.

In practice we have incorporated the S.M.A.R.T. characteristics into both the POS and the project plan. The specific characteristic can be found in the problem/opportunity statement, the goal statement, and the objective statements discussed later in this chapter. The measurable characteristic is incorporated into the success criteria, discussed later in the chapter. The assignable, realistic, and time-related characteristics are part of the project plan and are discussed in Chapters 4 through 8.

Defining the Project Objectives

The third section of the POS is the project objectives. Think of objective statements as a more detailed version of the goal statements. The purpose of objective statements is to clarify the exact boundaries of the goal statement and define the boundaries or the scope of your project. In fact, the objective statements you write for a specific goal statement are nothing more than a decomposition of the goal statement into a set of necessary and sufficient objective statements. That is, every objective must be accomplished in order to reach the goal, and no objective is superfluous.

A good exercise to test the validity of the objective statements is to ask if it is clear what is in and what is not in the project. Statements of objectives should specify a future state, rather than be activity based. We like to think of them as statements that clarify the goal by providing details about the goal. Think of them as subgoals, and you will not be far off the mark.

It is also important to keep in mind that these are the current objective statements. They may change during the course of planning the project. This will happen as the details of the project work are defined. We all have the tendency to put more on our plates than we need. The result is to include project activities and tasks that extend beyond the boundaries defined in the POS. When this occurs, stop the planning session and ask whether the activity is outside the scope of the project, and if so, whether you should adjust the scope to include the new activity or delete the new activity from the project plan.

[1] 1George T. Doran, “There’s a S.M.A.R.T. Way to Write Management Goals and Objectives,” Management Review (November 1981): 35–36.

Note

You will find that all through the project planning activities discussed in this book, there will be occasions to stop and reaffirm project boundaries. Boundary clarification questions will continually come up. Adopting this questioning approach is sound TPM.

An objective statement should contain four parts:

An outcome. A statement of what is to be accomplished

A time frame. The expected completion date

A measure. Metrics that will measure success

An action. How the objective will be met

In many cases the complete objective statement will be spread across the POS rather than collected under the heading of “Objectives.” This is especially true for the time frame and measures of success.

Identifying Success Criteria

The fourth section of the POS answers the question, “Why do we want to do this project?” It is the measurable business value that will result from doing this project. It sells the project to senior management.

Whatever criteria are used, they must answer the question, “What must happen for us and the customer to say the project was a success?” The Conditions of Satisfaction will contain the beginnings of a statement of success criteria. Phrased another way, success criteria form a statement of doneness. It is also a statement of the business value to be achieved, and therefore, it provides a basis for senior management to authorize the resources to do detailed planning. It is essential that the criteria be quantifiable and measurable, and if possible, expressed in terms of business value. Remember that you are trying to sell your idea to the decision makers.

No matter how you define success criteria, they all reduce to one of three types:

Increased revenue. As a part of the success criteria, that increase should be measured in hard dollars or as a percentage of a specific revenue number.

Reduced costs. Again, this criterion can be stated as a hard-dollar amount or a percentage of some specific cost. Be careful here because oftentimes a cost reduction means staff reductions. Staff reductions do not mean the shifting of resources to other places in the organization. Moving staff from one area to another is not a cost reduction.

Improved service. Here the metric is more difficult to define. It usually is some percentage improvement in customer satisfaction or a reduction in the frequency or type of customer complaints.

In some cases, it can take some creativity to identify the success criteria. For example, customer satisfaction may have to be measured by some pre- and post-surveys. In other cases, a surrogate might be acceptable if directly measuring the business value of the project is impossible. Be careful, however, and make sure that the decision maker buys into your surrogate measure. Also be careful of traps such as this one: We haven’t been getting any customer complaint calls; therefore, the customer must be satisfied. Did you ever consider the possibility that the lack of complaint calls may be the direct result of your lack of action responding to complaints? Customers may feel that it does no good to complain because nothing happens to settle their complaint.

The best choice for success criteria is to state clearly the bottom-line impact of the project. This is expressed in terms such as increased margins, higher net revenues, reduced turnaround time, improved productivity, reduced cost of manufacture or sales, and so on. Because you want senior management approval of your proposal, you should express the benefits in the terms with which they routinely work.

While you recognize bottom-line impact as the best success criteria, that may not be possible. As an alternative, consider quantifiable statements about the impact your project will have on efficiency and effectiveness, error rates, reduced turnaround time to service a customer request, reduced cost of providing service, quality, or improved customer satisfaction. Management deals in deliverables, so always try to express your success criteria in quantitative terms. By doing this, you avoid any possibility of disagreement as to whether the success criteria were met and the project was successful.

Senior management also will look at your success criteria and assign business value to your project. In the absence of other criteria, this will be the basis for their decision whether to commit resources to complete the detailed plan. The success criteria are another place to sell the value of your project. For example, one success criteria can be as follows:

This reengineering project is expected to reduce order entry to order fulfillment cycle time by 6 percent.

Management may conclude from this number:

If that is all you expect to gain from this project, we cannot finance the venture.

Alternatively, they may respond:

If you can get 6 percent improvement from our current process, that will be a remarkable feat; so remarkable, in fact, that we would like more detail on how you expect to get that result. Can you provide an analysis to substantiate your claim?

Subjective measures of success will not do the job. You must speak quantitatively about tangible business benefits. This may require some creativity on your part. For example, when proposing a project that will have an impact on customer satisfaction, you will need to be particularly creative. There may be some surrogates for customer satisfaction. A popular approach to such situations is to construct a pre- and post-survey. The change will measure the value of the project.

Listing Assumptions, Risks, and Obstacles

The fifth section of the POS identifies any factors that can affect the outcome of the project and that you want to bring to the attention of senior management. These factors can affect deliverables, the realization of the success criteria, the ability of the project team to complete the project as planned, or any other environmental or organizational conditions that are relevant to the project. You want to record anything that can go wrong.

Warning

Be careful, however, to put in the POS only those items that you want senior management to know about and in which they will be interested. Save for the Project Definition Statement (PDS) those items that are quite specific and too detailed to be of interest to senior managers. (We discuss the PDS in more detail later in the chapter.) The PDS list may be extensive. It will generate good input for the risk analysis discussed in Chapter 2.

The project manager uses the assumptions, risks, and obstacles section to alert management to any factors that may interfere with the project work or compromise the contribution that the project can make to the organization. Management may be able to neutralize their impact. On the other hand, the project manager will include in the project plan whatever contingencies can help reduce the probable impact and its effect on project success.

Do not assume that everyone knows what the risks and perils to the project will be. Planning is a process of discovery—discovery about the project and those hidden perils that cause embarrassment for the team. Document them and discuss them.

There are several areas where the project can be exposed to factors that may inhibit project success. These are described in the following:

Technological. The company may not have much or any experience with new technology, whether it is new to the company or new to the industry. The same can be said for rapidly changing technology. Who can say whether the present design and technology will still be current in three months or six months?

Environmental. The environment in which the project work is to be done can also be an important determinant. An unstable or changing management structure can change a high-priority project to a low-priority project overnight. If your project sponsor leaves, will there be a new sponsor? And if so, how will he or she view the project? Will the project’s priority be affected? High staff turnover will also present problems. The project team cannot get up on the learning curve because of high turnover. A related problem stems from the skill requirements of the project. The higher the skill level required, the higher the risk associated with the project.

Interpersonal. Relationships between project team members are critical to project success. You don’t have to be friends, but you do have to be coworkers and team players. If sound working relationships are not present among the project team or stakeholders, there will be problems. These interpersonal problems should be called to the attention of senior management.

Cultural. How does the project fit with the enterprise? Is it consistent with the way the enterprise functions, or will it require a significant change to be successful? For example, if the deliverable from the project is a new process that takes away decision-making authority from staff who are used to making more of their own decisions, you can expect development, implementation, and support problems to occur.

Causal relationships. We all like to think that what we are proposing will correct the situation addressed. Assumptions about cause-and-effect relationships are inevitable. The proposer assumes that the solution will, in fact, solve the problem. If this is the case, these assumptions need to be clearly stated in the POS. Remember that the rest of the world does not stand still waiting for your solution. Things continue to change, and it is a fair question to ask whether your solution depends on all other things remaining equal.

Attachments

Even though we strongly recommend a one-page POS, there will be instances in which a longer document is necessary. As part of their initial approval of the resources to do detailed project planning, senior management may want some measure of the economic value of the proposed project. They recognize that many of the estimates are little more than a guess, but they will nevertheless ask for this information. In our experience, we have seen two types of analyses requested frequently:

  • Risk analysis

  • Financial analysis

The following sections briefly discuss these types of analysis. Check the bibliography in Appendix B for sources where you can find more information about these topics.

Risk Analysis

Risk analysis is the most frequently used attachment to the POS, in our experience. In some cases, this analysis is a very cursory treatment. In others, it is a mathematically rigorous exercise. Many business-decision models depend on quantifying risks, expected loss if the risk materializes, and the probability that the risk will occur. All of these are quantified, and the resulting analysis guides management in its project approval decisions.

In the high-technology industries, risk analysis is becoming the rule rather than the exception. Formal procedures are established as part of the initial definition of a project and continue through the life of the project. These analyses typically contain the identification of risk factors, the likelihood of their occurrence, the damage they will cause, and containment actions to reduce their likelihood or their potential damage. The cost of the containment program is compared with the expected loss as a basis for deciding which containment strategies to put in place.

Financial Analyses

Some organizations require a preliminary financial analysis of the project before granting approval to perform the detailed planning. Although such analyses are very rough because not enough information is known about the project at this time, they will offer a tripwire for project-planning approval. In some instances, they also offer criteria for prioritizing all of the POSs senior management will be reviewing. Some of the possible analyses are as follows:

Feasibility studies. The methodology to conduct a feasibility study is remarkably similar to the problem-solving method (or scientific method, if you prefer):

  1. Clearly define the problem.

  2. Describe the boundary of the problem—that is, what is in the problem scope and what is outside the problem scope.

  3. Define the features and functions of a good solution.

  4. Identify alternative solutions.

  5. Rank alternative solutions.

  6. State the recommendations along with the rationale for the choice.

  7. Provide a rough estimate of the timetable and expected costs.

    The project manager will be asked to provide the feasibility study when senior management wants to review the thinking that led to the proposed solution. A thoroughly researched solution can help build credibility for the project manager.

    Cost/benefit analysis. These analyses are always difficult to do because you need to include intangible benefits in the decision situation. As mentioned earlier in the chapter, things such as improved customer satisfaction cannot be easily quantified. You could argue that improved customer satisfaction reduces customer turnover, which in turn increases revenues, but how do you put a number on that? In many cases, senior management will take these inferences into account, but they still want to see hard-dollar comparisons. Opt for the direct and measurable benefits to compare against the cost of doing the project and the cost of operating the new process. If the benefits outweigh the costs over the expected life of the project deliverables, senior management may be willing to support the project.

    Break-even analysis. This is a time line that shows the cumulative cost of the project against the cumulative revenue or savings from the project. Wherever the cumulative revenue or savings line crosses the cumulative cost line is that point where the project recoups its costs. Usually senior management looks for an elapsed time less than some threshold number. If the project meets that deadline date, it may be worthy of support. The targeted break-even date is getting shorter and shorter because of more frequent changes in the business and its markets.

    Return on investment. This section analyzes the total costs as compared with the increased revenue that will accrue over the life of the project deliverables. Here senior management finds a common basis for comparing one project against another. They look for the high ROI projects or the projects that at least meet some minimum ROI.

Cross-Reference

Many books provide more detailed explanations of each of these analyses. The bibliography in Appendix B contains some suggested titles.


Using the Joint Project Planning Session to Develop the POS

The Joint Project Planning (JPP) session is the tool we recommend for developing the project plan. We will not discuss the full project planning exercise until Chapter 8. However, in this section, we briefly discuss how it could be used to draft the POS. In fact, there will be situations where you will want to convene a planning session to draft the POS.

Whenever a COS exercise has not been completed and the project manager is given the project assignment (remember the water cooler example?), the first step that project manager should take is to convene a preplanning session to draft a POS. This session will involve the customer or his or her representative, the project manager, and, if they have been identified, key members of the project team.

Drafting the POS is the first part of the JPP. It may have to be completed in two parts. The first part drafts the POS; the second part completes the detailed plan after having received approval of the POS.

The first order of business is to agree on the request and the response to the request. These are the Conditions of Satisfaction and become the problem/ opportunity, goal, objectives, and success criteria parts of the POS.

Next, you conduct a sanity check with those who were not party to developing the COS. Discussion should follow until all parties are satisfied with the request and the response. Expect to add to the COS in reaching consensus.

The last item is to complete the assumptions, risks, and obstacles portion. Here the planning participants will be able to offer a number of points to consider.

Beginning with the POS, the planning team will often begin the planning session by spending some time discussing the POS in greater detail. This will bring the team to a greater depth of understanding of the scope of the project. That additional information should be documented in the Project Definition Statement. The PDS is a document for the exclusive use of the project team. It is discussed later in this chapter.


Submitting a Project for Approval

Once the POS is complete, it is submitted to management for approval. The approval process is far from a formality. It is a deliberate decision on the part of senior management that the project as presented does indeed have business value and that it is worth proceeding to the detailed planning phase. As part of the approval process, senior management asks several questions regarding the information presented. Remember, they are trying to make good business decisions and need to test your thinking along the way. Our best advice is to remember that the document must stand on its own. You will not be present to explain what you meant. Write in the language of the business, and anticipate questions as you review the content of the POS.

During this process, expect several iterations. Despite your best efforts to make the POS stand on its own, you will not be successful at first. Senior management always has questions. For example, they can question the scope of the project and may ask you to consider expanding or contracting it. They may ask for backup on how you arrived at the results that you claim in your success criteria. If financial analyses are attached, you may have to provide additional justification or explanation of the attachments.

The approved POS serves three audiences:

Senior management. Their approval is their statement that the project makes enough business sense to move to the detailed planning stage.

The customer. The customer’s approval is his or her concurrence that the project has been correctly described and he or she is in agreement with the solution being offered.

The team. The approved POS is their message from senior management and the customer that the project has been clearly defined at this high level of detail.

Approval of the POS commits the resources required to complete a detailed plan for the project. It is not the approval to do the project. Approval to proceed with the project is the result of an approval of the detailed plan. At this early stage, not too much is known about the project. Rough estimates of time or cost variables (or WAGs, for “wild a** guesses,” if you prefer; SWAGs are the scientific version) are often requested from the project manager and the project team, as well as what will be done and of what value it is to the enterprise. More meaningful estimates of time and cost are part of the detailed plan.

Gaining management approval of the POS is a significant event in the life of a project. The approving manager questions the project manager, and the answers are scrutinized very carefully. While the POS does not have a lot of detailed analysis supporting it, it is still valuable to test the thinking of the proposer and the validity of the proposed project. It is not unusual to have the project manager return to the drawing board several times for more analysis and thought as a prerequisite to management approval. As senior managers review the POS, you can anticipate the following review questions:

  • How important is the problem or opportunity to the enterprise?

  • How is the project related to our critical success factors (CSFs)?

  • Does the goal statement relate directly to the problem or opportunity?

  • Are the objectives clear representations of the goal statement?

  • Is there sufficient business value as measured by the success criteria to warrant further expenditures on this project?

  • Is the relationship between the project objectives and the success criteria clearly established?

  • Are the risks too high and the business value too low?

  • Can senior management mitigate the identified risks?

The approval of the POS is not a perfunctory or ceremonial approval. By approving the document, professionals and managers are saying that, based on what they understand the project to involve and its business value, it demonstrates good business sense to go to the next level—that is, to commit the resources needed to develop a detailed project plan.

Participants in the Approval Process

Several managers and professionals participate in the approval process:

Core project team. At the preliminary stages of the project, a core project team may have been identified. These will be the managers, professionals, and perhaps the customer who will remain on the project team from the beginning to the very end of the project. They may participate in developing the POS and reach consensus on what it contains.

Project team. Some potential members of the project team are usually known beforehand. Their subject matter expertise and ideas should be considered as the POS is developed. At the least, you should have them review the POS before submission.

Project manager. Ideally, the project manager will have been identified at the start and can participate in drafting the POS. Because he or she will manage the project, he or she should have a major role to play in its definition and its approval.

Resource managers. Those who will be asked to provide the skills needed at the times when they will be needed are certainly important in the initial definition of the project and later its detailed planning. There is little point in proposing a project if the resources are not or cannot be made available to the project.

Function/process managers. Project deliverables don’t exist in a vacuum. Several units will provide input to or receive output from the project products or services. Their advice should be sought. Give them an early chance to buy into your project.

Customer. Our project management methodology includes a significant role for the customer. We have discussed the COS as a prerequisite to, or a concurrent exercise in developing, the POS. Many professionals are not skilled in interpersonal communications. Developing the COS is a difficult task.

In some situations the customer is the project manager—for example, if the development of a product or service affects only one department or in projects whose customer is very comfortable with project management practices. In these situations, we encourage the customer to be the project manager. The benefits to the organization are several: buy-in, lower risk of failure, better implementation success, and deliverables more likely to meet the needs of the customer, to name a few. Commitment and buy-in are always difficult to get. Having the customer as project manager solves that problem. For this approach to work, the technical members of the project team take on the role of advisor and consultant. It is their job to keep the feasible alternatives, and only the feasible alternatives, in front of the project manager. Decision making will be a little more difficult and time-consuming. By engaging the customer as project manager, the customer not only appreciates the problems that are encountered but also gains some skill in resolving them. We have seen marvelous learning-curve effects that have their payoff in later projects with the same customer.

Senior management. Senior management support is a critical factor in successful projects and successful implementation of the deliverables. Their approval says, “Go and do detailed planning; we are authorizing the needed resources.”

Approval Criteria

The approval criteria at this stage of the project life cycle are not as demanding as they will be when it’s time to approve the project for execution or addition to the organization’s project portfolio. All that senior management is looking for at this point is a rough estimate of the value of the project to the organization. Their approval at this stage extends only to an approval to plan the project. That detailed project plan will give them a more specific estimate of the cost of the project. Knowing the actual costs, senior management can calculate the return that they can expect from this project.

Project Approval Status

In the absence of approval to plan the project, senior management might take one of several courses of action:

  • They may reject the proposal out of hand. That decision will often be based on a comparison of expected benefits versus total cost coupled with a timeframe as to when the benefits will be realized.

  • They may request a recalibration of the goal and scope of the project followed by a resubmission to seek approval to plan the project.

  • They might decide that a later resubmission is in order. In other words, they are not ready to commit to the project at this time.

Finally, the approval may be associated with a consideration to add the project to the organization’s project portfolio. We defer discussion of that topic to Part III of this book, which discusses project portfolio management.


The Project Definition Statement

Just as the customer and the project manager benefit from the POS, the project manager and the project team can benefit from a closely related document, which we call the Project Definition Statement (PDS). The PDS uses the same form as the POS but incorporates considerably more detail. The project manager and the project team use the detailed information provided in the PDS for the following:

  • As a basis for planning

  • To capture an idea

  • To obtain an agreement from the customer to move forward

  • To clarify the project for management

  • As a reference that keeps the team focused in the right direction

  • As an orientation for new team members

  • As a method for discovery by the team

In most cases the PDS expands on two sections of the POS:

Project objectives. In the POS, the project objectives are written so that they can be understood by anyone who might have reason to read them. In the PDS, the situation is somewhat different. The PDS is not circulated outside the project team; therefore, the language can be technical and the development more detailed. Project objectives take on more of the look of a functional requirements or functional specification document. The purpose is to provide a description that the project team can relate to.

Assumptions, risks, and obstacles. The POS contains statements of assumptions, risks, and obstacles that will be of interest to senior management. For the PDS, the list will be of interest to the project team. For that reason, it will be much longer and more detailed. In our experience, this list is built during the Joint Project Planning session, whereas the POS list is built as part of the scoping activity of the project.

The PDS is a document that was discussed for the first time in the second edition. Since then, our consulting engagements have verified for us that the PDS can be used by the team to help them understand the project at their level of detail. The POS did not satisfy this need, so we developed the PDS. It is simply a variant of the POS designed specifically for the team. In implementing the PDS, we did feel that it could further clarify the communications problems that often arise in the project as team members come and go. In the limited use we have made of it, it has proven to be of value to the team; we suspect that it in time it will reduce the risk of project failure.

At this point, you have documented the project through the POS and received approval from senior management to go forward with detailed project planning. The next four chapters are devoted to the second phase of the project management life cycle (which was discussed in Chapter 2): developing the detailed project plan.


Putting It All Together

In TPM a clear understanding of the scope of the project is critical to the planning and execution phases of the project. We have discussed the Conditions of Satisfaction and the Project Overview Statements as the two basic tools for developing a joint agreement and a joint statement of scope in collaboration with the client. As you will see in later chapters, these documents are the foundation of the TPM approach.


Discussion Questions

  1. Traditional project management depends heavily on being able to clearly define what the client needs. You cannot create a detailed project plan without that information. Within the framework of TPM, what could you do if it were not possible to get that clear definition?

  2. You have run the Conditions of Satisfaction by the book, and your gut tells you that the client’s wants may be a bit too far-reaching. In fact, you have a strong suspicion that what they need is not what they have told you they want. Within the framework of TPM, what could you do?

Start Sidebar
Case Study

Write a scope statement for the Jack Neift case, outlined in the Introduction. Be sure to leave out features that will not be included in this project. The scope statement should be no longer than a page, and, ideally, it should take much less space than that. (A sample scope statement for a different case is included on the CD-ROM.)

Then, referring to the case study background information, discuss and formulate the five parts of the POS for this project.

End Sidebar


Chapter 4: Identifying Project Activities

Let all things be done decently and in order.

—I Corinthians 14:40

The Work Breakdown Structure

The Work Breakdown Structure (WBS) is a hierarchical description of the work that must be done to complete the project as defined in the Project Overview Statement (POS). Several processes can be used to create this hierarchy, which we discuss in this chapter. An example of the WBS is shown in Figure 4.1.

Start Sidebar
Chapter Learning Objectives

After reading this chapter, you will be able to:

  • Recognize the difference between activities and tasks

  • Understand the importance of the completeness criteria to your ability to manage the work of the project

  • Explain the approaches to building the Work Breakdown Structure

  • Determine which of the approaches to use for generating the Work Breakdown Structure for a given project

  • Generate a complete Work Breakdown Structure

  • Use a Joint Project Planning session to generate a Work Breakdown Structure

  • Understand top-down versus bottom-up processes for building the Work Breakdown Structure in the Joint Project Planning session

  • Use the Work Breakdown Structure as a planning tool

  • Use the Work Breakdown Structure as a reporting tool

End Sidebar

To begin our discussion of the WBS, you need to be familiar with the terms introduced in Figure 4.1. The first term is activity. An activity is simply a chunk of work. Later in this chapter, in the section Six Criteria to Test for Completeness in the WBS, we expand on this definition. The second term is task. Note that in Figure 4.1, activities turn to tasks at some level in the hierarchy. A task is a smaller chunk of work. While these definitions seem a bit informal, the difference between an activity and a task will become clearer shortly.

Click To expand
Figure 4.1: Hierarchical visualization of the Work Breakdown Structure.

The terms activity and task have been used interchangeably among project managers and project management software packages. Some would use the convention that activities are made up of tasks, while others would say that tasks are made up of activities, and still others would use one term to represent both concepts. In this book, we refer to higher-level work as activities, which are made up of tasks.

We also use the term work package. A work package is a complete description of how the tasks that make up an activity will actually be done. It includes a description of the what, who, when, and how of the work. We’ll describe work packages in more detail later in this chapter.

Breaking down work into a hierarchy of activities, tasks, and work packages is called decomposition. For example, take a look at the top of the WBS in Figure 4.1. Notice that the goal statement from the POS is defined as a Level 0 activity in the WBS. The next level, Level 1, is a decomposition of the Level 0 activity into a set of activities defined as Level 1 activities. These Level 1 activities are major chunks of work. When the work associated with each Level 1 activity is complete, the Level 0 activity is complete. For this example, that means that the project is complete. As a general rule, when an activity at Level n is decomposed into a set of activities at Level n+1 and the work associated with those activities is complete, the activity at Level n, from which they were defined, is complete.

Decomposition is important to the overall project plan because it allows you to estimate the duration of the project, determine the required resources, and schedule the work. The complete decomposition will be developed by using the completeness criteria discussed later in this chapter. By following those criteria, the activities at the lowest levels of decomposition will possess known properties that allow us to meet planning and scheduling needs.

This process of decomposition is analogous to the process we all used in grammar school to prepare a detailed outline of a research paper we were going to write. Despite the teacher’s extolling the value of preparing the outline before we wrote the paper, we chose to do it the other way around—by writing the paper first and extracting the outline from it. That won’t work in project planning. We have to define the work before we set out to do the work.

Those who have experience in systems development should see the similarity between the hierarchical decomposition and functional decomposition. In principle, there is no difference between a WBS and a functional decomposition of a system. Our approach to generating a WBS departs from the generation of a functional decomposition in that we follow a specific process with a stopping rule for completing the WBS. We are not aware of a similar process being reported for generating the functional decomposition of a system. Veterans of system development might even see some similarity to older techniques like stepwise refinement or pseudo-code. These tools do, in fact, have a great deal in common with the techniques we use to generate the WBS.


Uses for the WBS

The WBS has four uses:

Thought process tool. First and maybe foremost, the WBS is a thought process. As a thought process, it is a design and planning tool. It helps the project manager and the project team visualize exactly how the work of the project can be defined and managed effectively. It would not be unusual to consider alternative ways of decomposing the work until an alternative is found with which the project manager is comfortable.

Architectural design tool. When all is said and done, the WBS is a picture of the work of the project and how the items of work are related to one another. It must make sense. In that context, it is a design tool.

Planning tool. In the planning phase, the WBS gives the project team a detailed representation of the project as a collection of activities that must be completed in order for the project to be completed. It is at the lowest activity level of WBS that we will estimate effort, elapsed time, and resource requirements; build a schedule of when the work will be completed; and estimate deliverable dates and project completion.

Project status reporting tool. The WBS is used as a structure for reporting project status. The project activities are consolidated (that is, rolled up) from the bottom as lower-level activities are completed. As work is completed, activities will be completed. Completion of lower-level activities causes higher-level activities to be partially complete. Some of these higher-level activities may represent significant progress whose completion will be milestone events in the course of the project. Thus, the WBS defines milestone events that can be reported to senior management and to the customer.

Note

Trying to find a happy compromise between a WBS architecture that lends itself well to the planning thought process and the rolling up of information for summary reporting can be difficult. It is best to have input from all the parties that may be using the WBS before settling on a design. There is no one right way to do it; it’s subjective. You will get better with practice.

In the final analysis, it is the project manager who decides on the architecture of the WBS and the level of detail required. This detail is important because the project manager is accountable for the success of the project. The WBS must be defined so that the project manager can manage the project. That means that the approach and detail in the WBS might not be the way others would have approached it. Apart from any senior management requirements for reporting or organizational requirements for documentation or process, the project manager is free to develop the WBS according to his or her needs and those of management. Because of this requirement, the WBS is not unique. That should not bother you, because all that is required is a WBS that defines the project work so that you, the project manager, can manage it. “Beauty is in the eyes of the beholder” applies equally well to the WBS.


Generating the WBS

The best way to generate the WBS is as part of the Joint Project Planning (JPP) session. We describe the steps as we look at two different approaches to building the WBS. Before we discuss those approaches, let’s recall where we are in the planning process and then offer a few general comments about procedures we have followed in our practice regardless of the approach taken.

One of two simple decomposition processes is used to identify the activities that must be performed from the beginning to the completion of the project. These activities are the lowest level of managed work for the project manager. At this point in the planning process, you should have completed the Project Overview Statement. You may have to go back and reconsider the POS as a result of further planning activities, but for now let’s assume the POS is complete. Our technique for generating the WBS will reduce even the most complex project to a set of clearly defined activities. The WBS will be the document that guides the remainder of the planning activities.

There may be as many as 10 to 20 participants involved in building the WBS, so gathering around a computer screen won’t do the job. Neither will projecting the screen on an overhead LCD projector. The only way we have found that works consistently is to use Post-It notes, marking pens, and plenty of whiteboard space. In the absence of whiteboard space, you might wallpaper the planning room with flip-chart or butcher paper. You cannot have too much writing space. We have even used butcher paper and filled the four walls of the planning room and several feet of hallway outside the planning room. It is sloppy, but it gets the job done.

Two approaches can be used to identify the project activities. The first is the top-down approach; the second is the bottom-up approach.

Top-Down Approach

The top-down approach begins at the goal level and successively partitions work down to lower levels of definition until the participants are satisfied that the work has been sufficiently defined. The completion criteria discussed later in this chapter structure the partitioning exercise for this approach.

Once the project activities have been defined using the top-down approach, they will be defined at a sufficient level of detail to allow you to estimate time, cost, and resource requirements first at the activity level and then aggregate to the project level. Because the activities are defined to this level of detail, project time, cost, and resource requirements are estimated much more accurately.

Once the activities are described, you can sequence the project work so that as many activities as possible are performed in parallel, rather than in sequence. In other words, the list of activities can be sequenced so that the project duration (clock time needed to complete all project work) will be much less than the sum of all the times needed to complete each activity.

We recommend two variations of the top-down approach. We have used both in our consulting practices.

Team Approach

The team approach, while it requires more time to complete than the subteam approach discussed next, is the better of the two. In this approach the entire team works on all parts of the WBS. For each Level 1 activity, appoint the most knowledgeable member of the planning team to facilitate the further decomposition of that part of the WBS. Continue with similar appointments until the WBS is complete. This approach allows all members of the planning team to pay particular attention to the WBS as it is developed, noting discrepancies and commenting on them in real time.

Subteam Approach

When time is at a premium, the planning facilitator will prefer the subteam approach. The first step is to divide the planning team into as many subteams as there are activities at Level 1 of the WBS. Then follow these steps:

  1. The planning team agrees on the approach to building the first level of the Work Breakdown Structure.

  2. The planning team creates the Level 1 activities.

  3. A subject matter expert leads the team in further decomposition of the WBS for his or her area of expertise.

  4. The team suggests decomposition ideas for the expert until each activity within the Level 1 activities meets the WBS completion criteria.

Note that the entire planning team decides on the approach for the first-level breakdown. After that the group is partitioned into teams, with each team having some expertise for that part of the WBS. It is hoped that they will have all the expertise they need to develop their part of the WBS. If not, outside help may be brought in as needed. Be careful not to clutter the team with too many people.

It is important to pay close attention to each presentation and ask yourself these questions: Is there something in the WBS that I did not expect to see? Or is there something not there that I expected to see? The focus here is to strive for a complete WBS. In cases where the WBS will be used for reporting purposes, the project manager must be careful to attach lower-level activities to higher-level activities to preserve the integrity of the status reports that will be generated.

As the discussion continues and activities are added and deleted from the WBS, questions about agreement between the WBS and the POS will occur. Throughout the exercise, the POS should be posted on flip-chart paper and hung on the walls of the planning room. Each participant should compare the scope of the project as described in the POS with the scope as presented in the WBS. If something in the WBS appears out of scope, challenge it. Either redefine the scope or discard the appropriate WBS activities. Similarly, look for complete coverage of the scope as described in the WBS with the POS. This is the time to be critical and carefully define the scope and work to accomplish it. Mistakes found now, before any work is done, are far less costly and disruptive than they will be if found late in the project.

The dynamic at work here is one of changing project boundaries. Despite all efforts to the contrary, the boundaries of the project are never clearly defined at the outset. There will always be reason to question what is in and what is not in the project. That is all right. Just remember that the project boundaries have not yet been formally set. That will happen once the project has been approved to begin. Until then, we are still in the planning mode, and nothing is set in concrete.

Bottom-Up Approach

Another approach to identifying the activities in the project is to take a bottom-up approach. This approach is more like a brainstorming session than an organized approach to building the WBS.

The bottom-up approach works as follows. The first steps are the same as those for the top-down approach. Namely, the entire planning team agrees to the first-level breakdown. The planning team is then divided into as many groups as there are first-level activities. Each group then makes a list of the activities that must be completed in order to complete the first-level activity. To do this, they proceed as follows:

  1. Someone in the group identifies an activity and announces it to the group. If the group agrees, then the activity is written on a slip of paper and put in the middle of the table. The process repeats itself until no new ideas are forthcoming.

  2. The group then sorts the slips into activities that seem to be related to one another. This grouping activity should help the planning team add missing activities or remove redundant ones.

  3. Once the team is satisfied it has completed the activity list for the first-level breakdown, the members are finished. Each group then reports to the entire planning team the results of its work.

  4. Final critiques are given, missing activities added, and redundant activities removed.

    Warning

    While this approach has worked well in many cases, there is the danger of not defining all activities or defining activities at too high or low a level of granularity. The completeness criteria that we define later in the chapter are not ensured through this process. Our caution, then, is that you may not have as manageable a project as you would if you followed the top-down approach. Obviously, risk is associated with the bottom-up approach; if you do not have to take the risk, why expose yourself to it voluntarily? Unless there is a compelling reason to the contrary, we recommend the top-down approach. In our experience there is less danger of missing part of the project work using the top-down approach.

WBS for Small Projects

While we have advocated a whiteboard and marker pen approach to building the WBS, we would be remiss if we did not make you aware of some automated tools that you might want to consider for small projects. Small projects are those where the team might be you or you and only one or two others. While the approaches described previously could certainly be used, you might want to consider modifying the approach taken to incorporate some help from available software. We have used a technique called mindmapping.

Mindmapping has been popularized by Joyce Wycoff1 and Tony Buzan.2 The technique is best described as a graphic dump of your brain. It is a nonsequential approach to recording your thoughts about things that must be done or considered in completing a certain task. Figure 4.2 is an example output from a software package called MindManager, which was developed and is sold through the Buzan Centre.3

[1] 1Joyce Wycoff, Mindmapping (New York, N.Y.: Berkley Books, 1991), ISBN 0-425-12780-X.
[2] 2Tony Buzan, The Mind Map Book (New York, N.Y.: Penguin Group, 1996), ISBN 0-452-27322-6.

Click To expand
Figure 4.2: A typical mindmap generated by MindManager.

Intermediate WBS for Large Projects

For very large projects, you may be tempted to modify the top-down approach. While we prefer to avoid modification, difficulty in scheduling people for the planning meeting may necessitate some modification. We offer here not another approach but rather a modification to the top-down approach.

As project size increases, it becomes unwieldy to build the entire WBS with the entire planning team assembled. When the size of the project forces you into this situation, begin by decomposing the WBS down to Level 3. At that point, develop intermediate estimates of time, resources, and dependencies for all Level 3 activities. The planning session is adjourned, and the Level 3 activity managers are charged with completing the WBS for their part of the project. They will convene a JPP session to complete that work. The JPP facilitator may choose to consolidate these Level 3 WBSs into the WBS for the entire project. The full JPP team can be reassembled and the planning process continues from that point.

[3] 3The Buzan Centre’s U.S. distribution center can be contacted at (561) 881-0188 or BuzanCentres@Buzan.co.uk.

In many large projects, the project manager may manage only down to the Level 3 activities and leave it to the Level 3 activity managers to manage their part of the project according to the schedule developed at Level 3.


Six Criteria to Test for Completeness in the WBS

Developing the WBS is the most critical part of the JPP. If we do this part right, the rest is comparatively easy. How do you know that you’ve done this right? Each activity must possess six characteristics to be considered complete—that is, completely decomposed. The six characteristics are as follows:

  • Status/completion is measurable.

  • Start/end events are clearly defined.

  • Activity has a deliverable.

  • Time/cost is easily estimated.

  • Activity duration is within acceptable limits.

  • Work assignments are independent.

If the activity does not possess these six characteristics, decompose the activity and ask the questions again. As soon as an activity possesses the six characteristics, there is no need to further decompose it. As soon as every activity in the WBS possesses these six characteristics, the WBS is defined as complete. An earlier four-criteria version of this completion test was introduced in Weiss and Wysocki (1991).4 We have continued to refine the criteria and present an updated version here. The following sections look at each of these characteristics in more detail.

Measurable Status

The project manager can ask for the status of an activity at any point in time during the project. If the activity has been defined properly, that question is answered easily. For example, if a system’s documentation is estimated to be about 300 pages long and requires approximately four months of full-time work to write, here are some possible reports that your activity manager could provide regarding the status:

  • Let’s see, the activity is supposed to take four months of full-time work. I’ve been working on it for two months full-time. I guess I must be 50 percent complete.

[4] 4Joseph W. Weiss and Robert K. Wysocki, 5-Phase Project Management: A Practical Planning and Implementation Guide (Reading, Mass.: Perseus Publishing Company, 1991).

  • I’ve written 150 pages, so I guess I am 50 percent complete.

  • I’ve written, and had approved, 150 pages and estimate that the remaining work will require two more months. I am 50 percent complete.

No one would buy the first answer, but how many times is that the information we get? Even worse, how many times do we accept it as a valid statement of progress? Although the second answer is a little better, it doesn’t say anything about the quality of the 150 pages that have been written, nor does it say anything about the re-estimate of the remaining work. And so we see that an acceptable answer must state what has been actually completed (approved, not just written, in our example) and what remains to be done, along with an estimate to completion. Remember, you always know more tomorrow than you do today. After working through about half of the activity, the activity manager should be able to give a very accurate estimate of the time required to complete the remaining work.

A simple metric that has met with some success is to compute the proportion of tasks completed as a percentage of all the tasks that make up the activity. For example, suppose the activity has six tasks associated with it and four of the tasks are complete; the ratio of tasks complete to total tasks is 4/6, that is, the activity is 66 percent complete. Even if work had been done on the fifth task in this activity, because the task is not complete on the report date, it cannot be counted in the ratio. This metric certainly represents a very objective measure. Although it may seem somewhat inaccurate, it is a good technique. Best of all, it is quick. Project manager and activity manager do not have to sit around mired in detail about the percentage complete. This same approach can be used to measure the earned value of an activity.

Cross-Reference

We define and discuss earned value in Chapter 10.

Bounded

Each activity should have a clearly defined start and end event. Once the start event has occurred, work can begin on the activity. The deliverable is most likely the end event that signals work is closed on the activity. For example, using the systems documentation example, the start event might be notification to the team member who will manage the creation of the systems documentation that the final acceptance tests of the system are complete. The end event would be notification to the project manager that the customer has approved the system documentation.

Deliverable

The result of completing the work that makes up the activity is the production of a deliverable. The deliverable is a visible sign that the activity is complete. This sign could be an approving manager’s signature, a physical product or document, the authorization to proceed to the next activity, or some other sign of completion.

Cost/Time Estimate

Each activity should have an estimated time and cost of completion. Being able to do this at the lowest level of decomposition in the WBS allows you to aggregate to higher levels and estimate the total project cost and the completion date. By successively decomposing activities to finer levels of granularity, you are likely to encounter primitive activities that you have performed before. This experience at lower levels of definition gives you a stronger base on which to estimate activity cost and duration for similar activities.

Cross-Reference

We cover activity duration estimation in more detail in the next chapter.

Acceptable Duration Limits

While there is no fixed rule for the duration of an activity, we recommend that activities have a duration of less than two calendar weeks. This seems to be a common practice in many organizations. Even for long projects where contractors may be responsible for major pieces of work, they will generate plans that decompose their work to activities having this activity duration. There will be exceptions when the activity defines process work, such as will occur in many manufacturing situations. There will be exceptions, especially for those activities whose work is repetitive and simple. For example, if we are going to build 500 widgets and it takes 10 weeks to complete this activity, we are not going to decompose the activity into 5 activities with each one building 100 widgets. There is no need to break the 500-widget activity down further. If we can estimate the time to check one document, then it does not make much difference if the activity requires two months to check 400 documents or four 2-week periods to check 100 documents per period. The danger you avoid is longer-duration activities whose delay can create a serious project-scheduling problem.

Activity Independence

It is important that each activity be independent. Once work has begun on the activity, it can continue reasonably without interruption and without the need of additional input or information until the activity is complete. The work effort could be contiguous, but it can be scheduled otherwise for a variety of reasons. You can choose to schedule it in parts because of resource availability, but you could have scheduled it as one continuous stream of work.

Related to activity independence is the temptation to micromanage an activity. Best practices suggest that you manage an individual’s work down to units of one week. For example, Harry is going to work on an activity that will require 10 hours of effort. The activity is scheduled to begin on Monday morning and be completed by Friday afternoon. Harry has agreed that he can accommodate the 10 hours within the week, given his other commitments during that same week. Now, Harry’s manager (or the project manager) could ask Harry to report exactly when during the week he will be working on this 10-hour activity and then hold him to that plan. What a waste of everyone’s time that would be! Why not give Harry credit for enough intelligence to make his commitments at the one-week level? No need to drill down into the workweek and burden Harry with a micro-plan and his manager with the burden of managing to that micro-plan. The bottom line may, in fact, be to increase the time to complete the activity, because it has been burdened with unnecessary management overhead.

Using a Joint Project Planning Session to Build the WBS

The best way to build a WBS is as a group activity. To create the WBS, assemble a facilitator, the project manager, the core members of the project team, and all other managers who might be affected by the project or who will affect the project. The important thing is to have the expertise and the decision makers present in this part of the planning session who can give input into the WBS. This exercise should be continuous; you do not want to interrupt it while you go looking for input from people who should already be in the session. The exercise is easy to explain, as we will do in the text that follows, but it is difficult to execute, as we will also explain in the text that follows. The tools are low-tech (Post-It notes, marking pens, and whiteboards), and they greatly facilitate the orderly completion of the task.

  • The first step is for the whole planning team to decide on the first-level decomposition of the goal statement. One obvious approach would be to use the objective statements from the POS as the first-level decomposition. Objectives are generally of great interest to senior managers, and this fact might be a major consideration in the team’s choice. For a software development project, the systems development phases will often be a good first-level decomposition.

  • Once the first-level decomposition is developed, the team has two choices on how to proceed:

    • Without a doubt, the best way (from a WBS completion point of view) is to have the entire planning team remain intact and complete the WBS together. Often that will not work simply from the standpoint of it taking more of everybody’s time and also tying up the time of several high-level managers more than in the second choice.

    • The second choice is to divide the planning team into groups and let each group take one or more of the first-level activities and complete the WBS for that part only.

  • Whichever approach is used, it is essential that the entire group have the opportunity to review the final WBS and offer critiques of it. It is important that these efforts be made, because the WBS must be complete, and all the members of the team will see the final result of the JPP.


Approaches to Building the WBS

There are many ways to build the WBS. Even though we might like the choice to be a personal one that the project manager makes (after all, he or she is charged with managing the project, so why not allow him or her to choose the architecture that makes that task the easiest?), unfortunately, that will not work in many cases. The choice of approach must take into consideration the uses to which the WBS will be put. What may be the best choice for defining the work to be done may not be the best choice for status reporting.

There is no one correct way to create the WBS. Hypothetically, if we put each member of the JPP session in a different room and ask that person to develop the project WBS, they might all come back with different renditions. That’s all right—there is no single best answer. The choice is subjective and based more on the project manager’s preference than on any other requirements. In practice, we have tried to follow one approach only to find that it was making the project work more confusing rather than simpler. In such cases, our advice is simply to throw away the work you have done and start all over again with a fresh approach.

There are three general approaches to building the WBS:

Noun-type approaches. Noun-type approaches define the deliverable of the project work in terms of the components (physical or functional) that make up the deliverable. This approach is the one currently recommended by PMI.

Verb-type approaches. Verb-type approaches define the deliverable of the project work in terms of the actions that must be done to produce the deliverable. Verb-type approaches include the design-build-test-implement and project objectives approaches. This approach was recommended by PMI prior to the current release of PMBOK.

Organizational approaches. Organizational approaches define the deliverable of the project work in terms of the organizational units that will work on the project. This type of approach includes the department, process, and geographic location approaches.

We have seen these approaches used in practice to create the WBS. Let’s take a look at each of these approaches in more detail.

Noun-Type Approaches

There are two noun-type approaches:

Physical decomposition. In projects that involve building products, it is tempting to follow the physical decomposition approach. Take a mountain bike, for example. Its physical components include a frame, wheels, suspension, gears, and brakes. If each component is to be manufactured, this approach might produce a simple WBS. As mentioned previously, though, you have to keep in mind the concern of summary reporting.

As an example, think about rolling up all the tasks related to gears. If you were to create a Gantt chart for reporting at the summary level, the bar for the gears’ summary activity would start at the project start date. A Gantt chart is a simple graphical representation of the work to be done and the schedule for completing it. The Gantt chart consists of a number of rectangular bars—each one representing an activity in the project. The length of each bar corresponds to the estimated time it will take to complete the activity. These bars are arranged across a horizontal time scale, with the left edge of the bar lined up with the scheduled start of the activity. The bars are arranged vertically in the order of scheduled start date. The resulting picture forms a descending stair-step pattern. That is, after all, where the detail tasks of doing design work would occur. The finish of the bar would occur at about the project completion date. That is where testing and documentation for the gears occurs. Using the summary Gantt chart as a status reporting tool for the gears doesn’t have much use. The bar extends from beginning to end of the time line. The same is true of all the other nouns mentioned. Showing all of them on a summary Gantt chart would simply look like the stripes on a prison uniform.

This type of WBS is initially attractive because it looks similar and, in fact, could be identical to a company’s financial Chart of Accounts (CoA). CoAs are noun-oriented because they account for the cost of developing things such as gears and brakes. A CoA should not be confused with the WBS. The WBS is a breakdown of work; the CoA is a breakdown of costs. Most popular project management software products provide code fields that can be used to link project task costs with accounting CoA categories.

Functional decomposition. Using the bicycle example, we can build the WBS using the functional components of the bicycle. The functional components include the steering system, gear-shifting system, braking system, and pedaling system. The same cautions that apply to the physical decomposition approach apply here as well.

Verb-Type Approaches

There are two verb-type approaches:

Design-build-test-implement. The design-build-test-implement approach is commonly used in those projects that involve a methodology. Application systems development is an obvious situation. Using our bicycle example again, a variation on the classic waterfall categories could be used. The categories are design, build, test, and implement. If we were to use this architecture for our WBS, then the bars on the Gantt chart would all have lengths that correspond to the duration of each of the design, build, test, and implement activities and hence would be shorter than the bar representing the entire project. Most, if not all, would have differing start and end dates. Arranged on the chart, they would cascade in a stair-step manner, hence, the name “waterfall.” These are just representative categories; yours may be different. The point is that when the detail-level activity schedules are summarized up to them, they present a display of meaningful information to the recipient of the report.

Remember, the WBS activities at the lowest levels of granularity must always be expressed in verb form. After all, we are talking about work, and that implies action, which, in turn, implies verbs.

Objectives. The objectives approach is similar to the design-build-test-implement approach and is used when progress reports at various stages of project completion are prepared for senior management. Reporting project completion by objectives gives a good indication of the deliverables that have been produced by the project team. Objectives will almost always relate to business value and will be well received by senior management and the customer as well. There is a caveat, however. This approach can cause some difficulty because objectives often overlap. Their boundaries can be fuzzy. You’ll have to give more attention to eliminating redundancies and discovering gaps in the defined work.

Organizational Approaches

The deployment of project work across geographic or organizational boundaries often suggests a WBS that parallels the organization. The project manager would not choose to use this approach but rather would use it out of necessity. In other words, the project manager had no other reasonable choice. These approaches offer no real advantages and tend to create more problems than they solve. We list them here only because they are additional approaches to building the WBS.

Geographic. If project work is geographically dispersed (our space program, for example), it may make sense from a coordination and communications perspective to partition the project work first by geographic location and then by some other approach at each location.

Departmental. On the other hand, departmental boundaries and politics being what they are, we may benefit from partitioning the project first by department and then within department by whatever approach makes sense. We benefit from this structure in that a major portion of the project work is under the organizational control of a single manager. Resource allocation is simplified this way. On the other hand, we add increased needs for communication and coordination across organizational boundaries in this approach.

Business process. The final approach involves breaking the project down first by business process, then by some other method for each process may make sense. This has the same advantages and disadvantages as the departmental approach but the added complication that integration of the deliverables from each process can be more difficult than in the former case.

Again, no single approach can be judged to be best for a given project. Our advice is to consider each at the outset of the JPP session and pick the one that seems to bring clarity to defining the project work.


Representing the WBS

Whatever approach you use, the WBS can be generically represented, as shown in Figure 4.3. The goal statement represents the reason for doing the project.

Click To expand
Figure 4.3: WBS for a house.

The Level 1 partitioning into some number of activities (also known as chunks of work) is a necessary and sufficient set of activities. That is, when all of these first-level activities are complete, the project is complete. For any activity that does not possess the six characteristics, we partition it into a set of necessary and sufficient activities at Level 2. The process continues until all activities have met the six criteria. The lowest level of decomposition in the WBS defines a set of activities that will each have an activity manager, someone who is responsible for completing the activity.

The lowest-level activities are defined by a work package. A work package is simply the list of things to do to complete the activity. The work package may be very simple, such as getting management to sign off on a deliverable. On the other hand, a work package may be a mini project and may consist of all the properties of any other project, except that the activity defining this project possesses the six criteria and need not be further partitioned. We return to the work package in Chapter 7.

Some examples will help clarify. Figure 4.3 is a partial WBS for building a house, and Figure 4.4 is the indented outline version (for those of you who prefer an outline format to a hierarchical graph). Both convey exactly the same information.

Click To expand
Figure 4.4: Indented outline WBS for a house.

Figure 4.5 shows the WBS for the traditional waterfall systems development methodology. For our systems readers, this format could become a template for all your systems development projects. It is a good way to introduce standardization into your systems development methodology.

Click To expand
Figure 4.5: WBS for a waterfall systems development methodology.


Putting It All Together

Getting the WBS correct and complete is the only way a traditional project is going to succeed. In this chapter we have discussed several ways to build a WBS and how to test for its completeness.


Discussion Questions

  1. The WBS identifies all of the work that must be done to complete the project. What would you do if the answer to a question posed as part of the work determined which of two alternatives you should pursue?

  2. Under what conditions might you choose to decompose an activity that met all of the six completeness criteria? Give specific examples.

  3. Can you think of any activities that would not meet all six completeness criteria and yet need not be further decomposed? Give specific examples.

Start Sidebar
Case Study

The high-level WBS for the case study, based on Winston Royce’s Waterfall model, is stored on the CD-ROM. Pick one of the activities and decompose it down to the level where the six completion criteria are met for all of your lowest level activities. (We have decomposed Testing through a few levels as an example; that example is included on the CD-ROM as well.)

End Sidebar


Chapter 5: Estimating Duration, Resource Requirements, and Cost

Overview

Round numbers are always false.

—Samuel Johnson, English critic

Figures are not always facts.

—Aesop, Greek fabulist

You get more control over estimation by learning from evolutionary early and frequent result deliveries than you will if you try to estimate in advance for a whole large project.

—Tom Gilb, Principles of Software Engineering Management


Estimating Duration

Before we can estimate duration, we need to make sure everyone is working from a common definition. The duration of a project is the elapsed time in business working days, not including weekends, holidays, or other non-work days. Work effort is labor required to complete an activity. That labor can be consecutive or nonconsecutive hours.

Start Sidebar
Chapter Learning Objectives

After reading this chapter you will be able to:

  • Understand the difference between effort and duration

  • Explain the relationship between resource loading and activity duration

  • List and explain the causes of variation in activity duration

  • Use any one of six activity duration estimation methods

  • Use a particular estimation technique

  • Assign resources to meet project schedules

  • Understand the process of creating cost estimates at the activity level

  • Schedule people to project activities using a skill matrix

  • Understand the process of determining resource requirements at the activity level

End Sidebar

Duration and work effort are not the same thing. For example, we had a client pose the following situation. The client had an activity that required him to send a document to his client’s lawyer, where it would be reviewed, marked up, and then returned. He had done this on several previous occasions, and it normally took about 10 business days before the document was back in his office. He knew the client’s lawyer took only about 30 minutes to review and mark up the document. His question was, what’s the duration? The answer is 10 days. The work effort on the part of the lawyer is 30 minutes.

It is important to understand the difference between labor time and clock time. They are not the same. Let’s say that an estimate has been provided that a certain task requires 10 hours of focused and uninterrupted labor to complete. Under normal working conditions, how many hours do you think it will really take? Something more than 10 for sure. To see why this is so, let’s consider the data shown in Figure 5.1.

Click To expand
Figure 5.1: Elapsed time versus work time.

If a person could be focused 100 percent of the time on an activity, he or she could accomplish 10 hours of work in 10 hours. Such a person would be unique, for what is more likely is that his or her work will be interrupted by email, beepers, meetings, coffee breaks, and socializing. Several estimates for the percent of a person’s day that he or she can devote to project activity work have been made. Past data that we have collected from information technology professionals indicates a range of 66 to 75 percent. More recently, among the same client base, we have seen a downward trend in this percentage to 50 to 65 percent. Using the 75 percent estimate means that a 10-hour task will require about 13 hours and 20 minutes to complete. That is without interruptions, which we know always happen.

For some professionals interruptions are frequent (technical support, for example); for others interruptions are infrequent. We polled the 17-person technical support unit of a midsized information services department and found that about one-third of their time was spent on unplanned interruptions. Unplanned interruptions might include a phone call with a question to be answered, a systems crash, power interrupts, random events of nature, the boss stopping in to visit on an unrelated matter, or a phone call from your golfing buddies. Using the 75 percent focus figure and the 33 percent on unplanned interruptions figure means that a 10-hour task will take approximately 20 hours to complete.

It is this elapsed time that we are interested in estimating for each activity in the project. It is the true duration of the activity. For costing purposes, we are interested in the labor time (work) actually spent on an activity.

Note

When estimating activity duration, you have a choice to make. Do you want to estimate hours of billable labor to complete the activity, or do you want to estimate the clock time required to complete the activity? Probably both. The labor hours are needed in order to bill the client. The elapsed clock time is needed in order to estimate the project completion date.

Resource Loading versus Activity Duration

The duration of an activity is influenced by the amount of resources scheduled to work on it. We say influenced because there is not necessarily a direct linear relationship between the amount of resource assigned to an activity and its duration.

Adding more resources to hold an activity’s duration within the planning limits can be effective. This is called “crashing the activity.” For example, suppose you are in a room where an ordinary-size, four-legged chair is in the way. The door to the room is closed. You are asked to pick up the chair and take it out of the room into the hallway. You might try to do it without any help, in which case you would perform the following steps:

  1. Pick up the chair.

  2. Carry it to the door.

  3. Set the chair down.

  4. Open the door.

  5. Hold the door open with your foot as you pick up the chair.

  6. Carry the chair through the door.

  7. Set the chair down in the hallway.

Suppose you double the resources. We’ll get someone to help you by opening the door and holding it open while you pick up the chair and carry it out to the hallway. With two people working on the activity, you’d probably be willing to say it would reduce the time to move the chair out into the hall.

Doubling the resources sounds like a technology breakthrough in shortening duration. Let’s try doubling them again and see what happens. Now, we’ve got four resources assigned to the activity. The activity would go something like this: First, you hold a committee meeting to decide roles and responsibilities. Each person would like to get equal credit, so each one grabs a leg of the chair and tries to go through the door, but they all get stuck in the door. (By the way, there’s nobody left to open the door because each of the four resources is dedicated to one leg of the chair.)

The point of this silly example is to show that there are diminishing returns for adding more resources. You would probably agree that there is a maximum loading of resources on a task to minimize the activity duration, and that by adding another resource you will actually begin to increase the duration. You have reached the crashpoint of the activity. The crashpoint is that point where adding more resources will increase activity duration. There will be many occasions when the project manager will have to consider the optimum loading of a resource on a task.

A second consideration for the project manager is the amount of reduction in duration that results from adding resources. The relationship is not linear. Consider the chair example again. Does doubling the resource cut the duration in half? Can two people dig a hole twice as fast as one? Probably not. The explanation is simple. By adding the nth person to an activity, you create the need for n more communication links. Who is going to do what? How can the work of several persons be coordinated? There may be other considerations that actually add work. To assume that the amount of work remains constant as you add resources is simply not correct. New kinds of work will emerge from the addition of a resource to an activity. For example, adding another person adds the need to communicate with more people and increases the duration of the activity.

A third consideration for the project manager is the impact on risk that results from adding another resource. If we limit the resource to people, we must consider the possibility that two people will prefer to approach the activity in different ways, with different work habits and with different levels of commitment. The more people working on an activity, the more likely one will be absent, the higher the likelihood of a mistake being made, and the more likely they will get in each other’s way.

Variation in Activity Duration

Activity duration is a random variable. Because we cannot know what factors will be operative when work is underway on an activity, we cannot know exactly how long it will take. There will, of course, be varying estimates with varying precision for each activity. One of your goals in estimating activity duration is to define the activity to a level of granularity so that your estimates have a narrow variance—that is, the estimate is as good as you can get it at the planning stages of the project. As project work is completed, you will be able to improve the earlier estimates of activities scheduled later in the project.

There are several causes of variation in the actual activity duration:

Varying skill levels. Our strategy is to estimate activity duration based on using people of average skills assigned to work on the activity. In actuality, this may not happen. You may get a higher- or lower-skilled person assigned to the activity, causing the actual duration to vary from planned duration. These varying skill levels will be both a help and a hindrance to us.

Unexpected events. Murphy lives in the next cubicle and will surely make his presence known, but in what way and at what time we do not know. Random acts of nature, vendor delays, incorrect shipments of materials, traffic jams, power failures, and sabotage are but a few of the possibilities.

Efficiency of work time. Every time a worker is interrupted, it takes more time to get up to the level of productivity prior to the time of the interruption. You cannot control the frequency or time of interruptions, but you do know that they will happen. As to their effect on staff productivity, you can only guess. Some will be more affected than others.

Mistakes and misunderstandings. Despite all of your efforts to be complete and clear in describing the work to be performed, you simply will miss a few times. This will take its toll in rework or scrapping semicompleted work.

Common cause variation. Apart from all of these factors that can influence activity duration, the reality is that durations will vary for no reason other than the statistical variation that arises because the duration is in fact a random variable. It has a natural variation, and nothing you do can really decrease that variation. It is there, and it must be accepted.

Six Methods for Estimating Activity Duration

Estimating activity duration is challenging. You can be on familiar ground for some activities and on totally unfamiliar ground for others. Whatever the case, you must produce an estimate. It is important that senior management understand that the estimate can be little more than a WAG (wild a** guess). In many projects the estimate will be improved as you learn more about the deliverables from having completed some of the project work. Re-estimation and replanning are common. In our consulting practice, we have found six techniques to be quite suitable for initial planning estimates:

  • Similarity to other activities

  • Historical data

  • Expert advice

  • Delphi technique

  • Three-point technique

  • Wide-band Delphi technique

Let’s take a look at each of these techniques in more detail.

Extrapolating Based on Similarity to Other Activities

Some of the activities in your WBS may be similar to activities completed in other projects. Your or others’ recollections of those activities and their duration can be used to estimate the present activity’s duration. In some cases, this process may require extrapolating from the other activity to this one, but in any case, it does provide an estimate. In most cases, using the estimates from those activities provides estimates that are good enough.

Studying Historical Data

Every good project management methodology contains a project notebook that records the estimated and actual activity duration. This historical record can be used on other projects. The recorded data becomes your knowledge base for estimating activity duration. This technique differs from the previous technique in that it uses a record, rather than depending on memory.

Historical data can be used in quite sophisticated ways. One of our clients has built an extensive database of activity duration history. They have recorded not only estimated and actual duration but also the characteristics of the activity, the skill set of the people working on it, and other variables that they found useful. When an activity duration estimate is needed, they go to their database with a complete definition of the activity and, with some rather sophisticated regression models, estimate the activity duration. They build product for market, and it is very important to them to be able to estimate as accurately as possible. Again, our advice is that if there is value added for a particular tool or technique, use it.

Seeking Expert Advice

When the project involves a breakthrough technology or a technology that is being used for the first time in the organization, there may not be any local experience or even professionals skilled in the technology within the organization. In these cases, you will have to appeal to outside authorities. Vendors may be a good source, as are noncompetitors who use that technology.

Applying the Delphi Technique

The Delphi technique can produce good estimates in the absence of expert advice. This is a group technique that extracts and summarizes the knowledge of the group to arrive at an estimate. After the group is briefed on the project and the nature of the activity, each individual in the group is asked to make his or her best guess of the activity duration. The results are tabulated and presented, as shown in Figure 5.2, to the group in a histogram labeled First Pass. Those participants whose estimates fall in the outer quartiles are asked to share the reason for their guess. After listening to the arguments, each group member is asked to guess again. The results are presented as a histogram labeled Second Pass, and again the outer quartile estimates are defended. A third guess is made, and the histogram plotted is labeled Third Pass. Final adjustments are allowed. The average of the third guess is used as the group’s estimate. Even though the technique seems rather simplistic, it has been shown to be effective in the absence of expert advice.

Click To expand
Figure 5.2: The Delphi technique.

We attended an IBM business partners’ meeting several years ago. One of the sessions dealt with estimating software development time, and the presenter demonstrated the use of the Delphi technique with a rather intriguing example. She asked if anyone in the group had ever worked in a carnival as a weight-guessing expert. None had, so she informed the group that they were going to use the Delphi technique to estimate the average weight of the 20 people who were in the room. She asked everyone to write his or her best guess as to his or her weight on a slip of paper. These were averaged by the facilitator and put aside. Each person took an initial guess as to the average weight, wrote it down, and passed it to the facilitator. She displayed the initial pass histogram and asked the individuals with the five high and five low guesses to share their thinking with the group; a second guess was taken and then a third. The average of the third guess became the group’s estimate of the average body weight. Surprisingly, the estimate was just two pounds off from the reported average.

The approach the presenter used is actually a variation of the original Delphi technique. The original version used a small panel of experts (say, five or six) who were asked for their estimate independently of one another. The results were tabulated and shared with the panel, who were then asked for a second estimate. A third estimate was solicited in the same manner. The average of the third estimate was the one chosen. Note that the original approach does not involve any discussion or collaboration between the panel members. In fact, they weren’t even aware of who the other members were.

Applying the Three-Point Technique

Activity duration is a random variable. If it were possible to repeat the activity several times under identical circumstances, duration times would vary. That variation may be tightly grouped around a central value, or it might be widely dispersed. In the first case, you would have a considerable amount of information on that activity’s duration as compared to the latter case, where you would have very little or none. In any given instance of the activity, you would not know at which extreme the duration would likely fall, but you could make probabilistic statements about their likelihood in any case.

The three-point technique gives us a framework for doing just that. To use the method, you need three estimates of activity duration:

Optimistic. The optimistic time is defined as the shortest duration one has had or might expect to experience given that everything happens as expected.

Pessimistic. The pessimistic time is that duration that would be experienced (or has been experienced) if everything that could go wrong did go wrong, yet the activity was completed.

Most likely. The most likely time is that time usually experienced.

For this method you are calling on the collective memory of professionals who have worked on similar activities but for which there is no recorded history. Figure 5.3 is a graphical representation of the three-point method.

Applying the Wide-Band Delphi Technique

Combining the Delphi and three-point methods results in the wide-band Delphi technique. It involves a panel, as in the Delphi technique. In place of a single estimate, the panel members are asked, at each iteration, to give their optimistic, pessimistic, and most likely estimates for the duration of the chosen activity. The results are compiled, and any extreme estimates are removed. Averages are computed for each of the three estimates, and the averages are used as the optimistic, pessimistic, and most likely estimates of activity duration.

Click To expand
Figure 5.3: The three-point method.

Estimation Precision

A word of advice on estimating is in order. Early estimates of activity duration will not be as good as later estimates. It’s a simple fact that we get smarter as the project work commences. Estimates will always be subject to the vagaries of nature and other unforeseen events. We can only hope that we have gained some knowledge through the project to improve our estimates.

In our top-down project planning model, we start out with “roughly right” estimates, with the intention of improving the precision of these estimates later in the project. Management and the customer must be aware of this approach. Most of us have the habit of assuming that a number, once written, is inviolate and absolutely correct regardless of the circumstances under which the number was determined.


Estimating Resource Requirements

By defining project activities according to the completion criteria, you should have reached a point of granularity with each activity so that it is familiar. You may have done the activity or something very similar to it in a past project. That recollection, that historical information, gives us the basis for estimating the resources you will need to complete the activities in the current project. In some cases, it is a straightforward recollection; in others, the result of keeping a historical file of similar activities; in still others, the advice of experts.

The importance of resources varies from project to project. The six estimation techniques discussed in the previous section can be used to estimate the resource requirements for any project.

Types of resources include the following:

People. In most cases the resources you will have to schedule are people resources. This is also the most difficult type of resource to schedule.

Facilities. Project work takes place in locations. Planning rooms, conference rooms, presentation rooms, and auditoriums are but a few examples of facilities that projects require. The exact specifications as well as the precise time at which they are needed are some of the variables that must be taken into account. The project plan can provide the detail required. The facility specification will also drive the project schedule based on availability.

Equipment. Equipment is treated exactly the same as facilities. What is needed and when drive the activity schedule based on availability.

Money. Accountants would tell us that everything is eventually reduced to dollars, and that is true. Project expenses typically include travel, room and meals, and supplies.

Materials. Parts to be used in the fabrication of products and other physical deliverables are often part of the project work, too. For example, the materials needed to build a bicycle might include nuts, bolts, washers, and spacers.

People as Resources

People are the most difficult type of resource to schedule because we plan the project by specifying the types of skills we need, when we need them, and in what amounts. Note that we do not specify by name the resource (that is, the individual) we need; this is where problems arise.

There are a few tools you can use to help you schedule people.

Skills Matrices

We find more and more of our clients are developing skills inventory matrices for staff and skill needs matrices for activities. The two matrices are used to assign staff to activities. The assignment could be based on activity characteristics such as risk, business value, criticality, or skill development. Figure 5.4 illustrates how the process can work.

This process involves gathering inventory data for two inventories:

  • An inventory of the demand for skills needed to perform the tasks associated with specific activities. This is represented as a matrix whose rows are the activities and whose columns are the skills. These are both current and long-term needs.

  • An inventory of the current skills among the professional staff. This is represented as a matrix whose rows identify the staff and whose columns are the skills.

    Click To expand
    Figure 5.4: Assigning staff to activities.

The columns of both matrices define the same set of skills. This gives us a way to link the two matrices and assign staff to activities. This approach can be used for on-the-job staff development. As an on-the-job development strategy, the manager would have previously met with the staff member, helped him or her define career goals, and translated those goals into skill development needs. That information can now be used to assign staff to activities so that the work they will do on the activity will give them that on-the-job development.

Skill Categories

This part of the skill matrix is developed by looking at each activity that the unit must perform and describing the skills needed to perform the activity. Because skills may appear in unrelated activities, the list of possible skills must be standardized across the enterprise.

Skill Levels

A binary assessment—that is, you either have the skill or you don’t—is certainly easier to administer, but it isn’t sufficient for project management. Skills must be qualified with a statement of how much of the skill the person possesses. Various methods are available, and companies often develop their own skill-level system.

Resource Breakdown Structure

Just as there is a Work Breakdown Structure, so also is there a Resource Breakdown Structure. Figure 5.5 gives a simple example.

Click To expand
Figure 5.5: An example of a Resource Breakdown Structure.

The Resource Breakdown Structure is used to assist in not only resource estimation but also cost estimation. The Resource Breakdown Structure is determined by the job families, which are defined by the human resource department. That definition is simply put into this hierarchical framework and used as the basis for identifying the positions and levels that are needed to staff the project and from that constructing the staffing budget.


Estimating Duration as a Function of Resource Availability

Three variables influence the duration estimate of an activity, and all of them influence each other. They are as follows:

  • The duration itself

  • The total amount of work, as in person hours/days, that will be done on the activity by a resource

  • The percent per day of his or her time that the resource can devote to working on it

Many project management software products today allow you to enter any two of these three variables and calculate the third for you. There is no one right way; it’s a matter of what works best and is most consistent with the way you mentally approach estimating. There are four ways to approach the calculation of duration, total effort, and percent/day. Remember that two of them are specified and the third is calculated. The methods are listed here and described in the sections that follow.

  • Assign as a total work and constant percent/day

  • Assign as a duration and total work effort

  • Assign as a duration and percent/day

  • Assign as a profile

Assign as a Total Work and a Constant Percent/Day

If we know that the total “head down, focused” work effort required to do the activity is 40 hours but that the resource can devote only 50 percent of his or her typical day to doing project activity work, then the resulting duration is going to be 80 hours, or 10 business days. The formula is simply this:

40 hours/0.50 = 80 hours

The duration becomes a calculated value based on the percent per day and the work. This method is the one that most software products use as their default method. It’s tempting to use a percent-per-day resource allocation value that’s higher than it actually will be. We can be a bit squeamish about telling it like it really is. If that is done, the duration is shortened accordingly. The project completion date is then invalid because it is calculated using an overly optimistic duration.

Assign as a Duration and Total Work Effort

Alternatively, you could use your or someone else’s experience and estimate the duration based on history. Then the total work could be averaged over that duration, yielding the percent per day value. Using the same values as above, the formula would look like this:

5 person days / 10 days = 0.5

Here again we’re making the assumption of an eight-hour day. In this case, the percent is calculated. Approaching the estimate from this direction (we’re just running the numbers a different way) seems in practice to avoid the problem of squeamishness. You still need to do a sanity check on the resulting value; don’t just blindly accept it. In our consulting we’ve found that this usually results in an estimated duration that comes closer to matching the actual when all is said and done.

Assign as a Duration and Percent/Day

The third method is to estimate the duration as previously described and assign the percent per day. This method will calculate the total work effort. The formula works like this:

10 days x 0.50 = 5 person days

Of the three methods, this is the least used.

Assign as a Profile

The three duration estimating and resource assignment methods discussed here all presume that the resource is going to work at about the same percent per day for each day of the activity. In other words, they are flat-loaded at a constant rate. There will be cases where the person cannot work at a constant rate because of other commitments. In such cases, the duration is estimated first and then the work is assigned at different percents over the 40-hour window. For example, we might assign the worker 75 percent for 20 hours and 50 percent for 20 hours. If you find yourself having to use this profiling of resource assignments capability on activities more than two or three times in a project, you may need to take your WBS to a lower level of detail. In doing that, the duration will be shorter and the resources can work in a contiguous manner for the entire activity.


Estimating Cost

Now that we have estimated activity duration and resource requirements, we have the data we need to establish the cost of the project. This is our first look at the dollars involved in doing the project. We know the resources that will be required and the number of hours or volume of resources needed. Unit cost data can be applied to the amount of resource required to estimate cost.

Resource Planning

There are several questions you need to consider concerning the resources for your project. As we have pointed out, adding resources doesn’t necessarily mean that you will shorten the time needed for various activities. Adding too many people can actually add time to the project. Another factor to consider deals with the skill level of the resources.

Let’s say that you are going to have a team of developers work on the application. When you are planning resources, you have to know the skill level of the potential resources. You may have to trade money for time. That means you may be able to get a lower cost by using a junior developer, but it’s likely that you will also find the process takes longer. Knowing the skill sets of the available people and taking that into account when doing scheduling is a major part of resource planning.

Another issue to consider is that of using part-time people. At first glance, using part-time people looks like a good idea. It appears you can make good decisions concerning their schedules and that you are getting extremely efficient use of their time. However, this isn’t reality, particularly if the part-time people are coders. Development is a mental task; you’re working with knowledge workers. You can’t turn on and off a mental process at will.

Similarly, scheduling people on two projects the same day won’t be efficient use of resources. It takes some time for the developer to get up to writing speed. So when you’re scheduling, don’t think you can schedule different projects for the same knowledge worker on the same day. That kind of schedule may look good on paper, but it doesn’t work. Give your resources a chance to get into the flow of work, and you’ll be much more successful.

Cost Estimating

When doing an estimate, you need to consider a few concepts. The first is that no matter how well you estimate cost, it is always an estimate. One of the reasons that so many projects come in over budget is that people actually believe that they have done perfect estimating and that their baseline estimate is set in stone. Remember that it is always an estimate. Anytime you are forecasting the future, as you are when you plan a project, you are dealing with some amount of uncertainty. Because projects are unique by definition, you are doing an estimate. Projects are so often over budget because the budget is an estimate, not an exact mathematical calculation. Even experienced cost estimators miss the mark.

Having given you that warning, you still need to do your best to come up with a working budget for the project. Estimating can be done several ways. One is to find an analogous project, one that looks a great deal like the one you’re currently planning. By using it as a guideline, you’ll have a reference point on the costs. The caveat that you must keep in mind is that each project is unique, and it is that uniqueness that means you will have a slightly different budget for your estimate than the one from the previous project. Don’t use the exact same figures when you estimate; it will come back to haunt you sometime in the project.

Another good practice in estimating is to invite subject matter experts (SMEs) to help you prepare your estimate. Ideally, these SMEs will be able to discuss their areas of expertise and give you a better handle on the estimating for your current projects.

Three types of estimates are common in project management.

Order of magnitude estimate. This type means that the number given for the estimate is somewhere between 25 percent above and 75 percent below the number. Order of magnitude estimates are often used at the very beginning of the estimation process when very little detail is known about the project work and a rough estimate is all that management calls for. It is understood that this estimate will be improved over time.

Budget estimate. This type has a range of 10 percent over and 25 percent below the stated estimate. These estimates are generated during project planning time and are based on knowing some detail about the project activities.

Definitive estimate. This type is generally the one that is used for the rest of the project. It has a range of 5 percent over and 10 percent below the stated estimate. These estimates are most useful during project execution when new information helps further improve the estimates generated during project planning time.

When giving an estimate for a project, it’s a good idea to have these three ranges in mind. Remember that even if you tell a sponsor that your estimate is an order of magnitude estimate, the sponsor will remember it for the rest of the project. Protect yourself in this case by writing “order of magnitude” on the estimate. Doing so will at least give you something with which to defend yourself if it comes to that.

Cost Budgeting

Once you’ve done an estimate, you want to go into the cost budgeting phase. This phase is the time when you assign costs to tasks on the WBS. Cost budgeting is actually very formulaic. You take the needed resources and multiply the costs times the number of hours they are to be used. In the case of a one-time cost, such as hardware, you simply state that cost.

Cost budgeting gives the sponsor a final check on the costs of the project. The underlying assumption is that you’ve got all the numbers right. Usually you’ll have the cost of a resource right, but often it’s tough to be exact on the total number of hours the resource is to be used. Remember that no matter what, you are still doing an estimate. Cost budgeting is different than estimating in that it is more detailed. However, the final output is still a best effort at expressing the cost of the project.

Cost Control

Cost control represents two major issues for the project manager:

  • The first is how often you need to get reports of the costs. Certainly, it would be good if you could account for everything occurring on the project in real time. However, that is generally way too expensive and time-intensive. More likely, you’ll get figures once a week. Getting cost status figures once a week gives you a good snapshot of the costs that are occurring. If you wait longer than a week to get cost figures, you may find that the project has spun out of control.

  • The second issue deals with how you look at the numbers you’re receiving. If you’ve done a cost baseline, then you’ll have some figures against which you can measure your costs. What you’re looking for is a variance from the original costs. The two costs you have at this point are your baseline and the actual costs that have occurred on the project. The baseline was the final estimate of the costs on the project. Your job is to look at the two and determine if management action must be taken.

    Note

    How far off do the numbers need to be between the final estimate and your actual costs before you take some action? Usually 10 percent is the most allowed. However, if you see a trend appearing—usually meaning a trend of being over budget—you should take a look at the reasons behind the variance before it reaches 10 percent.

A word of advice: Remember that there are projects where time is the most important of the constraints for the project. Remember Y2K? In cases like those, you must balance your need for cost control with the need for a time-definite project ending. There may be a trade-off in cost control for time constraints. As a project manager, you must be aware of these trade-offs and be ready to justify changes in costs to the sponsor based on other considerations such as time and quality.


Using a JPP Session to Estimate Duration, Resource Requirements, and Cost

You have assembled the SMEs on your planning team, so you have all the information you need to estimate activity duration in the JPP session. The methodology is simple. During the WBS exercise, ask each subteam to provide activity duration estimates as part of their presentation. The subteam’s presentation will then include the activity duration estimates they determined. Any disagreement can be resolved during the presentation.

We have conducted many JPP sessions and have some advice for estimating activity duration during the JPP session. Namely:

Get it roughly right. Do not waste time deciding whether the duration is nine days or 10 days. By the time the activity is open for work, the team will have a lot more knowledge about the activity and will be able to provide an improved estimate—rendering the debate a waste of time. After some frustration with getting the planning team to move ahead quickly with estimates, someone once remarked, “Are you 70 percent sure you are 80 percent right? Good, let’s move on.”

Spend more effort on front-end activities than on back-end activities. As project work commences, back-end activities may undergo change. In fact, some may be removed from the project altogether.

Consensus is all that is needed. If you have no serious objections to the estimate, let it stand. It is easy to get bogged down in minutia. The JPP session is trying enough on the participants. Don’t make it any more painful than needed. Save your energy for the really important parts of the plan—like the WBS.

Determining Resource Requirements

The planning team includes resource managers or their representatives. At the time the planning team is defining the WBS and estimating activity duration, they will also estimate resource requirements.

We have found the following practice effective:

  1. Create a list of all the resources required for the project. For people resources, list only position title or skill level. Do not name specific people even if there is only one person with the requisite skills. Envision a person with the typical skill set and loading on the project activity. Activity duration estimates are based on workers of average skill level, and so should be resource requirements. You will worry about changing this relationship later in the planning session.

  2. When the WBS is presented, resource requirements can be reported, too.

We now have estimated the parameters needed to begin constructing the project schedule. The activity duration estimates provide input to planning the order and sequence of completing the work defined by the activities. Once the initial schedule is built, we can use the resource requirements and availability data to further modify the schedule.

Determining Cost

The team should have access to a standard costing table. This table will list all resources, unit of measure, and cost per unit. It is then just a simple exercise in calculating the cost per resource based on the number of units required and the cost per unit. Many organizations will have a spreadsheet template that will facilitate the exercise. These calculated figures can be transferred to the WBS and aggregated up the WBS hierarchy to give a total cost for each activity level in the WBS.

Start Sidebar
What If the Specific Resource Is Known?

Knowing the specific resource will occur quite often, and we are faced with the question: Should we put that person in the plan? If you do and if that person is not available when you need him or her, how will that affect your project plan? If he or she is very highly skilled and you used that information to estimate the duration of the activity that person was to work on, you may have a problem. If you cannot replace him or her with an equally skilled individual, will that create a slippage that dominoes through the project schedule? Take your choice.

End Sidebar


Putting It All Together

We now have all of the activity-level data that we need to build the project plan. What remains are the interactivity data in the form of dependencies and relationships. We can then build an initial project plan. In the next chapter, we discuss dependencies and relationships between activities and then learn how to display the project graphically in the form of a project network diagram.


Discussion Questions

  1. You have used the three-point method to estimate the duration of an activity that you know will be critical to the project. The estimate produces a very large difference between the optimistic and pessimistic estimates. What actions might you take, if any, regarding this activity?

  2. Discuss a project on which you’ve worked where time was the major factor in determining the success or failure of the project. What did you do about cost considerations? Did the sponsor(s) agree with the added cost? Was the project successful?

  3. Prepare a simple budget showing an order of magnitude estimate, a budget estimate, and a definitive estimate. What did you have to do to make each successive budget closer to the final working budget?

Start Sidebar
Case Study

You are going to do a presentation to the board of Jack Neift Trucking (see the Introduction for the case study). You are the outside project manager, Sal Vation. Here are some of the topics you are going to present to the board. Where will you go to find the information for the presentation?

The topics are as follows:

  1. Buy versus make—How did you come to the decision to build the application in-house?

  2. What are the risks inherent in building a new application?

  3. What means will you use to control costs? Will savings be passed along to the Jack Neift Trucking Company?

  4. If time, cost, and quality are the three major constraints of a project, which one do you think is the most important to Jack Neift? Defend your answer. How will this be put into your presentation for the board?

    Please put time values in MS Project based on your WBS and the major constraint you determined in Question 4. These time values mean you must consider the constraint as part of your scheduling requirements.

End Sidebar


Chapter 6: Constructing and Analyzing the Project Network Diagram

Overview

Structure is not organization.

—Robert H. Waterman, Management consultant

The man who goes alone can start today, but he who travels with another must wait ‘til that other is ready.

—Henry David Thoreau, American naturalist

In every affair consider what precedes and what follows, and then undertake it.

—Epictetus, Greek philosopher

Every moment spent planning saves three or four in execution.

—Crawford Greenwalt, President, DuPont


The Project Network Diagram

At this point in the TPM life cycle, you have identified the set of activities in the project as output from the WBS-building exercise and the activity duration for the project. The next task for the planning team is to determine the order in which these activities are to be performed.

Start Sidebar
Chapter Learning Objectives

After reading this chapter, you will be able to:

  • Construct a network representation of the project activities

  • Understand the four types of activity dependencies and when they are used

  • Recognize the types of constraints that create activity sequences

  • Compute the earliest start (ES), earliest finish (EF), latest start (LS), and latest finish (LF times for every activity in the network

  • Understand lag variables and their uses

  • Identify the critical path in the project

  • Define free slack and total slack and know their significance

  • Analyze the network for possible schedule compression

  • Use advanced network dependency relationships for improving the project schedule

  • Understand and apply management reserve

  • Use the critical path for planning, implementation, and control of the project activities

End Sidebar

The activities and the activity duration are the basic building blocks needed to construct a graphic picture of the project. This graphic picture provides you with two additional pieces of schedule information about the project:

  • The earliest time at which work can begin on every activity that makes up the project

  • The earliest expected completion date of the project

This is critical information for the project manager. Ideally, the required resources must be available at the times established in this plan. This is not very likely. Chapter 7 discusses how to deal with that problem. In this chapter, we focus on the first part of the problem—creating an initial project network diagram and the associated project schedule.

Envisioning a Complex Project Network Diagram

A project network diagram is a pictorial representation of the sequence in which the project work can be done. There are a few simple rules that you need to follow to build the project network diagram.

Recall from Chapter 1 that a project is defined as a sequence of interconnected activities. You could perform the activities one at a time until they are all complete. That is a simple approach, but in all but the most trivial projects, this approach would not result in an acceptable completion date. In fact, it results in the longest time to complete the project. Any ordering that allowed even one pair of activities to be worked on concurrently would result in a shorter project completion date.

Another approach is to establish a network of relationships between the activities. You can do this by looking forward through the project. What activities must be complete before another activity can begin? Or, you can take a set of activities and look backward through the project: Now that a set of activities is complete, what activity or activities could come next? Both ways are valid. The one you use is a matter of personal preference. Are you more comfortable looking backward in time or forward? Our advice is to look at the activities from both angles. One can be a check of the completeness of the other.

The relationships between the activities in the project are represented in a flow diagram called a network diagram or logic diagram.

Benefits to Network-Based Scheduling

There are two ways to build a project schedule:

  • Gantt chart

  • Network diagram

The Gantt chart is the oldest of the two and is used effectively in simple, short-duration types of projects. As mentioned in Chapter 4, to build a Gantt chart, the project manager begins by associating a rectangular bar with every activity. The length of the bar corresponds to the duration of the activity. He or she then places the bars horizontally along a time line in the order in which the activities should be completed. There can be instances in which activities are located on the time line so that they are worked on concurrently with other activities. The sequencing is often driven more by resource availability than any other consideration.

There are two drawbacks to using the Gantt chart:

  • Because of its simplicity, the Gantt chart does not contain detailed information. It reflects only the order imposed by the manager and, in fact, hides much of that information. You see, the Gantt chart does not contain all of the sequencing information that exists. Unless you are intimately familiar with the project activities, you cannot tell from the Gantt chart what must come before and after what.

  • Second, the Gantt chart does not tell the project manager whether the schedule that results from the Gantt chart completes the project in the shortest possible time or even uses the resources most effectively. The Gantt chart reflects only when the manager would like to have the work done.

Although a Gantt chart is easier to build and does not require the use of an automated tool, we recommend using the network diagram. The network diagram provides a visual layout of the sequence in which project work flows. It includes detailed information and serves as an analytical tool for project scheduling and resource management problems as they arise during the life of the project. In addition, the network diagram allows you to compute the earliest time at which the project can be completed. That information does not follow from a Gantt chart.

Network diagrams can be used for detailed project planning, during implementation as a tool for analyzing scheduling alternatives, and as a control tool:

Planning. Even for large projects, the project network diagram gives a clear graphical picture of the relationship between project activities. It is, at the same time, a high-level and detailed-level view of the project. We have found that displaying the network diagram on the whiteboard or flip charts during the planning phase is beneficial. This way, all members of the planning team can use it for scheduling decisions.

Cross-Reference

We explore using the network diagram in the JPP later in this chapter.

Implementation. For those project managers who use automated project management software tools, you will update the project file with activity status and estimate-to-completion data. The network diagram is then automatically updated and can be printed or viewed. The need for rescheduling and resource reallocation decisions can be determined from the network diagram, although some argue that this method is too cumbersome due to project size. Even a project of modest size, say, 100 activities, produces a network diagram that is too large and awkward to be of much use. We cannot disagree, but we place the onus on software manufacturers to market products that do a better job of displaying network diagrams.

Control. While the updated network diagram retains the status of all activities, the best graphical report for monitoring and controlling project work will be the Gantt chart view of the network diagram. This Gantt chart cannot be used for control purposes unless you have done network scheduling or incorporated the logic into the Gantt chart. Comparing the planned schedule with the actual schedule, the project manager will discover variances and, depending on their severity, will be able to put a get-well plan in place.

Cross-Reference

In Chapter 10 we examine monitoring and controlling progress in more detail and provide additional reporting tools for analyzing project status.


Building the Network Diagram Using the Precedence Diagramming Method

One of the early methods for representing project activities as a network dates back to the early 1950s and the Polaris Missile Program. It is called the activity-on-the-arrow (AOA) method. As Figure 6.1 shows, an arrow represents each activity. The node at the left edge of the arrow is the event “begin the activity,” while the node at the right edge of the arrow is the event “end the activity.” Every activity is represented by this configuration. Nodes are numbered sequentially, and the sequential ordering had to be preserved, at least in the early versions. Because of the limitations of the AOA method, ghost activities had to be added to preserve network integrity. Only the simplest of dependency relationships could be used. This technique proved to be quite cumbersome as networking techniques progressed. One seldom sees this approach used today.

Click To expand
Figure 6.1: The activity-on-the-arrow method.

With the advent of the computer, the AOA method lost its appeal, and a new method replaced it. Figure 6.2 shows the activity-on-the-node (AON) method. The term more commonly used to describe this approach is precedence diagramming method (PDM).

Click To expand
Figure 6.2: PDM format of a project network diagram.

The basic unit of analysis in a network diagram is the activity. Each activity in the network diagram is represented by a rectangle that is called an activity node. Arrows represent the predecessor/successor relationships between activities. Figure 6.2 shows an example network diagram. We take a more detailed look into how the PDM works later in this chapter.

Every activity in the project will have its own activity node (see Figure 6.3). The entries in the activity node describe the time-related properties of the activity. Some of the entries describe characteristics of the activity, such as its expected duration (E), while others describe calculated values (ES, EF, LS, LF) associated with that activity. We will define these terms shortly and give an example of their use.

Figure 6.3: Activity node.

In order to create the network diagram using the PDM, you need to determine the predecessors and successors for each activity. To do this, you ask “What activities must be complete before I can begin this activity?” Here, you are looking for the technical dependencies between activities. Once an activity is complete, it will have produced an output, a deliverable, which becomes input to its successor activities. Work on the successor activities requires only the output from its predecessor activities.

Note

Later we incorporate management constraints that may alter these dependency relationships. For now we prefer to delay consideration of the management constraints; they will only complicate the planning at this point.

What is the next step? While the list of predecessors and successors to each activity contains all the information we need to proceed with the project, it does not represent the information in a format that tells the story of our project. Our goal will be to provide a graphical picture of the project. To do that, we need to spell out a few rules first. Once we know the rules, we can create the graphical image of the project. In this section, we teach you the few simple rules for constructing a project network diagram.

The network diagram is logically sequenced to be read from left to right. Every activity in the network, except the start and end activities, must have at least one activity that comes before it (its immediate predecessor) and one activity that comes after it (its immediate successor). An activity begins when its predecessors have been completed. The start activity has no predecessor, and the end activity has no successor. These networks are called connected. In this book we have adopted the practice of using connected networks. Figure 6.4 gives examples of how the variety of relationships that might exist between two or more activities can be diagrammed.

Click To expand
Figure 6.4: Diagramming conventions.

Dependencies

A dependency is simply a relationship that exists between pairs of activities. To say that activity B depends on activity A means that activity A produces a deliverable that is needed in order to do the work associated with activity B. There are four types of activity dependencies, illustrated in Figure 6.5:

Click To expand
Figure 6.5: Dependency relationships.

Finish-to-start. The finish-to-start (FS) dependency says that activity A must be complete before activity B can begin. It is the simplest and most risk-averse of the four types. For example, activity A can represent the collection of data, and activity B can represent entry of the data into the computer. To say that the dependency between A and B is finish-to-start means that once we have finished collecting the data, we may begin entering the data. We recommend using FS dependency in the initial project planning session. The finish-to-start dependency is displayed with an arrow emanating from the right edge of the predecessor activity and leading to the left edge of the successor activity.

Start-to-start. The start-to-start (SS) dependency says that activity B may begin once activity A has begun. Note that there is a no-sooner-than relationship between activity A and activity B. Activity B may begin no sooner than activity A begins. In fact, they could both start at the same time. For example, we could alter the data collection and data entry dependency: As soon as we begin collecting data (activity A), we may begin entering data (activity B). In this case there is an SS dependency between activity A and B. The start-to-start dependency is displayed with an arrow emanating from the left edge of the predecessor (A) and leading to the left edge of the successor (B). We will use this dependency relationship in the Compressing the Schedule section later in the chapter.

Start-to-finish. The start-to-finish (SF) dependency is a little more complex than the FS and SS dependencies. Here activity B cannot be finished sooner than activity A has started. For example, suppose you have built a new information system. You don’t want to eliminate the legacy system until the new system is operable. When the new system starts to work (activity A) the old system can be discontinued (activity B). The start to finish dependency is displayed with an arrow emanating from the left edge of activity A to the right edge of activity B. SF dependencies can be used for just-in-time scheduling between two tasks, but they rarely occur in practice.

Finish-to-finish. The finish-to-finish (FF) dependency states that activity B cannot finish sooner than activity A. For example, let’s refer back to our data collection and entry example. Data entry (activity B) cannot finish until data collection (activity A) has finished. In this case, activity A and B have a finish-to-finish dependency. The finish-to-finish dependency is displayed with an arrow emanating from the right edge of activity A to the right edge of activity B. To preserve the connectedness property of the network diagram, the SS dependency on the front end of two activities should have an accompanying FF dependency on the back end.

Constraints

The type of dependency that describes the relationship between activities is determined as the result of constraints that exist between those activities. Each type of constraint can generate any one of the four dependency relationships. There are four types of constraints that will affect the sequencing of project activities and, hence, the dependency relations between activities:

  • Technical constraints

  • Management constraints

  • Interproject constraints

  • Date constraints

Let’s take a look at each of these in more detail.

Technical Constraints

Technical dependencies between activities are those that arise because one activity (the successor) requires output from another (the predecessor) before work can begin on it. In the simplest case, the predecessor must be completed before the successor can begin. We advise using FS relationships in the initial construction of the network diagram because they are the least complex and risk-prone dependencies. If the project can be completed by the requested date using only FS dependencies, there is no need to complicate the plan by introducing other, more complex and risk-prone dependency relationships. SS and FF dependencies will be used later when you analyze the network diagram for schedule improvements.

Within the category of technical constraints, four related situations should be accounted for:

Discretionary constraints. Discretionary constraints are judgment calls by the project manager that result in the introduction of dependencies. These judgment calls may be merely a hunch or a risk-aversion strategy taken by the project manager. Through the sequencing activities the project manager gains a modicum of comfort with the project work. For example, let’s revisit the data collection and data entry example we used earlier in the chapter. The project manager knows that a team of recent hires will be collecting the data and that the usual practice is to have them enter the data as they collect it (SS dependency). The project manager knows that this introduces some risk to the process, and because new hires will be doing the data collection and data entry, the project manager decides to use an FS rather than SS dependency between data collection and data entry.

Best-practices constraints. Best practices are past experiences that have worked well for the project manager or are known to the project manager based on the experiences of others in similar situations. The practices in place in an industry can be powerful influences here, especially in dealing with bleeding-edge technologies. In some cases, the dependencies that result from best-practices constraints, which are added by the project manager, might be part of a risk-aversion strategy following the experiences of others. For example, consider the dependency between software design and software build activities. The safe approach has always been to complete design before beginning build. The current business environment, however, is one in which getting to the market faster has become the strategy for survival. In an effort to get to market faster, many companies have introduced concurrency into the design-build scenario by changing the FS dependency between design and build to an SS dependency as follows. At some point in the design phase, enough is known about the final configuration of the software to begin limited programming work. By introducing this concurrency between designing and building, the project manager can reduce the time to market for the new software. While the project manager knows that this SS dependency introduces risk (design changes made after programming has started may render the programming useless), the project manager will adopt this best-practices approach.

Logical constraints. Logical constraints are like discretionary constraints that arise from the project manager’s way of thinking about the logical way to sequence a pair of activities. We feel that it is important for the project manager to be comfortable with the sequencing of work. After all, the project manager has to manage it. Based on past practices and common sense, we prefer to sequence activities in a certain way. That’s acceptable, but do not use this as an excuse to manufacture a sequence out of convenience. As long as there is a good, logical reason, that is sufficient justification. For example, in the design-build scenario, certainly several aspects of the software design lend themselves to some concurrency with the build activity. Part of the software design work, however, involves the use of a recently introduced technology with which the company has no experience. For that reason, the project manager decides that the part of the design that involves this new technology must be complete before any of the associated build activity can start.

Unique requirements. These constraints occur in situations where a critical resource, say, an irreplaceable expert or a one-of-a kind piece of equipment, is involved on several project activities. For example, a new piece of test equipment will be used on the software development project. There is only one piece of this equipment, and it can be used on only one part of the software at a time. It will be used to test several different parts of the software. To ensure that there will be no scheduling conflicts with the new equipment, the project manager creates FS dependencies between every part of the software that will use this test equipment. Apart from any technical constraints, the project manager may impose such dependencies to ensure that no scheduling conflicts will arise from the use of scarce resources.

Management Constraints

A second type of dependency arises as the result of a management-imposed constraint. For example, suppose the product manager on a software development project is aware that a competitor is soon to introduce a new product with similar features to theirs. Rather than following the concurrent design-build strategy, the product manager wants to ensure that the design of the new software will yield a product that can compete with the competitor’s new product. He or she expects design changes in response to the competitor’s new product and, rather than risk wasting the programmers’ time, imposes the FS dependency between the design and build activities.

You’ll see management constraints at work when you analyze the network diagram and as part of the scheduling decisions you make as project manager. They differ from technical dependencies in that they can be reversed, while technical dependencies cannot. For example, the product manager finds out that the competitor has discovered a fatal flaw as a result of beta testing and has decided to indefinitely delay the new product introduction pending resolution of the flaw. The decision to follow the FS dependency between design and build now can be reversed, and the concurrent design-build strategy can be reinstituted. That is, management will have the project manager change the design-build dependency from FS to SS.

Interproject Constraints

Interproject constraints result when deliverables from one project are needed by another project. Such constraints result in dependencies between the activities that produce the deliverable in one project and the activities in the other project that require the use of those deliverables. For example, suppose the new piece of test equipment is being manufactured by the same company that is developing the software that will use the test equipment. In this case, the start of the testing activities in the software development project depends on the delivery of the manufactured test equipment from the other project. The dependencies that result are technical but exist between activities in two or more projects, rather than within a single project.

Interproject constraints arise when a very large project is decomposed into smaller, more manageable projects. For example, the construction of the Boeing 777 took place in a variety of geographically dispersed manufacturing facilities. Each manufacturing facility defined a project to produce its part. To assemble the final aircraft, the delivery of the parts from separate projects had to be coordinated with the final assembly project plan. Thus, there were activities in the final assembly project that depended on deliverables from other subassembly projects.

Note

These interproject constraints are common. Occasionally, large projects are decomposed into smaller projects or divided into a number of projects that are defined along organizational or geographic boundaries. In all of these examples, projects are decomposed into smaller projects that are related to one another. This approach creates interproject constraints. Although we would prefer to avoid such decomposition because it creates additional risk, it may be necessary at times.

Date Constraints

At the outset, we want to make it clear that we do not approve of using date constraints. We avoid them in any way we can. In other words, “just say no” to typing dates into your project management software. If you have been in the habit of using date constraints, read on.

Date constraints impose start or finish dates on an activity that force it to occur according to a particular schedule. In our date-driven world, it is tempting to use the requested date as the required delivery date. These constraints generally conflict with the schedule that is calculated and driven by the dependency relationships between activities. In other words, date constraints create unneeded complication in interpreting the project schedule.

Date constraints come in three types:

No earlier than. This date constraint specifies the earliest date on which an activity can be completed.

No later than. This date constraint specifies a date by which an activity must be completed.

On this date. This date constraint specifies the exact date on which an activity must be completed.

All of these date constraints can be used on the start or finish side of an activity. The most troublesome is the on-this-date constraint. It firmly sets a date and affects all activities that follow it. The result is the creation of a needless complication in the project schedule and later in reporting the status of the project. The next most troublesome is the no-later-than constraint. It will not allow an activity to occur beyond the specified date. Again, we are introducing complexity for no good reason. Both types can result in negative slack. If at all possible, do not use them. There are alternatives, which we discuss in the next chapter. The least troublesome is the no-earlier-than constraint. At worst, it simply delays an activity’s schedule and by itself cannot cause negative float.

Using the Lag Variable

Pauses or delays between activities are indicated in the network diagram through the use of lag variables. Lag variables are best defined by way of an example. Suppose that the data is being collected by mailing out a survey and is entered as the surveys are returned. Imposing an SS dependency between mailing out the surveys and entering the data would not be correct unless we introduced some delay between mailing surveys and getting back the responses that could be entered. For the sake of the example, suppose that we wait 10 days from the date we mailed the surveys until we schedule entering the data from the surveys. Ten days is the time we think it will take for the surveys to arrive, for the recipients to answer the survey questions, and for us to get the surveys back to us in the mail. In this case, we have defined an SS dependency with a lag of 10 days. Or, to put it another way, activity B (data entry) can start 10 days after activity A (mail the survey) has started.

Creating an Initial Project Network Schedule

As mentioned, all activities in the network diagram have at least one predecessor and one successor activity, with the exception of the start and end activities. If this convention is followed, the sequence is relatively straightforward to identify. If, however, the convention is not followed, or if date constraints are imposed on some activities, or if the resources follow different calendars, understanding the sequence of activities that result from this initial scheduling exercise can be rather complex.

To establish the project schedule, you need to compute two schedules: the early schedule, which we calculate using the forward pass, and the late schedule, which we calculate using the backward pass.

The early schedule consists of the earliest times at which an activity can start and finish. These are calculated numbers that are derived from the dependencies between all the activities in the project. The late schedule consists of the latest times at which an activity can start and finish without delaying the completion date of the project. These are also calculated numbers that are derived from the dependencies between all of the activities in the project.

The combination of these two schedules gives us two additional pieces of information about the project schedule:

  • The window of time within which each activity must be started and finished in order for the project to complete on schedule

  • The sequence of activities that determine the project completion date

The sequence of activities that determine the project completion date is called the critical path. The critical path can be defined in several ways:

  • The longest duration path in the network diagram

  • The sequence of activities whose early schedule and late schedule are the same

  • The sequence of activities with zero slack or float (we define these terms later in this chapter)

All of these definitions say the same thing: The critical path is the sequence of activities that must be completed on schedule in order for the project to be completed on schedule.

The activities that define the critical path are called critical path activities. Any delay in a critical path activity will delay the completion of the project by the amount of delay in that activity. Critical path activities represent sequences of activities that warrant the project manager’s special attention.

The earliest start (ES) time for an activity is the earliest time at which all of its predecessor activities have been completed and the subject activity can begin. The ES time of an activity with no predecessor activities is arbitrarily set to 1, the first day on which the project is open for work. The ES time of activities with one predecessor activity is determined from the earliest finish (EF) time of the predecessor activity. The ES time of activities having two or more predecessor activities is determined from the latest of the EF times of the predecessor activities. The earliest finish (EF) of an activity is calculated as ((ES + Duration) – One time unit). The reason for subtracting the one time unit is to account for the fact that an activity starts at the beginning of a time unit (hour, day, and so forth) and finishes at the end of a time unit. In other words, a one-day activity, starting at the beginning of a day, begins and ends on the same day. For example, take a look at Figure 6.6. Note that activity E has only one predecessor, activity C. The EF for activity C is the end of day 3. Because it is the only predecessor of activity E, the ES of activity E is the beginning of day 4. On the other hand, activity D has two predecessors, activity B and activity C. When there are two or more predecessors, the ES of the successor, activity D in this case, is calculated based on the maximum of the EF dates of the predecessor activities. The EF dates of the predecessors are the end of day 4 and the end of day 3. The maximum of these is 4, and therefore, the ES of activity D is the morning of day 5. The complete calculations of the early schedule are shown in Figure 6.6.

Click To expand
Figure 6.6: Forward pass calculations.

The latest start (LS) and latest finish (LF) times of an activity are the latest times at which the activity can start or finish without causing a delay in the completion of the project. Knowing these times is valuable for the project manager, who must make decisions on resource scheduling that can affect completion dates. The window of time between the ES and LF of an activity is the window within which the resource for the work must be scheduled or the project completion date will be delayed. To calculate these times, you work backward in the network diagram. First set the LF time of the last activity on the network to its calculated EF time. Its LS is calculated as ((LF – Duration) + One time unit). Again, you add the one time unit to adjust for the start and finish of an activity within the same day. The LF time of all immediate predecessor activities is determined by the minimum of the LS, minus one time unit, times of all activities for which it is the predecessor.

For example, let’s calculate the late schedule for activity E in Figure 6.7. Its only successor, activity F, has an LS date of day 10. The LF date for its only predecessor, activity E, will therefore be the end of day 9. In other words, activity E must finish no later than the end of day 9 or it will delay the start of activity F and hence delay the completion date of the project. The LS date for activity E will be, using the formula, 9 – 2 + 1, or the beginning of day 7. On the other hand, consider activity C. It has two successor activities, activity D and activity E. The LS dates for them are day 5 and day 7, respectively. The minimum of those dates, day 5, is used to calculate the LF of activity C, namely, the end of day 4. The complete calculations for the late schedule are shown in Figure 6.7.

Click To expand
Figure 6.7: Backward pass calculations.

Critical Path

As mentioned, the critical path is the longest path or sequence of activities (in terms of activity duration) through the network diagram. The critical path drives the completion date of the project. Any delay in the completion of any one of the activities in the sequence will delay the completion of the project. The project manager pays particular attention to critical path activities. The critical path for the example problem we used to calculate the early schedule and the late schedule is shown in Figure 6.8.

Click To expand
Figure 6.8: Critical path.
Calculating Critical Path

One way to identify the critical path in the network diagram is to identify all possible paths through the network diagram and add up the durations of the activities that lie along those paths. The path with the longest duration time is the critical path. For projects of any size, this method is not feasible, and we have to resort to the second method of finding the critical path—computing the slack time of an activity.

Computing Slack

The second method of finding the critical path requires us to compute a quantity known as the activity slack time. Slack time (also called float) is the amount of delay expressed in units of time that could be tolerated in the starting time or completion time of an activity without causing a delay in the completion of the project. Slack time is a calculated number. It is the difference between the late finish and the early finish (LF – EF). If the result is greater than zero, the activity has a range of time in which it can start and finish without delaying the project completion date, as shown in Figure 6.9.

Click To expand
Figure 6.9: ES to LF window of an activity.

Because weekends, holidays, and other nonwork periods are not conventionally considered part of the slack, these must be subtracted from the period of slack.

There are two types of slack:

Free slack. This is the range of dates in which an activity can finish without causing a delay in the early schedule of any activities that are its immediate successors. Notice in Figure 6.8 that activity C has an ES of the beginning of day 2 and a LF of the end of day 4. Its duration is two days, and it has a day 3 window within which it must be completed without affecting the ES of any of its successor activities (activity D and activity E). Therefore, it has free slack of one day. Free slack can be equal to but never greater than total slack. When you choose to delay the start of an activity, possibly for resource scheduling reasons, first consider activities that have free slack associated with them. By definition, if an activity’s completion stays within the free slack range, it can never delay the early start date of any other activity in the project.

Total slack. This is the range of dates in which an activity can finish without delaying the project completion date. Look at activity E in Figure 6.8. Activity E has a free slack (or float) of four days, as well as a total slack (or float) of four days. In other words, if activity E were to be completed more than three days later than its EF date, it would delay completion of the project. We know that if an activity has zero slack, it determines the project completion date. In other words, all the activities on the critical path must be done on their earliest schedule or the project completion date will suffer. If an activity with total slack greater than zero were to be delayed beyond its late finish date, it would become a critical path activity and cause the completion date to be delayed.

Based on the method you used to compute the early and late schedules, the sequence of activities having zero slack is defined as the critical path. If an activity has been date-constrained using the on-this-date type of constraint, it will also have zero slack. However, this constraint usually gives a false indicator that an activity is on the critical path. Finally, in the general case, the critical path is the path that has minimum slack.

Near-Critical Path

Even though project managers are tempted to rivet their attention on critical path activities, other activities also require their attention. These are activities that we call near-critical path. The full treatment of near-critical activities is beyond the scope of this book. We introduce the concept here so that you are aware that there are paths other than critical paths that are worthy of attention. By way of a general example, suppose the critical path activities are activities in which the project team has considerable experience; duration estimates are based on historical data and are quite accurate in that the estimated duration will be very close to the actual duration. On the other hand, there is a sequence of activities not on the critical path for which the team has little experience. Duration estimates have large estimation variances. Suppose further that such activities lie on a path that has little total slack. It is very likely that this near-critical path may actually drive the project completion date even though the total path length is less than that of the critical path. This situation will happen if larger-than-estimated durations occur. Because of the large duration variances, such a case is very likely. Obviously, this path cannot be ignored.


Analyzing the Initial Project Network Diagram

After you have created the initial project network diagram, one of two situations will be present:

  • The initial project completion date meets the requested completion date. Usually this is not the case, but it does sometimes happen.

  • The more likely situation is that the initial project completion date is later than the requested completion date. In other words, we have to find a way to squeeze some time out of the project schedule.

We eventually need to address two considerations: the project completion date and resource availability under the revised project schedule. In this section, we proceed under the assumption that resources will be available to meet this compressed schedule. In the next chapter, we look at the resource-scheduling problem. The two are quite dependent on one another, but they must be treated separately.

Compressing the Schedule

Almost without exception, the initial project calculations will result in a project completion date beyond the required completion date. That means that the project team must find ways to reduce the total duration of the project to meet the required date.

To address this problem, you analyze the network diagram to identify areas where you can compress project duration. You look for pairs of activities that allow you to convert activities that are currently worked on in series into more parallel patterns of work. Work on the successor activity might begin once the predecessor activity has reached a certain stage of completion. In many cases, some of the deliverables from the predecessor can be made available to the successor so that work might begin on it.

Warning

The caution, however, is that project risk increases because we have created a potential rework situation if changes are made in the predecessor after work has started on the successor. Schedule compressions affect only the timeframe in which work will be done; they do not reduce the amount of work to be done. The result is the need for more coordination and communication, especially between the activities affected by the dependency changes.

First, you need to identify strategies for locating potential dependency changes. You focus your attention on critical path activities because these are the activities that determine the completion date of the project, the very thing you want to impact. You might be tempted to look at critical path activities that come early in the life of the project, thinking that you can get a jump on the scheduling problem, but this usually is not a good strategy for this reason: At the early stages of a project, the project team is little more than a group of people who have not worked together before (we refer to them as a herd of cats). Because you are going to make dependency changes (FS to SS), you are going to introduce risk into the project. Our herd of cats is not ready to assume risk early in the project. You should give them some time to become a real team before intentionally increasing the risk they will have to contend with. That means you should look downstream on the critical path for those compression opportunities.

A second factor to consider is to focus on activities that are partitionable. A partitionable activity is one whose work can be assigned to more than one individual working in parallel. For example, painting a room is partitionable. One person can be assigned to each wall. When one wall is finished, a successor activity, like picture hanging, can be done on the completed wall. In that way you don’t have to wait until the room is entirely painted before you can begin decorating the walls with pictures.

Writing a computer program may or may not be partitionable. If it is partitionable, you could begin a successor activity like testing the completed parts before the entire program is complete. Whether a program is partitionable will depend on many factors, such as how the program is designed, whether the program is single-function or multifunction, and other considerations. If an activity is partitionable, it is a candidate for consideration. You could be able to partition it so that when some of it is finished, you can begin working on successor activities that depend on the part that is complete. Once you have identified a candidate set of partitionable activities, you need to assess the extent to which the schedule might be compressed by starting the activity’s successor activity earlier. There is not much to gain by considering activities with short duration times. We hope we have given you enough hints at a strategy that you will be able to find those opportunities. If you can’t, don’t worry. We have other suggestions for compressing the schedule in the next chapter.

Let’s assume you have found one or more candidate activities to work with. Let’s see what happens to the network diagram and the critical path as dependencies are adjusted. As you begin to replace series (SF dependencies) with parallel sequences of activities (SS dependencies), the critical path may change to a new sequence of activities. This change will happen if the length of the initial critical path, because of your compression decisions, is reduced to a duration less than that of some other path. The result is a new critical path. Figure 6.10 shows two iterations of the analysis. The top diagram is the original critical path that results from constructing the initial network diagram using only FS dependencies. The critical path activities are identified with a filled dot.

The middle diagram in Figure 6.10 is the result of changing the dependency between activities A and B from FS to SS. Now, the critical path has changed to a new sequence of activities. The new critical path is shown in the middle diagram of Figure 6.10 by the activities with filled triangles. If you change the FS dependency between activities C and D, the critical path again moves to the sequence of activities identified by the filled squares.

Click To expand
Figure 6.10: Schedule compression iterations.

Occasionally, some activities always remain on the critical path. For example, notice in the figure the set of activities that have a filled circle, triangle, and square. They have remained on the critical path through both changes. We label this set of activities a bottleneck. While further compression may result in this set of activities changing, it does identify a set of activities deserving of particular attention as the project commences. Because all critical paths generated to this point pass through this bottleneck, we might want to take steps to ensure that these activities do not fall behind schedule.

Management Reserve

Management reserve is a topic associated with activity duration estimates, but it more appropriately belongs in this chapter because it should be a property of the project network more so than of the individual activities.

At the individual activity level, we are tempted to pad our estimates to have a better chance of finishing an activity on schedule. For example, we know that a particular activity will require three days of our time to complete, but we submit an estimate of four days just to make sure we can get the three days of work done in the four-day schedule we hope to get for the activity. The one day that we added is padding. First, let’s agree that you will not do this. Parkinson’s Law (which states that work will expand to the time slotted to complete it) will surely strike you down, and the activity will, in fact, require the four days you estimated it would take. Stick with the three-day estimate and work to make it happen. That is a better strategy. Now that we know padding is bad at the activity level, we are going to apparently contradict ourselves by saying that it is all right at the project level. There are some very good reasons for this.

Management reserve is nothing more than a contingency budget of time. The size of that contingency budget can be in the range of 5 to 10 percent of the total of all the activity durations in your project. The size might be closer to 5 percent for projects having few unknowns; it could range to 10 percent for projects using breakthrough technologies or that are otherwise very complex. Once you have determined the size of your management reserve, you create an activity whose duration is the size of management reserve and put that activity at the end of the project. It will be the last activity, and its completion will signal the end of the project. This management reserve activity becomes the last one in your project plan, succeeded only by the project completion milestone.

So, what is this management reserve used for? First, the project team should manage the project so that the reserve activity is not needed; in reality, though, this is rarely possible. The date promised to the customer is the one calculated by the completion of the reserve activity. The reserve activity’s duration can be shortened as necessary. For example, if the critical path slips by two days, the reserve activity’s duration will be reduced by two days. This holds the project completion date constant.

This technique keeps the management reserve activity visible and allows you to manage the rate at which it’s being used. If 35 percent of the overall project time line has gone by and 50 percent of the reserve task has been used, you know you’re heading for trouble.

Second, management reserve can be used as incentives for the project team. For example, many contracts include penalties for completing milestones later than planned, as well as rewards for completing milestones ahead of schedule. Think of management reserve as a contingency fund that you do not want to spend. Every day that is left in the contingency fund at the completion of the project is a day ahead of schedule for which the customer should reward you. On the other hand, if you spend that contingency fund and still require more time to complete the project, this means that the project was completed later than planned. For every day that the project is late, you should expect to pay a penalty.


Using the JPP Session to Construct and Analyze the Network

We believe in using the appropriate technology, and nowhere is that more obvious than in our approach to constructing and analyzing the project network. If you have tried to use automated tools for this planning exercise, you have probably experienced nothing short of complete frustration. Automated tools will do the job for small projects or one-person project teams, but for large projects, they just get in the way.

For example, let’s say your project has 100 activities (and that is not a large project). You can only see about six to eight activity nodes on your computer screen at any time, so any attempt to analyze the network diagram using the automated tool will do nothing but add confusion. You will require a tool that allows the planning team to see all the data at one time. How many people can you crowd around the computer screen and hope to get any meaningful work done? Even if you display the computer screen on a larger monitor you are still limited to six to eight nodes per view.

The best way to explain our approach for generating the project network diagram, which is foolproof by the way, is to discuss it step for step:

  1. Enter activities and their durations in the software tool. First, enter all the activities and their durations into the software tool. Print the network diagram. Because no dependencies have been entered, the network diagram for most software tools will be a columnar report with one activity node per row—not a very informative network diagram, but it serves our purposes. Some software tools might display these nodes in formats other than columnar, and that will work just fine, too.

  2. Cut out each activity node and tape it to a Post-It note. (Don’t forget to create start and end node milestones.) We use 3" by 3" Post-It notes because they allow you to put the node at the top and write in large numbers the activity ID number on the bottom. This technique makes it possible for the project planning team to see the activity ID from anyplace in the planning room.

  3. Affix each Post-It note to the white board in order. We recommend placing them at the rightmost edge of the white board space so that you have enough room to work. Ordering them by task ID number or WBS major category (or both) makes it easier to find them later.

  4. Place the start node at the left edge of the white board. Ask the planning group to identify all activities that have no predecessors. As each activity is called out, the planning group should listen and voice any objections, such as they believe that one of the identified activities does, in fact, have a predecessor. The objection is settled, and the exercise continues. When there are no objections, place these activities on the left side of the white board and connect them to the start node with a black erasable marker pen. Continue this process until all the remaining activities have predecessors.

    For each major part of the WBS, there will be a corresponding set of activities that must be incorporated into the nodes already connected from the previous step. The most expert person on the planning team will facilitate the activity sequencing exercise for the activities that are in his or her area of expertise. This person will build his or her part of the network using a left-to-right build. That is, once an activity has been posted on the left side of the white board, what other activity or activities may now be worked on? The other members of the planning team will be responsible for critiquing and commenting as the expert completes his or her part of the activity sequencing. One expert at a time facilitates completing part of the activity sequencing until the network diagram is complete. The conclusion of this exercise is a great time for a break. The team has reached a significant milestone in the project plan, and they deserve a rest.

  5. Input the network diagram into the software tool. While the planning team is on break, the network diagram is input into the software tool by the planning facilitator and his or her assistant, whom we call a technographer. As part of that exercise, they can input the network sketch into the software tool and review the predecessor and successor data to make sure the network is fully connected and note and correct any discrepancies. If an activity does not have a logical successor activity, it should be connected to the end activity. Remember, fully connected means that every activity (except the start and end activities) has at least one predecessor and one successor activity.

  6. Reassemble the planning team. It is now time to find out if the first draft of the network meets the project delivery dates. If it does, consider yourself fortunate. Usually it does not meet the expected completion date, and you need to analyze the network diagram. You can use the automated tool to find activities on the critical path. Place a large red dot on the sequence of activities that identify the critical path. The real value of the white-board-and-Post-It-note approach is that it facilitates using the planning group to identify ways to reduce the time on the critical path. To compress the project schedule, look for opportunities to change FS relationships to SS relationships with perhaps some lag time introduced. Be careful not to get carried away with schedule compression, because it will aggravate the resource-scheduling problem. Remember that you are cramming the project work into a shorter window of time, and that tends to increase the probability of creating scheduling conflicts. At each iteration, use the automated tool to check if the critical path has moved to a new sequence of activities. If it has, there may be other compression opportunities on the new critical path. When all of these types of schedule compression possibilities are exhausted, this part of the compression exercise is finished. Further improvements are discussed in the next chapter.

Now you’ve established a project schedule that meets the requested project completion date. The final step is to schedule the resources so as to complete the work according to the revised schedule.


Putting It All Together

You now know how to represent your project in the form of a precedence diagram from which you can calculate the initial schedule of the project. The missing ingredients are the resources and their availability. Once that is factored into the schedule, the schedule could change. That is the topic that we consider in the next chapter.


Discussion Questions

  1. The project network diagram has been constructed, and the project completion date is beyond the management-imposed deadline. You have compressed the schedule as much as possible by introducing parallel work through changes from FS to SS dependencies, and you still do not meet the schedule deadline. What would you do? (Hint: Use the scope triangle, discussed in Chapter 1.)

  2. Even though all of your tasks have met the WBS completion criteria, what scheduling problems might prompt you to further decompose one or more of them, and how will that resolve the problems?

Start Sidebar
Case Study

Show the critical path for your project by using MS Project. (To make this work, you must make sure that you don’t take any one heading in MS Project and let it go all the way through the project. If you do allow one heading to go all the way through, you can’t read the critical path.)

End Sidebar


Chapter 7: Finalizing the Schedule and Cost Based on Resource Availability

The hammer must be swung in cadence, when more than one is hammering the iron.

—Giordano Bruno, Italian philosopher

Behind an able man there are always other able men.

—Chinese proverb

Work smarter, not harder.

—Anonymous

Considering Resource Availability

The final step to putting together the project plan is to assign the resources according to the schedule developed in Chapter 6. Up to this point, we have identified the activities in the project and developed a schedule that meets the expected end date of the project. Now you need to determine if you can accomplish this schedule with the resources available. This chapter looks at tools and methods available to help you answer this question.

Start Sidebar
Chapter Learning Objectives

After reading this chapter, you will be able to:

  • Understand why resources should be leveled

  • Utilize various approaches to leveling resources

  • Determine the appropriate use of substitute resources

  • Define a work package and its purposes

  • Describe the format and explain the contents of a work package

  • Know when to require a work package description

End Sidebar

There could be cases where the resources are not available according to the project schedule. In those situations, the project manager has to revert to the original project definition, budget, time, and resource allocations to resolve the scheduling problem, which may require additional time, budget, and resource allocation in order to comply with the requested deliverables and deliverable schedule.


Leveling Resources

Resource leveling is part of the broader topic of resource management. This is an area that has always created problems for organizations. Some of the situations that organizations have to deal with are these:

  • Committing people to more than they can reasonably handle in the given timeframe, reasoning that they will find a way to get it done

  • Changing project priorities and not considering the impact on existing resource schedules

  • The absence of a resource management function that can measure and monitor the capacity of the resource pool and the extent to which it is already committed to projects

  • Employee turnover that is not reflected in the resource schedule

Any organization that does not have a way of effectively handling these situations will find itself in the situation analogous to the flow through a funnel, as depicted in Figure 7.1.

Click To expand
Figure 7.1: The resource scheduling problem.

Figure 7.1 is a graphic portrayal of the resource-scheduling problem. The diameter of the funnel represents the total of all the resources available for the project. Activities can pass through the funnel at a rate that is limited by the amount of work that can be completed by the available resources according to the schedule of the activities. You can try to force more into the funnel than it can accommodate, but doing so only results in turbulence in the funnel. You are familiar with the situation where managers try to force more work onto your already fully loaded schedule. The result is either schedule slippage or less-than-acceptable output. In the funnel example, it results in rupture due to overload (weekend time and long hours are the root cause of the rupture).

The core teamwork takes place at the center of the pipeline. This center is where the activity flow through the funnel is the smoothest because it is based on a well-executed schedule. The work assigned to the contract team takes place along the edge of the funnel. According to the laws of flow in a pipeline, there is more turbulence at the walls of the structure. The deliverables are the completed activity work. Because the diameter of the funnel is fixed, only so much completed work can flow from it. Too many organizations think that by simply adding more into the top, more will come out the bottom of the funnel. Their rationale is that people will work harder and more efficiently if they know that more is expected. While this may be true in a limited sense, it is not in the best interest of the project because it results in mistakes and compromised quality. Mistakes will be made as a direct result of the pressure of the overly ambitious schedule forced on people. In this chapter, we develop resource-leveling strategies that the project manager can adopt to avoid the situation depicted in the funnel example.

Let’s take a step back for a moment. When you were creating the project network diagram, the critical path was the principal focal point for trying to finish the project by a specified date. Resource over- or under-allocation was not a consideration. We do this for a reason. It is important to focus your attention on planning one portion of the project at a time. If you can’t hit the desired finish date based strictly on the logical order in which activities must be completed, why worry about whether resources are over- or under-allocated? You’ve got another problem to solve first. After the finish date has been accepted, you can address the problem of over-, and in some cases, under-allocation.

Resource leveling is a process that the project manager follows to schedule how each resource is allocated to activities in order to accomplish the work within the scheduled start and finish dates of the activity. Recall that the scheduled start and finish dates of every activity are constrained by the project plan to lie entirely within their ES-LF window. Were that not the case, the project would be delayed beyond its scheduled completion date. As resources are leveled, they must be constrained to the ES-LF window of the activities to which they are assigned, or the project manager must seek other alternatives to resolve the conflict between resource availability and project schedule.

The resource schedule needs to be leveled for two reasons.

  • To ensure that no resource is over-allocated. That is, we do not schedule a resource to more than 100 percent of its available time.

  • The project manager wants the number of resources (people, in most cases) to follow a logical pattern throughout the life of the project. You would not want the number of people working on the project to fluctuate wildly from day to day or from week to week. That would impose too many management and coordination problems. Resource leveling avoids this by ensuring that the number of resources working on a project at any time are fairly constant. The ideal project would have the number of people resources relatively level over the planning phases, building gradually to a maximum during the project work phases, and decreasing through the closing phases. Such increases and decreases are manageable and expected in the life of a well-planned project.


Acceptably Leveled Schedule

As we begin this discussion of leveling resources, let’s be clear on one point. It is very unlikely, perhaps impossible, that you will develop a resource schedule that simultaneously possesses all the desirable characteristics we discussed. Of course, you will do the best you can and hope for a resource schedule that is acceptable to management and to those who manage the resources employed on your project. When a resource schedule is leveled, the leveling process is done within the availability of the resource to that project. When we discussed activity estimating and resource assignments in Chapter 5, we said that resources are not available to work on an activity 100 percent of any given day. Our current observations show that this number ranges between 50 and 65 percent. This value, for a typical average day, is the resources maximum availability. Project management software products may also refer to it as max availability or max units. Some software applications allow this value to be varied by time period; others do not.

Ideally, we want to have a project in which all resource schedules can be accommodated within the resources’ maximum availability. On occasion this may not be possible, especially when project completion dates are paramount, which means that some overtime may be necessary. We’re all familiar with this. Overtime should be your final fall-back option, however. Use it with discretion and only for short periods of time. If at all possible, don’t start your project off with overtime as the norm. You’ll probably need it somewhere along the line, so keep it as part of your management reserve.

Cross-Reference

Chapter 6 contains an in-depth discussion of management reserve.


Resource-Leveling Strategies

You can use three approaches to level project resources:

  • Utilizing available slack

  • Shifting the project finish date

  • Smoothing

Let’s take a look at each of these strategies in more detail.

Utilizing Available Slack

Slack was defined in Chapter 6 as the amount of delay expressed in units of time that could be tolerated in the starting time or completion time of an activity without causing a delay in the completion of the project. Recall that slack is the difference between the ES-LF window of an activity and its duration. For example, if the ES-LF window is 4 days and the duration of the activity is 3 days, its slack is 4 – 3, or 1 day.

Slack can be used to alleviate the over-allocation of resources. With this approach, one or more of the project activities are postponed to a date that is later than their early start date but no later than their late finish date. In other words, the activities are rescheduled but remain within their ES-LF window.

When you are seeking to level resources, having free slack can come in handy. Free slack, as mentioned in Chapter 6, is the amount of delay that can be tolerated in an activity without affecting the ES date of any of its successor activities. When you need to resolve the “stack-up” of activities on the schedule, first look to see if any of the activities has free slack. If any of them do, and if rescheduling the activity to that later start date will solve the resource over-allocation problem, you are done. If moving the start date of the activity does not resolve the over-allocation, you have to use total slack, and at least one other activity will have its early start date delayed.

Shifting the Project Finish Date

Not all projects are driven by the completion date. For some, resource availability is their most severe constraint. On these projects, the critical path may have to be extended to achieve an acceptably resource-leveled schedule. This case could very well mean that the parallel scheduling on the activity network diagram that moved the original finish date to an earlier one needs to be reversed. The start-to-start and finish-to-finish dependencies might need to be set back to the linear finish-to-start type.

In some cases, a project is of a low enough priority within the organization that it is used mostly for fill-in work. In that case, the completion date is not significant and doesn’t have the urgency that it does in a time-to-market project. For most projects, however, moving the finish date to beyond a desired date is the least attractive alternative.

If you find yourself caught between over-allocated resources on a schedule that cannot be acceptably leveled and a firm fixed completion date, you may have to consider reducing the scope of the project. Consider delaying some of the features to the next release as one way of resolving the issue. In saying this, we’re referring to the concepts introduced regarding the scope triangle in Chapter 1.

Smoothing

Occasionally, limited overtime is required to accomplish the work within the scheduled start and finish dates of the activity. Overtime can help alleviate some resource over-allocation because it allows more work to be done within the same scheduled start and finish dates. We call this smoothing, and through its use, we eliminate resource over-allocations, which appear as spikes in the resource loading graphs. In effect, what we have done is move some of the work from normal workdays to days that otherwise are not available for work. To the person doing the work, it is overtime.

Alternative Methods of Scheduling Activities

Rather than treating the activity list as fixed and within that constraint leveling resources, you could resolve the leveling problem by considering further decomposition of one or more activities. One of the six characteristics of a complete WBS mentioned in Chapter 4 was activity independence. Activity independence means that once work has begun on an activity, work can continue without interruption until the activity is complete. Usually, you do not schedule the work to be continuous for a number of reasons, such as resource availability, but you could if you wanted. Other than for resource availability issues, the decision to do that may simply be a preference of the project manager.

Further Decomposition of Activities

Resource availability, or rather, the lack of it, can require some creative activity scheduling on the part of the project manager. For example, suppose that an activity requires one person for three days within a five-day window. There are two days of slack in the schedule for that activity. In other words, the ES-LF window of the activity is five days, and the activity duration is three days. The project manager would prefer to have the activity scheduled for its early start date, but the unavailability of the resource for three consecutive days beginning on the ES date will require scheduling the activity work to a longer period of time. One solution would be to have the resource work for three nonconsecutive days as early as possible in the five-day window. Continuing with the example, let’s say that the resource is available for the first two days in the five-day window and for the last day in the five-day window. To simplify the scheduling of the resource, the project manager could decompose the five-day activity into two activities—one two-day activity and one one-day activity. The two-day activity would then have an FS dependency on the one-day activity. The scheduled start and finish dates of the two activities would be set so that they fit the availability of the resource. There are other solutions to this scheduling problem, but we do not discuss them here. The one we have presented is the best approach to situations similar to the example.

Stretching Activities

Another alternative that preserves the continuity of the activity work is to stretch the work over a longer period of time by having the resource work on the activity at a percent per day lower than was originally planned.

Let’s modify the previous example to illustrate what we mean by stretching the activity. Suppose the resource is available 80 percent of each day in the five-day window, and you need four days of work. The resource is therefore available for 0.80 times five days, or four days of work, over the five-day window. You need only four days of work from the resource, so how do you schedule the work in the five-day window to accomplish the four days of work you need? The solution is to stretch the activity from four days to five and schedule the resource to work on the activity for those five days. Because the resource can only work 80 percent of the time on the activity, the resource will accomplish four days of work in five days.

In this simple example, the percentage was constant over the five days, but it might also follow some profile. For example, suppose you needed the resource for three days and the resource was available full-time for the first and second days but only half-time for the remaining three days of the five-day window.

You could first split the activity into two activities—a two-day activity and a one-day activity. The two-day activity would fully use the resource and get two days of work completed. The second activity would be stretched to two days, and the resource would be assigned half-time for two days to complete the remaining day of work on the activity. In other words, you got the three days of work in four days—the first two days at full-time and the next two days at half-time. Resource availability can be the determining factor for how the activity can be stretched within its ES-LF window and still get the required amount of work from the resource.

Assigning Substitute Resources

Our estimate of activity duration was based on the assumption that a typically skilled resource will be available to work on the activity. That may not be possible, though, because of unavailability of the resource. This unavailability will be especially true in the case of scarce resources such as some of the newer technologies. The project manager needs to find some other strategy. One approach would be to use less-skilled resources and add to the total number of hours requested. Here, the thinking is that a less-skilled resource would require a longer period of time to complete the activity work.

Warning

Be careful in using this tactic, however, because there will be additional risk in using a less-skilled person, and it is not clear exactly what increase in activity duration is needed to account for the lesser skilled person. This strategy works only for non- critical path activities. Using it for a critical path activity would extend the completion date of the project.


Cost Impact of Resource Leveling

It should be obvious to you that resource leveling almost always stretches the schedule. The case where it doesn’t stretch the schedule may occur if slack is available in the right places in the schedule. Scheduling the work of a resource over a longer period of time not only removes scheduling conflicts, but it also removes any over-allocations of that resource. To do all that, the project completion date is moved out in time, which can have the following results:

  • If the resources are billable based on the labor expended, project costs do not increase.

  • If there are resources that are charged on a calendar basis, project costs will increase. Such expenses would be attributable to equipment and space that is on a rental agreement. In some cases, there may be increased people costs as well.

  • If there are incentives for early completion and penalties for late completion of a project, a cost impact will be felt as well.


Implementing Micro-Level Project Planning

Micro-level planning is another step in the decomposition of the tasks that are assigned to an individual. It involves a decomposition to what we will call subtasks. In some cases, these subtasks may be a very simple to-do list or, in more complex situations, might appear as a very small project network. Remember that we are dealing with tasks that have met the six WBS completion criteria and are therefore relatively simple tasks or short duration.

Micro-level project planning begins with the lowest-level activity that is defined in the WBS. Because it appears in the WBS, it will have management oversight by the project manager. The responsibility for completing this activity within a defined window of time will be assigned to an activity manager (or team leader, if you prefer). The activity may be simple enough so that all of the work of completing it is done by the activity manager. In more complex situations, a small team assigned to the activity manager will actually complete the work of the activity. We’ll use the word subteam in the discussion that follows, but recognize that the team may be only one person, the activity manager.

The first thing the subteam must do is to continue the decomposition that was done in building the WBS. But this decomposition will be at the task level. The tasks might be nothing more than a simple to-do list that is executed in a linear fashion. More complex activities will actually generate an activity network diagram composed of tasks and their dependency relationships. Recall that the activity met the completeness criteria discussed in Chapter 4. These activities will each be less than two weeks’ duration, so the tasks that make them up will be of lesser duration. The decomposition should be fairly simple and result in tasks of one to three days’ duration. We would be surprised if it took more than 10 tasks to define the work of the activity.

Using a project management software package to create the micro-level plan and its accompanying schedule is overkill. Our suggestion is that you define the tasks, their dependency relationship, and schedule on a white board using Post-It notes and marking pens. Figure 7.2 is an example of what that white board display might look like. The activity consists of seven tasks that are shown in the upper portion of the figure along with their dependencies.

Click To expand
Figure 7.2: An example of a task dependency diagram and time-scaled resource schedule.

The lower portion of the figure shows the time scaled schedule for the three members of the subteam. The shaded areas of the schedule are non-workdays and days when a resource is not available. Half-day time segments are the lowest level of granularity used.

This activity is typical of others in the project plan. It is simple enough so that all of the work can be done at the white board. Updating is very simple. There is no need for software support. It simply adds management overhead with little return on the investment of time expended to capture and manage it.

In the next section, we make the transition to work packages. What we have done so far is decompose a task into subtasks. In other words, we have a list of things that have to be done in order to complete the task. The work package describes exactly how we are going to accomplish the task through the identified subtasks. In other words, it is a mini-plan for our task.


Work Packages

At this point, you have essentially completed all JPP session activities. The project work has been defined as a list of activities; activity duration and resource requirements are specified, the project network is built, the activity schedule is done, and resources have been scheduled. The JPP session attendees have reached a consensus. Whew, that’s a lot—and you probably wondered if it would ever be finished. There is one more step to go before project work can commence—that is, to define the work to be done in each activity but at the task level. Recall from Chapter 4 that activities are made up of tasks. The work to be done within an activity is called a work package.

This is really the final test of the feasibility of the schedule and resource- leveling decisions. The work package is a statement by each activity manager as to how he or she plans to complete the activity within the scheduled start and finish dates. It is like an insurance policy. For the project manager, the work package is a document that describes the work at a level of detail so that if the activity manager or anyone working on the activity were not available (if he or she were fired, hit by a bus on the way to work, or otherwise not available), someone else could use the work package to figure out how to continue the work of the activity with minimal lost time. This safeguard is especially important for critical path activities for which schedule delays are to be avoided.

A work package can consist of one or several tasks. They may be nothing more than a to-do list, which can be completed in any order. On the other hand, the work package can consist of tasks that take the form of a mini-project, with a network diagram that describes it. In this case, work packages are assigned to a single individual, called an activity manager or work package manager. This manager is responsible for completing the activity on time, within budget, and according to specification. Sounds like a project manager, doesn’t it? That person has the authority and the access to the resources needed to complete the assignment.

Purpose of a Work Package

The work package becomes the bedrock for all project work. It describes in detail the tasks that need to be done to complete the work for an activity. In addition to the task descriptions, the package includes start and end dates for the activity.

The work package manager (or activity manager) may decide to include the start and end dates for each task in the package so that anyone who has occasion to use the work package will have a sense of how the plan to complete the work would be accomplished.

Warning

Be careful if you adopt this approach, because you encourage micromanagement on the part of the project manager. The more you say, the more you encourage objections. The trade-off, though, is to protect the project schedule. There is always a trade-off between the need for detail and the need to spend work time accomplishing work, not shuffling papers.

The work package also can be adapted to status reporting. Tasks constitute the work to be done. Checking off completed tasks measures what percent of the activity is complete. Some organizations use the percent of tasks completed as the percent of activity completion, which is a simple yet effective metric that serves as the basis for earned value calculations. Earned value is discussed in detail in Chapter 10.

Format of a Work Package

We recommend two work package documents.

Work package assignment sheet. This is a very special type of telephone directory used as a ready reference for the project manager. It contains some basic information about each work package and its manager.

Work package description report. This is a detailed description of the activity plan. It contains much of the same information that is found in a project plan, but it focuses on activities, not projects. It is therefore a much simpler document than a project plan, even though it contains the same type of information as the project plan.

Work Package Assignment Sheet

The work package assignment sheet, shown in Figure 7.3, is a report for the project manager only. It includes the earliest start and latest finish times for each activity. This sheet is one of the few resources available to the project manager and should not be made available to anyone other than the project manager. The project manager is unlikely to tell an activity manager that the activity is scheduled for completion on July 15, for example, but the activity manager really has until August 15 because of slack. Activity managers should be given only the scheduled start and end dates for their activities.

Click To expand
Figure 7.3: Work package assignment sheet.

The work package assignment sheet has limited value in smaller projects but can be invaluable in larger ones. For example, our business was once involved in a project that consisted of more than 4000 activities. Over the seven-year life of the project, more than 10,000 activity managers were involved. This report became a phone directory that needed constant updating as team members came and went. Because of the complexity and personnel changes that accompany these large projects, the project manager needs an effective and efficient way of keeping up with the project team membership, who is assigned to what, and how they will accomplish their work.

Work Package Description Report

A work package description report is a document prepared by the activity manager in which he or she describes the details of how he or she will accomplish the work of the activity. A very simple example of a work package, or statement of work, is shown in Figure 7.4.

Click To expand
Figure 7.4: Work package description report.

Once the project plan has been approved, it is the activity manager’s responsibility to generate the work package documentation. Not all activities will require or should require work package documentation. The documentation can be limited to critical path activities, near-critical path activities, high-risk activities, and activities that use very scarce or highly skilled staff. It is the project managers who will decide which activities need a work package description report.

The descriptions must be complete so that anyone could pick them up, read them, and understand what has to be done to complete the activity. Each task must be described so that the status of the work package can be determined easily. Ideally, the task list is a check-off list. Once all the tasks have been checked off as being completed, the activity is completed. Each task will also have a duration estimate attached to it. In some project planning sessions, these estimates may have been supplied as a bottom-up method of estimating activity duration.


Putting It All Together

The work of planning the project is now complete. All that remains is to document the plan in the form of a project proposal and forward it to the appropriate manager(s) for approval. Approval at this stage is approval to do the project as defined in the project plan. In the next chapter, we bring together all the discussions from earlier chapters on the Joint Project Planning session. While we have discussed various parts of project planning, we have not given you a complete picture of exactly how a project planning session is planned, organized, who should attend, and how one is conducted.


Discussion Questions

  1. Discuss the concept of the work package as an insurance policy. How is it an insurance policy, and what might it contain that would make it an insurance policy?

  2. You have two choices for a resource to work on a programming task.

    • One choice is Harry. He is the most skilled programmer in the company and is therefore in constant demand. As a result, he is usually assigned to several projects at the same time. He is available to your project on a half-time basis. He currently has commitments to two other projects for the remaining half of his time.

    • Your other choice is actually a team of two programmers, both of whom have average skills. They are recent hires into the company and have never worked together before. They could each be assigned to your project quarter-time. This would be the only project they would be working on. The remainder of their time will be spent in training.

    Which choice would you make and why? Are there conditions under which one choice would be preferred over the other? Be specific.

Start Sidebar
Case Study

You have already done a WBS based on the case and placed time values on each of the tasks. As the vendor project manager on this project, what assumptions have you made on resources that will give you a good chance to bring this project in on time? Give your costs for your resources, and show when they will be used based on the current WBS. Do this in MS Project.

End Sidebar


Chapter 8: Organizing and Conducting the Joint Project Planning Session

This report, by its very length, defends itself against the risk of being read.

—Winston Churchill, English Prime Minister

Learn to write well, or not to write at all.

—John Dryden, English poet

If you don’t get the reader’s attention in the first paragraph, the rest of your message is lost.

—Public relations maxim

Joint Project Planning Sessions

Chapters 4 to 7 have all included a brief discussion of how the Joint Project Planning (JPP) session relates to the chapter topics. In this chapter, we bring all of that information together, along with a treatment of the logistics of planning projects using the Joint Project Planning session.

Start Sidebar
Chapter Learning Objectives

After reading this chapter, you will be able to:

  • Understand the purpose of the Joint Project Planning session

  • Know how to plan a Joint Project Planning session

  • Decide who should attend the Joint Project Planning session

  • Understand all of the deliverables from the Joint Project Planning session

  • Explain the purpose of the project proposal

  • Know the contents of the project proposal

End Sidebar

All of the planning activities we’ve discussed so far to create the detailed project plan take place in a JPP session. We advocate and use a group process for generating the detailed project plan. The JPP is a group session in which all of the people who are involved in the project meet to develop the detailed plan. The session can last from one to three days, and it can be work-intensive. Often, there is conflict between session attendees, but the final result of this meeting is an agreement about how the project can be accomplished within a specified time frame, budget, resource availabilities, and customer specification.

Note

Our planning process shares many of the same features as Joint Requirements Planning (JRP) and Joint Applications Design (JAD) sessions. The JRP session is commonly used to design computer applications. Our JPP is robust—that is, it can be used for any type of project, including the design and development of computer applications.

The objective of a JPP session is very simple: Develop a project plan that meets the Conditions of Satisfaction (COS) as negotiated between the requestor and the provider, and as described in the Project Overview Statement. Sounds simple, doesn’t it?

Unfortunately, it doesn’t happen with any regularity. There are many reasons for this fact. People are generally impatient to get on with the work of the project. After all, there are deadlines to meet and other projects demanding our attention. We don’t have time for planning; we have too much work to do and too many customers to satisfy. Regrettably, at the project’s eleventh hour, when it is too late to recover from a poor plan, we bow in defeat. Next time, we promise ourselves, we will pay more attention to the planning details. Somehow that next time never seems to come. It’s time for change!

Planning the JPP Session

Team planning has always been viewed as advantageous over other forms of project planning, such as the project manager planning the project by walking around gathering data for the plan. In our experience, the synergy of the group provides far more accurate activity duration estimates, and we expect more complete information input to the planning process itself. Perhaps the best advantage of all is that it creates a much stronger commitment to the project for all those who lived through the pain of generating and agreeing to the complete project plan. If all else fails, it is more fun than doing planning in isolation.

Sometimes, we feel that planning is a necessary evil. It is something we all do because we have to and because we can then say that we have thought about where we want to go and how we are going to get there. Once written, plans are often bound in nice notebooks and become bookends gathering dust on someone’s shelf.

Make up your mind right now to change that! Planning is essential to good project management. The plan that you generate is a dynamic document. It changes as the project commences. It will be a reference work for you and the team members when questions of scope and change arise. We make no bones about it: To do good planning is painful, but to do poor planning is even more painful. Take your choice.

The first document considered in the JPP session is the Project Overview Statement (POS). One may already exist and therefore will be the starting point for the JPP. If one doesn’t exist, it must be developed as the initial part or prerequisite to starting the JPP. The situation will dictate how best to proceed. The POS can be developed in a number of ways. If it is an idea for consideration, it will probably be developed by one individual—typically the person who will be the project manager. It can be departmentally based or cross-departmentally based. The broader the impact on the enterprise, the more likely it will be developed as the first phase of a JPP session. Finally, the POS may have been developed through a COS exercise. In any case, the JPP session begins by discussing and clarifying exactly what is intended by the POS. The project team might also use this opportunity to write the Project Definition Statement (PDS)—their understanding of the project.

The JPP session must be planned down to the last detail if it is to be successful. Time is a scarce resource for all of us, and the last thing we want to do is to waste it. Recognize before you start that the JPP session will be very intense. Participants often get emotional and will even dig their heels in to make a point.

Before we discuss how the session is planned and conducted, let’s talk about who should attend.

Attendees

The JPP participants are invited from among those who might be affected by or have input into the project. If the project involves deliverables or is a new process or procedure, anyone who has input to the process, receives output from the process, or handles the deliverables should be invited to participate in the JPP. The customer falls into one or more of these categories and must be present at the JPP. Any manager of resources that may be required by the project team also will attend the JPP session. In many organizations, the project has a project champion (not necessarily the project manager or customer manager) who may wish to participate at least at the start.

Facilitator. A successful JPP session requires an experienced facilitator. This person is responsible for conducting the JPP. It is important that the facilitator not have a vested interest or bring biases to the session, because that would diminish the effectiveness of the plan. It must be developed with an open mind, not with a biased mind. For this reason, we strongly suggest that the project manager should not facilitate the session. If using an outside consultant is not possible, we recommend a neutral party for facilitator, such as another project manager.

Project manager. Because the project manager is not leading the planning session, he or she can concentrate on the plan itself; that is the project manager’s major role in the JPP. Having the proposed project manager (if known) facilitate the JPP session may seem to be an excellent choice, but it can be the wrong choice if the project is politically charged or has customers from more than one function, process, or resource pool. The project manager must be comfortable with the project plan. After all, the project manager is the one who has final responsibility when it comes to getting the project done on time, within budget, and according to specification.

Another project manager. Skilled JPP facilitators are hard to find. If the project manager is not a good choice for facilitator, then maybe another project manager—presumably unbiased—would be a good choice, especially if he or she has JPP experience.

JPP consultant. Project management consultants will often serve as another source of qualified JPP facilitators. Their broad experience in project management and project management consulting will be invaluable. This will be especially true in organizations that have recently completed project management training and are in the process of implementing their own project management methodology. Having an outside consultant facilitate the JPP session is as much a learning experience as it is an opportunity to get off to a good start with a successful JPP session.

Technographer. The JPP facilitator is supported by a technographer, a professional who not only knows project management but also is an expert in the software tools used to support the project. While the JPP facilitator is coordinating the planning activities, the JPP technographer is recording planning decisions on the computer as they occur in real time. At any point in time—and there will be several—the technographer can print out or display the plan for all to see and critique.

Core project team. Commitment is so important that to exclude the core team from the JPP session would be foolish. Estimating activity duration and resource requirements will be much easier with the professional expertise these people can bring to the planning session. The core project team is made up of those individuals who will stay with the project from first day to last day. This does not mean that they are with the project full-time. In today’s organization that is not to be expected unless the organization is totally projectized or uses self-directed teams.

Customer representative. This attendee is always a bit tricky. Let’s face it: Some customers really don’t want to be bothered. It is up to the project manager or champion to convince customers of the importance of their participation in the JPP session. We don’t claim that this will be easy, but it is nevertheless important. There must be customer buy-in to the project plan. The customer won’t get that if the project manager simply mails a copy of the plan. The customer must be involved in the planning session. Not having the customer’s buy-in is to court disaster. Changes to the project plan will occur, and problems will arise. If the customer is involved in preparing the plan, he or she can contribute to resolution of change requests and problem situations.

Resource managers. These managers control resources that the project will require. Putting a schedule together without input and participation from these managers would be a waste of time. They may have some suggestions that will make the plan all that more realistic, too. In some cases, they may send a representative who might also be part of the project team. The important factor here is that someone from each resource area is empowered to commit resources to the project plan.

Project champion. The project champion drives the project and sells it to senior management. In many cases, the champion can be the customer— an ideal situation because commitment is already there. In other cases, the project champion can be the senior managers of the division, department, or process that will be the beneficiary of the project deliverables.

Functional managers. Because functional managers manage areas that can either provide input to or receive output from the project deliverables, they or a representative should participate in the planning session. They will ensure that the project deliverables can be smoothly integrated into existing functions or that the functions will have to be modified as part of the project plan.

Process owner. For the same reasons that functional managers should be present, so should process owners. If the project deliverables do not smoothly integrate into their processes, either the project plan or the affected processes will have to be altered.

A formal invitation, announcing the project, its general direction and purpose, and the planning schedule, should be issued to all these individuals.

Note

RSVPs are a must! Full attendance is so important that we have cancelled a JPP session because certain key participants were not able to attend. On one occasion, we acted as the project manager for a client and cancelled the JPP session because the customer did not think his attendance was important enough. Our feedback to the

customer was that as soon as it was a high enough priority for him to attend, we would schedule the JPP session. Pushback like this is tough, but we felt that the JPP is so critically important to the ultimate success of the project that we were willing to take this strong position with the customer.

Facilities

Because the planning team may spend as many as three consecutive days in planning, it is important that the physical facility is comfortable and away from the daily interruptions. To minimize distractions, you might be tempted to have the planning session off-site. However, while off-site seems preferable, we prefer on-site planning sessions. On-site planning sessions have both advantages and disadvantages, but with proper planning, they can be controlled. Easy access to information has been a major advantage to on-site planning sessions in our experience; interruptions due to the daily flow of work have been the major disadvantage. With easy access to the office made possible by cell phones and email, the potential for distraction and interruptions has increased. These need to be minimized in whatever way makes sense.

You need to allocate enough space so that groups of four or five planning members each have separate work areas with tables, chairs, and flip charts. All work should be done in one room. In our experience, we have found that breakout rooms tend to be dysfunctional. To the extent possible, everybody needs to be present for everything that takes place in the planning session. The room should have plenty of whiteboard space or blank walls. In many cases, we have taped flip-chart paper or butcher paper to the walls. You can never have enough writing space in the planning room.

Equipment

You will need an ample supply of Post-It notes, tape, scissors, and colored marking pens. For more high-tech equipment, an LCD projector and a PC are all you need for everyone in the room to see the details as they come together.

The Complete Planning Agenda

The agenda for the JPP session is straightforward. It can be completed in one, two, or three sessions. For example, an early meeting with the requestor can be scheduled, at which time the COS are drafted. These will be input to the second session in which the POS is drafted. In those cases where the POS must be approved before detailed planning can commence, there will be an interruption until approval can be granted. Once approval is obtained, the third session can be scheduled. At this session (usually two or three days long), the detailed project plan can be drafted for approval.

Here’s a sample agenda for the JPP session:

Session 1

  1. Negotiate the Conditions of Satisfaction.

    Session 2

    1. Write the Project Overview Statement.

    Session 3 (JPP session)

    1. The entire planning team creates the first-level WBS.

    2. Subject matter experts develop further decomposition with the entire planning team observing and commenting.

    3. Estimate activity durations and resource requirements.

    4. Construct a project network diagram.

    5. Determine the critical path.

    6. Revise and approve the project completion date.

    7. Finalize the resource schedule.

    8. Gain consensus on the project plan.

Deliverables

The deliverables from the JPP session are given in the project management life cycle and have already been discussed in detail in the appropriate chapters. They are repeated here:

Work Breakdown Structure. Recall that the Work Breakdown Structure (WBS) is a graphical or indented outline list of the work (expressed as activities) to be done to complete the project. It is used as a planning tool, as well as a reporting structure.

Activity duration estimates. The schedule, which is also a major deliverable, is developed from estimates of the duration of each work activity in the project. Activity duration estimates may be single-point estimates or three-point estimates, as discussed in Chapter 5.

Resource requirements. For each activity in the project, an estimate of the resources to perform the work is required. In most cases, the resources will be the technical and people skills, although they can also include such things as physical facilities, equipment, and computer cycles.

Project network schedule. Using the WBS, the planning team will define the sequence in which the project activities should be performed. Initially, this sequence is determined only by the technical relationships between activities, not by management prerogatives. That is, the deliverables from one or more activities are needed to begin work on the next activity. We can understand this sequence most easily by displaying it graphically. The definition of the network activities and the details of the graphical representation were covered in Chapter 6.

Activity schedule. With the sequence determined, the planning team will schedule the start date and end date for each activity. The availability of resources will largely determine that schedule.

Resource assignments. The output of the activity schedule will be the assignment of specific resources (such as skill sets) to the project activities.

Project notebook. Documentation of any type is always a chore to produce. Not so in the five-phase project management life cycle that we have used in this book. Project documentation happens as a natural by-product of the project work. All that is needed is to appoint a project team member to be responsible. His or her responsibilities include gathering information that is already available, putting it in a standard format, and electronically archiving it. This responsibility begins with the project planning session and ends when the project is formally closed.


Project Proposal

The culmination of all the planning is the project proposal. The project proposal is the deliverable from the JPP session and is forwarded to the senior management team for approval to do the project. It states the complete business case for the project. This includes expected business value, as well as cost and time estimates. In addition to this information, the proposal details what is to be done, who is going to do it, when it is going to be done, and how it is going to be done. It is the roadmap for the project.

Note

Expect feedback and several revisions before approval is granted. It is not the purpose of this section to spell out in detail what a project proposal should look like. The organization will have a prescribed format to follow. Rather, it is our intention to outline the contents you will be expected to submit.

Contents of the Project Proposal

Each organization will have a prescribed format for its project proposal, but most proposals will have sections similar to the ones in the list that follows.

You will see a remarkable resemblance to the topics we have covered in Chapters 3 through 7. Rightly so, for the project proposal is a restatement of all the planning work that has been done so far.

Background. This brief description details the situation that led to the project proposal. It often states the business conditions, opportunities, and any problems giving rise to the project. It sets the stage for later sections and puts the project in the context of the business.

Objective. This is another short section that gives a very general statement of what you hope to accomplish through this project. Avoid jargon, because you don’t know who might have reason to read this section. Use the language of the business, not the technical language of your department. The objective should be clearly stated so that there is no doubt as to what is to be done and what constitutes attainment of the objective.

Overview of approach to be taken. For those who might not be interested in the details of how you are going to reach your objective, this section provides a high-level outline of your approach. Again, avoid jargon whenever possible. Give a brief statement of each step and a few sentences of supporting narrative. Brevity and clarity are important.

Detailed statement of work. Here is where you give the details of your approach. Include what will be done, when it will be done, who will do it, how much time will be required of them, and what criteria will be used to measure completeness. This is the roadmap of all the project work. We have found Gantt charts useful for presentations of schedule data. They are easily understood and generally intuitive even for people who are seeing them for the first time.

Time and cost summary. It is our practice to include a summary page of time and cost data. This usually works best if done as a Gantt chart. Often the data will have been stated over several pages and is brought together here for easy review and comment by the customer.

Appendices. We reserve the appendix for all supporting data and details that are not germane to the body of the proposal. Anticipate questions your customer might have, and include answers here. Remember that this is detail beyond the basic description of the project work. Supporting information is generally found here.

There are no hard-and-fast rules as to format. You will surely be able to find examples of successful proposals in your department to be used as guides. Once you have your ideas sketched out, share the proposal with a trusted colleague. His or her feedback may be the most valuable advice you can get.


Putting It All Together

In this chapter, we provided a structure for you to follow as you organize and conduct the planning session that will produce a detailed description of the project. Most books on project management devote very little space to the mechanics of producing a project plan. In our experience, poor planning is one of the major obstacles to successful project execution, and so we have given you our best advice on planning a project garnered from our many years of experience in planning projects with our clients.

This chapter also completes all of the planning discussion. The next two chapters cover implementation, beginning with a chapter on team organization (Chapter 9) and one on monitoring and controlling the project work (Chapter 10). Finally, Chapter 11 covers the closing activities that take place once the project work has been completed.


Discussion Questions

  1. What are the advantages and disadvantages of holding a JPP session on-site versus off-site?

  2. Your planning session seems to have reached an impasse. The planning team is divided between two ways to approach a particularly difficult part of the project. Approximately two-thirds of them want to use a well-tested and well-understood approach. The remaining third (of which you are a member) wants to use a new approach that has the promise of significantly reducing the time to complete this part of the project. You are the project manager and feel very strongly about using the new approach. Should you impose your authority as project manager and take the new approach, or should you go with the majority? Why? Why not? Be specific. Is there anything else you might do to resolve the impasse?

Start Sidebar
Case Study

Based on the case and the description of management of the Jack Neift Trucking Company, which of the managers will need to be involved only at the beginning of the project to gather requirements and which will be needed all the way through the project? For those not participating actively, what communication will you give to them?

Also, who needs to be in your JPP session? List these persons by title and include those people whom you listed in your resource recommendations from the previous chapter.

End Sidebar


Chapter 9: Recruiting, Organizing, and Managing the Project Team

The productivity of a workgroup seems to depend on how the group members see their own goals in relation to the goals of the organization.

—Paul Hersey and Kenneth H. Blanchard

When the best leader’s work is done the people say, ‘We did it ourselves.’

—Lao-Tzu, Chinese philosopher

When a team outgrows individual performance and learns team confidence, excellence becomes reality.

—Joe Paterno, Football Coach, Penn State University

The project plan has been approved, and it’s time to get on with the work of the project. Before we turn the team loose, we must attend to a few housekeeping chores.

Start Sidebar
Chapter Learning Objectives

After reading this chapter you will be able to:

  • Explain the relationship between the project manager and the functional manager

  • Use projects for motivation and development

  • Understand the concept of job design and how it relates to project management

  • Define the three components of a project team

  • Describe the characteristics of an effective project manager

  • Describe the characteristics of an effective project team member

  • Understand the differences in roles and responsibilities of core versus contracted team members

  • Help contracted team members become part of the team

  • Understand the tools of an effective team

  • Organize the project team

  • Manage contracts and vendors

End Sidebar

Project Manager vis-à-vis the Functional Manager

First, let’s juxtapose the roles of the project manager with those of the functional manager. The distinction is an important foundation to the material presented in this chapter.

  • The objective of the project manager is clear: Complete the project on time, within budget, and according to the customer’s Conditions of Satisfaction, in other words—according to specification. Staff development is not on the list. The only cases when staff development is an objective of the project manager occur when the project manager also has line responsibility for the project team, in self-managed teams, or in project forms of organizational structures. In these cases, staff development is definitely part of the project manager’s objectives. The project manager must develop the skills on his or her project team to handle whatever assignments come along.

  • On the other hand, the functional (or resource) manager’s objectives include development of staff skills to meet project requirements and deployment of staff to projects. These objectives pertain regardless of the organizational structure.

The project manager’s objectives and the functional (or resource) manager’s objectives will often conflict. Part of the program for developing staff skills will occur through on-the-job training. Functional (or resource) managers will look for opportunities to deploy staff to project assignments that provide opportunities to learn new skills. The project manager, on the other hand, would rather have experienced staff assigned to project activities, especially activities that are critical to the completion of the project according to plan. The project manager will not be interested in being the training ground for professional staff.

A further complication arises in those situations where the functional (or resource) manager is also a project manager. In matrix organizations, this situation occurs frequently. Here the functional (or resource) manager is torn between assigning the best professionals to the activity and assigning professionals so that they can learn new skills or enhance current skills.

The last conflict arises when the choice between assigning a skilled professional to a project not in his or her area of responsibility and assigning the professional to a project in his or her area of responsibility emerges. In matrix organizations, this situation can occur with regularity. The primary issues arise when the manager must assign staff to projects. He or she not only has to staff projects internal to functional responsibilities but also assign staff to proj-ects outside the functional area. The project manager must address such questions as these: What projects have priority? Should I assign my best staff to my projects? After all, I do have to take care of my needs, although that stance may be hard to explain to the other project managers. Or do I assign the best staff to outside projects? Am I shooting myself in the foot? After all, I do have responsibilities to meet and want to succeed in doing them.

Tip

Always assigning the best professionals to projects within their area of responsibility will cause senior managers to wonder whether the functional (or resource) manager has the proper corporate focus.

We don’t want you to think that the project manager is totally insensitive to staff development and motivation. He or she needs the commitment of each project team member and in that sense will have to provide opportunities for development, but only with the goal of the project in mind. To the extent that the two are compatible, development will be an objective of the project manager.


Projects as Motivation and Development Tools

Not everyone can be motivated. In fact, in most cases all the manager can do is create an environment in which the subordinate might be motivated and then hope that he or she is. It’s really like farming. All the farmer can do is pick the crop to plant, the acreage to plant it on, and the fertilizer to use, then hope that nature supplies the right amounts of rain, wind, and sunshine. The same scenario applies to the project manager. He or she must create a working environment that is conducive to and encourages development of the team member and leave it up to the team member to respond positively.

Fortunately, we do have some information on what professional staff perceive as motivators and hygiene factors on the job.1 Motivators are those behaviors or situations that have a positive impact on the worker—they motivate the worker to better performance. Hygiene factors, on the other hand, are those things that, by their absence, have a negative impact on performance, but don’t necessarily motivate the worker if they are present. To put it another way, there are certain expectations that the worker has, and to not have them is to demotivate him or her. These are hygiene factors. For example, workers expect a reasonable vacation policy; to not have one acts as a demotivator. On the other hand, having a good vacation policy does not motivate the worker. The following list was created as a result of a 1959 survey of professionals by Frederick Herzberg,1 a professor known for his research in motivational theory. While the survey was conducted over 40 years ago, it has become a classic study and still applies today.

Motivators

  • Herzberg identified the following motivators:

  • Achievement

  • Recognition

  • Advancement and growth

  • Responsibility

  • Work itself

Hygiene Factors

Herzberg identified the following hygiene factors:

  • Company policy

  • Administrative practices

  • Working conditions

  • Technical supervision

  • Interpersonal relations

  • Job security

  • Salary

[1] Both the Herzberg and Couger studies are reported in Toledo Mata and Elizabeth A. Unger, “Another Look at Motivating Data Processing Professionals,” Department of Computer Science, Kansas State University, Manhattan, Kans., 1988, p. 4.

Note that the motivators are related to the job, specifically to its intrinsic characteristics; the hygiene factors are related to the environment in which the job is performed. This list offers both good news and bad news for the manager. The good news is that the manager has some amount of control over the motivators relating to the job. The bad news is that the hygiene factors, being environmental, are usually beyond the control of the manager. Managers can bring them to the attention of their senior management but are otherwise powerless to change them.

Daniel Cougar, a professor of Computer Science at Colorado State, conducted a similar survey in 1988. Here the respondents were analysts and programmers. The responses were grouped by those areas that the respondents considered motivators and those that they considered demotivators. The combined list represents the areas ordered from highest motivator to lowest motivator:

  • The work itself

  • Opportunity for achievement

  • Opportunity for advancement

  • Pay and benefits

  • Recognition

  • Increased responsibility

  • Technical supervision

  • Interpersonal relations

  • Job security

  • Working conditions

  • Company policy

The motivators that are high on the list tend to be intrinsic to the job, such as providing opportunities for advancement and for recognition, while the demotivators, which are lower on the list, tend to be environmental factors, such as working conditions (parking areas) and company policy (sick leave and vacation time).

Several of the motivators are directly controlled or influenced by actions and behaviors of the project manager regarding the work itself that the team member will be asked to do. They are as follows:

Challenge. Professionals always have responded to challenge. In general, if you tell a professional that something cannot be done, his or her creative juices begin to flow. The result: a solution. Professionals dread nothing more than practicing skills, long since mastered, over and over again. Boredom can lead to daydreaming and lack of attention to detail, which results in errors. Challenging the professional does not mean that every moment of every day should be spent solving previously unsolved problems. Usually, an hour or two on a new and challenging task per day is sufficient to keep a professional motivated throughout the day.

Recognition. Professionals want to know that they are progressing toward a professional goal. Publicly and personally recognizing their achievements and following them with additional challenges tells the professional that his or her contribution is valued. Recognition, therefore, does not necessarily mean dollars, promotions, or titles.

Job design. Because the job itself is such an important part of the motivators, let’s look at job design for just a moment. Five dimensions define a job:

Skill variety. Jobs that do not offer much task variety or the opportunity to learn and practice new skills become boring for most people. In designing jobs, it is important to consider building in some task variety. The variety, at the least, provides a diversion from what otherwise would be a tedious and boring workday. On the other hand, it also can provide a break during which the person can learn a new skill. With a little bit of forethought, the manager can find opportunities for cross-training by introducing some task variety for new skills development.

Warning

The manager will want to consider the risk involved in such actions. The person may not rise to the challenge of the new task or might not have the native ability to master the skills needed to perform the new task.

Task identity. People need to know what they are working on. This idea is especially true for contracted team members. The project manager should help them understand their work in relation to the entire project. Knowing that their task is on the critical path will affect their attitude and the quality of their work.

Task significance. In assessing a task’s significance, workers ask themselves questions such as these: Does it make any difference if I am successful? Will anybody notice? Just how important is my work to the overall success of the project? Am I just doing busy work to pass the day? Team members need to know whether their effort and success make any difference to the success of the project.

Autonomy. Professionals want to know what is expected from them—what are the deliverables? They don’t want to hear every detail of how they will accomplish their work. Systems people are rugged individualists. They want to exercise their creativity. They want freedom, independence, and discretion in scheduling their work and determining the procedures they will follow to carry it out.

Feedback. Good, bad, or indifferent, professionals want to know how effective they are in their work. Paying attention to a professional is motivating in itself. Having something good to say is even better. When performance is below expectations, tell them. If you can convince them that they own the problem, then ask them for an action plan to correct their marginal performance.


Recruiting the Project Team

Project plans and their execution are only as successful as the manager and team who implement them. Building effective teams is as much an art as a science.

When recruiting and building an effective team, you must consider not only the technical skills of each person but also the critical roles and chemistry that must exist between and among the project manager and the team members. The selection of project manager and team members will not be perfect—there are always risks with any personnel decision.

A project team has three separate components:

  • Project manager

  • Core team

  • Contracted team

Be aware of the characteristics that should be part of an effective project manager and project team. The following sections describe the responsibilities of each of the three components to a project team. We give you a checklist that should assist you in your selection process, and we also suggest guidelines for organizing the project in an organization.

The Project Manager

Project managers are the leaders of the projects. They are responsible for completing the project on time, within budget, and according to specification. They have the authority to get the job done. The project manager represents the project to the organization and to external groups. In many cases, the project manager has responsibility for more than one project simultaneously.

When to Select the Project Manager

The timing in selecting a project manager varies. Ideally, you want the project manager in the chair at the very beginning of the project. In some cases, the project manager might not be identified until the project has been approved for implementation. For example, in contemporary organizations, senior management assigns project managers to projects after the project proposal has been approved. In those instances, the project manager will not have participated in the scoping and definition phases. This leads to a number of significant problems, one of which is short schedules. Short schedules arise in projects that are defined generally between the account representative and the customer (whether internal or external). These agreements usually constrain all sides of the triangle, as well as the scope. All too often, the project manager is put in a no-win situation. One rule that we all learned a long time ago is this: “The sooner the project manager and team are involved in planning the project, the more committed they will be to its implementation.” (This is also true for other members in the organization whose expertise and resources are required to implement the project.)

Another problem with assigning the project manager after the project has been approved for implementation is buy-in by the project manager. Even when placed in situations that are not to his or her liking, the project manager must outwardly display enthusiasm and support for the project.

Selection Criteria

Harold Kerzner,2 a pioneer in project management and one of the leading authorities in the field, states that because the roles and responsibilities of the project manager are so important, his or her selection should be general management’s responsibility. If you are working in a large organization, a group or committee is usually assigned to help screen project manager candidates.

A project manager must be experienced, capable, and competent in getting the project done on time, within budget, and according to specifications. Easier said than done. The potential project manager should have the following general skills:

Background and experience. Background and experience in good project management practices are difficult to find in many organizations. The problem is that the demand for experienced project managers outstrips the supply. The solution for many organizations is to create a learning laboratory for wannabe project managers, those who are acquiring project management skills and competencies. To help develop a cadre of project managers of varying backgrounds and experiences, a hierarchy of project management assignments is commonly put in place. That hierarchy might start at team member and then progress to activity manager, to project manager, and finally to program manager. (These assignments have a one-to-one correspondence to projects ranging from Type D to Type A, as discussed in Chapter 1.) Project managers progress through this hierarchy as a result of training and experience in the skill areas needed to take on projects of increasing scope and complexity
[2] 2Harold Kerzner, Project Management: A Systems Approach to Planning, Scheduling, and Controlling (New York, N.Y.: Van Nostrand Reinhold Co., 1984). In addition to on-the-job experience training, several alternatives to “build your own” project managers are available. The most common training method is to learn the project management skills through reviewing project documentation, attending and later supporting JPP sessions, observing project status meetings, maintaining project documentation, and playing the role of technographer in JPP sessions. By participating in whatever way is practical, the individual can gain the skills through on-the-job experiences.Leadership and strategic expertise. The project manager is generally not the line manager of the team members. The project manager’s job is to manage the work of the project. That puts him or her in relationships with the team members that are very different from the relationship that would evolve if the team members reported directly to the project manager. The project manager must get the team members’ cooperation and support without having direct authority over them. It simply means that the project manager’s skills as a leader are more important to his or her role. The project manager’s success as a leader is also related to his or her ability to link the project to the strategy of the business. Often that will be at the heart of his or her relationship and any leverage he or she might have with the project team.Technical expertise. There are two schools of thought regarding the level of technical expertise that a project manager should have. One school suggests that managing one project is like managing any other project. These are the same pundits who would say that if you can manage one department you can manage any department. We’ll ignore the comment on managing departments, but we do take issue with the statement that implies that project management is independent of the project being managed. Despite all that has been written and said about project management, the discipline is primitive. There is a lot we do not know about the successful management of projects. If that were not the case, how would you explain the high project failure rates as reported by the Standish Group and discussed in Chapter 2? While we would agree that the project manager does not need an intimate knowledge of and to be skilled in working with the technology involved, he or she does need to have sufficient knowledge to know what questions to ask, how to interpret the answers, and whether he or she is being given the technical information needed to make a management decision.Interpersonal competence. Sooner or later, the job of the project manager reduces to his or her ability to interact successfully with another individual. In the course of the project, the project manager will interact with the team, other project managers, business managers, functional managers, senior managers, the customer, outside contractors, and suppliers. These interactions will challenge all of the project manager’s interpersonal skills as they relate to such areas as negotiations, conflict resolution, and problem resolution.Managerial ability. Certain managerial skills are a superset of project management skills. By superset we mean that they apply to project management but are more appropriate on a larger scale to the business. These tend to be strategic and tactical in nature and include skills such as strategic planning, budget planning, staff planning, quality management, business process reengineering, and personnel development.

Core Team Members

Core team members are with the project from cradle to grave. They typically have a major role to play in the project and bring a skill set that has broad applicability across the range of work undertaken in the project. They might also have responsibility for key activities or sets of activities in the project.

Similar to the project manager’s assignment, this assignment is usually not full-time. In matrix organizations, professional staff can be assigned to more than one project at a time. This case is especially true when a staff member possesses a skill not commonly found in the staff. A core team member will have some percentage of his or her time allocated to the project—say, a 0.25 full-time equivalent person.

When to Select the Core Team

Because the core team will be needed for the JPP session, its members should be identified as early as possible. The core team is usually identified at the beginning of the scoping phase. This means that the members can participate in the early definition and planning of the project.

Selection Criteria

Because of the downsizing, rightsizing, and capsizing going on in corporate America, much of the responsibility for choosing core team members has been designated to the project manager. While the situation differs from organization to organization, the project manager may have little or no latitude in picking core team members, even though he or she may have been given that responsibility. The problem stems from several causes:

  • Most organizations have a very aggressive portfolio of projects with constantly changing priorities and requirements.

  • The workload on the individual is so large that the thought of joining another team is not in his or her mind.

  • Staff turnover, especially among highly technical and scarce professionals, is out of control in many organizations.

All of these situations make it difficult for the project manager to select the core dream team. For example, suppose a project manager has a choice between the A Team and the B Team. The A Team is the most skilled in a particular technology. Its members are the company’s experts. The B Team, on the other hand, is made up of those individuals who would like to be on the A Team but just don’t have the experience and skills to justify A Team membership. The project manager would like to have all A Team members on the core team but realizes that this is just not going to happen. Even suggesting such a core team would be rejected out of hand by the managers of such highly skilled professionals. The politically savvy project manager would determine the project work that must have an A Team member and the project work that could get done with a B Team member and negotiate accordingly with the managers of these potential team members.

The project manager will have to pick his or her battles carefully, because he or she may want to consider the A Team for critical path activities, high-risk activities, and high-business-value projects and accept the B Team for activities and projects of lesser criticality. Be ready to horse-trade between projects, too. Give the resource managers an opportunity to use noncritical path activities as on-the-job training for their staff. Remember that they have as many staff development and deployment problems as you have project planning and scheduling problems. Trading a favor of staff development for an A Team member may be a good strategy.

In our project management consulting work, we identified a list of characteristics that many project managers have offered as successful characteristics in their core teams. For the most part, these characteristics are observed in individuals based on their experiences and the testimony of those who have worked with them. Typically, these are not characteristics whose presence or absence in an individual are determined through interviews.

In many cases, the project manager will just have to take a calculated risk that the team member possesses these characteristics even though the individual has not previously demonstrated that he or she has them. It will become obvious very quickly whether or not the individual possesses these characteristics. If not, and if those characteristics are critical to the team member’s role in the project, the project manager or the team member’s line manager will have to correct the team member’s behavior.

The characteristics that we consider important for the core team members are as follows:

Commitment. Commitment to the project by the core team is critical to the success of the project. The project manager must know that each core team member places a high priority on fulfilling his or her roles and responsibilities in the project. The core team must be proactive in fulfilling those responsibilities and not need the constant reminders of schedule and deliverables from the project manager.

Shared responsibility. Shared responsibility means that success and failure are equally the reward and blame of each team member. Having shared responsibility means that you will never hear one team member taking individual credit for a success on the project nor blaming another team member for a failure on the project. All share equally in success and failure. Furthermore, when a problem situation arises, all will pitch in to help in any way. If one team member is having a problem, another will voluntarily be there to help.

Flexibility. Team members must be willing to adapt to the situation. “That is not my responsibility” doesn’t go very far in project work. Schedules may have to change at the last minute to accommodate an unexpected situation. It is the success of the project that has priority, not the schedule of any one individual on the project team.

Task-orientedness. In the final analysis it is the team members’ ability to get their assigned work done according to the project plan that counts. In other words, they must be results-oriented.

Ability to work within schedule and constraints. Part of being results- oriented means being able to complete assignments within the timeframe planned instead of offering excuses for not doing so. It is easy to blame your delay on the delay of others—that is the easy way out. The team member will encounter a number of obstacles, such as delays caused by others, but he or she will have to find a way around those obstacles. The team depends on its members to complete their work according to plan.

Willingness to give trust and mutual support. Trust and mutual support are the hallmarks of an effective team. That means that every member must convey these qualities. Team members must be trusting and trustworthy. Are they empathetic and do they readily offer help when it is clear that help is needed? Their interaction with other team members will clearly indicate whether they possess these characteristics. Individuals that do not will have a difficult time working effectively on a project team.

Team-orientedness. To be team-oriented means to put the welfare of the team ahead of your own. Behaviors as simple as the individual’s frequency of use of “I” versus “we” in team meetings and conversations with other team members are strong indicators of team orientation.

Open-mindedness. The open-minded team member will welcome and encourage other points of view and other solutions to problem situations. His or her objective is clearly to do what is best for the team and not look for individual kudos.

Ability to work across structure and authorities. In the contemporary organization, projects tend to cross organizational lines. Cross-departmental teams are common. Projects such as these require the team member to work with people from a variety of business disciplines. Many of these people will have a different value system and a different approach than the team member might be used to working with. Their adaptability, flexibility, and openness will be good assets.

Ability to use project management tools. The team member must be able to leverage technology in carrying out his or her project responsibilities. Projects are planned using a variety of software tools, and the team member must have some familiarity with these tools. Many project managers will require the team member to input activity status and other project progress data directly into the project management software tool.

Contracted Team Members

The business-to-business environment is changing, and those changes are permanent. Organizations are routinely outsourcing processes that are not part of their core business or core expertise. There are two reasons for choosing to use contract team members instead of the company’s own employees:

  • Shortage of staff

  • Shortage of skills

Those shortages have made it possible for a whole new type of business to grow—tech-temps is the name we associate with this new business opportunity. The day of the small contractor and niche market player is here to stay. To the project manager, this brings the need to effectively manage a team whose membership will probably include outside contractors. Some may be with the project for only a short time. Others may be no different from core teams except they are not employees of your company.

Typically, contracted team members are available for only short periods of time on the project. They possess a skill that is needed for just a brief time. They are assigned to the project when it is time for them to contribute their skills. As soon as they have completed their assigned task, they leave the project.

Implications of Adding Contract Team Members

Contracted team members present the project manager with a number of problems. In most systems development efforts, it is unlikely that professionals would be assigned full-time to the project team. Rather, people will join the project team only for the period of time during which their particular expertise is needed. The project manager must be aware of the implications to the project when contracted professionals are used, which may include the following:

  • There may be little or no variance in the time contracted team members are available, so the activities on which they work must remain on schedule.

  • They must be briefed on their role in the project and how their activity relates to other activities in the project.

  • Commitment of contracted members is always a problem because their priorities probably lie elsewhere.

  • Quality of work may be an issue because of poor levels of commitment. They just want to get the job done and get on with their next assignment. Often anything will do.

  • Contracted team members will often require more supervision than core team members.

Selection Criteria

If the project manager (PM) has made the decision to buy rather than build a project team, the PM must determine who will get the business. Contracted team members are usually employed or represented by agencies that cater to technical professionals who prefer freelancing to full-time employment. These professionals are available for short-term assignments in their area of specialization. To employ these professionals, the project manager must make several decisions: what process to follow, who should be invited to submit information, and how to evaluate the information received. The evaluation often takes the form of a score sheet. The score sheet contains questions grouped by major features and functions, with weights attached to each answer. A single numeric score is often calculated to rank vendor responses. Nonquantitative data such as customer relations and customer service are also collected from reference accounts provided by the vendor.

The steps the project manager follows to engage the services of a contracted team member might look something like the following:

  1. Identify the types of skills needed, the number of personnel, and the timeframe within which they will be needed.

  2. Identify a list of companies that will be invited to submit a proposal.

  3. Write the request for proposal.

  4. Establish the criteria for evaluating responses and selecting the vendor(s).

  5. Distribute the request for proposal.

  6. Evaluate the responses.

  7. Reduce the list of vendors to a few who will be invited on site to make a formal presentation.

  8. Conduct the onsite presentations.

  9. Choose the final vendor(s), and write and sign the contract.

Types of Proposals

A project manager might consider three types of proposals as he or she looks for a vendor or agency to provide contracted team members: Request for Information, Request for Proposal, Request for Quote.

Request for Information. A Request for Information (RFI) is used when an organization is looking for information relevant to a particular process or product. It usually does not have a written specification. The purpose of an RFI is to discover vendors and products that the organization will investigate further with one of the other two types of proposals.

Request for Proposal. A Request for Proposal (RFP) is used to find the vendor or vendors that can provide the best solution and price. The RFP always includes a specification that identifies the features, functions, physical specifications, performance requirements, and environment in which the requested deliverable must operate. Generally, descriptions of steps to be followed to select the vendor and the method of evaluation are included. In some cases, more than one vendor will be chosen. Each vendor will provide a piece of the final solution. Using several vendors presents special challenges to the project manager.

Request for Quote. The Request for Quote (RFQ) is used to find the best price-to-performance ratio for a given solution. In this case, the company knows exactly what it wants; it is only a matter of finding the vendor that best meets the Conditions of Satisfaction. The definition of what the company wants will often include the exact hardware, software, and more. This approach offers the PM an easier-to-manage situation than the multivendor alternative.

Types of Contracts

There are four types of contracts:

Retainer. These arrangements pay the contractor a fixed fee per period (usually monthly). Often no end date is specified. At some time the organization will decide that the arrangement can terminate because the contractor’s services are no longer needed. The retainer will state how many days per period are expected of the contractor and the deliverables the contractor will provide. The deliverables are often only vaguely described, because such arrangements are usually investigative or design-related.

Time and materials In these cases, a little more specificity exists, but a detailed specification is not available or cannot be provided. The company is willing to accept the risk of high costs in the face of unknowns.

Time and materials—not to exceed. Here the vendor assumes more of the risk. A detailed specification may not exist, but enough is known so that the contractor will meet the customer’s requirements at a cost not to exceed a specified figure and within a specified timeframe.

Fixed bid. In these cases, a detailed specification exists, and the vendor is willing to meet the deliverables and a deadline date for a specified figure. Obviously, the vendor assumes most of the risk here. Fixed bid contracts usually include a payment schedule, too. In our consulting practice, we use the 40-40-20 rule: 40 percent is due on contract signing, 40 percent is due at an agreed-on midpoint in the project, and the remaining 20 percent is due once the final deliverables have been accepted and the company signs off that the contract is complete.

Contract Administration

Once the contract is signed and the vendor begins to deliver the contracted work, contract administration for that vendor has begun. Contract administration is the responsibility of the project manager. Our general advice is to have the contract spell out in detail exactly how business will be done—not a detailed list of what will be done for every possible occurrence during the contract period, but rather clear guidelines that everyone understands. The guidelines might include obligations, responsibilities, performance goals and deadline dates, penalties for missed dates, rewards for early delivery, status reporting dates, problem discovery, escalation and resolution, change management procedures, milestone dates, project status meeting dates, acceptance test criteria, cancellation conditions, cancellation policies, and closing criteria.

Contract Cancellation

The contract should clearly spell out the conditions under which the contract may be cancelled. For example, can either party cancel for any reason by simply notifying the other according to a defined procedure? Or does cancellation require both parties’ mutual agreement? Cancellation will often be the result of performance not meeting expectations.

Contract Closing

Once the acceptance criteria have been met, a series of events occurs. These are generally debriefing sessions and handoffs of deliverables and documentation. A final payment to the vendor is commonly withheld pending receipt of these items.


Organizing the Project Team

Now that you have identified the individuals who will become the project team, it is time to make them function as a team. Remember right now that they are a herd of cats; they are not a team—at least not yet. First, we’ll briefly look at authority and responsibility, then several procedural matters that the team will have to discuss and agree on.

Authority

Authority and responsibility go hand in hand. To have one and not the other makes no sense. How often have we been in situations where we were responsible for making a certain thing happen but had no authority over the resources needed to make it happen or no authority to make and carry out a decision? To be effective, the project manager must have authority over the project. It is his or her job to get the project done on time, within budget, and according to specification. That authority is often delegated, but it is the project manager who is ultimately responsible.

The major difficulty that project managers have is that the project team is not their line responsibility. Team members are assigned based on their expertise but report to other managers, which means that the project manager will have to exercise the best leadership skills and diplomacy to get the job done. The key is in the project planning activities that schedule resources to windows of time. It is here that the resource manager makes the commitment of people resources. Honoring that commitment within the time allotted reduces the incidence of problems. If the project manager remembers to keep the resource managers involved and aware of all project changes, negotiations will proceed better when circumstances warrant.

Responsibility

There is no question where the responsibility lies. This responsibility cannot be delegated. The project manager assigns activity management responsibility to team members. They are then responsible for completing their assigned activity within its scheduled window of time and for producing the activity deliverables on time according to specification. It is the project manager, though, who is ultimately responsible for completing the project as expected. In conveying this sense of responsibility to each team member, the project manager must exercise sound leadership and management skills. He or she will do this by maintaining a consistent level of interest in and communication with each of their activity managers, by involving them and engaging them in planning, change management deliberations, and problem resolution. He or she will keep everybody on the team informed of project status.

Balancing a Team

Balance on the team is a critical success factor for any team that hopes to successfully complete its project. There are several ways to measure balance and several characteristics of the team that have been used to define balance. Let’s take a simple example—learning styles. Learning styles are measured using an instrument, the Learning Styles Inventory (LSI), which was developed by David Kolb in 1981. Kolb identifies four learning styles:

Assimilating. Assimilators are people who excel at collecting and representing data in crisp logical form. They are focused on ideas and concepts rather than people. These individuals like to put data and information together into models that explain the situation from a larger perspective. As a result, they are more interested in something making sense logically than they are in any practical value. They are not results-oriented people. These types of individuals are generally found in the more technical or specialist careers, such as developers.

Diverging. These individuals like to look at alternatives and view the situation from a variety of perspectives. They would rather observe than take action. Divergers like brainstorming and generally have a broad range of interests and like together information. On a project team these people will often suggest outside-the-box thinking and offer suggestions for other approaches than those that may have already been identified.

Accommodating. These individuals are results-oriented and want to put things into practice. They are adaptive and can easily change with the circumstances. Accommodators are people persons. They are strong at implementation and hands-on activities and are good team players. They tend to be action-oriented and more spontaneous than logical. As problem solvers they rely on people for input rather than on any technical analysis. On the project team you can count on these people to help foster a strong sense of teamwork, and they will often be found facilitating the working together of team members. They will often be the peacekeepers as well.

Converging. These individuals like to assemble information in order to solve problems. They like to converge to the correct solution. Convergers are the solution finders but not the solution implementers. Their strength lies in their ability to take concepts, models, and ideas and turn them into practical use. They are not particularly people-oriented and would rather work with technical tasks and problems. They are good at picking the best option among a number of alternatives. On the project team these will be the results-oriented members. They will drive the team into action by helping it focus on which approach to a situation is best and then mobilizing the team into action.

Now suppose you have a team that is loaded with convergers and does not have a single diverger among their members. What do you think might happen? With no one on the team to encourage looking for alternatives (the role of the diverger), you would very likely have a rush to judgment, or “group think,” as the convergers press the team into action. We have personally witnessed many situations where a single approach to a problem is presented, and the convergers on the team aggressively suggest that the team go forward with the single proposed solution without even considering whether there is an alternative. Teams that are involved in high-technology projects are likely to display this behavior.

A team that has balanced learning styles among its members is a team that is prepared to do a very good job at solving problems and making decisions.

Cross-Reference

Learning styles are not the only point of balance. Thinking styles, conflict resolution styles, and skills and competencies are also important, but an in-depth discussion of such matters is beyond the scope of this book. For more information about balancing your project team in this manner you can consult Robert K. Wysocki’s Building Effective Project Teams (John Wiley & Sons, Inc., 2002).

Developing a Team Deployment Strategy

Having balance on the team in all of the characteristics discussed in the previous section is certainly a worthy goal, but it is a goal not likely to be reached. In reality, the team is formed more on availability than on any need to balance its membership. That means that teams are not balanced, but they are the team nevertheless. What’s a project manager to do?

First of all, the project manager had better know where the imbalance exists. What characteristics does the team have? Where are its strengths and where are its weaknesses? For example, suppose a confrontation has arisen with the client. We would much rather send an accommodator than a converger to resolve the confrontation. However, there might not be an accommodator on the team. Teams are most likely to be formed without knowledge of this kind of information. It is only after the fact that these imbalances are discovered. On a larger scale, the project manager needs to determine which team members have a greater likelihood of success on which types of work assignments. Build the strategy. If you still have gaping holes, you need a team development plan. That is the topic of the next section.

Developing a Team Development Plan

Our team has been assembled, and we have assessed each member on all of the characteristics important to achieving balance. The picture is not very pretty. There are several areas where the team is noticeably weak. While our job as project manager is not to be a career or professional development manager of the team members, we still have to get the project done, and the imbalance on the team is a barrier to our success. As project manager, we would identify the high-risk areas that are not covered by at least one team member that can deal with those types of risks. As part of your risk management plan, you need to put a development plan in place for selected members of the team.

What form might that development plan take? Here are a couple possibilities:

  • You might want to use a conflict resolution management called masked behavior. Briefly, it means that you find the person on your team whose normal behavior is as close as possible to the missing behavior. That person then role-plays as though his or her normal behavior were the missing behavior.

  • You might consider sensitivity training for all or some of the team. That training involves creating an awareness of the behavior that is lacking and practicing it under supervision. For example, technology professionals are generally not very good people persons. They often lack the traits of an accommodator. Their training might include listening skills, learning how to be a team player, acceptance of change, diversity training, and other related interpersonal skills training.


Establishing Team Operating Rules

Project teams all too often fail to define and agree on the team operating rules. These operating rules define how the team works together, makes decisions, resolves conflicts, reports progress, and deals with a host of other administrative chores. Even before the work of the project begins, the team should agree on how it will work together. When the team is deep into the work of the project is no time to be deciding how they will work together. First we will look at the areas where operating rules are needed, and then we will discuss the specifics of those operating rules.

Situations Requiring Team Operating Rules

The following is a fairly complete list of general situations that may arise during the course of a project and that will require some action on the part of the team. We have grouped them into six general areas.

  • Problem solving

  • Decision making

  • Conflict resolution

  • Consensus building

  • Brainstorming

  • Team meetings

Consider the following questions from Managing the Project Team: The Human Aspects of Project Management, Volume 3, by Vijay K. Verma (Project Management Institute, 1997) that must be answered at some point in the project life cycle:

  • What has to be done and where? (Scope)

  • Why should it be done? (Justification)

  • How well must it be done? (Quality)

  • When is it required and in what sequence? (Schedule)

  • How much will it cost? (Budget/Cost)

  • What are the uncertainties? (Risk)

  • Who would do the job? (Human resources)

  • How should people be organized into teams? (Communication/ Interpersonal skills)

  • How will we know if we have done the job? (Information dissemination/Communication)

Each one of these questions will engage one or more of the six action areas listed previously. The team needs to decide ahead of time how it will carry out each of the action areas—that is, what are the rules of engagement. Let’s look at those action areas in more detail and see what is involved on the part of the team.

Problem Solving

There will be many situations during the course of the project work where the team will be challenged to figure out how to satisfactorily meet the client’s needs while maintaining the schedule and the budget within the assigned resources. Some situations will be easily resolved, while others will challenge even the most creative of minds. The problem-solving process is well known, and many variations are in print. Creativity and problem solving go hand in hand. A good problem solver will think outside the box. He or she will conceive of approaches that may have been overlooked. As we discuss next, each of the learning styles mentioned earlier in the chapter relates to a different part of the problem-solving model. That means that the team must have all learning styles represented in order to solve problems effectively. In this section, we see how those learning styles relate to the problem-solving process.

The model that seems most appropriate for project problem solving is one put forward by J. Daniel Couger in his work Creative Problem Solving and Opportunity Finding (Boyd and Fraser Publishing, 1995). The model is shown in Figure 9.1.

Couger’s process begins with an outside stimulus: A situation has arisen that creates an out-of-control situation in the project that must be rectified. That launches a series of actions that clarifies the situation, identifies and assembles relevant data, gets a number of ideas and approaches on the table, and analyzes the ideas. It then selects the idea that would appear most promising as the way to rectify the situation and return it to normal. Finally, an action plan is put in place and executed (the exit point of the model is the action itself). We will see how all of the learning styles are needed to complete each step in the model. Couger identifies the five steps that make up this problem-solving process:

Step 1: Delineate the opportunity and define the problem. This is a scoping step in which the team members attempt to establish a formulation and definition of the problem and the desired results that a solution to the problem will provide. It helps the team develop the boundaries of the problem—that is, what is in scope and what is out of scope. This step is best performed by team members who have a preference for the assimilator style. These individuals look at the problem independently of any focus on people and try to present the problem at the conceptual level and put it into a logical framework. Their penchant for collecting and concisely reporting data is an early activity in this model.

Step 2: Compile the relevant data. With a definition of the problem in hand, the team can now identify and specify the data elements that will be needed to further understand the problem and provide a foundation on which possible solutions can be formulated. Again, the assimilator is well suited to this activity.

Click To expand
Figure 9.1: Couger’s Creative Problem Solving (CPS) Model.

Step 3: Generate ideas. This step typically begins with a brainstorming session. The team needs to identify as many solutions as possible. This step is the time to think outside the box and look for creative and innovative ways to approach a solution. Ideas will spawn new ideas until the team has exhausted its creative energies. The diverger is well suited to the activities that take place in this step. The job of this individual is to look at the problem from a number of perspectives. Like the assimilator, the diverger also has an interest in data and information with the purpose of generating ideas, but he or she is not interested in generating solutions.

Step 4: Evaluate and prioritize ideas. In this step the list of possible solutions needs to be winnowed down to the one or two solutions that will actually be planned. Criteria for selecting the best solution ideas need to be developed (that’s a job for the converger), metrics for assessing advantages and disadvantages need to be developed (again, a job for the converger), and the metrics are then used to prioritize the solutions. The calculation of the metric value for each alternative and the ranking of the alternatives based on those metric values is a straightforward exercise that anyone on the team can perform. This individual has the ability to take a variety of ideas and turn them into solutions. His or her work is not finished, however, until he or she has established criteria for evaluating those solutions and makes recommendations for action.

Step 5: Develop the implementation plan. The solution has been identified, and it’s now time to build a plan to implement the solution. This step is a whole-team exercise that will draw on the team’s collective wisdom for planning and implementation. When it is results that you want, call on the accommodator. His or her contribution will be to put a plan in place for delivering the recommended solution and making it happen. The accommodator is a good person to lead this planning and implementation exercise.

While this five-step process may seem cumbersome and involved, many of the steps will often be executed in a simple and straightforward manner. Situations requiring a problem-solving effort occur frequently and are often done from start to finish by one team member. There will, of course, be more complex situations requiring several team members and the collective creativity of the whole team. The five steps should become second nature to each team member. As team members become familiar with the five steps, the steps will begin to form a commonsense sequence, and they should not be overly burdensome to anyone on the team.

Decision Making

Team members make decisions all of the time as they engage in the work of the project. Some of those decisions are obvious and straightforward and may not require the involvement of others; other decisions are more complex and may require the involvement and active participation of the team, the client, and even people outside of the project. There are three major types of decision-making models:

Directive. In this model, the person with the authority—the project manager for the project and the activity manager for the activity—makes the decision for all team members. While this approach is certainly expedient, it has obvious drawbacks. The only information available is the information that the decision maker possesses, which may or may not be correct or complete. An added danger is that those who disagree or were left out of the decision may not be willing to carry it out or at least be resistant to carrying it out. A directive approach is often used when time is of the essence and a decision is needed immediately. It makes no sense to hold a committee meeting to get everyone’s input before proceeding.

Participative. In this model, everyone on the team contributes to the decision-making process. A synergy is created as the best decision is sought. Because everyone has an opportunity to participate, commitment will be much stronger than in the directive approach. Obviously, there are additional benefits to team building—empowerment of the team. Whenever possible, we recommend this participative approach. Because the team members had a chance to participate in the decision-making process, they will be much more committed to the decision that was made and more likely to support it in implementation. From a political perspective, the project manager is much better off from having used this approach that a direc-tive approach.

Consultative. This middle-ground approach combines the best of the other two approaches. While the person in authority makes the decision, the decision is made only after consulting with all members to get their input and ideas. This approach is participative at the input stage but directive at the point of decision. In some cases, when expediency is required, this approach is a good one to take. Rather than having to involve the entire team, the project manager can decide whose input should be sought and then make the decision based on that input. Politically this is a very good strategy, and it can have positive effects on those whose input was sought.

Deciding Which Decision-Making Model to Use

Which model to use in a specific situation is generally a function of the gravity and time sensitivity of the pending decision. Some organizations have constructed categories of decisions, with each category defined by some financial parameters, such as the value of the decision, or by some scope parameters, such as the number of business units or customers affected by the decision. The person responsible for making the decision is defined for each decision category. The more serious the category, the higher the organizational level of the decision maker. Some decisions might be made by an individual team member, some by an activity manager, some by the project manager, some by the customer, and some by senior management. Yet others might require a group decision, using either a participative or a consultative approach.

Decision Making and the Learning Styles Inventory

Just as the LSI, discussed earlier in the chapter, relates to the problem-solving process, it also relates to the decision-making process. While it is true that decision making and problem solving are closely related, it is instructive for us to see just how the LSI relates to decision making as well. Problem solving cannot happen without some decisions having been made. In that sense, decision making can be thought of as a subset of problem solving.

Note

Decision making can also occur outside of the problem-solving context. For example, suppose a project is behind schedule and the design phase is not yet complete. We could start some preliminary programming, but at the risk that when the design is complete, we may have to rework some of the earlier programming. Do we begin programming to make up lost time and take the risk, or do we wait for the design to be finished before we begin programming? This is clearly a decision-making situation and not a problem-solving one.

Decision making is pervasive throughout the life of the project. How will the project team make decisions? Will they be based on a vote? Will they be a team consensus decision? Will they be left up to the project manager? Just how will the team operate?

However, deciding how to decide is only one piece of the puzzle. Another piece is whether the team can make a decision, and if not, what they do about it. Let’s take a closer look at the decision-making environment that the project team faces.

In their book Organizational Behavior in Action: Skill Building Experiences (West Publishing Co., 1976), William C. Morris and M. Sashkin propose a six-phase model for rational decision making. The six phases in their approach are outlined in the bullet list that follows. However, as we have indicated, there is a lot of similarity between the use of the LSI in problem solving and in decision making, and the following bullet list also draws attention to how the LSI applies to Morris and Sashkin’s rational decision making in a way similar to how it applied to Couger’s problem-solving process.

Phase I: Situation definition. This phase is one of discovery for the team and clarifying the situation to make sure that there is a shared understanding of the decision the team faces. Phase I requires the services of an assimilator. As part of the process of discovery, the assimilator will collect data and information and formulate the situation and the required decision.

Phase II: Situation decision generation. Through brainstorming, the team tries to expand the decision space. Phase II, the search for alternative decisions, is the province of the diverger. This is a collaborative effort because it continues to involve the assimilator in a definition type of activity.

Phase III: Ideas to action. Metrics are devised to attach reward and penalty to each possible decision that might be made. With the alternatives identified, the work can be turned over to the converger in Phase III. His or her job is to establish criteria. His or her work is complete when a plan for implementing the decision is in place in Phase IV.

Phase IV: Decision action plan. The decision has been made, and the development of a plan to implement it is now needed. In Phase IV the accommodator takes over and implements the decision.

Phase V: Decision evaluation planning. This phase is kind of a post-decision audit of what worked and what didn’t work. Some lessons learned will be the likely deliverable as well. The team, under the direction of an accommodator, will take an honest look at how effective the decision was.

Phase VI: Evaluation of outcome and process. The team needs to find out if the decision got the job done and whether another attempt at the situation is needed. Finally, an evaluation of the results in Phase IV puts the work back into the hands of the assimilator. If the expected results were not attained, another round may be required.

Table 9.1 provides a summary of the six decision-making phases and the required learning styles.

Table 9.1: The Six Phases of the Decision-Making Process
PHASE | DESCRIPTION | LEARNING STYLE
Phase I: Situation definition | Discovery phase. The team investigates, discusses, clarifies, and defines the situation. It is important for the team to understand the root causes and evidence that led to the need for a decision. | Assimilator
Phase II: Situation decision generation | Continuation of Phase I. Characterized by brainstorming and searching for new ideas and alternatives for resolving the situation, which should lead to better choices for the decision. Above all, the team needs to avoid a rush to judgment. | Diverger
Phase III: Ideas to action | Define the criteria for evaluating the alternative decisions. This involves identifying the advantages and disadvantages of each alternative. Whatever approach is used, the result should be a ranking of alternatives from most desirable to least desirable. | Converger
Phase IV: Decision action plan | Begins once the alternative is chosen. This is the planning phase for the project team. The team determines activities, resources, and time lines that are required to implement the decision. This phase requires a concerted effort to obtain buy-in from all affected parties. | Converger
Phase V: Decision evaluation planning | Learning opportunity for the project team. The team identifies what did and did not work, as well as areas in which it can improve and how to do so. The value of this discussion lies in the team’s willingness to be honest and straightforward with one another. | Accommodator
Phase VI: Evaluation of outcome and process | Focuses on the quality of results. The team evaluates the situation: Was the situation improved satisfactorily, or will another round be required? Was the situation defined correctly, or is revision required? Did the process work as expected, or will it need adjustment for the next attempt? | Assimilator
Cross-Reference

Our discussion has been brief and very much a summary of a complex and interesting topic. The decision-making model discussed here is discussed in more detail in the book Building Effective Project Teams by Robert K. Wysocki (John Wiley & Sons, Inc., 2002).

Conflict Resolution

The next area for which operating rules are needed deals with how the team resolves conflicts. Conflicts arise when two or more team members have a difference of opinion, when the customer takes issue with an action to be taken by the project team, or in a variety of other situations involving two parties with different points of view. In all of these examples, the difference must be resolved. Clearly, conflict resolution is a much more sensitive situation than the decision-making rule because it is confrontational and situational, whereas the decision-making rule is procedural and structured. Depending on the particular conflict situation, the team might adopt one of three conflict resolution styles:

Avoidant. Some people will do anything to avoid a direct confrontation. They agree even though they are opposed to the outcome. This style cannot be tolerated on the project team. Each person’s input and opinion must be sought. It is the responsibility of the project manager to make sure that this happens. A simple device is to ask each team member in turn what he or she thinks about the situation and what he or she suggests be done about it. Often this approach will diffuse any direct confrontation between two individuals on the team.

Combative. Some avoid confrontation at all costs; others seem to seek it out. Some team members play devil’s advocate at the least provocation. There are times when this is advantageous—testing the team’s thinking before making the decision. At other times it tends to raise the level of stress and tension, when many view it as a waste of time and not productive. The project manager knows who these team members are and must act to mitigate the chances of these situations arising.

Tip

One technique we have used with success is to put such individuals in charge of forming a recommendation for the team to consider. Such an approach offers less opportunity for combative discussion because the combative team member is sharing recommendations before others give reason for disagreement.

Collaborative. In this approach, the team looks for win-win opportunities. The approach seeks out a common ground as the basis for moving ahead to a solution. This approach encourages each team member to put his or her opinions on the table and not avoid the conflict that may result. At the same time, team members do not seek to create conflict unnecessarily. The approach is constructive, not destructive.

The choice of conflict resolution styles is beyond the scope of this book. There are several books on the topic that you can consult. Two that we have found particularly helpful are “Conflict and Conflict Management” by Kenneth Thomas in The Handbook of Industrial and Organizational Psychology, (John Wiley & Sons, Inc., 1983) and The Dynamics of Conflict Resolution: A Practitioner’s Guide by Bernard S. Mayer (Jossey-Bass, 2000). Of particular importance will be the variety of collaborative models that might be adopted.

Consensus Building

Consensus building is a process that a team can follow to reach agreement on which alternative to proceed with for the item (action, decision, and so forth) under consideration. The agreement is not reached by a majority vote, or any vote for that matter. Rather, the agreement is reached through discussion, whereby each participant reaches a point when he or she has no serious disagreement with the decision that is about to be taken. The decision will have been revised several times for the participants to reach that point.

Consensus building is an excellent tool to have in the project team tool kit. In all but a few cases, there will be a legitimate difference of opinion as to how a problem or issue should be addressed. There will be no clear-cut action on which all can agree. In such situations the team must fashion an action or decision with which no team members have serious disagreement even though they may not agree in total with the chosen action. To use the method successfully, make sure that everyone on the team gets to speak. Talk through the issue until an acceptable action is identified. Conflict is good, but try to be creative as you search for a compromise action. As soon as no one has serious objections to the defined action, you have reached consensus. Once a decision is reached, all team members must support it.

If the project manager chooses to operate on a consensus basis, he or she must clearly define the situations in which consensus will be acceptable. The team needs to know these situations.

Brainstorming

Brainstorming is an essential part of the team operating rules because, at several points in the life of the project, the creativity of the team will be tested. Brainstorming is a technique that can focus that creativity and help the team discover solutions. There will be situations where acceptable ideas and alternatives have not come forth from the normal team deliberations. In such cases the project manager might suggest a brainstorming session. A brainstorming session is one in which the team contributes ideas in a stream-of-consciousness mode, as described in the next paragraph. Brainstorming sessions have been quite successful in uncovering solutions where none seemed present. The team needs to know how the project manager will conduct such sessions and what will be done with the output.

The method for brainstorming is simple and quick:

  1. First, assemble together those individuals who may have some knowledge of the problem area. They don’t need to be experts. In fact, it may be better if they are not. You need people to think creatively and outside the box. Experts tend to think inside the box.

  2. The session begins with everyone throwing any idea out on the table. No discussion (except clarification) is permitted. This continues until no new ideas are forthcoming. Silence and pauses are fine.

  3. Once all the ideas are on the table, you discuss the items on the list. Look to combine ideas or revise ideas based on each member’s perspective.

  4. In time, some solutions begin to emerge. Don’t rush the process, and by all means test each idea with an open mind. Remember, you are looking for a solution that no individual could identify but that, we hope, the group is able to identify.

    Note

    This is a creative process, one that must be approached with an open mind. Convention and “we’ve always done it that way” have no place in a true brainstorming session.

Team Meetings

The project manager needs to define team meetings in terms of frequency, length, meeting dates, submission/preparation/distribution of the agenda, who calls the meeting, and who is responsible for recording and distributing the minutes. The entire team needs to participate in and understand the rules and structure of the meetings that will take place over the life of the project. Different types of team meetings, perhaps with different rules governing their conduct and format, may occur.

Team meetings are held for a variety of reasons, including problem definition and resolution, scheduling work, planning, discussing situations that affect team performance, and decision making. The team will need to decide on several procedural matters, including the following:

Meeting frequency. How often should the team meet? If it meets too frequently, precious work time will be lost. If it meets too infrequently, problems may arise and the window of opportunity may close before a meeting to discuss and solve the problem takes place. If meetings happen too infrequently, the project manager risks losing management control over the project. Meeting frequency will vary as the length and size of the project varies. There is no formula for frequency. The project manager must simply make a judgment call.

Agenda preparation. When the project team is fortunate enough to have a project administrative assistant, that person can receive agenda items and prepare and distribute the agenda. In the absence of an administrative assistant, the assignment should be rotated to each team member. The project manager may set up a template agenda so that each team meeting covers essentially the same general topics.

Meeting coordinator. Just as agenda preparation can be circulated around to each team member so can the coordination responsibility. Coordination involves reserving a time, place, and equipment.

Recording and distributing meeting minutes. Meeting minutes are an important part of project documentation. In the short term, they are the evidence of discussions of problem situations and change requests, the actions taken, and the rationale for those actions. When confusion arises in the project and clarifications are needed, the meeting minutes can settle the issue. Recording and distributing the minutes are important responsibilities and should not be treated lightly. The project manager should establish a rotation among the team members for recording and distributing the meeting minutes.


Managing Team Communications

Communicating among and between technical team members does not come naturally. Technical people often simply aren’t good communicators. In most cases, they would rather spend their time immersed in the technical details of what they are working on. However, for the team members to be truly effective, they have to openly communicate with one another. For some, that will be difficult; for others, it simply is a matter of practice. In this section, we examine the importance and role of communications in the effective team.

Managing Communications Timing, Content, and Channels

Getting information to the correct team members at the right time in the project usually determines the success or failure of the project. The project manager must manage the communication process as much as the technical process or risk failure. It isn’t possible to manage all the communication in a project; that in itself is more than a full-time job. What the project manager has to do is look at what the needs of the project team are and make sure that communication occurs at the correct time with the correct information. Let’s look at those ideas.

Timing

First, the timing of information can be critical. Problems can arise if the information comes too soon or too late.

  • If the information comes too far in advance of the action needed, it will be forgotten. It’s almost impossible to remember information given one year in advance of its use. So the project manager has to understand what the various team members need to know to carry out their assignments. Where does this information come from? Like so many other things in a project, you can find communication needs in the WBS. As you look through the tasks in the WBS, you will see that team members have to be alerted to upcoming tasks and need to be in communication with the team members whose tasks have precedence to their own. The project manager can make this happen.

  • A second problem in timing is getting the information needed to the project team member after they need it. Remember that project team members may need a few days to assimilate the information you’re passing, particularly if you’re speaking about a new technology. This requires that you, as the project manager, manage the timing carefully so that everyone has as much information as possible and that you give them sufficient time to absorb it and process it so as to get the job done.

Content

The next communications management issue you need to be concerned about is communicating the correct information. This means you must understand what the project team members need to know to be successful. If you don’t know what information the team members need, ask them. If the team members don’t know, you need to sit down with other of their colleagues and find out what sort of information needs to be passed in order to make the project run smoothly. Sometimes you will know what information is needed intuitively; other times you need to meet with the project team to consider critical information needs. Whichever the case, you need to be in charge of getting the information to your team members at the right time and with the right content.

Choosing Effective Channels

Once you know when the communication needs to occur for the project team to be successful and you have identified the basic communication content, the choice of how to get the information to the team members becomes important. As the project manager, you should stipulate how the team will communicate the information that others on the team need. You have a choice among various channels through which communication can flow. Let’s look at each of these channels.

Face-to-face, in-person meeting. A verbal, face-to-face, in-person meeting is usually the absolute best way to communicate. Not only can you get immediate feedback, you can see the person’s reaction to information in their nonverbal reactions. However, while it is often the best way to communicate, it’s not always possible.

Videoconferencing. The cost of teleconferencing has dropped dramatically, and it is now much less expensive to send yourself electronically rather than physically across the country. And don’t forget the time savings either. The software available to support these types of meetings has become far more accessible as well. Products such as NetMeeting and WebCast can be very helpful in supporting not only the face-to-face video portion, but also the presentation of slides across the Internet. However, while videoconferencing gives you a chance to see the other people, some people are “telenerds” and they don’t come off very well on TV. Just be aware that videoconferencing is not the same as in-person, face-to-face communication.

Email. Email is not, we repeat not, the communication blessing that everyone thinks it is. It does have certain advantages: It is fast, you can read email at your own speed, and we both know people who won’t respond to voice mail but will respond immediately to email. However, there are a number of problems surrounding it. Namely:

Many people get hundreds of emails a day. There’s a pretty good chance that the email you sent isn’t the single most visible email on that list, even if you put an exclamation point in front of it. Be aware the email is so ubiquitous that it loses the visibility needed to get important information to other people simply because there is so much other email “noise” out there.

Email tends to be short, much shorter that voice mail, and often people misinterpret the intended tone of the message. It happens. Be aware that the tone of the message in an email may not be the one that you would use if you had voice communication.

Sending an email doesn’t automatically make you into a good writer. It’s still difficult to send clear information to others in written form.

Email is very valuable, but you need to remember the caveats we just listed. While email is a nice invention, it still requires as much management by the project manager as any of the other channels of communication.

Note

Manage the frequency of email use; don’t overuse it. Your messages will end up being dismissed as so much spam, and that will defeat your purpose. Manage the distribution list for your emails. Because it is so easy just to add another name to the distribution list, resist it. Pretend that you only have so many email coins to spend, and spend them wisely and frugally.

Written materials. Written materials are permanent. That’s the good news. If you want to keep it, write it down. But as with all of these channels, it requires work to write things down well. It is also difficult for many people to write succinctly. Some use length to make up for good communication. Try to keep your writing short and clear. It will help the project team if this happens.

Phone. The phone is great if you actually get someone on it, but a lot of people let the phone ring and dump you into voice mail. (We are conditioned to leave a message and find ourselves surprised when a human actually answers.) The phone has the same good points and pitfalls that all of the other channels do. Its strength, as with verbal, face-to-face communication, lies in the fact that you can get immediate feedback and exchange ideas quickly. As the project manager, you will be in phone meetings often, either on a one-to-one basis or a conference call. It’s important to manage these calls as you would any of the other channels.

The effective management of communications is a critical success factor for successful project management. A complete treatment of this topic is beyond the scope of this book, but an example of this effective management is certainly in order.

Suppose part of the project involves soliciting review comments from a number of people who will be using the process being designed and implemented. You are going to distribute a document that describes the process, and you want them to return their comments and critique what you are proposing. What is the most effective way to distribute the document and get meaningful feedback from the recipients? For the sake of the example, assume that the document is 50 pages long. Your first impulse might be to send it electronically and ask recipients to respond by making their comments directly on the electronic version. If you are using MS Word, you would request that they use the Track Changes feature. Is this the most effective way? It certainly keeps everything in electronic format and makes it reasonably straightforward to incorporate the changes into the final document. But look at this request from the recipient’s point of view. We know from experience that many people do not like to make edits to an electronic document. They prefer marking up a hard-copy version. Your process does not give them that option. Should it? Probably. Now the task of incorporating their handwritten feedback is a little more involved than it would be with the electronic markup, but you have gained more and better feedback. Getting meaningful feedback is the goal, and you should use whatever means are at your disposal to ensure that happens.

What about the fact that the document is 50 pages long? Is that a barrier to meaningful feedback? We think so. If you agree, then what is the fix? Our suggestion is that you dole out the document in bite-sized pieces. Does everyone on the distribution list need to see all 50 pages? Maybe not. Maybe you would get better meaningful feedback by parceling out the document based on level of interest and involvement in the process rather than asking everyone to read and comment on the entire document.

The professional project manager is aware of the communication patterns he or she needs to manage to make it possible for the project team to have success as a unit. The areas to manage include timing, content, and channel. While it’s probable that most project managers do a lot of the communication management on an ad hoc basis, it’s important to be aware of the different areas of communication that you can manage. The skill of managing communication is just as important as any of the technical skills in project management. As a matter of fact, most surveys we’ve seen list project communication as the most important of all the areas to manage. By being aware of some of the components of project communication, you can be more effective as a project manager.

Managing Communication Beyond the Team

To be successful as a project manager, you need to communicate not only within the team but also to various stakeholders outside of the team. Your project may seem a success to you, but unless that is conveyed to the right people outside of the team, it won’t matter. The question is then, “Who are those right people?”

Managing Communications with the Sponsor

The single most important communication for the whole project is the communication you have with the project sponsor. The sponsor is the person who has agreed to give you the necessary resources to complete the project, which makes the sponsor your new best friend for this project. Without sponsor involvement in all phases of the project, you will be in dire trouble. There are a couple of good strategies for managing communications with your project sponsor, which we discuss here.

The first action to take when you are about to start a project is to go to the sponsor and ask what he or she wants to know and when he or she wants to know it. The sponsor is the one who gets to use the information you pass on and is ultimately the person who has to justify the expenditure on your project. The sponsor may want a different type of information than you are used to giving. It doesn’t matter. Sponsors pay the bills; they should get what they want in the way of communication.

Warning

Here’s a cautionary note. Don’t tell the sponsor what he or she is going to get. For example, don’t start talking about earned value and watch the sponsor’s eyes glaze over before telling you what he or she wants.

A second consideration is to make sure that the sponsor gets information regularly. Status reports should be sent to the sponsor at least once a week. It’s not a good idea to hold on to information concerning the project if it is important to the sponsor. Get the information to the sponsor as fast as possible if it will affect the project.

Now let’s look at another topic to consider as a project manager managing communication: upward communication filtering.

Upward Communication Filtering and “Good News”

Upward communication filtering is a strange form of distorting information that is found in almost any type of organizational life. It can also be called the “good news” syndrome. Unfortunately, it can kill a project as fast as any facet of bad communication management. There are two types of upward communication filtering. The first type occurs when the person who is reporting upward, say, to a sponsor, spins the information or leaves out information so that the communication looks like nothing but good news. For example, instead of saying that a company building has burned down, the person says that everything is under control, that he has called the fire department and the insurance company, and that all the people are safe. Sure, some of this information the sponsor needs to know, but a good-news filter is something that puts a positive spin on everything, often at the expense of accuracy.

If something is going badly on a project, let the sponsor know what’s going on a soon as possible. It is a good idea to talk about what you plan to do about the problem, but it never pays to filter problems from upward communication.

The second type of upward communication filtering involves withholding information. Perhaps there is a problem that you think can be resolved sometime in the future. So you withhold the current information from the sponsor, thinking that you can fix the problem. Such actions will almost always come back to bite you. Don’t withhold information just because you’re worried about a reaction. It’s better to give all the news to the sponsor than it is to hope you can fix something that is broken, because if you can’t fix the problem, it will just get worse and worse. Go ahead; tell the sponsor the truth.

Communicating with Other Stakeholders

A sponsor isn’t the only stakeholder that is outside of the operating project team. A stakeholder is anyone who has an interest in the outcome of the project. The other stakeholders may be line managers of people on the team or consumers who are going to be involved in user acceptance tests. The best way to keep them informed is to copy them with the meeting notes from the status meeting. That way all stakeholders will be informed and aware of the progress of the project. It’s simple enough to do but is often overlooked. The effective project manager makes sure all people who have an interest in the project are informed. If there is a special piece of information that will affect only one stakeholder, get the information to them immediately. Once again, you start this whole process by asking what the stakeholders want to know and when. Then you go and do it.

Ultimately, communication occurs on a project all the time. A professor once said, “You can’t not communicate.” While you can’t spend all your time managing it, it is a good idea to be aware of the communication needs of your team and stakeholders all the time. The better you are at filling the communication needs of your team members and stakeholders, the better the chance that you will manage a successful project.


Putting It All Together

In this chapter we discussed the team, its membership, the skills needed of the members, and the rules that the team must follow as it goes about the work of the project. Even though you have done your best to put the team together and have set and agreed on the operating rules, much is yet to be done. The team needs to learn how to work together by actually working together. Mistakes will be made, procedures will not always be followed as intended, and the first few team meetings will be clumsy. Learning is taking place, and it must be allowed to do so. The team is passing through a stage called norming, where it is learning to work together as teams should. It is a phase of development that must occur. Unfortunately, we can’t wait for the team to become a lean, mean machine. The work of the project must begin.

In the next chapter, we discuss monitoring and reporting project progress against the plan and the changes that we can expect as the project work is done.


Discussion Questions

  1. You are the project manager. How would you balance your efforts to get the project done with your efforts to help team members use their work on the project to develop themselves professionally?

  2. Your project managers have been able to communicate very effectively with all of your clients except one. Getting feedback from this client has always been a nagging problem. What should you do?

Start Sidebar
Case Study

Based on your resource loading from the previous chapters, are there specific people who are key to the project being done on time (see Introduction)? If so, what are you doing to mitigate the risk that they may leave, get moved to another project, and so on?

End Sidebar


Chapter 10: Monitoring and Controlling Progress

When you are drowning in numbers you need a system to separate the wheat from the chaff.

—Anthony Adams, Vice President, Campbell Soup Co.

If two lines on a graph cross, it must be important.

—Ernest F. Cooke, University of Baltimore

Control versus Risk

At this point, you have put considerable effort into building and getting approval for a project plan that describes in great detail how you will accomplish the goal of the project. The project work has begun, and you want to make sure that it is progressing as planned. To do this, you will institute a number of reports that are designed to tell exactly how well the project is doing with respect to the plan and how to correct variances from this plan. The first question to consider is the extent to which you want to maintain control through the reports you require.

Start Sidebar
Chapter Learning Objectives

After reading this chapter you will be able to:

  • Understand the reasons for implementing controls on the project

  • Track the progress of a project

  • Determine an appropriate reporting plan

  • Measure and analyze variances from the project plan

  • Understand and use cost/schedule control

  • Determine the appropriate corrective actions to restore a project to its planned schedule

  • Use Gantt charts to track progress and identify warning signs of schedule problems

  • Understand the change control process

  • Reallocate resources to maintain the project schedule

  • Report project status with graphical tools

  • Establish trend charts for early warning signals

  • Properly identify corrective measures and problem escalation strategies

End Sidebar

The project plan is a system. As such, it can get out of balance, and a get-well plan must be put in place to restore the system to equilibrium. The longer the project manager waits to put the fix in place, the longer it will take for the system to return to equilibrium. The controls are designed to discover out-of-balance situations early and put get-well plans in place quickly.

You can use a variety of reports as control tools. Most can be used in numeric and tabular form, but we suggest using graphics wherever possible. A well-done graphic will be intuitive. It will not require a lengthy explanation and certainly doesn’t require a lot of reading. Be cognizant of the fact that senior managers just don’t have a lot of time to dwell on your report. Give them what they need as succinctly as possible. Graphics are particularly effective as part of your status report to management. Senior managers generally aren’t interested in reading long reports only to find out that everything is on schedule. While they will be pleased that your project is on track, their time could have been spent on other pursuits that require their attention. If projects are not on schedule, they want to know so right away and see what corrective action you plan to take.

Purpose of Controls

Controls are actions taken as a result of reports. When implemented, controls are designed to bring actual project status back into conformance with the project plan. These reports are designed to support control activities by drawing attention to certain aspects or characteristics of the project, such as planned versus actual schedule, trends in the schedule, and actual versus planned resource use.

We typically track performance levels, costs, and time schedules. There are three reasons to use reports in your project (Weiss and Wysocki, 1991):1

To track progress. The project manager will want to use a periodic (at least biweekly, but weekly is best) reporting system that identifies the status of every activity scheduled for work since the last progress report. These reports summarize progress for the current period as well as the cumulative progress for the entire project.

To detect variance from plan. Variance reports are of particular importance to management. They are simple and intuitive, and they give managers an excellent tool by which to quickly assess the health of a project. To detect variance, the project manager needs to compare planned performance to actual performance. In larger projects (those with 50 or more activities), reports that indicate everything is on schedule and on budget are music to the ears of the project manager, but these reports can be too long and boring. Exception reports, variance reports, and graphical reports give management the information necessary for decision making in a concise format.

To take corrective action. To take corrective action, it is necessary to know where the problem is and to have that information in time to do something about it. Once there is a significant variance from plan, the next step is to determine whether corrective action is needed and then act appropriately. In complex projects, this requires examining a number of what-ifs. When problems occur in the project, delays result and the project falls behind schedule. For the project to get back on schedule, resources might have to be reallocated. In larger projects, the computer can assist in examining a number of resource reallocation alternatives and help to pick the best.

High Control—Low Risk

There is a trade-off between the amount of control (through reports and their frequency) that you can achieve and the protection you buy against out-of-control situations that may arise undetected and, hence, unfavorably affect risk. Simply exerting more controls can reduce project risk.

Low Control—High Risk

At the other extreme, having no controls in place and just assuming that the project work will get done according to the plan are foolish. Knowing that the project is sick in time to formulate and implement a get-well plan is critical to project success. Answering the question “How long am I willing to wait before I find out that there is a problem?” may provide the clue about how much control to put in place. We analyze these situations with the milestone trend charts presented later in this chapter.

[1] 1Joseph W. Weiss and Robert K. Wysocki, 5-Phase Project Management: A Practical Planning and Implementation Guide (Reading, Mass.: Addison Wesley Publishing Co., 1991).

Balancing the Control System

It is very easy to get carried away with controls and reports. The more controls that are put in place, the lower the project risk, and the less likely it will be for the project to get in trouble. As Figure 10.1 shows, however, there is a point of diminishing returns. Cost aside, there is another impact to consider. To comply with the project controls, project team members will have to spend time preparing and defending progress reports. This subtracts from the time spent doing project work.

Click To expand
Figure 10.1: The total cost of control and risk.

The project manager needs to strike a balance between the extent of the control system and the risk of unfavorable outcomes. Just as in the insurance industry, compare the cost of the policy against the dollar value of the loss that will result from the consequences. Figure 10.1 shows the relationship between risk and control. Conceptually, there is a balance point that minimizes the total cost exposure for having chosen a particular level of control.

Note

Control also implies rigidity and structure. Both tend to stifle creativity. The project manager should allow the team members to have some latitude to exercise their individuality. The cost of the control must be weighed against the value of empowering team members to be proactive (hence risk takers).


Control versus Quality

Quality will not happen by accident. It must be designed into the project management process. Chapter 2 discusses the Continuous Quality Management and Process Quality Management Models. You might want to refer to Chapter 2 to see what those management models are and what they do regarding quality.

Fortunately, control and quality are positively correlated with one another. If we do not take steps to control the product and the process, we will not enjoy the benefits that quality brings to the equation.


Progress Reporting System

Once project work is underway, you want to make sure that it proceeds according to plan. To do this, you need to establish a reporting system that keeps you informed of the many variables that describe how the project is proceeding as compared to the plan.

A reporting system has the following characteristics:

  • Provides timely, complete, and accurate status information

  • Doesn’t add so much overhead time as to be counterproductive

  • Is readily acceptable to the project team and senior management

  • Warns of pending problems in time to take action

  • Is easily understood by those who have a need to know

To establish this reporting system, you will want to look into the hundreds of reports that are standard fare in project management software packages. Once you decide what you want to track, these software tools will give you several suggestions and standard reports to meet your needs. Most project management software tools allow you to customize their standard reports to meet even the most specific needs.

Types of Project Status Reports

There are five types of project status reports:

Current period reports. These reports cover only the most recently completed period. They report progress on those activities that were open or scheduled for work during the period. Reports might highlight activities completed and variance between scheduled and actual completion dates. If any activities did not progress according to plan, the report should include a discussion of the reasons for the variance and the appropriate corrective measures that will be implemented to correct the schedule slippage.

Cumulative reports. These reports contain the history of the project from the beginning to the end of the current report period. They are more informative than the current period reports because they show trends in project progress. For example, a schedule variance might be tracked over several successive periods to show improvement. Reports can be at the activity or project level.

Exception reports. Exception reports report variances from plan. These reports are typically designed for senior management to read and interpret quickly. Reports that are produced for senior management merit special consideration. Senior managers do not have a lot of time to read reports that tell them that everything is on schedule and there are no problems serious enough to warrant their attention. In such cases, a one-page, high-level summary report that says everything is okay is usually sufficient. It might also be appropriate to include a more detailed report as an attachment for those who might wish to read more detail. The same might be true of exception reports. That is, the one-page exception report tells senior managers about variances from plan that will be of interest to them, while an attached report provides more details for the interested reader.

Stoplight reports. Stoplight reports are a variation that can be used on any of the previous report types. We believe in parsimony in all reporting. Here is a technique you might want to try. When the project is on schedule and everything seems to be moving as planned, put a green sticker on the top right of the first page of the project status report. This sticker will signal to senior managers that everything is progressing according to plan, and they need not even read the attached report. When the project has encountered a problem—schedule slippage, for example—you might put a yellow sticker on the top right of the first page of the project status report. That is a signal to upper management that the project is not moving along as scheduled but that you have a get-well plan in place. A summary of the problem and the get-well plan may appear on the first page, but they can also refer to the details in the attached report. Those details describe the problem, the corrective steps that have been put in place, and some estimate of when the situation will be rectified. Red stickers placed on the top right of the first page signal that a project is out of control. Red reports are to be avoided at all costs because they mean that the project has encountered a problem, and you don’t have a get-well plan or even a recommendation for upper management. Senior managers will obviously read these reports because they signal a major problem with the project. On a more positive note, the red condition may be beyond your control. For example, there is a major power grid failure on the East Coast and a number of companies have lost their computing systems. Your hot site is overburdened with companies looking for computing power. Your company is one of them, and the loss of computing power has put your project seriously behind in final system testing. There is little you can do to avoid such acts of nature.

Variance reports. Variance reports do exactly what their name suggests—they report differences between what was planned and what actually happened. The report has three columns:

  • The planned number

  • The actual number

  • The difference, or variance, between the two

    A variance report can be in one of two formats:

    • The first is numeric and displays a number of rows with each row giving the actual, planned, and variance calculation for those variables in which such numbers are needed. Typical variables that are tracked in a variance report are schedule and cost. For example, the rows might correspond to the activities open for work during the report period and the columns might be the planned cost to date, the actual cost to date, and the difference between the two. The impact of departures from plan is signified by larger values of this difference (the variance).

    • The second format is a graphical representation of the numeric data. It might be formatted so that the plan data is shown for each report period of the project and is denoted with a curve of one color; the actual data is shown for each report period of the project and is denoted by a curve of a different color. The variance need not be graphed at all because it is merely the difference between the two curves at some point in time. One advantage of the graphic version of the variance report is that it can show the variance trend over the report periods of the project, while the numeric report generally shows data only for the current report period.

    Typical variance reports are snapshots in time (the current period) of the status of an entity being tracked. Most variance reports do not include data points that report how the project reached that status. Project variance reports can be used to report project as well as activity variances. For the sake of the managers who will have to read these reports, we recommend that one report format be used regardless of the variable being tracked. Top management will quickly become comfortable with a reporting format that is consistent across all projects or activities within a project. It will make life a bit easier for the project manager, too.

    There are five reasons why you would want to measure duration and cost variances:

    • •Catch deviations from the curve early. The cumulative actual cost or actual duration can be plotted against the planned cumulative cost or cumulative duration. As these two curves begin to display a variance from one another, the project manager will want to put corrective measures in place to bring the two curves together. This reestablishes the agreement between the planned and actual performance. This topic is treated in detail later in the chapter in the section Cost Schedule Control.

    • •Dampen oscillation. Planned versus actual performance should display a similar pattern over time. Wild fluctuations between the two are symptomatic of a project that is not under control. Such a project will get behind schedule or overspent in one period, be corrected in the next, and go out of control in the next report period. Variance reports can give an early warning that such conditions are likely and give the project manager an opportunity to correct the anomaly before it gets serious. Smaller oscillations are easier to correct than larger oscillations.

    • Allow early corrective action. As just suggested, the project manager would prefer to be alerted to a schedule or cost problem early in the development of the problem rather than later. Early problem detection may offer more opportunities for corrective action than later detection.

    • Determine weekly schedule variance. In our experience, we found that progress on activities open for work should be reported on a weekly basis. This is a good compromise on report frequency and gives the project manager the best opportunity for corrective action plans before the situation escalates to a point where it will be difficult to recover any schedule slippages.

    • •Determine weekly effort (person hours/day) variance. The difference between the planned effort and actual effort has a direct impact on both planned cumulative cost and schedule. If the effort is less than planned, it may suggest a potential schedule slippage if the person is not able to increase his or her effort on the activity in the following week. Alternatively, if the weekly effort exceeded the plan and the progress was not proportionately the same, a cost overrun situation may be developing.

Early detection of out-of-control situations is important. The longer we have to wait to discover a problem, the longer it will take for our solution to bring the project back to a stable condition.

How and What Information to Update

As input to each of these report types, activity managers and the project manager must report the progress made on all of those activities that were open for work (in other words, those that were to have work completed on them during the report period) during the period of time covered by the status report. Recall that your planning estimates of activity duration and cost were based on little or no information. Now that you have completed some work on the activity, you should be able to provide a better estimate of the duration and cost exposure. This reflects itself in a reestimate of the work remaining to complete the activity. That update information should also be provided.

The following is a list of what should actually be reported.

Determine a set period of time and day of week. The project team will have agreed on the day of the week and time of day by which all updated information is to be submitted. A project administrator or another team member is responsible for seeing that all update information is on file by the report deadline.

Report actual work accomplished during this period. What was planned to be accomplished and what was actually accomplished are two different things. Rather than disappoint the project manager, activity managers are likely to report that the planned work was actually accomplished. Their hope is to catch up by the next report period. Project managers need to verify the accuracy of the reported data rather than simply accept it as accurate. Spot-checking on a random basis should be sufficient. If the activity was defined according to the completion criteria, as is discussed in Chapter 2, verification should not be a problem.

Record historical and reestimate remaining (in-progress work only). Two kinds of information are reported:

  • All work completed prior to the report deadline is historical information. It will allow variance reports and other tracking data to be presented and analyzed.

  • The other kind of information is futures-oriented. For the most part, this information is reestimates of duration and cost and estimates to completion (both cost and duration) of the activities still open for work.

    Report start and finish dates. These are the actual start and finish dates of activities started or completed during the report period.

    Record days of duration accomplished and remaining. How many days have been spent so far working on this activity is the first number reported. The second number is based on the reestimated duration as reflected in the time-to-completion number.

    Report resource effort (hours/day) spent and remaining (in-progress work only). Whereas the preceding numbers report calendar time, these numbers report labor time over the duration of the activity. There are two numbers. One reports labor completed over the duration accomplished. The other reports labor to be spent over the remaining duration.

    Report percent complete. Percent complete is the most common method used to record progress because it is the way we tend to think about what has been done in reference to the total job that has to be done. Percent complete isn’t the best method to report progress, though, because it is a subjective evaluation. When you ask someone “What percent complete are you on this activity?” what goes through his or her mind? The first thing he or she thinks about is most likely “What percent should I be?” followed closely by “What’s a number that we can all be happy with?”

    To calculate the percent complete for an activity, you need something quantifiable. At least three different approaches have been used to calculate the percent complete of an activity:

    • Duration

    • Resource work

    • Cost

    Each of these could result in a different percent complete! So when we say percent complete, what measure are we referring to?

    If you focus on duration as the measure of percent complete, where did the duration value come from? The only value you have is the original estimate. You know that original estimates often differ from actual performance. If you were to apply a percent complete to duration, however, the only one you have to work with is the original estimated one. Therefore, percent complete is not a good metric.

    Our advice is to never ask for and never accept percent complete as input to project progress. Always allow it to be a calculation. Many software products will let you do it either as an inputted value or as a calculated value. The calculated value that we recommend above all others is one based on the number of tasks actually completed in the activity as a proportion of the number of tasks that currently define the activity. Recall that the task list for an activity is part of the work package description. Here we count only completed tasks. Tasks that are underway but not reported as complete may not be used in this calculation.

Frequency of Gathering and Reporting Project Progress

A logical frequency for reporting project progress is once a week, usually on Friday afternoon. There are some projects, such as refurbishing a large jet airliner, where progress is recorded after each shift, three times a day. We’ve seen others that were of such a low priority or long duration that they were updated once a month. For most projects, start gathering the information about noon on Friday. Let people extrapolate to the end of the workday.

Variances

Variances are deviations from plan. Think of a variance as the difference between what was planned and what actually occurred. There are two types of variances: positive variances and negative variances.

Positive Variances

Positive variances are deviations from plan that indicate that an ahead-of-schedule situation has occurred or that an actual cost was less than a planned cost. This type of variance is good news to the project manager, who would rather hear that the project is ahead of schedule or under budget. Positive variances bring their own set of problems, which can be as serious as negative variances. Positive variances can allow for rescheduling to bring the project to completion early, under budget, or both. Resources can be reallocated from ahead-of-schedule projects to behind-schedule projects.

Not all the news is good news, though. Positive variances also can result from schedule slippage! Consider budget. Being under budget means that not all dollars were expended, which may be the direct result of not having completed work that was scheduled for completion during the report period.

Cross-Reference

We return to this situation later in the Cost Schedule Control section of this chapter.

On the other hand, if the ahead-of-schedule situation is the result of the project team’s finding a better way or a shortcut to completing work, the project manager will be pleased. This situation may be a short-lived benefit, however. Getting ahead of schedule is great, but staying ahead of schedule presents another kind of problem. To stay ahead of schedule, the project manager will have to negotiate changes to the resource schedule. Given the aggressive project portfolios in place in most companies, there is not much reason to believe that resource schedule changes can be made. In the final analysis, being ahead of schedule may be a myth.

Negative Variances

Negative variances are deviations from plan that indicate that a behind-schedule situation has occurred or that an actual cost was greater than a planned cost.

Being behind schedule or over budget is not what the project manager or his reporting manager wants to hear. Negative variances, just like positive variances, are not necessarily bad news. For example, you might have overspent because you accomplished more work during the report period than was planned. But in overspending during this period, you could have accomplished the work at less cost than was originally planned. You can’t tell by looking at the variance report.

Cross-Reference

More details are forthcoming on this topic in the Cost Schedule Control section later in this chapter.

In most cases, negative time variances affect project completion only if they are associated with critical path activities or if the schedule slippage on noncritical path activities exceeds the activity’s total float. Variances use up the float time for that activity; more serious ones will cause a change in the critical path.

Negative cost variances can result from uncontrollable factors such as cost increases from suppliers or unexpected equipment malfunctions. Some negative variances can result from inefficiencies or error. We discuss a problem escalation strategy to resolve such situations later in this chapter.


Applying Graphical Reporting Tools

As mentioned earlier in the chapter, senior managers may have only a few minutes of uninterrupted time to digest your report. Respect that time. They won’t be able to fully read and understand your report if they have to read 15 pages before they get any useful information. Having to read several pages only to find out that the project is on schedule is frustrating and a waste of valuable time.

Gantt Charts

As we discussed in Chapters 4 and 6, a Gantt chart is one of the most convenient, most used, and easy-to-grasp depictions of project activities that we have encountered in our practice. The chart is formatted as a two-dimensional representation of the project schedule with activities shown in the rows and time shown across the horizontal axis. It can be used during planning, for resource scheduling, and for status reporting. The only downside to using Gantt charts is that they do not contain dependency relationships. Some project management software tools have an option to display these dependencies, but the result is a graphical report that is so cluttered with lines representing the dependencies that the report is next to useless. In some cases, dependencies can be guessed at from the Gantt chart, but in most cases, they are lost.

Figure 10.2 shows a representation of the Cost Containment Project as a Gantt chart using the format that we prefer. The format shown is from Microsoft Project 2000, but it is typical of the format used in most project management software packages.

Click To expand
Figure 10.2: Gantt chart project status report.

Milestone Trend Charts

Milestones are significant events in the life of the project that you wish to track. These significant events are zero-duration activities and merely represent that a certain condition exists in the project. For example, a milestone event might be that the approval of several different component designs has been given. This event consumes no time in the project schedule. It simply reflects the fact that those approvals have all been granted. The completion of this milestone event may be the predecessor of several build-type activities in the project plan. Milestone events are planned into the project in the same way that activities are planned into the project. They typically have FS relationships with the activities that are their predecessors and their successors.

Let’s look at a milestone trend chart for a hypothetical project (see Figure 10.3). The trend chart plots the difference between the planned and estimated date of a project milestone at each project report period. In the original project plan, the milestone is planned to occur at the ninth month of the project. That is the last project month on this milestone chart. The horizontal lines represent one, two, and three standard deviations above or below the forecasted milestone date. Any activity in the project has an expected completion date that is approximately normally distributed. The mean and variance of its completion date are a function of the longest path to the activity from the report date. In this example, the units of measure are one month. For this project, the first project report (at month 1) shows that the new forecasted milestone date will be one week later than planned. At the second project report date (month two of the project), the milestone date is forecasted on target. The next three project reports indicate a slippage to two weeks late, then three weeks late, then four weeks late, and finally six weeks late (at month 6 of the project). In other words, the milestone is forecasted to occur six weeks late, and there are only three more project months in which to recover the slippage. Obviously, the project is in trouble. The project appears to be drifting out of control, and in fact, it is. Some remedial action is required of the project manager.

Click To expand
Figure 10.3: A run up or down of four or more successive data points.

Certain patterns signal an out-of-control situation. These are given in Figures 10.3 through 10.6 and are described here:

Successive slippages. Figure 10.3 depicts a project that is drifting out of control. Each report period shows additional slippage since the last report period. Four such successive occurrences, however minor they may seem, require special corrective action on the part of the project manager.

Radical change. Figure 10.4, while it does show the milestone to be ahead of schedule, reports a radical change between report periods. Activity duration may have been grossly overestimated. There may be a data error. In any case, the situation requires further investigation.

Click To expand
Figure 10.4: A change of more than three standard deviations.

Successive runs. Figure 10.5 signals a project that may have encountered a permanent schedule shift. In the example, the milestone date seems to be varying around one month ahead of schedule. Barring any radical shifts and the availability of resources over the next two months, the milestone will probably come in one month early. Remember that you have negotiated for a resource schedule into these two months, and now you will be trying to renegotiate an accelerated schedule.

Click To expand
Figure 10.5: Seven or more successive data points above or below the planned milestone date.

Schedule shift. Figure 10.6 depicts a major shift in the milestone schedule. The cause must be isolated and the appropriate corrective measures taken. One possibility is the discovery that a downstream activity will not be required. Perhaps the project manager can buy a deliverable rather than build it and remove the associated build activities from the project plan.

Click To expand
Figure 10.6: Two successive data points outside three standard deviations from the planned milestone date.

Cost Schedule Control

Cost schedule control is used to measure project performance and, by tradition, uses the dollar value of work as the metric. As an alternative, resource person hours/day can be used in cases where the project manager does not directly manage the project budget. Actual work performed is compared against planned and budgeted work expressed in these equivalents. These metrics are used to determine schedule and cost variances for both the current period and cumulative to date. Cost and resource person hours/day are not good objective indicators with which to measure performance or progress. While this is true, there is no other good objective indicator. Given this, we are left with dollars or person hours/day, which we are at least familiar working with in other contexts. Either one by itself does not tell the whole story. We need to relate them to one another.

One drawback that these metrics have is that they report history. Although they can be used to make extrapolated predictions for the future, they primarily provide a measure of the general health of the project, which the project manager can correct as needed to restore the project to good health.

Figure 10.7 shows an S curve, which represents the baseline progress curve for the original project plan. It can be used as a reference point. You can compare your actual progress to date against the curve and determine how well the project is doing. Again, progress can be expressed as either dollars or person hours/day.

Click To expand
Figure 10.7: The standard S curve.

By adding the actual progress curve to the baseline curve, you can now see the current status versus the planned status. Figure 10.8 shows the actual progress curve to be below the planned curve. If this represented dollars, we might be tempted to believe the project is running under budget. Is that really true?

Click To expand
Figure 10.8: Baseline versus actual cost curve illustrating cost variance.

Projects rarely run significantly under budget. A more common reason for the actual curve to be below the baseline is that the activities that should have been done have not been, and thus the dollars or person hours/day that were planned to be expended have not been. The possible schedule variance is highlighted in Figure 10.9.

Click To expand
Figure 10.9: Baseline versus actual cost illustrating schedule variance.

To determine whether there has really been a progress schedule variance, you need some additional information. Cost schedule control (CSC) comprises three basic measurements: budgeted cost of work scheduled, budgeted cost of work performed, and actual cost of work performed. These measurements result in two variance values: schedule variance and cost variance. Figure 10.10 is a graphical representation of the three measurements.

Click To expand
Figure 10.10: Cost/performance indicators.

The figure shows a single activity that has a five-day duration and a budget of $500. The budget is prorated over the five days at an average daily value of $100. The left panel of Figure 10.10 shows an initial (baseline) schedule with the activity starting on the first day of the week (Monday) and finishing at the end of the week (Friday). The budgeted $500 value of the work is planned to be accomplished all within that week. This is the planned value (PV). The center panel shows the actual work that was done. Note that the schedule slipped and work did not begin until the third day of the week. Using an average daily budget of $100, we see that we were able to complete only $300 of the scheduled work. This is the earned value (EV). The rightmost panel shows the actual schedule as in the center panel, but now we see the actual dollars that were spent to accomplish the three days’ work. This $400 is the actual cost (AC).

The PV, EV, and AC are used to compute and track two variances. The first is schedule variance (SV). SV is the difference between the EV and PV, which is –$200 (EV – PV) for this example. That is, the SV is the schedule difference between what was done and what was planned to be done, expressed in dollar or person hours/day equivalents. The second is cost variance (CV). CV is the difference between the EV and the AC, which is $100 in this example. That is, we overspent by $100 (AC – EV) the cost of the work completed.

Start Sidebar
Cost/Schedule Control Terminology

For those who are familiar with the older cost/schedule control terminology, we have used the new terminology as defined in PMBOK 2000. The old terminology compares to the new terminology as follows:

  • ACWP is the actual cost (AC).

  • BCWP is the earned value (EV).

  • BCWS is the planned value (PV).

End Sidebar

Management might react positively to the news shown in Figure 10.8, but they might also be misled by such a conclusion. The full story is told by comparing both budget variance and schedule variance, shown in Figure 10.11.

Click To expand
Figure 10.11: The full story.

To correctly interpret the data shown in Figure 10.9, you need to add the EV data that was given in Figure 10.10 to produce Figure 10.11. Comparing the EV curve with the PV curve, you see that you have underspent because all of the work that was scheduled has not been completed. Comparing the EV curve to the AC curve also indicates that you overspent for the work that was done. Clearly, management would have been misled by Figure 10.8 had they ignored the data in Figure 10.10. Either one by itself may be telling a half-truth.

In addition to measuring and reporting history, CSC can be used to predict the future status of a project. Take a look at Figure 10.12. By cutting the PV curve at the height from the horizontal axis, which has been achieved by the EV, and then pasting this curve onto the end of the EV curve, you can extrapolate the completion of the project. Note that this is based on using the original estimates for the remaining work to be completed. If you continue at the rate at which you have been progressing, you will finish beyond the planned completion date. Doing the same thing for the AC shows that you will finish over budget. This is the simplest method of attempting to “estimate to completion,” but it clearly illustrates that a significant change needs to occur in the way this project is running.

Click To expand
Figure 10.12: PV, EV, and AC curves.

The three basic indicators yield one additional level of analysis for us. Schedule performance index (SPI) and cost performance index (CPI) are a further refinement. They are computed as follows:

SPI = EV/PV
CPI = EV/AC

Schedule performance index. The schedule performance index is a measure of how close the project is to performing work as it was actually scheduled. If we are ahead of schedule, EV will be greater than PV, and therefore the SPI will be greater than 1. Obviously, this is desirable. On the other hand, an SPI below 1 would indicate that the work performed was less than the work scheduled. Not a good thing.

Cost performance index. The cost performance index is a measure of how close the project is to spending on the work performed to what was planned to have been spent. If you are spending less on the work performed than was budgeted, the CPI will be greater than 1. If not, and you are spending more than was budgeted for the work performed, then the CPI will be less than 1.

Some managers prefer this type of analysis because it is intuitive and quite simple to equate each index to a baseline of 1. Any value less than 1 is undesirable; any value over 1 is good. These indices are displayed graphically as trends compared against the baseline value of 1.

Using the WBS to Report Project Status

Because the Work Breakdown Structure (WBS) shows the hierarchical structure of the work to be done, it can be used for status reporting, too. In its simplest form, each activity box can be shaded to reflect completion percentages. As lower-level activities are completed, the summary activities above them can be shaded to represent percent complete data. Senior managers will appreciate knowing that major parts of the project are complete. Unfortunately, the WBS does not contain scheduling or sequencing information. To the extent that this adds to the value of the report, narrative data or brief tabular data might be added to the report. Figure 10.13 shows an example status report using the WBS.

Click To expand
Figure 10.13: Status reporting with the WBS.

Although this report is rather intuitive, it does not contain much detail. It would have to be accompanied by an explanatory note with schedule and cost detail.


Deciding on Report Level of Detail

There are always questions about the level of detail and frequency of reporting in project status reports. Our feeling is that the more you report, the more likely it is that someone will object or find some reason to micromanage your project. Let’s examine this issue in more detail by considering the reporting requirements at the activity manager, project manager, and senior manager levels.

Activity Manager

The activity manager will want the most detailed and granular information available. After all, the activity manager is directly responsible for getting the work done. Because he or she manages the resources that are used to complete project work, he or she will want to know what happened, what was scheduled to happen, who did what (or didn’t do what), why it happened as it did, what problems have arisen, what solutions are within reach, and what changes need to be made. Reports that reflect very detailed information are of use to the activity manager and the project manager but, because of their very detail, are of little value to anyone outside of the project team.

Project Manager

The project manager is concerned with the status information of all activities open for work during the report period. Activity reports are for the use of the project manager. He or she may decide to pass them forward to senior management in his or her report. The activity-level reports can follow a format similar to project-level reports.

Reports for the project manager present data at the activity level and show effects on the project schedule. If project management software is used, the posted data from the activity managers is used to update the project schedule and produce reports on overall project status. Any slippage at the activity level ripples through the successor activities, triggers a new activity schedule, and recomputes project completion dates. These reports display all scheduling information, including float and resource schedule data. In effect, they become working documents for the project manager for schedule adjustments and problem resolution. Because these reports are at a very detailed level, they are not appropriate for distribution beyond the project team. In many cases, they may be for the project manager’s eyes only.

Senior Management

We recommend using a graphical exception report structure to report project status to senior management. For many projects, reports at the activity level will be appropriate. For large projects, either milestone-level or summary task-level reports are more effective. Senior managers have only a few minutes to review any single project report. Keeping a report to a single page is a good strategy. The best report format, in our experience, is the Gantt chart. These charts require little explanation. Activities should be listed in the order of scheduled start date, a line designating the report date should be given, and all percent completed displayed.

Tip

Tip If the project is sick, attach a one-page get-well plan to your report. This plan usually is in the form of a narrative discussion of the problem, alternative solutions, recommended action, and any other details relevant to the issue at hand.


Managing Project Status Meetings

To keep close track of progress on the project, the project manager needs to have information from his or her team on a timely basis. This information will be given during a project status meeting. At a minimum, you need to have a status meeting at least once a week. On some of the major projects on which we’ve worked, daily status meetings were the norm for the first few weeks, and then as the need for daily information wasn’t as critical, we switched to twice a week and finally to weekly status.

Who Should Attend?

To use the status meetings correctly and efficiently, it’s important to figure out who should be in attendance. This information should be a part of your communication plan.

When choosing who should attend, keep a couple points in mind:

  • At first your status team may have a tendency to include people who are needed only in the planning phase. If they don’t have a need to know information, don’t make them come to a meeting and sit there without a good reason. You are going to put out meeting minutes anyway, so those people that aren’t needed at the actual meeting will get the minutes in any case.

  • There will be times in a status meeting when two people will get into a discussion where the other people in the meeting aren’t needed. If this happens, ask them to do a sidebar meeting so that your own status meeting can go on. A sidebar meeting is one in which a limited number of people need to participate, and these types of meetings can be done more effectively away from your status meeting. Having everyone in the room listen to these sidebar topics isn’t useful.

    Ask the people who are going to the sidebar meeting to let you know what happens in the meeting, particularly if what they talk about impacts the project. If possible, get a meeting summary from the people, even if it’s only a sentence or two long. Get this circulated to the rest of the team with your minutes so that everyone on the team is kept up-to-date. Typical attendees at sidebar meetings will be the people who must have the problem solved and those who should be able to solve it, or at least those who can escalate it to those who can solve it.

When Are They Held?

Usually, status meetings are held toward the end of the week. Whatever the day, make sure it’s the same one time after time. People get used to preparing information for a status meeting if they know exactly when the meeting will occur.

What Is Their Purpose?

The reason for a status meeting is to get information to the whole team. It may be that on large projects the participants in the status meeting are actually representatives of their department. You can’t have all the people on a 250-person project team come into a meeting once a week, so make sure that someone is there to represent the rest of the people in their section. The purpose of the meeting is to encourage free flow of information, and that means being sure that the people who need to have information to do their jobs get the information at the status meeting. Remember once again that you are going to send out minutes of the meeting, so that will take care of the people who aren’t in attendance.

Tip

Tip Project size may be the determining factor, but in general, we prefer a one-hour limit. This is the maximum, and an entire hour should not be needed at every project status meeting. Good judgment is needed here. Do not waste people’s time.

What Is Their Format?

While the format of the status review meetings should be flexible, as project needs dictate, certain items are part of every status meeting. We recommend that you proceed in a top-down fashion:

  1. The project champion reports any changes that may have a bearing on the future of the project.

  2. The customer reports any changes that may have a bearing on the future of the project.

  3. The project manager reports on the overall health of the project and the impact of earlier problems, changes, and corrective actions as they impact at the project level.

  4. Activity managers report on the health of activities open or scheduled open for work since the last status meeting.

  5. Activity managers of future activities report on any changes since the last meeting that might impact project status.

  6. The project manager reviews the status of open problems from the last status meeting.

  7. Attendees identify new problems and assign responsibility for their resolution (the only discussion allowed here is for clarification purposes).

  8. The project champion, customer, or project manager, as appropriate, offers closing comments.

  9. The project manager announces the time and place of the next meeting and adjourns the meeting.

Minutes are part of the formal project documentation and are taken at each meeting, circulated for comment, revised as appropriate, distributed, and filed in the project notebook (electronic, we hope). Because there is little discussion, the minutes contain any handouts from the meeting and list the items assigned for the next meeting. The minutes should also contain the list of attendees, a summary of comments made, and assigned responsibilities.

A project administrative support person should be present at the project status review meetings to take minutes and monitor handouts. The responsibility might also be passed around to the project team members. In some organizations, the same person is responsible for distributing the meeting agenda and materials ahead of time for review. This advance distribution is especially important if decisions will be made during the meeting. People are very uncomfortable if they are seeing important information for the first time, are expected to read and understand it, and then are expected to make a decision, all at the same time.


Managing Change

It is difficult for anyone, regardless of his or her skills at prediction and forecasting, to completely and accurately define the needs for a product or service that will be implemented 6, 12, or 18 months in the future. Competition, customer reactions, technology changes, a host of supplier-related situations, and many other factors could render a killer application obsolete before it can be implemented. The most frequent situation starts something like this: “Oh, I forgot to tell you that we will also need...” or “We have to go to market no later than the third quarter instead of the fourth quarter.” How often have you heard sentences that start something like those examples? Let’s face it, change is a way of life in project management. We might as well confront it and be prepared to act accordingly.

Because change is constant, a good project management methodology has a change management process in place. In effect, the change management process has you plan the project again. Think of it as a mini-JPP session.

Two documents are part of every good change management process: project change request and project impact statement.

Project change request. The first principle to learn is that every change is a significant change. Adopt that maxim and you will seldom go wrong. What that means is that every change requested by the customer must be documented in a project change request. That document might be as simple as a memo but might also follow a format provided by the project team. In any case, it is the start of another round of establishing Conditions of Satisfaction. Only when the request is clearly understood can the project team evaluate the impact of the change and determine whether the change can be accommodated.

Project impact statement. The response to a change request is a document called a project impact statement. It is a response that identifies the alternative courses of action that the project manager is willing to consider. The requestor is then charged with choosing the best alternative. The project impact statement describes the feasible alternatives that the project manager was able to identify, the positive and negative aspects of each, and perhaps a recommendation as to which alternative might be best. The final decision rests with the requestor.

Six possible outcomes can result from a change request:

It can be accommodated within the project resources and time lines. This is the simplest of situations for the project manager to handle. After considering the impact of the change on the project schedule, the project manager decides that the change can be accommodated without any harmful effect on the schedule and resources.

It can be accommodated but will require an extension of the deliverable schedule. The only impact that the change will have is to lengthen the deliverable schedule. No additional resources will be needed to accommodate the change request.

It can be accommodated within the current deliverable schedule, but additional resources will be needed. To accommodate this change request, the project manager will need additional resources, but otherwise the current and revised schedule can be met.

It can be accommodated, but additional resources and an extension of the deliverable schedule will be required. This change request will require additional resources and a lengthened deliverable schedule.

It can be accommodated with a multiple release strategy and prioritizing of the deliverables across the release dates. This situation comes up more often than you might expect. To accommodate the change request, the project plan will have to be significantly revised, but there is an alternative. For example, suppose that the original request was for a list of 10 features, and they are in the current plan. The change request asks for an additional two features. The project manager asks the customer to prioritize all 12 features. He or she will give the customer eight of them earlier than the delivery date for the original 10 features and will deliver the remaining four features later than the delivery date for the original 10. In other words, the project manager will give the customer some of what is requested earlier than requested and the balance later than requested. We have seen several cases where this compromise has worked quite well.

It cannot be accommodated without a significant change to the project. These change requests are significant. They are so significant, in fact, as to render the current project plan obsolete. There are two alternatives here. The first is to deny the change request, complete the project as planned, and handle the request as another project. The other is to call a stop to the current project, replan the project to accommodate the change, and launch a new project.

An integral part of the change control process is the documentation. First, we strongly suggest that every change be treated as a major change until proven otherwise. To do otherwise is to court disaster. That means that every change request follows the same procedure. Figure 10.14 is an example of the steps in a typical change process. The process is initiated, and the change request is submitted by the customer, who uses a form like the one shown in Figure 10.15. This form is forwarded to the manager or managers charged with reviewing such requests. They may either accept the change as submitted or return it to the customer for rework and resubmission. Once the change request has been accepted, it is forwarded to the project manager, who will perform an impact study.

Click To expand
Figure 10.14: A typical change control process.
Click To expand
Figure 10.15: Change control form.

The impact study involves looking at the project plan, assessing how the change request impacts the plan, and issuing the impact study, which is forwarded to the management group for final disposition. They may return it to the project manager for further analysis and recommendations or reject it and notify the customer of their action. The project manager reworks the impact study and returns it to the management group for final disposition. If they approve the change, the project manager will implement it into the project plan.


Managing Problem Escalation

Something has happened that put the project plan at risk. Late shipments from suppliers, equipment malfunction, sickness, random acts of nature, resignations, priority changes, errors, and a host of other factors give rise to problems that can affect deliverables, deliverable schedules, and resource schedules. The project manager owns the problem and must find a solution.

This situation is very different for the project manager than the case of a change request. When a change request has been made, the project manager has some leverage with the customer. The customer wants something and might be willing to negotiate to an acceptable resolution. That is not the case when a problem has arisen on the project team. The project manager does not have any leverage and is in a much more difficult position.

When the unplanned happens, the project manager needs to determine the extent of the problem and take the appropriate corrective measures. Minor variations from plan will occur and may not require corrective measures. There are degrees of corrective measures available to the project manager: In trying to resolve the problem the project manager will begin at the top of the following list and work down the list, examining each choice until one is found that solves the problem.

There are three levels of escalation strategy: project manager–based, resource manager–based, and customer-based.

Project manager–based strategies. If the problem occurs within a noncritical path activity, it can be resolved by using the free float. One example is to reschedule the activity later in its ES to LF window or extend the duration to use some of the free float. Note that this strategy does not affect any other activities in the project. By using total float, you impact the resource schedule for all activities that have this one as a predecessor. Another approach is to continue the schedule compression techniques employed in defining the original project plan. This strategy can impact resource schedules just as in the prior case. The last option open to the project manager is to consider the resource pool under his or her control. Are there resources that can be reassigned from noncritical path activities to assist with the problem activity?

Resource manager–based strategies. Once the project manager has exhausted all the options under his or her control, it is time to turn to the resource managers for additional help. This help may take the form of additional resources or rescheduling of already committed resources. Expect to make some trade-off here. For example, you might be accommodated now, but at the sacrifice of later activities in the project. At least you have bought some time to resolve the downstream problem that will be created by solving this upstream problem. If the project manager has other projects underway, some trades across projects may solve the problem.

Customer-based strategies. When all else fails, the project manager will have to approach the customer. The first strategy would be to consider any multiple release strategies. Delivering some functionality ahead of schedule and the balance later than planned may be a good starting point. The last resort is to ask for an extension of time. This is not as unpleasant as it may seem because the customer’s schedule may have also slipped and the customer may be relieved to have a delay in your deliverable schedule, too.

The Escalation Strategy Hierarchy

Our problem escalation strategy is based on the premise that the project manager will try to solve the problem with the resources he or she controls. Failing to do that, the project manager will appeal to resource managers. As a last resort, the project manager will appeal to the customer.

One thing to note here that is very different from the change request situation discussed previously is the leverage to negotiate. As mentioned, the project manager has leverage when the customer has requested a change but has no leverage when he or she has a project problem to solve. The customer has nothing to gain and, therefore, is less likely to be cooperative. In most cases, the problem can be reduced to how to recover lost time. There are six outcomes to this problem situation.

No action required (schedule slack will correct the problem). In this case, the slippage involved a noncritical path activity, and it will self-correct.

Examine FS dependencies for schedule compression opportunities. Recall that you originally compressed the schedule to accommodate the requested project completion date by changing FS dependencies to SS dependencies. The project manager will use that same strategy again. The project schedule will have changed several times since work began, and there may be several new opportunities to accomplish further compression and solve the current problem.

Reassign resources from noncritical path activities to correct the slippage. Up to a point, the project manager controls the resources assigned to this project and others that he or she manages. The project manager may be able to reassign resources from noncritical path activities to the activities that have slipped. These noncritical path activities may be in the same project in which the slippage occurred, or they may be in another project managed by the same project manager.

Negotiate additional resources. Having exhausted all of the resources he or she controls, the project manager needs to turn to the resource managers as the next strategy. To recoup the lost time, the project manager needs additional resources. They may come in the form of added staff or dollars to acquire contract help.

Negotiate multiple release strategies. These last two strategies involve the customer. Just as in the case of a change request, the project manager can use multiple release strategies here to advantage. An example will illustrate the strategy. The project manager shares the problem with the customer and then asks for the customer to prioritize the features requested in the project plan. The project manager then offers to provide the highest-priority features ahead of their scheduled delivery date and the remaining priorities later than the scheduled delivery date. In other words, the project manager asks for an extended delivery schedule, but by giving the customer something better than the original bargain, namely something ahead of schedule.

Request schedule extension from the customer. This is the final alternative. Although similar to the multiple release strategy, it offers the customer nothing in trade. The slippage is such that the only resolution is to ask for a time extension.

The project manager tries to solve the problem by starting at the top of the list and working down until a solution is found. By using this approach, the project manager will first try to solve the problem with resources he or she controls, then with resources the resource managers control, and finally with resources and constraints the customer controls.

Problem Management Meetings

Problem management meetings provide an oversight function to identify, monitor, and resolve problems that arise during the life of a project. Every project has problems. No matter how well planned or managed, there will always be problems. Many problems arise just as an accident of nature. For example, one of your key staff members has resigned just as she was to begin working on a critical path activity. Her skills are in high demand, and she will be difficult to replace. Each day that her position remains vacant is another day’s delay in the project. What will you do? Nevertheless, the project manager must be ready to take action in such cases. The problem management meeting is one vehicle for addressing all problems that need to be escalated above the individual for definition, solution identification, and resolution.

This is an important function in the management of projects, especially large projects. Problems are often identified in the project status meeting and referred to the appropriate persons for resolution. A group is assembled to work on the problem. Progress reports are presented and discussed at a problem management meeting. Problem management meetings usually begin with a review of the status of the activity that gave rise to the problem, followed by a statement of the problem and a discussion to make sure everyone has the same understanding of the problem. At that point the meeting should move into the problem-solving process that was discussed in detail in Chapter 9.


Putting It All Together

Monitoring and controlling the progress of a project won’t happen just because the team is committed to the project. There must be an organized oversight process put in place and understood by the client, senior management, the project manager, and all the team members. As we have seen, there are reports for all of these audiences. We have also seen that the extent to which progress reports are necessary and the amount of effort to generate them requires a balance. Requiring too much reporting takes away from the available time to work on the project. Requiring too little reporting puts the project manager at risk of not being able to complete the project within time and cost constraints. We have also seen that there are both numeric and graphic reporting formats. Some managers prefer numeric data, and some prefer graphic data. The reporting system you choose must meet the needs of both groups.


Discussion Questions

  1. A number of your clients seem to be abusing the change request process. You have seen an increase in the number of frivolous requests. These, of course, must be researched and resolved, and that takes away from the time that your team members can do actual project work. From a process point of view what might you do? Be specific.

  2. What are the advantages and disadvantages of checking up on the accuracy of status reports filed by your team members?

Start Sidebar
Case Study

The project work is soon to begin, and you are conferring with your team members to decide on reporting requirements and frequency. Take into account the stakeholders in this project and what their needs might be. Refer back to the case study background in the Introduction for the input you will need to answer the following questions:

  • Who are the people that you need to hear from to know if they are satisfied with your progress on this project?

  • How will you get information from your team and get it to the other stakeholders for this project?

  • You have already determined one major constraint desired by the management of Jack Neift. How will that affect your monitoring and control of this project?

End Sidebar


Chapter 11: Closing Out the Projects

We judge ourselves by what we feel capable of doing, while others judge us by what we have already done.

—Henry Wadsworth Longfellow, American poet

We cannot afford to forget any experiences, even the most painful.

—Dag Hammerskjold, Secretary General of the United Nations

Steps in Closing a Project

Closing the project is routine once we have the customer’s approval of the deliverables. There are six steps to closing the project:

  1. Getting client acceptance of deliverables

  2. Ensuring that all deliverables are installed

  3. Ensuring that the documentation is in place

  4. Getting client sign-off on final report

  5. Conducting the post-implementation audit

  6. Celebrating the success

Start Sidebar
Chapter Learning Objectives

After reading this chapter you will be able to:

  • Understand the steps needed to effectively close a project

  • Develop a closing strategy

  • Identify the components of project documentation

  • Conduct a post-implementation audit

  • Explain the significance of each post-implementation audit question

End Sidebar

Let’s take a look at each of these steps in more detail.


Getting Client Acceptance

The client decides when the project is done. It is the job of the project manager to demonstrate that the deliverables (whether product or service) meet client specifications. This acceptance can be very informal and ceremonial, or it can be very formal, involving extensive acceptance testing against the client’s performance specifications.

Ceremonial Acceptance

Ceremonial acceptance is an informal acceptance by the customer. It does not have an accompanying sign-off of completion or acceptance. It simply happens. Two situations fall under the heading of ceremonial acceptance:

  • The first involves deadline dates at which the client must accept the project as complete, whether or not it meets specification. For example, if the project was to plan and conduct a conference, the conference will happen whether or not the project work has been satisfactorily completed.

  • The second involves a project deliverable requiring little or no checking to see if specifications have been met—for example, planning and taking a vacation.

Formal Acceptance

Formal acceptance occurs in those cases in which the client has written an acceptance procedure. In many cases, especially computer applications development projects, writing an acceptance procedure may be a joint effort by the customer and appropriate members of the project team; it typically is done very early in the life of the project. This acceptance procedure requires that the project team demonstrate compliance with every feature in the client’s performance specification. A checklist is used and requires a feature-by-feature sign-off based on performance tests. These tests are conducted jointly and administered by the client and appropriate members of the project team.

Note

The checklist is written in such a fashion that compliance is either demonstrated by the test or it is not demonstrated by the test. It must not be written in such a way that interpretation is needed to determine whether compliance has been demonstrated.


Installing Project Deliverables

The second step of closing a project is to go live with the deliverables. This commonly occurs in computer systems work. The installation can involve phases, cutovers, or some other rollout strategy. In other cases, it involves nothing more than flipping a switch. In either case, some event or activity turns things over to the customer. This installation triggers the beginning of a number of close-out activities that mostly relate to documentation and report preparation.


Documenting the Project

Documentation always seems to be the most difficult part of the project to complete. There is little glamour and no attaboys in doing documentation. That does not diminish its importance, however. There are at least five reasons why we need to do documentation:

Reference for future changes in deliverables. Even though the project work is complete, there will be further changes that warrant follow-up projects. By using the deliverables, the customer will identify improvement opportunities, features to be added, and functions to be modified. The documentation of the project just completed is the foundation for the follow-up projects.

Historical record for estimating duration and cost on future projects, activities, and tasks. Completed projects are a terrific source of information for future projects, but only if data and other documentation from them is archived so that it can be retrieved and used. Estimated and actual duration and cost for each activity on completed projects are particularly valuable for estimating these variables on future projects.

Training resource for new project managers. History is a great teacher, and nowhere is that more significant than on completed projects. Such items as how the WBS architecture was determined, how change requests were analyzed and decisions reached, problem identification, analysis and resolution situations, and a variety of other experiences are invaluable lessons for the newly appointed project manager.

Input for further training and development of the project team. As a reference, project documentation can help the project team deal with situations that arise in the current project. How a similar problem or change request was handled in the past is an excellent example.

Input for performance evaluation by the functional managers of the project team members. In many organizations, project documentation can be used as input to the performance evaluations of the project manager and team members.

Warning

Care must be exercised in the use of such information, however. There will be cases where a project was doomed to fail even though the team members’ performance may have been exemplary. The reverse is also likely. The project was destined to be a success even though the team members’ performance may have been less than expected.

Given all that documentation can do for you, to be most effective and useful, the documentation for a given project should include the following parts:

  • Project Overview Statement

  • Project proposal and backup data

  • Original and revised project schedules

  • Minutes of all project team meetings

  • Copies of all status reports

  • Design documents

  • Copies of all change notices

  • Copies of all written communications

  • Outstanding issues reports

  • Final report

  • Sample deliverables (if appropriate)

  • Client acceptance documents

  • Post-implementation audit report

This list is all-encompassing. For a given project, the project manager has to determine what documentation is appropriate. Always refer back to value-added considerations. If the document has value, and many will have good value for future projects, then include it in the documentation. Note also that the list contains very little that does not arise naturally in the execution of the project. All that is needed is to appoint someone to care for and feed the project notebook. This job involves collecting the documents at the time of their creation and ensuring that they are in a retrievable form (electronic is a must).


Post-Implementation Audit

The post-implementation audit is an evaluation of the project’s goals and activity achievement as measured against the project plan, budget, time deadlines, quality of deliverables, specifications, and client satisfaction. The log of the project activities serves as baseline data for this audit. There are six important questions to be answered:

  1. Was the project goal achieved?

    1. Does it do what the project team said it would do?

    2. Does it do what the client said it would do?

    The project was justified based on a goal to be achieved. It either was or it wasn’t, and an answer to that question must be provided in the audit. The question can be asked and answered from two different perspectives. The provider may have suggested a solution for which certain results were promised. Did that happen? On the other hand, the requestor may have promised that if the provider would only provide, say, a new or improved system, certain results would occur. Did that happen?

  2. Was the project work done on time, within budget, and according to specification?

    Recall from the scope triangle that is discussed in Chapter 1 that the constraints on the project were time, cost, and the customer’s specification, as well as resource availability and quality. Here we are concerned with whether the specification was met within the budgeted time and cost constraints.

  3. Was the client satisfied with the project results?

    It is possible that the answers to the first two questions are yes, while the answer to this question is no. How can that happen? Simple; the Conditions of Satisfaction changed, but no one was aware that they had. The project manager did not check with the customer to see if the needs had changed; the customer did not inform the project manager that such changes had occurred.

    Note

    We remind you again that it is absolutely essential that the Conditions of Satisfaction be reviewed at every major event in the life of the project, including changes in the team membership, especially a new project manager, and changes in the sponsor. Reorganization of the company, acquisitions, and mergers are other reasons to recheck the Conditions of Satisfaction.

  4. Was business value realized? (Check success criteria.)

    The success criteria were the basis on which the business case for the project was built and were the primary reason why the project was approved. Did we realize that promised value? When the success criteria measure improvement in profit or market share or other bottom-line parameters, we may not be able to answer this question until some time after the project is closed.

  5. What lessons were learned about your project management methodology?

    Companies that have or are developing a project management methodology will want to use completed projects to assess how well the methodology is working. Different parts of the methodology may work well for certain types of projects or in certain situations, and these should be noted in the audit. These lessons will be valuable in tweaking the methodology or simply noting how to apply the methodology when a given situation arises. This part of the audit might also consider how well the team used the methodology, which is related to, yet different from, how well the methodology worked.

  6. What worked? What didn’t?

    The answers to these questions are helpful hints and suggestions for future project managers and teams. The experiences of past project teams are real “diamonds in the rough”; you will want to pass them on to future teams.

The post-implementation audit is seldom done. This is unfortunate because it does have great value for all stakeholders. Some of the reasons for skipping the audit include these:

Managers don’t want to know. They reason that the project is done and what difference does it make whether things happened the way we said they would? It is time to move on.

Managers don’t want to pay the cost. The pressures of the budget (both time and money) are such that they would rather spend resources on the next project than on those already done.

It’s not a high priority. Other projects are waiting to have work done on them, and completed projects don’t rate very high on the priority list.

There’s too much other billable work to do. Post-implementation audits are not billable work, and they have billable work on other projects to do.

Note

We can’t stress enough the value in the post-implementation audit. There is so much valuable information that can be extracted and used in other projects. Organizations have such a difficult time deploying and improving their project management process and practice that it would be a shame to pass up the greatest source of information to help that effort. We won’t kid you, though—actually doing the post-implementation audit is difficult because of all the other tasks waiting for your attention, not the least of which is at least one project that is already behind schedule.


The Final Report

The final project report acts as the memory or history of the project. It is the file that others can check to study the progress and impediments of the project. Many formats can be used for a final report, but the content should include comments relative to the following points:

Overall success of the project. Taking into account all of the measures of success that we considered, can we consider this project to have been a success?

Organization of the project. Hindsight is always perfect, but now that we are finished with the project, did we organize it in the best way possible? If not, what might that organization have looked like?

Techniques used to get results. By way of a summary list, what specific things did you do that helped to get the results?

Project strengths and weaknesses. Again by way of a summary list, what features, practices, and processes did we use that proved to be strengths or weaknesses? Do you have any advice to pass on to future project teams regarding these strengths/weaknesses?

Project team recommendations. Throughout the life of the project, there will have been a number of insights and suggestions. This is the place to record them for posterity.


Celebrating Success

There must be some recognition for the project team at the end of the project. This can be as simple as a commemorative mug, a tee shirt, a pizza party, tickets to a ball game, or something more formal, such as bonuses. We recall that when Release 3 of the spreadsheet package Lotus 1-2-3 was delivered, each member of the project team was presented with a videotape showing the team at work during the last week of the project. That was certainly a good touch and one that will long be remembered by every member of the team.

Even though the team may have started out as a “herd of cats,” the project they have just completed has honed them into a real team. Bonding has taken place, new friendships have formed, and mentor relationships have been established. The individual team members have grown professionally through their association with one another, and now it is time to move on to the next project. This can be a very traumatic experience for them, and they deserve closure. That is what celebrating success is all about. Our loud and continual message to the senior management team is this: Don’t pass up an opportunity to show the team your appreciation. Loyalty, motivation, and commitment by your professional staff are the result of this simple act on your part.


Putting It All Together

You have now completed all five phases of the traditional project management life cycle. We can only hope that the practical tools and techniques we have shared will provide a lasting and valuable store of resources for you to use as you grow in this exciting profession. Whether you are a full-time project manager, an occasional project manager, an experienced project manager, or a wannabe project manager, you should have found value in these pages.

We haven’t finished adding to your store of project management tools and processes, though. There is much more to come. For example, in the next chapter, we introduce the topic of critical chain project management as yet another variation on the theme. As you will see, it fills a gap left by TPM that we have ignored so far but will take care of in the next chapter.

Good luck as you continue on your journey to expand your mind into the many possibilities of effective project management!


Discussion Questions

  1. We have advocated the use of a checklist as the acceptance test procedure for establishing that the project is finished. What other type of acceptance test procedure might you suggest? Be specific.

  2. Can you suggest a cost/benefit approach to selling management on the value of the post-implementation audit? Be specific.

Start Sidebar
Case Study

Based on the case outlined in the introduction, how will you know when the project is finished? Did you write some sort of contract with the sponsor at the beginning to make sure that everyone was on the same page as to the exact ending of the project? What is (or could be) the parts of that contract for this project?

End Sidebar


Chapter 12: Critical Chain Project Management

New ideas are not born in a conforming environment.

—Roger von Oech, President, Creative Thinking

In 1984 Eliyahu M. Goldratt introduced the Theory of Constraints (TOC) in a book entitled The Goal. Peter Senge, in his book The Fifth Discipline (Currency/Doubleday, 1994), stated that “to change the behavior of a system, you must identify and change the limiting factor,” which Lawrence P. Leach, in his book Critical Chain Project Management (Artech House, 2000), called the best definition of TOC that he has heard. Still, it was not until the late 1990s that practitioners were able to link TOC to project management. Critical chain project management (CCPM) is the result of the linkage between TOC and project management. CCPM has grown in popularity and is making an impact on project success. In the second edition of this book, there was a brief paragraph on CCPM. At the suggestion of several readers, we have decided to expand our treatment of CCPM. That is the purpose of this chapter. We are aware that many project management practitioners and writers dismiss CCPM as just another way of managing risk and suggest that it does not represent any new thinking about project management. It is not our purpose to settle that debate. We merely want to give some space to an idea, to an approach, that all project managers will appreciate. The interested reader should consult Critical Chain Project Management by Leach.

Start Sidebar
Chapter Learning Objectives

After reading this chapter, you will be able to:

  • Explain the difference between the critical path and the critical chain

  • Identify resource constraints and know how to resolve them

  • Use the critical chain approach to project management for single projects

End Sidebar

What Is the Critical Chain?

As mentioned in Chapter 6, the critical path is the longest duration path through the project. It is built by considering only the task dependencies and their individual durations in an additive fashion. CCPM claims that the critical path approach to project management is flawed. Instead, CCPM claims that the focus should not be on the critical path, which is resource-independent, but on the path that is task-dependent and resource-constrained, the so-called critical chain. The critical chain is defined as the longest duration path through the project considering both the task dependencies and the resource constraints. Critical chain project management is defined as the planning, scheduling, and maintenance of the critical chain throughout the course of the project. Furthermore, by giving priority to the critical chain, the project manager identifies and schedules tasks around the most constrained of the resources and increases the probability of completing the project in less time than the critical path approach. This chapter includes a simple example to illustrate how that schedule compression happens.

In the critical path approach, resources are allocated first to the critical path, which is known to not be the optimal way to create the shortest schedule. There are two concepts that form the justification of the CCPM approach. They are described in the next two sections.


Variation in Duration: Common Cause versus Special Cause

The first concept that justifies the CCPM approach is that there are two basic kinds of variation that we experience in task duration:

Common cause variation. Fluctuation in task duration that comes about because of the capacity of the system affecting that task. In other words, this type of variation occurs naturally in nature. For example, if we consider the time it takes an experienced runner to complete a 100-meter race under normal environmental conditions, we might observe times like 9.85, 9.88, 9.92, and 9.86 seconds. These are not all the same because the runner (the system) has only a certain capacity for repeatability. There is a natural variation in the actual execution times. Nothing can be done to affect that; it is the nature of the runner. These variations are attributable to common cause variation.

Special cause variation. On the other hand, if the runner is running against a 20 mile per hour wind, or running at a 5000-foot elevation, or running in 100-degree heat, the recorded times will be even higher and have a higher variation from one another. Those higher recordings are the result of special causes. We can do something to mitigate or avoid special cause variations but not common cause variations.

What do these mean to the project manager? First, common cause variation is accounted for in the contingency attached to each task. Common cause variation occurs naturally and is always present. We live with that and plan accordingly. Second, special cause variation is dealt with as part of our risk management plan. These are the variations we can manage as project managers.

Note

Both of these sources of variation have to be accounted for in TPM and in CCPM. However, CCPM takes advantage of common cause variation through the use of the central limit theorem from mathematical statistics, whereas TPM essentially ignores it. It is this use of common cause variation and some statistical properties of variances of additive random variables that allows a CCPM project to actually complete in less time than a TPM approach, even on the same project.


Statistical Validation of the Critical Chain Approach

The second concept that lends credence to the CCPM approach is based in statistical distribution theory. Here we call on a basic concept from statistics that states that the variance of a sum is the square root of the sum of the variances of each of the components in the sum. The square root of the sum of squares is less than the sum itself. That may sound like gibberish to most of you, so let’s take a look at how it translates to project duration. Figure 12.1 shows a sequence of four consecutive tasks. Each one has a contingency associated with it (the shaded area after the task). Contingency is defined as the difference in duration between a 50 percent probable estimate and a 90 percent probable estimate. For example, suppose that about half the time a particular activity completes in 10 hours or less. That is the 50 percent probable estimate. Also, that same activity completes in 15 hours or less approximately 90 percent of the time. That is the 90 percent probable estimate. The difference between the two (15 – 10, or 5 hours) is the contingency.

Click To expand
Figure 12.1: Using contingency can reduce project time.

In the lower part of the figure, we have moved the contingency of each task to the end of the sequence of tasks. Note that the variance of the sum of the contingencies is less than the sum of the variances of the contingencies. Calling on that statistical property has allowed us to shorten the duration of the sequence of tasks. You might say that we haven’t really done anything; we’ve just defined things a little differently. Not quite. First, we have used the average task duration as the point estimate of task duration. (A point estimate is a single number that represents our best guess as to the real value of the number we are trying to estimate. A range estimate is a low and high number, which we believe spans the unknown number we are trying to estimate.) The average is that number the duration will exceed half of the time and will be less than half of the time. Because of the variation in duration due to common causes, we can expect some of the tasks to take more time than their average duration and some to take less time. That variation is collected into the contingency at the end of the sequence. To bring the sequence in by the shorter time, the project manager has to manage the contingency. So what we have accomplished by collecting the contingencies at the end of the sequence is to change the focus of the project manager to that newly aggregated contingency. The contingency has been made visible, and therefore, it is manageable.

A final comparison of the critical path versus the critical chain approaches is valuable. The critical path project manager reacts to a single critical path activity taking longer than it was estimated to take. That excess is immediately translated into a project that will be late by that amount. The critical chain project manager reacts differently. That activity is one of a sequence of activities. Some of them will take longer than their estimated duration, and others will take less time. They review the status of the contingency and decide whether to act or to let the statistical variation correct the overage. We’ll have more to say on that later in the chapter by way of our example, but for now it is important to see the distinction and the real strength of CCPM. The TPM project manager reacts to the performance of a single task in a sequence of dependent tasks and expends management time. The CCPM project manager dismisses that as a waste of time because the attention should be given to the sequence and not to any single task. CCPM is relying on the statistical properties of a sequence of dependent tasks, and TPM is not.


The Critical Chain Project Management Approach

The CCPM approach is identical to the TPM approach up to the point where the project network diagram is defined and the critical path is identified. The traditional project manager would next conduct a resource leveling exercise targeting resource usage on the critical path. At this point, the critical chain project manager develops the critical chain plan. In the discussion that follows, we describe each of the CCPM planning steps for you by way of a simple example. We will use as an example the project shown in Figure 12.2.

Step 1: Creating the Early Schedule Project Network Diagram

Figure 12.2 shows the early schedule for a simple seven-task project. This early schedule is the same as someone using TPM might make. Note that the project duration is estimated at 16 days using the original task duration estimates, which include contingency for each task. Figure 12.2 shows the critical path (C1-C2-C3) for a project manager using TPM, and it is the starting point for resolving any resource contention problems.

Click To expand
Figure 12.2: The early schedule.

Step 2: Converting the Early Schedule to the Late Schedule and Adding Resources

The first thing that a project manager using CCPM does is convert the task schedule to the late schedule. That is shown in Figure 12.3. Note that this conversion removes the slack associated with the sequence defined by tasks A1–A2 and B1–B2. In fact, it removes all of the free slack and total slack associated with any task or task sequence in the project. Note also that the 50 percent duration estimates have replaced the original estimates, which included contingency. In doing that, the project duration has been reduced from the original 16 days to 8 days. We have also added the three resources (Duffy, Ernie, and Fran) to the tasks to which they have been assigned. Note that there is a resource conflict with Ernie on tasks A2 and B2. Also note that the project duration reduces to eight days when the contingencies are removed.

Click To expand
Figure 12.3: The late schedule with resource assignments.

Step 3: Resolving Resource Conflicts

In general, resource conflicts are removed by beginning with the task sequence that has the least slack. After resolving that conflict, move to the task path that now has the least slack. Continue in this fashion until all resource conflicts have been resolved. In our example, the critical chain (C1-C2-C3) does not have any resource conflicts. The next task path to consider is A1-A2. In this case, Ernie would be scheduled to work on A2, and that means pushing his work on B1 to an earlier date. This resolution is illustrated in Figure 12.4.

Click To expand
Figure 12.4: One way to resolve the resource conflict.

The other way to resolve the resource conflict is to have Ernie work on B2; then after Duffy has completed A1, Ernie can work on A2. This resolution is illustrated in Figure 12.5. The second choice extends the duration of the project.

Click To expand
Figure 12.5: Another way to resolve the resource conflict.

This simple example illustrates the major difference between TPM and CCPM. TPM uses the early schedule as the base for all management decisions. CCPM uses the late schedule. TPM focuses only on the critical path and manages in accordance with that. CCPM focuses on the paths with resource constraints and manages in accordance with the best use of the resources. It does so by using the critical path but only to identify the chains with the least slack and prioritizes resource use based on the minimum slack paths. To protect the scarce resources, CCPM uses the concept of buffers, which is the topic of the next section.


Buffers

Now that we have adjusted the late schedule for the resource conflicts, we can add the appropriate buffers to the project schedule. There are many different kinds of buffers and many different purposes for which they are used. We discuss and illustrate three of them with our simple project.

Cross-Reference

For a complete discussion of buffers, see Lawrence P. Leach’s book Critical Chain Project Management.

Defining Buffers

Buffers are segments of time that are placed at the end of a sequence of tasks for the purpose of protecting the schedule of those tasks. Buffers can also be used to protect cost, much like a contingency for unexpected expenses in a budget. The size of time buffers is based on the total duration of the sequence of tasks to which they are attached. Basically, the size of the buffer is determined by calculating the total of the contingencies in the tasks that make up the sequence.

Types of Buffers

Although there are others, in this chapter we focus on the following three types of buffers:

  • Project buffers

  • Feeding buffers

  • Resource buffers

Project Buffers

The project buffer is a time buffer placed at the end of the critical chain to protect the overall project schedule. Its size can be calculated as the square root of the sum of the squared differences between the original task duration estimate and the reduced task duration estimate.

Feeding Buffers

The feeding buffer is a time buffer placed at the end of a sequence of tasks that lead into the critical chain. Its size is calculated the same way as the project buffer size.

Resource Buffers

The resource buffer is different than the previous buffers. First, it is not a time buffer. It is a flag, usually placed on the critical chain to alert a resource that it is needed. The flag can be placed at intervals such as one week before the resource is needed, three days before the resource is needed, or one day before the resource is needed. Because it does not contain any time interval, it does not affect the project scheduled completion date. It serves merely to protect the critical chain.

Other Buffers

As we have said, there are several other buffers that we could talk about, but they relate to a multiproject environment and are beyond the scope of this overview chapter. The interested reader should consult Leach’s book Critical Chain Project Management. Some of the other pertinent buffers found in Leach’s book are as follows:

  • Capacity constrained buffer. A buffer placed between projects to ensure a specific sequence of projects in a multiproject environment

  • Cost buffer. A contingency added to a project or sequence of tasks to protect overall cost

  • Drum buffer. The capacity of a single resource that is scheduled across several projects

Using Buffers

Let’s return to the example project in Figure 12.4. So far, the project can be completed at the end of the eighth day. Resolving the resource conflict with Ernie did not add any duration to the project. First, we put a project buffer after C3, the final task in this project. Its size is the square root of the square of the contingencies in tasks C1, C2, and C3 (or the square root of 9 + 9 + 4), which is approximately 4.7 days. Next, we add feeding buffers at the end of the sequences A1-A2 and B1-B2. The calculated buffer sizes are 3.6 days for A1-A2 and 2.8 days for B1-B2. Incorporating these buffers into Figure 12.4 results in Figure 12.6.

Click To expand
Figure 12.6: Project schedule with buffers added.

Note that the CCPM approach gives us a project duration (including contingency buffers) of 13.7 days, compared to the TPM approach of 16 days. In other words, extracting the contingency from each task, collecting it at the end of the task sequences, and managing it has saved us an average of 2.3 days out of a 16-day schedule. That’s about a 14 percent schedule improvement!

Managing Buffers

The CCPM project manager is concerned about the starting time of a sequence of tasks including the critical chain, but isn’t concerned about the finish time of the sequences. The finishing times are not even in the CCPM project plan. Instead, the CCPM project manager manages the buffers. In managing the buffers, the CCPM project manager is protecting the actual duration sequence and, hence, the completion time of the project.

The TPM will see the buffer as nothing more than management reserve, which we discuss in Chapter 6. The only real similarity between the a management reserve and a buffer may be in how they are managed. Managing management reserve and managing buffers can follow very similar logic. The three decision trigger levels in buffer management are as follows:

  • When the sequence of tasks schedule slips and penetrates into the first third of the buffer

  • When the sequence of tasks schedule slips and penetrates into the middle third of the buffer

  • When the sequence of tasks schedule slips and penetrates into the final third of the buffer

Let’s take a closer look at each of these trigger points and the appropriate action that the CCPM project manager should take.

Penetration into the First Third of the Buffer

Unlike the project manager using TPM who chases every slippage on the critical path or change in the critical path, the project manager using CCPM is looking at the performance of a sequence and is less likely to act in haste. Penetration into the first third of the buffer means that the cumulative slippage in the sequence is less than one third of the buffer. There is no defensible reason why the CCPM project manager would want to take any action.

Tip

The later in the sequence this occurs, the less likely any action will be taken.

Penetration into the Middle Third of the Buffer

Penetration into the middle third of the buffer does call for some action on the part of the CCPM project manager. In this case, the correct action is to investigate the cause of the slippage and put a get-well plan in place. The earlier in the sequence this occurs, the more serious the problem.

Penetration into the Final Third of the Buffer

Penetration into the final third of the buffer is serious regardless of when in the sequence it occurs. Obviously, if it is in the first third of the duration of the sequence, it is very serious. If it occurs late in the final third, there may be little that can be done. In any case, action is called for.

Figure 12.7 is a matrix that can be used to determine schedule slippage severity and need for action as a function of buffer penetration and distance into the task sequence.

Click To expand
Figure 12.7: Buffer penetration and action decisions.

To grasp the significance of the penetration matrix, let’s first consider the diagonal from the top left cell to the bottom right cell in Figure 12.7. The cells on the diagonal reflect situations where task sequence penetration is about equal to buffer penetration. The statistician would say that is what we should expect on the average. However, the further we move into task sequence penetration (moving down the diagonal), the more we should be paying attention to the team’s performance on the work being done on the tasks in the sequence. The nearer we are to the ending tasks in the sequence, the less likely it is that we can formulate and execute a get-well plan should things go poorly. For example, if we are in the second third of the task sequence, it might be a good idea to take a look at the problem situation and formulate an action plan in the event things deteriorate. The problem is not serious, but it does deserve our attention. In the final third of the task sequence, all we can do is closely monitor and take action at the slightest aberration in the task sequence schedule.

Below the diagonal we’ve been discussing is a great place to be. We could even be experiencing a situation where the task sequence will finish ahead of schedule and the time saved can be passed to the successor task sequence. Above the diagonal are situations we are more used to. If we are in the first third of the task sequence and have penetrated into the second third of the buffer, we have a serious problem that needs immediate investigation and solution implementation. There may be some systemic flaw in the project plan, and early intervention is needed. If the schedule should continue to slip and we find ourselves having penetrated into the final third of the buffer, we are in real trouble, as the matrix suggests. We could be looking at a significant slippage that may impact the project buffer as well.


Track Record of Critical Chain Project Management

It was not until the 1997 publication of Eliyahu M. Goldratt’s book Critical Chain (North River Press Publishing Corp.) that people began to see the connections between TOC and project management. CCPM has only a five-year history to draw upon for its successes. Leach cites a few of them in his book Critical Chain Project Management. They are briefly summarized in the following list:

Honeywell Defense Avionics Systems. Using critical chain concepts, a team at Honeywell was able to reduce a 13-month project to 6 months. And they did finish it in 6 months.

Lucent Technologies. A project that was scheduled using CCPM was to have taken one year. Many said it couldn’t possibly be done in one year. It was, with buffer to spare.

Harris. Harris undertook to build a new manufacturing facility using the CCPM approach. The industry standard for such facilities was that it took 46 months to get the plant up and running to 90 percent capacity. Harris built it and brought it up to 90 percent capacity in 13 months.

Israeli aircraft industry. A particular type of aircraft maintenance requires three months on the average. Using CCPM techniques the maintenance team reduced the average to two weeks.

Better online solutions. A software package was originally planned to be released to the public in August 1997. The TOC schedule cut it down to May 1, 1997. The actual delivery date was early April 1997.

These stories do not in any way validate CCPM as better than TPM. It is too early to tell that, but it is a fact that there have been many successes using it. You be the judge. You decide if CCPM wins out over TPM or if it is just another repackaging of PMBOK. We have simply presented another way of managing resources and leave it up to the project team to decide which approach makes more sense, given the situation.


Putting It All Together

We have given you enough of an overview of CCPM to be able to use it in your projects. The overview is brief and applied to a simple project. Those of you who are more serious about its application will need to dig deeper into it. Again, we heartily endorse Leach’s book Critical Chain Project Management.


Discussion Questions

  1. Assume that your organization is interested in using CCPM along with TPM. What criteria would you use to decide which approach makes more sense for a given project? You might try answering this question by considering some of the characteristics of the project that would lead you to one choice over the other.

  2. You are a senior project manager in your company. You have 15 years’ experience with them and a solid reputation for delivering successful projects. What might you, acting on your own, do to get your organization to appreciate the value of CCPM? What obstacles might prevent you from going forward with your plan?


Part Two: Adaptive Project Framework

Chapter List

Chapter 13: Introduction to the Adaptive Project Framework
Chapter 14: Version Scope
Chapter 15: Cycle Plan
Chapter 16: Cycle Build
Chapter 17: Client Checkpoint
Chapter 18: Post-Version Review
Chapter 19: Variations to APF

Project management is at a major crossroads. How we choose to go forward will either endear us to our clients or give them more reasons to dismiss project management as irrelevant to their needs. Changes that have taken place in the past few years in the way businesses operate have given us good reason to pause and reflect on whether or not our traditional approach to project management still satisfies the needs of organizations. We are of the belief that we are not meeting the needs of contemporary organizations and that we must do something to correct that deficiency. These thoughts have dominated our thinking for several years now. We’ve had this feeling that the business world is passing us by, and that what we are offering them isn’t up to expectations. It’s time for some out of the box thinking.

Part II of this book rose out of that belief and the need to act. We call this new approach Adaptive Project Framework (APF). It reflects our thinking on an approach to projects that do not fit the traditional project profile. Much of APF is the direct result of working with project managers who are frustrated with their foiled attempts to adapt TPM to projects for which it was not designed. We warn you now that what you are going to read about in Part II is different. We ask you to be open-minded as you read these chapters. What we have done is take parts from the traditional approach and parts from the extreme approach and integrate them in a way that meets the needs of a type of project that is not served by either the traditional or the extreme approaches. There is a new taxonomy of projects. It ranges from the traditional approach to APF and then to extreme project management. As we discussed in the Introduction, projects also follow a taxonomy that maps directly to these approaches.

If you would like to reduce the cost of projects to your organization, read this part of the book. We believe it is required reading for Project Office directors and managers, program managers, project managers, project leaders, team members, and those who use the services of any of these professionals. Executives will want to read Chapter 13 and learn that there is something that can be done to significantly reduce the high percentage of failed projects without spending any more money. That’s right—without spending any more money. APF does not require any special tools or software or consultant expertise to be implemented. For the traditionalist, APF should be intuitive. Everything you need is in this book. In fact, we hypothesize that the APF approach that is introduced here is actually less costly than the traditional processes now in place in every organization.

We first introduce Adaptive Project Framework at a 60,000-foot level. The first chapter of this part describes the five-phase APF approach and briefly explains each phase. This chapter is an excellent introduction to APF for senior-level executives, directors, and managers. They will come away with a good grasp and understanding of why APF is so critically important to our organizations at this time. The following five chapters discuss each of the five phases in detail sufficient for a project team to follow the approach. The final chapter discusses a few variations of APF and focuses mostly on extreme project management (xPM). xPM is a variation of APF in that the goal is not clearly specified in xPM, whereas it is in APF. That slight difference leads to a number of variations in the approach. These are discussed in some detail for the practitioner.

Part II is a work in process. We continue to learn and discover the real power behind APF as we discuss it with our colleagues and implement it with our clients. How interesting it is to realize that our project to develop a fully functional version of APF is an APF project.

Many strict traditionalist project managers will probably find APF controversial. At least we hope to get their attention and open their minds to other possibilities. There is an entire class of projects that we believe is not being served by the traditionalist approach. Recent developments in extreme project management address some of those projects. APF addresses projects that fall in the growing gap between the traditional and agile approaches. In our experience, the majority of projects fall into this middle ground.

We claim full responsibility for the contents and any reactions that follow. If nothing else, we hope to get a number of traditionalists excited enough to take a look at what we are presenting. Perhaps they will help us smooth the edges to APF and make it a viable tool in their project management arsenal. If you care to comment, contact Bob Wysocki at rkw@eiicorp.com or Rudd McGary at rmcgary@hotmail.com. We promise you a personal and thoughtful response.


Chapter 13: Introduction to the Adaptive Project Framework

Overview

It is a mistake to look too far ahead. Only one link of the chain of destiny can be handled at a time.

—Winston Churchill

There is no data on the future.

—Laurel Cutler, Vice Chairman, FCB/Leber Katz Partners

For those businesses that have only recently realized the pain of not having a project management process in place and are struggling to adapt traditional practices to nontraditional projects, we say, “Stop wasting your time!” We’re not advocating the overthrow of the project management world, but rather asking you to stop and think about what has been happening. It’s time to pay attention to the signals coming from the changing business environment and discover how to survive the fast-paced, constantly changing, high-quality demands of the new business model.

Note

Adaptive Project Framework (APF) incorporates selected tools and processes from traditional project management (TPM). Those tools and processes are not repeated here. This part of the book assumes that the reader is familiar with the TPM approach. A quick review of Part I is suggested for those who do not have a working knowledge of TPM.
Start Sidebar
Chapter Learning Objectives

After reading this chapter, you will be able to:

  • Give a general explanation of APF

  • Understand the purpose of each of the five phases of APF

  • Apply the APF core values

  • Describe the types of projects that are appropriate for APF

End Sidebar

The project survival strategy that we explore in this groundbreaking part of the book is what we are calling Adaptive Project Framework (APF). This is definitely not your father’s project management. It’s new. We don’t even use the word management. APF represents a shift in thinking about projects and how they should be run. For one thing, it eliminates all of the non-value-added work time that is wasted on planning activities that are never performed. Why plan the future when you don’t know what it is? In APF, planning is done just-in-time. Sounds like an oxymoron, doesn’t it? It is a new mind-set—one that thrives on change rather than one that avoids change.

APF is not a one-size-fits-all approach; it continuously adapts to the unique character of the specific business situation as it learns more about that business situation. Based on the principle that form follows function, this strategy adapts some of the tools and processes from TPM (discussed in Part I of this book) and extreme project management ( discussed in Chapter 19) to its own special needs. It is a framework based on the principle that you learn by doing and one that guarantees, “If you build it, they will come.”

APF seeks to get it right every time. It is client-focused and client-driven and is grounded in a set of immutable core values. It ensures maximum business value for the time and dollars expended and has squeezed out all of the non-value-added work that it possibly could. As a framework that meaningfully and fully engages the client as the primary decision maker, APF creates a shared partnership with shared responsibility between requestor and provider. APF is a framework that works, 100 percent of the time. No exceptions!

Do we have your attention?


Defining APF

APF is an iterative and adaptive five-phase approach designed to deliver maximum business value to clients within the limits of their time and cost constraints. The fundamental concept underlying APF is that scope is variable, and within specified time and cost constraints, APF maximizes business value by adjusting scope at each iteration. It does this by making the client the central figure in deciding what constitutes that maximum business value. At the completion of an iteration, the client has an opportunity to change the direction of the project based on what was learned from all previous iterations. This constant adjustment means that an APF project’s course is constantly corrected to ensure the delivery of maximum business value. In other words, change is embraced, not avoided.

Planning takes on a whole new meaning in APF. Initial planning is done at a high level and is component or functionally based. TPM planning is activity- and task-based. In APF, planning at the micro level is done within each iteration.

It begins with a mid-level component or function-based WBS and ends with a micro-level activity and task-based WBS. We like to think of it as just-in-time planning. The underlying strategy to APF planning is not to speculate on the future, because such speculation is a waste of time and energy. A key phrase to keep in mind when applying APF is “when in doubt, leave it out,” meaning that we only include in our detailed planning those activities that clearly will be part of the final solution—that is, at each iteration, include in your detailed plan only what you know to be factual. So, planning is done in segments where each chunk represents work that will require only a few weeks to complete.

The five phases that define APF are as follows:

  • Version Scope

  • Cycle Plan

  • Cycle Build

  • Client Checkpoint

  • Post-Version Review

They are briefly described in the next section.


An Overview of the APF

The stage is now set to take our first look at APF. Figure 13.1 is a graphic portrayal of how APF is structured. First, note that APF is an iterative process. We iterate within a cycle and between cycles. Every iteration presents the team and the client with a learning and discovery opportunity. APF is crafted to take advantage of these opportunities. As you continue to study each phase, you will come to realize that is its real strength.

Version Scope

APF begins with a stated business problem or opportunity. This beginning is the same as TPM. A request has been made to develop a solution to the stated problem or opportunity, and that request has all the earmarks of a project. At this point, we are not at all sure what kind of project this might be or how we might approach it from a methodology perspective. A Conditions of Satisfaction (COS) conversation takes place between the requestor and the provider to define more clearly exactly what is needed and what will be done to meet that need. The result of that conversation is a decision as to which project management approach will be followed: traditional (covered in Part I), extreme (covered in Chapter 19), or APF. We have decided that APF is the approach to be taken, so a project scoping document, specifically, a Project Overview Statement (POS), is written.

Click To expand
Figure 13.1: The Adaptive Project Framework.
Cross-Reference

We discuss the POS in great detail in Part I, particularly in Chapter 3. See that discussion for more information.

Recall that a POS basically summarizes the Conditions of Satisfaction. It is a brief (usually one page, maybe an attachment) document that contains the following:

  • A statement of the problem or opportunity (reason for doing the project)

  • A goal statement (what will generally be done)

  • A statement of the objectives (general statements of how it might be done)

  • The quantifiable business outcomes (what business value will be obtained)

  • General comments on risks, assumptions, and obstacles to success

The second deliverable from this phase is a prioritized list of the functionality that has been requested and agreed to in the COS. Both parties recognize that this list may change, but at this point in the project, the list reflects the best information available.

Cross-Reference

There are several ways to establish that priority, and we discuss them in Chapter 14. The COS is fully described in Chapter 3.

The third deliverable from this phase is the mid-level Work Breakdown Structure (WBS). For our purposes, a mid-level WBS is one that shows the goal at level 0, major functions at level 1, and subfunctions at level 2. Generally, such a WBS would have a two- or three-level decomposition. The number of levels is not important. What is important is to have at least one level of decomposition for each functional requirement. At this point any more WBS detail is not considered useful. The reason for that will become clear in the Cycle Plan phase. The traditionalist would have a problem with this because the entire foundation of traditional project planning and scheduling is based on having a complete WBS. We contend that the time spent creating a complete WBS at this stage is largely a waste of time. Again, we remind you, why plan for the future when you don’t know what it is? In our case, the piece that is missing is that we are not exactly sure how we are going to deliver the functionality. We do know what functionality has to be delivered, and we are using that information to generate the mid-level WBS but not the complete WBS. The complete WBS will eventually be generated when we know enough to generate it. That will happen within repeated iterations of Cycle Plan–Cycle Build–Client Checkpoint phases. We will generate it when we need it and not before, and when we do generate it, we will know that it is correct and not a guess.

The fourth deliverable from this phase is a prioritization of the variables that define the scope triangle (time, cost, resources, scope, and quality). This prioritization will be used later as an aid to decision making and problem solving during the Cycle Build phase.

Cycle Plan

The Project Overview Statement has been written and is presented along with a prioritized list of functionality that the client and the provider believe are needed to take advantage of the business opportunity or solve the business problem. (Again, for a complete discussion of the POS see Chapter 3.) Some high-level planning is done very quickly to prioritize the functionality into a number of time-boxed cycles for development. Typical cycle length is 2 to 6 weeks. This cycle length is documented and agreed to by both parties—along with the expectation that it will change as project work commences.

The Cycle Plan phase will be repeated a number of times before this project is complete. The first Cycle Plan phase has as input the POS, the prioritized scope triangle, the functionality that will be built in this cycle, and the mid-level WBS. Subsequent Cycle Plan phases will also have a Scope Bank as input.

Cross-Reference

The Scope Bank is introduced in Chapter 16.

Contrary to what you might think, the creation of the cycle build plan is a low-tech operation. While you could certainly use project management software tools, we have found that a whiteboard, Post-It notes, and marking pens are just as effective. It does keep the maintenance of a project file down considerably and allows the team to focus on value-added work. This advice may sound heretical to those of you who are software aficionados, so let us explain. Cycle length generally falls within a 2- to 6-week timeframe. There will likely be several small teams (a typical small team will be one architect and two or three software engineers), each working in parallel but independently on a separate piece of functionality. Each of these small teams will plan the cycle build in this phase and then conduct the cycle build in the next phase. Based on this description, a minimal planning effort is all that makes sense.

The cycle planning effort might go something like this:

  1. Extract from the WBS those activities that define the functionality that will be built in this cycle.

  2. Decompose the extracted WBS down to the task level.

  3. Establish the dependencies among these tasks.

  4. Partition the tasks into meaningful groups and assign teams to each group.

  5. Each team develops a micro-level schedule with resource allocations for the completion of their tasks within the cycle timebox and budget constraints.

There is no critical path to calculate and manage. Traditionalists would have a problem with this. Their approach is based on managing the critical path. We could certainly calculate one here and maintain it, but we believe that is overkill. The cycle is so short that too much planning and analysis leads to paralysis. We don’t need to clutter the cycle with non-value-added work. The entire effort can be whiteboard-, Post-It note-, and marker pen-based. A dedicated war room would be helpful (12' by 12' should work fine). The team can post their plans, work schedules, Scope Bank, Issues Log, and so on, and have their daily 15-minute updates, weekly status meetings with the client, and problem-solving sessions here.

Cycle Build

Detailed planning for producing the functionality assigned to this cycle is conducted. The cycle work begins and is monitored throughout the cycle, and adjustments are made as necessary. The cycle ends when its time has expired. Any functionality not completed during this cycle is reconsidered as part of the functionality in the next cycle.

The first activity in the Cycle Build phase is to finish the cycle build schedule and resource allocation. With everything in place and understood by the team, work begins. Every team member has a daily task list and posts task status at the completion of every day. Any variances are caught early, and corrective action plans put in place. Nothing escapes the attention of the project manager for more than one working day. A Scope Bank is created to record all change requests and ideas for functional improvements. An Issues Log records all problems and tracks the status of their resolution.

Cross-Reference

The Issues Log is discussed in detail in Chapter 16.

Client Checkpoint

The client and the project team jointly perform a quality review of the functionality produced in the just competed cycle. It is compared against the overall goal of maximum business value, and adjustments are made to the high-level plan and next cycle work as appropriate. The sequence Cycle Plan–Cycle Build–Client Checkpoint is repeated until the time and cost budgets for this version have been expended.

The Client Checkpoint phase is a critical review that takes place after every Cycle Build phase is completed. During the cycle build, both the client and the project team will benefit from several discovery and learning episodes. Variations to the version functionality will surface; alternative approaches to delivering certain functionality will be suggested, and the client will learn through his or her continuous involvement with the team. All of this must be considered along with the functionality that had originally been assigned to the next cycle. The result is a revised prioritization of functionality for the next cycle. The most important thing to remember is not to speculate on the future. In the next cycle, prioritize only the functionality that you are certain will be in the final solution.

We don’t dismiss this as being an easy exercise. It definitely isn’t. Most of the difficulty stems from either the client or the project team not approaching reprioritization with an open mind. People tend to get wedded to their earlier ideas and are hard-pressed to give them up in favor of others. To be successful with APF, both the team and the client must have an open mind and not display pride of authorship on any previous functionality that was discussed.

Tip

Change is a critical success factor in APF.

One of the greatest benefits from this approach is the meaningful and continuous involvement of the clients. They are the decision makers in all going-forward activities. They are doing it with full knowledge of what has taken place to date and with the collaborative support of the project team. They understand how business value can be achieved by changes in functionality, and they are in a position to take action. APF encourages the clients to engage in the project even to the level of operating as a co-project manager. Their presence will be a constant reminder to the team of the business aspects and value of what they are doing and what changes should be made to protect that business value. This client involvement is a very important point to remember. It ensures that what is eventually built will meet client needs.

Post-Version Review

During the Version Scope phase, we developed measurable business outcomes in discussions with the client. These became the rationale for why the project was undertaken in the first place. Think of these outcomes as success criteria.

That is, the undertaking will have been considered a success if, and only if, these outcomes are achieved. In many cases, these outcomes cannot be measured for some time after the project has been completed. Take the case of the project impacting market share. It won’t happen next Tuesday. It may happen several quarters later, but the timeframe is part of the success criteria statement as well.

The budget and time allotted to this version have been spent, and that marks the end of the project. Some functionality that was planned to be completed may not have been completed. The main focus of the post-version review is to check how you did with respect to the success criteria, to document what you learned that will be useful in the next version, and to begin thinking about the functionality for the next version.

What the client and the project team believe to be the best mix of functionality has been built into the solution. The project is done. The deliverables are installed, and the solution is in production status. At this stage, three questions need to be answered:

  1. Was the expected business outcome realized?

  2. What was learned that can be used to improve the solution?

  3. What was learned that can be used to improve the effectiveness of APF?

The business outcome was the factor used to validate the reason for doing the project in the first place. If it was achieved, chalk that one up on the success side of the ledger. If it wasn’t, determine why not. Can something further be done to achieve the outcome? If so, that will be input to the functional specifications for the next version. If not, kill the project right now. No need to send good money after bad money.

There is also a lesson here for all of us. If projects are limited in scope and they fail and there is no way to rescue them, we have reduced the dollars lost to failed projects. The alternative of undertaking larger projects is that we risk losing more money. If there is a way of finding out early that a project isn’t going to deliver as promised, cut your loses. The same logic works from cycle to cycle. If we can learn early that a version will not work, kill the version and save the time and cost of the latter cycles.

Note

TPM would find out a project wasn’t working only after all the money was spent, and then a great deal of trouble might be involved in killing the project. The traditional thought goes, “After all, there is so much money tied up in this project, we can’t just kill it. Let’s try to save it.” How costly and unnecessary.


The APF Core Values

APF is more than just a framework. It represents a way of thinking about clients and how best to serve them. This way of thinking is embodied in the six core values described in the sections that follow. These core values are immutable. They must be practiced in every APF project. No exceptions. In time the APF teams will be recognized for the visible practice of their core values. We have had occasion to work with teams that periodically reward team members for practicing the APF core values. They are that important.

Client-Focused

While we were looking for the appropriate name for this core value, the phrase “walk in the shoes of the client” was always on our minds. It still is an operative part of truly being client-focused. This value is the most important of the core values. The needs of the client must always come first, as long as they are within the bounds of ethical business practices. This value can never be compromised, and it goes beyond simply keeping it in mind. It must be obvious through our actions with one another and through our interactions with our clients.

Don’t think that we are advocating passive acceptance of whatever the client might request. Client-focused also means that we have their best interests at heart. In a spirit of openness, we are obligated to challenge ideas, wishes, and wants whenever we believe challenge is called for. To do otherwise is not part of being client-focused. We want to do the right things for the right reasons and to always act with integrity.

Client-Driven

One of the guiding principles of our business has always been to engage the client in every way that we could. We want them not only to be meaningfully involved but to also have the sense that they are determining the direction that the project is taking. At the extreme, this value would mean having the client take on the role and responsibilities of the project manager. Such an extreme will not happen very often, but there are occasions when this will occur. An effective arrangement is to have co-project managers—one from the client and one from your organization. In this arrangement, both individuals share equally in the success and failure of the project. There is a clear and established co-ownership. Practice tells us that this is a key to successful implementation. We say that this is a key factor to successful projects.

Incremental Results Early and Often

In the spirit of prototyping, we want to deliver a working application to the client as early as possible. This early delivery is especially valuable when there is any question that the real needs of the client have not yet surfaced despite our best efforts. The functionality of the first iteration of the application will be very limited but useful in any case. In some cases, the first iteration might be a proof of concept. (See Chapter 19 for more on this point.) It should deliver business value even though it is of very limited functionality. It gives the client an early feel for the final deliverables. Giving the client an opportunity to work with something concrete is always better than asking them to react to some vague concept or sketch on a notepad.

Continuous Questioning and Introspection

Building a solution iteratively affords the opportunity to be creative. It creates the opportunity to adjust as better and more valuable features or presentations are discovered. As the cycle build proceeds, both the client and the project team should always be looking for improvements in the solution or the functionality offered. Look back at previous cycles, and ask whether what was done was the best that could have been done. All of this learning and discovery will be captured in the Scope Bank and come together in the Client Checkpoint phase. Here is where the client and the project team propose, discuss, and approve changes.

A true spirit of openness must exist. Neither party should be afraid to offer or challenge an idea or the real value of some present or future deliverable. We’ve frequently told teams that if anyone of their members had an idea and didn’t share it with the rest of the team, we would consider it dereliction of duty. The same is true for the client. The successful practice of this core value is heavily dependent on the existence of a true team environment.

Change Is Progress to a Better Solution

One of our colleagues is often heard saying, “You’re always smarter tomorrow than you are today.” He is referring to improving estimates over time, but his comment applies to APF as well. The Version Scope phase begins with the requestor and provider coming to a definition of what is needed and what will be delivered through the COS experience. Despite their best efforts, all the two parties have done to this point is take the best guess they can as to what will be done. That guess may turn out to be very good, but that is not important. What is important is that by working with the deliverables from the first cycle, both parties will get a better picture of what should be delivered. They will be smarter as a result of their experiences with the early deliverables. The result is to change the project going forward in the next cycle.

Don’t Speculate on the Future

APF strips out all non-value-added work. Guessing only adds non-value-added work back in. So, when in doubt, leave it out. APF is designed to spend the client’s money on business value not on non-value-added work.


Putting It All Together

In this introductory chapter, we have set the stage for the rest of Part II. The rationale behind the APF has been briefly explored, and we have given you the high-level view of what the APF involves. This introduction could well meet the needs of the senior manager who simply wants to understand APF at a high level. For those at the program or project manager level, you are off to a good start. With that understanding in place, we can now proceed to peel back the layers of our onion—the APF. In Chapters 14 through 19, you will discover and come to understand the most granular of details for each of the five phases and adaptations of the APF. Our intent is that you have a working knowledge of APF when you are finished.

We are truly thankful to have this opportunity to introduce a new way of thinking about an important class of projects. It is our hope that you find it a valuable addition to your arsenal.


Discussion Questions

  1. Under your leadership, your organization has spent considerable effort to adopt a traditional approach to project management. It has reached maturity level three, that is, there are fully documented project management processes and templates and everyone is following them. PMBOK is the recognized standard. You have earned a good reputation among your management colleagues. You have noticed a number of projects where the client has requested and gotten approval for several changes throughout the project. These have cost significant money and time, the loss of e-business market share, and the subsequent loss of revenues. As Director of the Project Support Office, you have come to realize that APF is the approach that should have been taken on this project. You are convinced that by using APF these types of projects could have been completed earlier, at less cost, and with a much better end results. What strategy would you suggest to introduce and institutionalize APF in your company? What obstacles do you foresee?

  2. You are a senior project manager in your company. You have 15 years’ experience with them and a solid reputation for delivering successful projects. What might you, acting on your own, do to get your organization to appreciate the value of APF? What obstacles might prevent you from going forward with your plan? How do you feel about stepping outside the box?


Chapter 14: Version Scope

Overview

Prediction is very difficult, especially about the future.

—Neils Bohr

Define the problem before you pursue a solution.

—John Williams, CEO, Spence Corp.

The Version Scope phase is the beginning of APF (see Figure 14.1). It is a formal set of activities that take place very soon after a request has been made. There are two major parts to version scope:

A defining part. The defining part can effectively be completed by two parties: a requestor and a provider. These may each be single individuals or small groups that represent the two parties. In either case, the critical factor is that they not only represent their constituency but they speak for their constituency and can make decisions for their constituency.

Start Sidebar
Chapter Learning Objectives

After reading this chapter, you will be able to:

  • Describe the components of the Version Scope phase

  • Conduct a Conditions of Satisfaction process

  • Write a Project Overview Statement for an APF project

  • Develop a mid-level WBS

  • Prioritize version functionality using one of three methods

  • Prioritize the scope triangle using success sliders

  • Determine the number of cycles and the cycle timeboxes

  • Assign functionality to cycles

    A planning part. The planning part is not unlike the early stages of the TPM planning session. It should be attended by the stakeholders and core project team. The difference here is that the version plan is not a detailed plan. It does not provide a detailed definition of the work to be done or of a schedule to be followed. Those details are part of the cycle plans.

    Click To expand
    Figure 14.1: Version Scope phase.

End Sidebar


Defining the Version Scope

You have probably guessed by now that more than one version of the solution is expected. And you are correct. However, we are only concerned with this version and will not reference any future versions of the solution. Information will be gathered during this version that will inform management about any further enhancements they might want to consider in future versions. These future versions are not unlike the normal releases we see in products, services, and systems.

While there are similarities between TPM and APF, one major difference has to do with scope. Scope creep is the bane of the traditionalist. They put up with it because they have no choice. They know it will happen, and they just have to make the best of it. In APF there is no such thing as scope creep. What occurs is change brought about by discovery and learning by the team and by the client. This change is expected, and APF is designed to handle it with ease at each client checkpoint.

So let’s get into the details of the defining part of the Version Scope phase.

Developing the Conditions of Satisfaction

The Conditions of Satisfaction (COS) are determined by a one-on-one, real-time, face-to-face dialogue between the requestor and the provider. Emails will never be a substitute for face-to-face dialogue. The problem with email requests and replies is that we are never really sure what the other individual is saying because we don’t have the opportunity for immediate feedback or to see nonverbal reactions to the dialogue. With emails we assume we understand, but we have no way of verifying that we understand correctly.

To further press our point, here is an example from our early days of training IT professionals in project management. We would ask each student to write down his or her definition of implementation. They could do it by making a list of what was in and not in implementation. Would you be surprised to know that there wasn’t much agreement from one list to another? IT professionals can hardly say a sentence without using the word implementation, and they don’t really know what they are talking about. With this simple example, it is clear that the message sent is surely not the message received. How serious a communications problem might there be between a requestor (a businessperson) and the provider (a technical person)? Such communications problems can be pretty serious. They could result in the project team having one idea of what the client needed and the client having yet another understanding of what the team is going to deliver. It is so important that both the client and the team have a common understanding of what is needed and what is being delivered that to pass up the COS exercise could be fatal. The COS, which is introduced in Chapter 3 and is briefly revisited here, solves the problem once and for all.

Note

The requestor and provider may be individuals or small groups, but they must be representative of the requestor group and the provider group and be empowered to make commitments and decisions for the groups they represent.

Let’s review how the COS works. The COS consists of two conversations. The first one is driven by the requestor and the second by the provider. Figure 14.2 is a schematic of the process.

Let’s look at the two types of conversation:

Requestor-driven conversation. The requestor states and describes the request using their language. The provider makes sure he or she understands the request by using questions and eventually feeding back the request in his or her own language. At some point in this conversation, you want the requestor to be able to say to the provider, “You clearly understand what I am asking you to do.” The conversation now shifts to the provider-driven conversation.

Provider-driven conversation. The provider responds by stating and describing what can be done to meet the requestor’s request. The requestor asks questions to frame the answer and eventually describes the response in his or her own language. At some point in this conversation, the provider is able to say to the requestor, “You clearly understand what I can provide.”

Click To expand
Figure 14.2: Establishing Conditions of Satisfaction.

We should now have agreement and a clear understanding of what is being asked and what can be done. There will be some negotiating to reach agreement, and you shouldn’t assume that everything is in sync until finishing the process. Note that the requestor and provider, through their earlier conversations, have established a common language. They each understand the other, which will smooth the negotiating that will take place. This understanding is one of the major benefits of COS; a clear communication link is now established between the two parties. This communication link is very important now because the project does not have a clear solution. It will take the best efforts of both the project team and the client to fashion a solution that meets the expectations of the client.

The COS process is not a one-time event. It occurs continuously throughout the project. At each client checkpoint, revisit the COS. Because of the learning and discovery that has taken place, something will have surely changed that renders the previous agreement obsolete. This revisiting the COS is your guarantee of always staying in alignment with what the client needs. It is also the pathway to move the client from what they want to what they need. Remember, APF embraces change, and here is the place where change enjoys the light of day.

Writing the Project Overview Statement

The output from the COS contains all of the information needed to write the Project Overview Statement.

Cross-Reference

The POS is introduced and discussed in detail in Chapter 3.

To review, the POS has five parts:

  • Problem/opportunity statement

  • Goal statement

  • Objectives statement

  • Success criteria

  • Risks and obstacles

Ideally, the POS is a one-page document. Its primary purpose is to get approval to move forward with the Cycle Plan phase. At this early stage in the project, the last thing you want to do is burden the decision maker with a 70-page tome when all you are asking for is the authority to continue to the next phase.

Some organizations may require a little analysis to validate the business outcome of the proposed project. We have seen a number of attachments included with the POS, such as:

  • Risk analysis

  • Return on investment (ROI)

  • Break-even analysis

  • Internal rate of return

These (and any other necessary supporting documents) are all appropriate and should be considered as aids to getting the approval to move forward with mid-level project planning.

Identifying the Business Problem or Opportunity

A well-defined need and a clear solution pathway planned to meet that need define a project that the traditionalist would die for. A rather vague idea of a want coupled with a vague idea of how it will be satisfied define a project that the agilest (an agilest is one who aligns their project management approach with xPM, which is discussed in Chapter 19) would die for. Everything in between belongs to the project manager using APF. The problem or opportunity that our project is going to respond to must already be recognized by the organization as a legitimate problem or opportunity. If anyone in the organization were asked about it, he or she would surely answer, “You bet it is and we need to do something about it.” In other words, it is not something that needs a defense. It stands on its own merits.

Defining the Goal of This Version

This goal will be a simple yet definitive statement about what this project intends to do to address the problem or opportunity. It might be a total solution, but to be more realistic, it should be a solution that addresses a major segment of the problem or opportunity. We say this because all too often we define projects that are far too large in scope. That opens us to scope creep and changes in the environment that render the global solution ineffective or irrelevant. By defining the goal of this version to be a reachable target rather than a lofty or unattainable ambition, we protect the client and the team from scope creep. We are sure that this has a lot to do with the high incidence of project failure. It may sound too pedestrian to some of you, but we believe that we will be far more successful in the long run by biting off less than we think we can chew. We are not asking for heroic efforts, just successful ones.

Writing the Objectives of This Version

By way of analogy, we think of the goal statement as a pie and the objective statements as slices of the pie. All of the slices that make up the pie are the objective statements. If you would rather have a mathematical interpretation, think of the objectives as necessary and sufficient conditions for the attainment of the goal. In either case, the objective statements give a little more detail on how the goal will be achieved. They are the boundary conditions, if you will. We would expect to see you write six to eight objective statements to clarify your goal statement.

Defining the Success Criteria

The success criteria (or explicit business outcomes) are quantitative statements of the results that will be realized from having successfully completed this project. They are formulated in such a way that they either happened or they didn’t. There will be no debate over attainment of success criteria. Statements like “Gross profit margins will increase from their current average of 11 percent per month to an average of at least 14 percent per month by the end of the second quarter of production using the new system” are acceptable. Statements like “Increase customer satisfaction” are not. We would expect to see two or perhaps three success criteria for your project. Success criteria generally fall into three categories:

  • A metric related to an increase in revenues

  • A metric related to a reduction or avoidance of cost

  • A metric related to an improvement or increase in services

Listing the Major Risks

Put yourself in the shoes of the financial analyst who might ask, “I am being asked to invest $10 million in a new system that is supposed to cut operating expenses by 5 percent per month. What risks are we exposed to that might prevent us from achieving that ROI?” What would you tell the analyst? That is what you list in the major risks. You might also make senior managers aware of the fact that certain staff skill shortages are going to be a problem or that the reorganization of sales and marketing will have to be complete or there will be serious consequences during system implementation.

Holding a Fixed Version Budget and Timebox

In APF the budget and timebox are fixed. The timebox refers to the window of time within which the project must be completed. This timebox includes all cycles, which have their own timeboxes, too. We suggest trying to keep a version timebox to less than six months. Any longer and you invite many of the problems that plague the traditionalist. There are no rolling schedules. There is no going back to the well for another budget increase. One of the objectives in an APF project is to maximize business value under fixed time and cost constraints. Period. This is a very different approach to the project than the traditionalist would take. As long as the client is satisfied that the maximum business value has been attained for the time and dollars expended, the project was successfully completed. If the client and the project team pay attention, this result can be achieved every time. No exceptions!

Unfortunately, the maximum business value they attain may not meet the success criteria, but that is an issue for the client to deal with and should not determine the success or failure of the APF approach. Whatever didn’t get done in this version will have to be left for the next version or not at all. Hence, we have another reason for keeping scope to a feasible minimum and the timebox to less than six months. Those restrictions reduce the occasions where schedules are extended or more dollars are needed. Those restrictions then also reduce the financial loss to the organization as compared to the traditional approach. With APF you can kill a bad project much earlier than you can with the traditional approach, and that accounts for the dollar savings.


Planning the Version Scope

This planning function will look quite similar to what the traditionalist would do. In APF. however, we stop the process earlier than the traditionalist would. The APF version plan extends only to the mid level, whereas the traditional plan would extend to the low level. In APF we plan only to the level that we know will happen. Anything below that level is playing with the future, and the project manager using APF doesn’t play with the future. APF planning is just-in-time planning.

So let’s get into the details of the planning part of the Version Scope phase.

Developing the Mid-Level WBS

The input to planning the version is the mid-level WBS. The mid-level WBS identifies the functionality that will be built in this version. It is a noun-type decomposition of the goal statement.

Cross-Reference

Refer to Chapter 4 for a refresher on the noun-type decompositions.

The mid-level WBS does not show the tasks have to be done to build that functionality. To complete the WBS down to that level at this point in time would define work that might never be done. In APF we don’t know enough about the future to spend the time creating the full WBS to that level of detail. Over the course of all of the cycles, we may end up generating the complete WBS, but we don’t know that for sure. In APF we will build the WBS detail when we need it. For our purposes here, we simply decompose the WBS to a level where we can reasonably estimate the time and resources needed for each piece of functionality. These are not top-down estimates nor are they bottom-up. We simply need a reasonable guesstimate.

The techniques described in Chapter 4 can be used here to build the mid-level WBS. Typically, the mid-level WBS is detailed down to level 2, but this is not mandatory. Level 2 would consist of subfunctions, but they are still noun-type statements. If you find yourself decomposing using verb-type statements, you have gone too far. In the APF mid-level WBS, the lowest level of detail is still a definition of what needs to be built (functionality) rather than how it is built. This is an important distinction. To define how to build something that may not even be built is a waste of time. Again, why plan the future when you don’t know what it is?

Prioritizing the Version Functionality

Using the mid-level WBS as a starting point, the core team, along with representatives from the requestor organization, must determine the priorities of the subfunctions identified in the mid-level WBS. Before you can determine the priorities of the various functionalities, you need a criterion on which to make those priority decisions. Some possibilities are risk, complexity, duration, business value, or dependencies. Let’s take a look at each one and discuss some of the reasons why you might want to use it.

Risk

This criterion suggests that high-risk functionality has the highest priority and low-risk functionality has the lowest priority. Why? The strategy goes something like this. If we get started on the tough stuff early and we have problems, we’ll have time to make any mid-project corrections. If we leave it till later, we may not have time to solve it before the version timebox expires.

Complexity

This criterion says that highly complex functionality has the highest priority and low-complexity functionality has the lowest priority. Why? The rationale here is exactly the same as the risk criterion.

Duration

This criterion says that short duration functionality has the highest priority and long duration functionality has the lowest priority. Again, why? If the driving strategy is to get something to the client ASAP, this criterion does the job. This criterion also keeps the client’s interest at a high level. You don’t want them to wait three months before you produce some working piece of the solution, and this strategy allows you to get back to them quickly. They have something to inspect, and you get some input for the next cycle. As you move further into the cycles, cycle length can increase because by that time you will have the committed interest of the client and longer cycles will not be a problem for them.

Business Value

This criterion states that high business value has the highest priority and low business value has the lowest priority. From a business perspective, this criterion makes perfect sense. Get the most business value into the solution ASAP and start to reap the benefits.

Dependencies

There will be cases where the functions and even subfunctions between two or more functions are dependent upon one another. For example, subfunction A1 in function A must be in place in order for subfunction B2 in function B to work. Dependencies like the example may suggest that subfunctions A1 and B2 be in the same cycle build.

So which criterion do you use? If you guessed that the answer is “it depends,” you are partially right. Actually, the best strategy is to defer to the client for the answer. Of course, you as project manager had better provide a detailed analysis of the pluses and minuses of each choice. Still, this decision is really a business decision, and the client is in the best position to give the answer. In any case, the functionality gets prioritized.

Prioritization Approaches

Before we leave this topic, we need to spend a few lines on what that prioritization looks like. The choice of how you establish the priority order of the subfunctions is entirely up to the client and the team. If you need some suggestions about the rule you will use to prioritize, here are three suggestions. They are briefly described in the sections that follow by way of examples.

Forced Ranking

The first approach to prioritizing is called forced ranking. Suppose 10 pieces of functionality have been requested. Number them 1, 2, ..., 10 so that we can refer to them later on. Let’s also suppose that the client has a panel of six managers (A, B, ..., F), and they are each asked to rank the functionality from most important (1) to least important (10). They can use any criteria they wish, and they do not have to describe the criteria they used. The results of their rankings are shown in Table 14.1.

Table 14.1: Force Ranking of 10 Pieces of Functionality
Functionality # | A | B | C | D | E | F | Rank Sum | Forced Rank
1 | 2 | 5 | 3 | 2 | 1 | 6 | 19 | 2
2 | 4 | 3 | 2 | 7 | 9 | 10 | 35 | 6
3 | 7 | 4 | 9 | 8 | 6 | 3 | 37 | 7
4 | 1 | 8 | 5 | 1 | 2 | 2 | 19 | 3
5 | 3 | 6 | 8 | 4 | 7 | 5 | 33 | 5
6 | 8 | 9 | 10 | 9 | 10 | 8 | 54 | 9
7 | 5 | 1 | 1 | 3 | 3 | 4 | 17 | 1
8 | 6 | 2 | 4 | 5 | 4 | 1 | 22 | 4
9 | 10 | 10 | 7 | 10 | 8 | 9 | 54 | 10
10 | 9 | 7 | 6 | 6 | 5 | 7 | 40 | 8

The individual rankings from each of the six members for specific functions (or subfunctions) are added to produce the rank sum for each function (or subfunction). Low values for the rank sum are indicative of functions (or subfunctions) that have been given high priority by the members. So for example, Function 7 has the lowest rank sum and is therefore the highest-priority function. Ties are possible. In fact, the preceding example has two ties (1 and 4, 6 and 9). Ties can be broken in a number of ways. We prefer to use the existing rankings to break ties. In this example, taking the tied function with the lowest rank score and moving it to the next lowest forced rank breaks a tie. For example, the lowest rank for Function 1 is 6, and the lowest rank for Function 4 is 8. Therefore, the tie is broken by giving Function 1 a rank of 2 and Function 4 a rank of 3.

Must-Haves, Should-Haves, Nice-to-Haves

The second prioritization approach is a bit less demanding. Here you simply create three buckets: the must-haves, the should-haves, and the nice-to-haves. Every piece of functionality is assigned to one and only one bucket. Be careful with this one because there is a temptation to make everything a must-have. To prevent that from happening, you might put a rule in place that every bucket must have at least 20 percent of the functionality in it. Adjust the percentage to suit your taste.

Q-Sort

The third approach to prioritizing is called the Q-Sort. This approach discussed by William E. Souder in Project Selection and Economic Appraisal (Van Nostrand Reinhold, 1984) starts out much like the previous one. Functions (or subfunctions) are divided into two groups: high priority and low priority. The high-priority group is then divided into two groups: high priority and medium priority. The low-priority group is also divided into two groups: low priority and medium priority. The next step is to divide the High-Priority group into two groups: very high priority and high priority. The same is done for the low-priority group. The decomposition continues until all groups have eight or fewer members (see Figure 14.3). As a last step, you could distribute the medium priority projects to the other final groups.

Prioritizing the Scope Triangle

You are probably wondering why we would want to do this or even what it means to prioritize the scope triangle. First, let’s define the scope triangle, and then we can talk intelligently about what it means to prioritize it and why we want to do that. Figure 14.4 is the scope triangle that is used in APF. It’s the same one that was introduced in Chapter 1 and is reproduced here for your convenience.

Click To expand
Figure 14.3: An example of the Q-Sort.

Recall that the scope triangle consists of five variables: time, cost, resource availability, scope, and quality. To understand the triangle, think in terms of geometry. There is a triangle whose area is defined by scope and quality. The triangle is bounded by the three sides defined by time, cost, and resource availability. The sides are exactly long enough to bound the area defined by scope and quality. This triangle also represents a system in balance because of its geometric properties. If any one of these variables should change (client wants the deliverables earlier than originally planned or a scarce resource leaves the company and will be very difficult to replace), the length of its line will decrease, and the three sides of the triangle could no longer encompass the area represented by scope and quality. Then one or more of the other variables must somehow change in order to bring this system back into balance.

Click To expand
Figure 14.4: The scope triangle.

In APF this scope triangle is used as our model for decision making. First, we have to prioritize the five variables that define the triangle. The highest-priority variable will be the one that we will change only as a last resort. For example, suppose we are developing a new release of a commercial software package, and getting to market first is very important to our business strategy. Time will be our highest-priority variable. Cost might be our second priority because the price points for this type of product are well-established by the competition.

A useful tool for establishing the scope triangle priorities was developed by Rob Thomsett in his book Radical Project Management (Prentice Hall, 2002). It is called success sliders. We have adapted it to the scope triangle as shown in Figure 14.5.

Click To expand
Figure 14.5: Success sliders for the scope triangle.

Think of each of these sliders as a dimmer switch. Accompanying each criterion is a dimmer switch that is set to ON or OFF, or any spot in between. If the dimmer switch is set to ON, then the constraint is binding. In other words, there is no room for compromise. That constraint must be met. For example, if the dimmer switch for the delivery date of the product was set to ON, that date is firm and may not be compromised. If the dimmer switch is set to OFF, the constraint is not binding. For example, if the dimmer switch for budget was set to OFF, that means that the budget constraint is not binding and more dollars can be made available for good business reasons. If the dimmer switch is set somewhere between ON and OFF, the sponsor is willing to negotiate that constraint. The closer the setting is to either endpoint, the more or less flexible the sponsor is willing to be. To determine the settings, the stakeholder should be asked for their individual opinions. The sponsor will use that data to make the final determination as to the settings.

Determining the Number of Cycles and Cycle Timeboxes

This task can be as simple or as complex as you care to make it. We don’t need to make a lifetime project out of this step, so for a first pass, we suggest that you think in terms of four-week cycles and simply compute how many of them you can fit into the version timebox. Later on, when you assign functionality to each cycle, you may want to adjust cycle length to accommodate the subfunctions that will be built in a particular cycle. If you want to be a little more sophisticated, take a look at the durations of the prioritized functionality and determine cycle length from those data. In this approach, you may vary cycle length so as to accommodate functionality durations of varying lengths. If you want to get even more sophisticated, take a look at dependencies between pieces of functionality, and sequence the development effort across cycles with those dependencies in mind.

There are a number of ways to proceed here. Choose the one that is the best for your needs. The most important consideration is the core value that says to deliver incremental results early and often. Once we complete the Version Scope phase with our clients, they are excited about the project. They want to see results, and to have them wait for even eight weeks may dampen their enthusiasm. For that reason, you should think in terms of quick deliverables early in the cycles and leave more extensive build activities for later cycles. The early part of the project is the best time to capture the involvement of the clients. Don’t miss that opportunity.

Assigning Functionality to Cycles

Using the established priorities, simply map the functionality into the cycles, and then step back and ask the following questions about what you have just done:

  • Based on the dependencies between functionality and the resources available, does this assignment make sense?

  • When you finish the first few cycles, will you have a working version of part of the final solution?

  • Can you improve on this assignment if you vary cycle length for the early cycles?

  • Does this assignment fully utilize your resources in the early cycles?

  • Are you practicing the core value to “deliver incremental results early and often”?

There is no substitute for common sense, and we always want to do what is right. Don’t make the mistake that a traditionalist might make if they were making the assignments. Don’t plan the details out to the last cycle. You really have no idea what will take place in the late cycles. Focus on the first few cycles and do what makes sense for them. We’ll worry about the later cycles in due time.

Writing Objective Statements for Each Cycle

These objective statements are primarily for the benefit of the clients and their management. You need to be able to tell them what they can expect at each cycle. The objectives have to make business sense, and that means you may need some further modification of the assignments to each cycle as a result of the client having reviewed and commented on your plan so far. You also want to make sure that the client can do something productive with the deliverables from each cycle. Those deliverables are your key to further modifications of the version scope that will be discussed at the Client Checkpoint phase following the completion of a Cycle Build phase.


Putting It All Together

We hope you are beginning to get a feel for what APF has to offer and how it differs from the traditionalist approach. So far, we’ve only completed our discussion of the first phase of APF. Some of it is similar to the traditionalist approach, but some of it is quite different. For example, APF uses the WBS but not to the extent that the traditionalist approach does. Traditionalists develop a complete WBS because they have to show all of the work needed to complete the project. After all, that’s what the definition of the WBS says you have to do. The project manager using APF would say that’s great as long as you know all of the work that has to be done. In APF we don’t know all the work that has to be done, and so we are taking some liberties with the WBS. We are going to define only the early work that has to be done (the topic of the next chapter). Some of that later work, even though we think we know what it is, may not be done. Why worry about it? We’ll take care of that part of our planning when we need to, and right now we don’t need to.

At this point we have done all of the planning that we are going to do for the version. In the next chapter, we complete the planning for the next cycle.


Discussion Questions

  1. From what you know so far about APF, do you see a conflict between process and people? Explain.

  2. Clients are always reluctant to get too involved in planning. What might you do to sell them on the idea that their full involvement in APF is needed for this effort to succeed?

  3. Referring to the case study in the Introduction, how might you define the version scope if you were to use APF instead of TPM? Be careful to differentiate between functions and features that you know will be in the final solution versus those that would be nice to have.


Chapter 15: Cycle Plan

Overview

You’ve got to think about “big things” while you’re doing small things, so that all the small things go in the right direction.

—Alvin Toffler

This chapter will bear remarkable similarity to the TPM approach. In fact, everything we do in this chapter the traditionalist will also do. See Figure 15.1 There are two differences. The first difference is that the traditionalist will do it for the entire project using a complete version of the WBS. As noted in the previous chapter, the project manager using APF (APFist) works only on the part of the WBS that corresponds to the work that will be done in the cycle coming up. Anything beyond that would be conjecture on the part of the APFist. The second difference is that the traditionalist will use project management software, while the APFist will use a whiteboard, Post-It notes, and marking pens. The APFist could use project management software, but it is not necessary. In fact, using project management software to do cycle planning is like killing mosquitoes with sledgehammers. Remember that cycle length is typically around two to six weeks, and that is the window of time over which the APFist is doing cycle planning. Because TPM and APF are so similar in this planning stage, there will be some repetition of material presented in Part I. The repetition is needed to keep the presentation flowing smoothly, but we will try to keep it to a minimum.

Start Sidebar
Chapter Learning Objectives

After reading this chapter, you will be able to:

  • Create a low-level WBS for a cycle

  • Apply the WBS completion criteria to the low-level WBS

  • Understand the problems associated with APF micromanagement

  • Estimate resource requirements

  • Sequence the low-level WBS tasks

    Click To expand
    Figure 15.1: Cycle Plan phase.

    Note

    If you are an APFist and you still want to use project management software, be our guest. Just remember that you have to feed and care for the monster that you create. Ask yourself if the time spent doing that is really value-added time. Two years ago we don’t think you would have heard us say anything like that. Then we worked with a few major clients over those two years and watched and participated with them as they integrated the approach that we have just explained. It works and it really does save time.
End Sidebar


Developing a Low-Level WBS for This Cycle Functionality

Our starting point for the cycle plan is the mid-level WBS, which we created in Chapter 14. Figure 15.2 is a generic version of the mid-level WBS. We decomposed the WBS down to the second level, which is still expressing the WBS in terms of deliverables—the functionality that was identified in the Version Scope phase. In this phase we will extract from the mid-level WBS the functionality that will be worked on during the cycle we are now planning. It is that part of the WBS that becomes the basis of our cycle plan and that we will decompose down to the low level. This level is where we define the WBS down to the task level. This decomposition will be in terms of verb-type statements rather than the noun-type statements that are characteristics of the mid-level WBS.

Click To expand
Figure 15.2: Mid-level WBS.

So far the mid-level WBS is deliverables-oriented (subfunctions). We will create the low-level WBS for each of the subfunctions assigned to this cycle. To do that, we have to decompose deliverables into activities and finally into tasks that must be done to produce the deliverables. The top-down approach is our clear choice for how to do this. Start with any subfunction and ask yourself, “What major activities (segments of work) must be done in order to deliver this subfunction?” Think in the broadest sense, and come up with three to five activities. At this level we are defining work, and that means a verb statement. Make sure these activities are defined at a high enough level so that you can easily tell when they are all completed and when the subfunction is completed. We will continue this decomposition of activities until certain completion criteria have been met. Once an activity meets the completion criteria, we call it a task. No other activity will have this property, and so the term task is a precise term in our project management vocabulary.

Cross-Reference

The completion criteria are fully discussed in Chapter 4. See that chapter for more details.


Micromanaging an APF Project

Remember that every activity that you define in the low-level WBS must be managed. That opens up the possibility of micromanagement. We want to make sure that the final decomposition isn’t at such a granular level that we are forcing ourselves to be micromanagers.

Warning

Understand at the outset that micromanagement is an easy trap to fall into in an APF project.

Best APF practices suggest that you manage an individual’s work down to units of one week. For example, Harry is going to work on an activity that requires 10 hours of effort. The activity is scheduled to begin on Monday morning and to be completed by Friday afternoon. Harry has agreed that he can accommodate the 10 hours within the week given his other commitments during that same week. Now, Harry’s manager (or the project manager) could ask Harry to report exactly when during the week he will be working on this 10-hour activity and then hold him to that plan. What a waste of everyone’s time that would be, let alone an insult to Harry’s abilities and commitment. Why not give Harry credit for enough intelligence to make his commitments at the one-week level? No need to drill down into the workweek and burden Harry with a micro-plan and his manager with the burden of managing that micro-plan. The net result of this micromanagement may, in fact, be to increase the actual time to complete the activity, because Harry has been burdened with the need to comply with the unnecessary management oversight done by his manager. The exemplary APF project manager will place more confidence in the team member knowing that the processes are in place to ensure plan attainment. Harry, being the good team player that he is, will report daily on status and let us know if there are any issues or concerns regarding his meeting his commitments for delivery. In other words, we manage Harry on an exception basis, and we accept his status reports.

It is more valuable to the project to have the APF project manager spend time encouraging that behavior from Harry than it is to waste the time micromanaging Harry. If it should happen that Harry doesn’t deliver against the commitment, there will certainly be a conversation between him and the project manager about future assignments and how progress will be managed. As you can see in this example, APF defines a structured framework, and within that framework, it gives maximum latitude to the team members.

Once the low-level WBS has been deemed complete and all task durations have been estimated, print the unique name of each task and its duration on a separate Post-It note. For an added efficiency, you might color-code the Post-It notes. Each function gets a different color. You will see the value of this later in the phase. If you are still using project management software, enter the name of each task and its duration into the package. Print the PERT diagram, which will produce a columnar display of the tasks because no dependencies have been specified. You can then cut out each task node and tape each one to a Post-It note.

By defining project tasks according to the completion criteria, you should have reached a point of granularity with each task so that it is familiar. You may have done the task or something very similar to it in a past project. That recollection, that historical information, gives us the basis for estimating the resources you will need to complete the tasks in the current project. In some cases, it is a straightforward recollection; in others, the result of keeping a historical file of similar tasks; in others, the advice of experts.


Estimating Task Duration

For each task estimate the clock time (duration) it would take with normal resources to complete it. Don’t get heroic here. This estimation is nothing different than the traditionalist would do at this point. Just think of the average skilled person working on the task at a normal pace with all of the interruptions and so on that get in the way. That is the duration we want to record for this task. Record this duration in the software tool, if you are using one.

Cross-Reference

Chapter 5 provides the tools you will need to complete this level of estimation.


Estimating Resource Requirements

There are two ways to approach this estimation: by skill or by person. You may not have your team assembled yet and may have to estimate resource requirements by skills needed. If you do have your team together, which you most likely will at this point in the project, they will be participating in the cycle plan, and by person is OK. Add their name to the Post-It notes for the tasks they will work on. Alternatively, you might consider color-coding the Post-It notes so that each color represents a different person. Be creative because this visual display will be the foundation of all further planning and plan adjustment for this cycle. These strategies may be low-tech, but believe us, they work! For the high-tech folks, add this information to the software tool and print the PERT diagram. You can then cut out each node, and you will be in the same place as the low-tech folks.

Types of resources include the following:

People. In most cases, the resources you will have to schedule are people resources. This is also the most difficult type of resource to schedule.

Facilities. Project work takes place in locations. Planning rooms, conference rooms, presentation rooms, and auditoriums are but a few examples of facilities that projects require. The exact specifications as well as the precise time at which they are needed are some of the variables that must be taken into account. The project plan can provide the detail required. The facility specification will also drive the project schedule based on availability.

Equipment. Equipment is treated exactly the same as facilities. What is needed and when it is needed drive the activity schedule based on availability.

Money. Accountants would tell us that everything is eventually reduced to dollars, and that is true. Project expenses typically include travel, room and meals, and supplies.

Materials. Parts to be used in the fabrication of products and other physical deliverables are often part of the project work, too. For example, the materials needed to build a bicycle might include nuts, bolts, washers, and spacers.

Determining Resource Requirements in the WBS

The planning team includes resource managers or their representatives. At the time the planning team is defining the WBS and estimating task duration, they will also estimate resource requirements.

We have found the following practice effective. First, create a list of all the resources required for the cycle. For people resources, list only position title or skill level. Do not name specific people even if there is only one person with the requisite skills. Envision a person with the typical skill set and loading on the project activity. Task duration estimates are based on workers of average skill level, and resource requirements should be also. You will worry about changing this relationship later in the planning session. Second, when the WBS is presented, resource requirements can be reported, too.

Identifying a Specific Resource Needed

Knowing the need for a specific resource will occur quite often. When the situation comes up, we are faced with the question, “Should we put that specific person in the plan?” If you do and if that person is not available when you need him or her, how will that affect your cycle plan? If he or she is very highly skilled and you used that information to estimate the duration of the task that person was to work on, you may have a problem. If you cannot replace him or her with an equally skilled individual, will that create a slippage that dominoes through the cycle schedule? Take your choice. It’s often a good idea to have a contingency plan if you can’t get a specific resource at exactly the time when you need him or her.

We now have estimated the parameters needed to begin constructing the cycle schedule. The task duration estimates provide input to planning the order and sequence of completing the work defined by the tasks. Once the initial schedule is built, we can use the resource requirements and availability data to further modify the schedule.


Sequencing the Tasks

Now we are going to put all the pieces of the puzzle together for a first look at what we have. Arrange these tasks in the shape of a network diagram from left to right on the whiteboard, showing their dependencies with the marking pens. You can follow the same procedure used in Chapter 6. You will want to scale the display on a time line so that you will know if you are meeting the cycle timebox constraint. The high-tech folks won’t be able to resist the temptation and will go ahead and put these dependencies into the software tool.

They will let the tool tell them when the critical path ends. That’s fine; just remember that the cycle task duration is only two to six weeks, so the task list will be short. Be careful not to create a monster in your software tool, because you will have to feed it throughout the cycle to get any return for your investment of time.

The tasks are few in number, and you know the resources availability of your team members. APF works best when the resources are assigned 100 percent to the cycle. If that is the case, you should have total control over their schedule. That means that you can create the cycle schedule with both dependencies and resources schedules taken into account. The traditionalist seldom has that luxury.


Putting It All Together

We’ve come as far as we can with the cycle plan. It is now time to go into execution mode. There are a few more cycle plan details to figure out, but these are better left as the starting activities in the Cycle Build phase, which is discussed in the next chapter.


Discussion Questions

  1. Suppose your team has one person who can’t do without the support of a software tool and another who is violently opposed to using them. You are the project manager. How might you resolve this dilemma?

  2. Make a list of the advantages and disadvantages of using and not using a project management software tool for this phase of APF. Discuss your findings. Does either approach win out over the other? In what ways?

  3. Suppose you were to use the case study results from Discussion Question 3 in Chapter 14 to build your cycle plan. What risks might there be from having isolated these tasks from the rest of the WBS? How would you mitigate these risks? Be specific.


Chapter 16: Cycle Build

Overview

Try several solutions at once. Maybe none of them, alone, would solve the problem, but in combination they do the job.

—Ray Josephs, President, Ray Josephs Associates, Inc.

No matter how complicated a problem is, it usually can be reduced to a simple, comprehensible form, which is often the best solution.

—Dr. An Wang

The Cycle Plan phase works best as a team event, but we realize that some project teams might not be fully staffed and able to participate in the Cycle Plan phase. For that reason, we have left the remaining details of the cycle plan for this phase. The Cycle Build phase is an event that requires the presence of the entire team from the very start of the phase. We left the Cycle Plan phase with a first pass at the cycle build schedule. We start this phase by continuing to work with the schedule and complete the last details of scheduling in this phase. Figure 16.1 graphically displays the Cycle Build phase.

Start Sidebar
Chapter Learning Objectives

After reading this chapter, you will be able to:

  • Build a micro-level WBS

  • Create a micro-level network schedule for the cycle build

  • Display and update the micro-level resource schedule

  • Understand the purpose of the Scope Bank

  • Use the Scope Bank to record change requests

  • Use the Issues Log to record and resolve cycle build problems

    Click To expand
    Figure 16.1: Cycle Build phase.

End Sidebar


Creating a Micro-Level Schedule and Finalizing Resource Assignments

The team begins the creation of the micro-level schedule by taking the tasks that make up this cycle’s functionality and further decomposing them to the subtask level. This process is a top-down whole-team exercise, and it follows the same process that is discussed in Chapter 4. Once the micro-level WBS has been created, perform two basic tasks:

  • Make Post-It notes for each of these subtasks and lay them out in a network diagram as shown in the upper portion of Figure 16.2. Note that the network diagram is time-scaled. This time scaling is important because it is going to replace what otherwise would have been a schedule produced by a project management software package.

  • At another spot on the whiteboard (ideally below the network diagram and on the same time scale), lay out a grid that shows the time line on a daily basis across the columns, and have one row allocated to each resource. The resources for this example are Duffy, Ernie, and Fran. Show all seven days on this grid. For any workday or half workday in this cycle for which a resource will not be available for cycle build work, put an X or some other indicator of unavailability (we have used shading to indicate unavailability in the figure) in the corresponding cell or half cell. This grid is your resource calendar for this cycle.

    Tip

    Half-day units are the smallest unit of time that we build our plan around. Smaller units just create non-value-added work and begin to border on micromanagement.

The lower part of Figure 16.2 gives an example grid for the network diagram. For this example, the tasks in this cycle build were A, B, and C. The subtasks, which are what we are scheduling, are A1, A2, B1, B2, C1, C2, and C3.

Click To expand
Figure 16.2: An example micro-level schedule.

Before we finalize the micro-level schedule, check to see if the initial schedule and resource assignments allow the team to complete the cycle within the cycle timebox. You can do this by inspecting the scaled time line you created in the Cycle Plan phase. If the current schedule doesn’t meet the cycle timebox, look for alternative resource assignments that bring the schedule inside the cycle timebox. Resources that are not assigned for periods of time are the place to look. They can either take over a task or help another resource complete a task earlier than currently scheduled. What you are doing is manual resource leveling in a way that makes more sense than the approach taken by most software tools. Some of the ideas presented in Chapter 12 may be useful for this work.

Once you have met the cycle timebox constraint, you are ready to finalize the information on the grid. For each resource, simply transfer the information to the grid that shows what task he or she is working on, what day he or she expects to start it, and what day he or she expects to end it. Every morning you will have a team status meeting, at which time you compare what was completed the previous day with what the grid had scheduled for that day. Any adjustments to the plan are made on the grid. Resources can be moved to meet schedule delays. Because you still have the Post-It note network diagram on the whiteboard, you will be able to see if schedule delays will cause any other delays downstream in the plan, and you can adjust accordingly.

Let’s look at a few important points with regard to Figure 16.2:

  • First, when scheduling resources, try to keep them busy for consecutive days. That makes it easier if you need to replace an individual on the team.

  • Second, notice when a resource is not busy (for example, Duffy is available for a half-day on Thursday of the first week). While this is early in the cycle, it may provide a resource that can help either Ernie or Fran or help the team recover from a slippage or a problem.

  • Finally, note that in the second week Duffy and Ernie are available to perhaps help Fran complete C2 when Fran is unavailable on Wednesday afternoon. If that can be scheduled, C3 may be able to be completed early. This means that the cycle would be completed ahead of schedule. Alternatively, that staffing adjustment might provide a way to make up for earlier slippages.

This grid should be permanently displayed in the team war room. It will be the focal point of daily team meetings. As status is being reported, the team can refer to this schedule and make any changes to the latter parts of the schedule. The most important benefit to having it displayed is that it is visible and accessible to the team. The only negative you have to worry about is that there is no backup for this approach. The fact that the team war room is reserved for the exclusive use of the team and is secure will mitigate most of the risk but not all of the risk.

Tip

We have made it a practice to have one of the team members, when he or she is not otherwise busy, update an electronic version of the data posted in the team war room. Because this is only for backup, it doesn’t need to be saved in a high-powered software application. A word processor or a spreadsheet package will do just fine. We have even used Visio on occasion.

The reason that the use of Post-It notes and the grid works is that the cycle length is short. The example cycle is only two weeks long, but even if it was three or four weeks long, the same approach will work. Even though we have used project management software packages extensively, we still find this low-tech approach to be far more intuitive than any software display. The entire team can see what’s going on and can see how to resolve scheduling problems in a very intuitive manner. Try it.

This approach would never do well in TPM for the following reasons:

  • The network diagram would take up too much real estate and is generally not available from the software package, and not because it can’t be generated. We all know that it can, but the labor to create it just doesn’t justify it.

  • Resource balancing is the other side of the coin. On the whiteboard it is easy. In a software package, who knows what happens when you try to level resources? Most popular project management software packages level resources using an algorithm that starts at the beginning of the project and works on the critical path, moving the task schedule out in time to remove any overallocations of resources. That sounds all right, but in our experience, it has produced some rather bizarre resource schedules that put the project completion date outside what the client requires. Because we are working with a cycle of only a few weeks, we can easily represent the problem on the grid and create a workable resource schedule that meets client time line requirements for this cycle. We want to see the problem, and the software package just doesn’t measure up.


Writing Work Packages

By inspection you will be able to identify the critical tasks for which work packages will be needed. The aficionados will want to use a software tool to locate the critical path. That’s fine, but don’t let the tool do the thinking for you. The critical path tasks are only some of the tasks for which a work package will be written. The actual decision as to which tasks you finally decide to create work packages for is based not just on how those tasks fit into the cycle schedule but who is working on them, what level of risk is associated with the task, whether or not the assigned resources are scarce resources, and a host of other factors. We would rather have you reason to the decision than to default to the software tool. There is no substitute for thinking.

For every critical task in the cycle plan, it is a good insurance policy to have the person responsible for the subtasks develop a brief step-by-step description of what they plan on doing to complete the subtask within the allotted time. Remember, these subtasks are of short duration (only a few days) and quite simple to understand. The description should be one or two sentences. Your concern here is to not add a lot of narrative, which may turn out to be lost effort and time. Don’t waste time! If you lose that person or have to reassign the subtask, the person who takes over can continue with minimal loss of time.

You might also want to create work packages for high-risk tasks or tasks for which there is little experience among the team members. We have tended to write work packages for tasks that require a scarce resource. If we lose that resource, perhaps we can replace it with less skilled resources and depend on the work package to help them over the tough spots. If formatted correctly, the task manager can use this work package to post progress and record any other information that might be useful in the event that he is not able to continue with the cycle build.


Building Cycle Functionality

Work is now underway to build the functionality prioritized for this cycle. Even though the cycle is short and the build not very complex, things will not go according to plan. About this time the APFist is thankful that not a lot of time was spent planning and takes the unexpected in stride. Something unexpected is sure to happen. A person gets sick or leaves the company; a vendor is late in shipping or ships the wrong hardware or goes out of business. These are the same kinds of risks that the traditionalist faces, but for them the results are far more catastrophic than they are for the APFist.

Depending on the severity, the APFist either finishes the current cycle or, for the really major problems, cancels the current cycle and immediately moves into the Cycle Plan phase for the next cycle. In rare cases, he or she may jointly decide with the client to cancel the version and start all over, if at all.

Note

Note that by making these decisions at this point in the process, the APF approach wastes the minimum amount of time and money as compared to the traditionalist approach.


Monitoring and Adjusting the Cycle Build Schedule

The team will have morning team status meetings every day—no exceptions. The meeting need not last more than 15 minutes. Everyone is standing and everyone gives his or her status. If the status is behind, each should report what he or she plans on doing to catch up. Issues that affect only certain members of the team are taken offline by the affected persons so as not to waste the time of the entire team. Those who are ahead of plan become a resource for the others. We are talking here about minor adjustments to a few weeks of work. There are no big surprises.

To help monitor and adjust the cycle build schedule, the team will use three tools continually throughout the Cycle Build phase:

  • Scope Bank

  • Issues Log

  • Prioritized Scope Matrix

Maintaining a Scope Bank

The process of discovery and learning by the team is continuous throughout the cycle. Any new ideas or thoughts on functionality are simply recorded in the Scope Bank and saved for the Client Checkpoint phase. The Scope Bank can physically be a list posted in the team room, or some electronic form (spreadsheet or word processing document). Whichever form you decide to use, make sure it is visible to the team. Changes to scope are never made during a cycle. The cycle plan is adhered to religiously. There are no schedule extensions or additions of resources within a cycle. Whatever can get done gets done. All of these extraneous items are taken up in the Client Checkpoint phase.

The following fields make up the Scope Bank:

  • Date posted

  • Posted by

  • Brief description of scope item

  • Assigned to

  • Date scheduled for action

  • Recommended action

  • Reason for recommendation

The Scope Bank is posted in the team war room. The first three items are completed by the person who initiated the scope item. At the next team meeting, someone is assigned to investigate the scope item further. He or she reports back at the team meeting on or before the date scheduled for action. The report consists of a recommended action and a reason for the recommendation. The date scheduled for action is changed to the date of the next client checkpoint. Until that time, this information remains in the Scope Bank to be acted upon at the client checkpoint.

Maintaining an Issues Log

Despite all of the team’s due diligence in putting the micro-level schedule together, there will be problems. We don’t need to enumerate what they might be—we all know them by now. The bigger issue for APF is how to handle them within the context of a learning and discovery framework.

The fields that make up the Issues Log are as follows:

  • Date posted

  • Date scheduled for resolution

  • Posted by

  • Assigned to

  • Brief description of issue

  • Current status of issue

  • Next step

The Issues Log is posted in the team war room and lists the problems and issues that the team has encountered during the cycle. Because the list is continually changing, we recommend that it be handwritten (we use nonpermanent marking pens) in a convenient location on the whiteboard. That facilitates the updating and keeps it always visible to the team. It contains the information shown in this bullet list and is updated daily. The items in the Issues Log need resolution, and there should be a plan to resolve them. The person to whom the issue was assigned is responsible for developing that plan and keeping the team informed through daily team meetings of the status and next steps of the plan.

Using a Prioritized Scope Matrix

Any additions to either the Scope Bank or the Issues Log must take into account the prioritization of the project constraints.

Cross-Reference

Refer to Chapter 14, where we discuss how the prioritization is done. Here we discuss how to apply it.

  • For the Scope Bank entry, which was either a change request or an idea, a project impact statement should accompany the entry. At this point the impact statement should include comments relevant to the constraints that will be impacted if the change request or idea is incorporated in the version scope. There may be alternative ways to satisfy the change request or idea, and each of these should also have an impact statement relative to the constraints. Remember, the impact statement is brief. Don’t get all wrapped up writing the perfect document in the king’s best English. Just get the basic information recorded in the Scope Bank. Do it at the time the change request or idea is new, so that a good idea is not lost with the passage of time.

  • For the Issues Log entry, which is the statement of a problem or a condition that has arisen, the Prioritized Scope Matrix serves a different purpose. There will typically be a sense of urgency with an Issues Log entry. If it affects the current cycle, something must be done ASAP. Here is where the prioritized constraints help us. The constraints help us focus our efforts at finding a solution within the constraints that are available to us. These constraints will save us the needless wasting of time pursuing solutions that are not feasible in the minds of the stakeholders and sponsor.

Holding Team Meetings

The entire project team meets every morning for about 15 minutes. These are stand-up meetings where status is reported. Each task leader should state where he or she is with respect to the time line (ahead, on target, or behind) and if his or her team is ahead or behind, by how many hours or days. If the team is behind, they should briefly state their get-well plan. If anyone in the meeting is able to help, that person should say so and take that conversation offline. Problems and issues are not discussed in the team meeting except to

add them to the Scope Bank and Issues Log. Their resolution or further clarification should be dealt with by the affected parties offline. Do not use team time to discuss things that are of interest to only a few members.

For larger teams (above 20 members) there is an exception to what we just outlined in the previous paragraph. Such teams generally have task leaders who have a few team members responsible to them for their work. In such cases the task leaders should meet daily and inform their team of the outcome of those meetings. Once a week the entire team should gather for a team meeting.

Tip

While the project manager might be the first choice for leading the team meetings, this is not necessary. Rotating the person who leads the team meeting is a good idea. It gives others a chance to develop that skill.

Status Reports

The project status is always posted in the team war room and is kept up-to-date. Anyone who has an interest or a need to know can always go there for the details. Brief written status reports should be available for the client at the end of each cycle and more lengthy reports to senior management at the end of the version. While the project is underway, we tend to place responsibility for status reporting outside of the extended project team into the hands of the client. Placing it with the client maintains the core value of a client-focused and client-driven approach. Ownership is in the hands of the client, not in the hands of the project manager or project team. That is as it should be. The reason for this recommendation is that it puts the client in a position of responsibility for reporting the status of their project to senior management. It now becomes a business-type report not a project-type report.


Putting It All Together

With a few exceptions, the Cycle Build phase looks just like the traditionalist approach. Note, however, that the cycle plan and functionality is not tampered with. Whatever doesn’t get done within the cycle is reconsidered for the next or some future cycle. Change management, which is a big issue for the traditionalist, doesn’t even come up in APF. It is imbedded in the Client Checkpoint phase as a routine activity. In the next chapter, we spend some time on the Client Checkpoint phase. It is the critical piece that makes or breaks APF.


Discussion Questions

  1. Make a list of the advantages and disadvantages of using a high-tech versus a low-tech approach in this phase of the project. Discuss your findings. Does either approach win out over the other? In what ways?

  2. Clearly, this phase is very dependent upon the people on your team. APF gives team members great discretion in completing their work. If you were managing an APF project, how would you balance your need to know against the need to empower team members to do their work? Be specific.

  3. Compare what happens with a TPM project and an APF project when a team member is taken off the team and no longer available. What are the impacts on each approach? Which approach is least affected by such a change? To do this comparison, you will be considering a full TPM plan versus an APF cycle plan.


Chapter 17: Client Checkpoint

Overview

Any plan is bad which is not susceptible to change.

—Bartolommeo de San Concordio, Florentine painter and writer

One of the real advantages of APF over other approaches is that the client is involved as a principal and as a decision maker at all critical junctures in the project. Because cycle length is so short and is so controlled, there is little that can go wrong that is not easily corrected. Within the cycle itself, not even a day goes by that the team doesn’t take stock of where it is compared to where it was planned to be and adjusts accordingly. So it is true between cycles. Little can go wrong that cannot be corrected. Few dollars and little time are wasted because of the structure of APF. This chapter is really the heart of APF. It is here that the team and the client spend valuable time looking at what was done, reflecting on what was discovered and learned since the last checkpoint, and planning the functionality that will be built in the next cycle.

Start Sidebar
Chapter Learning Objectives

After reading this chapter, you will be able to:

  • Explain the significance of each input to the client checkpoint

  • Assess the status of the completed cycle relative to its plan

  • Describe the inputs to the next cycle plan

  • Explain the outputs of the client checkpoint

End Sidebar

As you will see, this introspection with client and project team fully engaged is a very thorough process. If properly done, it is unlikely that anything significant will be missed. Figure 17.1 is a graphical display of the Client Checkpoint phase.

Click To expand
Figure 17.1: Client Checkpoint phase.


Inputs to the Client Checkpoint

The following lists the inputs to the Client Checkpoint phase:

  • Planned versus actual functionality added

  • Scope Bank

Planned versus Actual Functionality Added

For the cycle just completed, the cycle plan called for a specific list of functionality to be added to the deliverables. No changes were made during the cycle, so it is possible that not all the planned functionality actually made it into the deliverables. There are several reasons for that, which we will not discuss; they are obvious (schedule slippages that could not be recovered, a discovery that rendered the functionality unnecessary). Any functionality not completed in the just completed cycle will be prioritized along with this cycle’s functionality and any adjustments made in the cycle plan going forward.

Scope Bank

First discussed in Chapter 16, the Scope Bank is the cumulative depository of all the ideas and proposed changes that were generated during all previous cycles and have not yet been acted upon. Some of them were incorporated in previous cycles and are no longer in the Scope Bank, and some were not incorporated and are still in the Scope Bank. In any case, the current contents are all of the items not previously acted upon. There may be cases where any ideas suggested earlier that had not been incorporated may now be viable. That is the reason the Scope Bank is cumulative.

Note

The only time anything is deleted from the Scope Bank is when it is incorporated into the solution.


Questions to Be Answered during Client Checkpoint

The following is a list of the questions to be answered during the Client Checkpoint phase:

  • What was planned?

  • What was done?

  • Is the version scope still valid?

  • Is the team working as expected?

  • What was learned?

What Was Planned?

The answer to this question is nothing more than a list of the objectives and functionality that were planned to be completed during the previous cycle.

What Was Done?

This answer is nothing more than a checkoff of the objectives and functionality completed. There are often comments accompanying the checkoff because some items may not have been completed as planned. Subfunctions may have been left undone, and there may be good reasons for it. In such cases, the Scope Bank should reflect the situation.

Again, the only questions to be answered here are these: Did the cycle meet its objectives? Did the cycle meet its planned functional specifications? If no, where are the variances? The answers will provide input into planning for the objectives of the next cycle and the functionality to be built in the next cycle. Remember, we already specified objectives and functionality for the next cycle in the Version Scope phase. So we have the original scope and potential revised scope to consider as we consider what the next cycle will contain.

Note

TPM defines a formal change management process that can be invoked at any time in the project. In APF the change process is imbedded in the client checkpoint. The only changes that are accommodated in APF occur between cycles. No changes to scope are incorporated within an ongoing cycle.

Is the Version Scope Still Valid?

Armed with the information discussed in the previous two sections, we now can ask a very basic question: “Is the version scope still valid?” If yes, we are on the right track. If not, we need to revise accordingly. Revisions to version scope can be significant. In some cases revisions may be so significant that the correct business decision is to kill the current project, go back to the drawing board, and start over again. You can see that the cost of killing an APF project will always be less than the cost of killing a TPM project. The reason is that TPM spends money and time on functionality that may not remain in the solution. APF, on the other hand, almost guarantees that all functionality that is built will remain in the application. Further to the point, TPM projects are often killed, if at all, very late in the game when all the money is spent. APF projects are killed at a point where it becomes obvious that the solution will not be acceptable. That will generally happen while there is still money and time left in the budget.

Is the Team Working as Expected?

Real teamwork is a critical success factor in APF. A lot of worker empowerment is threaded throughout APF. If you count the frequency of the use of the word I as compared to the use of the word we, you will have a pretty good metric for measuring team strength. The formula would be as follows:

Team Strength = number of We’s/(number of I’s plus number of We’s)

You would like to see this number hovering around 1. The APF team needs to work in an open and honest environment for this to happen. That means that every team member must be forthright in stating the actual status of their project work. To do otherwise would be to violate the trust that must exist among team members. The project manager must ensure that the working environment on the project is such that team members are not afraid to raise their hand, say they are having trouble, and ask for help. To do otherwise would be to let the teammates down.

What Was Learned?

This question is perhaps the most important one of all. Here is where the process will be reviewed to provide more value to the client. The new ideas that are generated here could not have come about through the TPM approach. This point in the process is where APF (and xPM, in all fairness) really shine. Both APF and xPM take their value from learning by doing.


Adjusting Functionality for the Next Cycle Plan

Once the answers have been given to the preceding questions, it is time for the client and the project team to look forward to the next cycle. The inputs to the next cycle planning activity are as follows:

  • Any functionality completed during the previous cycle

  • Any functionality planned but not completed in the previous cycle

  • The functionality planned for this cycle

  • The functionality planned for all the cycles beyond the next one

  • All learning and discovery that took place in all previous cycles (Scope Bank)

  • Any items still remaining on the Issues Log

  • Any changes that took place in the business environment during the previous cycles

From these inputs, you generate the following outputs from the Client Checkpoint phase:

  • Updated functionality list

  • Reprioritized functionality list

  • Next cycle length

Updated Functionality List

We started this whole process with the Conditions of Satisfaction, and it is to the COS that we now return. The only question to be answered here is this: Are the COS still valid? If yes, continue on. If not, revise accordingly. These revisions are the planned functionality for the next cycle.

The client and the team should spend most of a day in frank and honest conversation, considering all of these factors and then agreeing on the functionality that will be planned for the next cycle. Do not underestimate the value that can come from the sharing of learning and discovery. That will be your most important information because it really helps both parties understand what this solution is really all about and what should be offered as a final solution. This part of the process is no trivial task.

Reprioritized Functionality List

The process that was used in the first cycle to prioritize functionality can be repeated here. The criterion that was used to determine the priority may be the same or different. Again, take advantage of all the learning and discovery from the previous cycles.

Next Cycle Length

The initial estimates of functionality duration for those functions planned for the next cycle may require a change in cycle length. Remember to be true to the overall timebox for the version. That cannot be adjusted.

Cross-Reference

See Chapter 14 for a more detailed discussion on prioritizing functionality and working with cycle length and timebox constraints in APF.


Putting It All Together

In this chapter we have tried to give you an understanding of how important the Client Checkpoint phase is to the success of an APF project. As we have already discussed, APF embraces change, and it is through change that we can converge on a solution that delivers maximum business value for the time and money invested. All of the change that occurs in APF occurs in the Client Checkpoint phase. There is no separate change management process as there is in the traditional approach. Make the Client Checkpoint phase the high spot of your APF experience and you won’t go wrong. The Client Checkpoint phase is the last phase in a loop that returns back to the Cycle Plan phase. The loop cycle plan–cycle build–client checkpoint repeats itself for as many cycles as have been planned within the version timebox.

In the next chapter, we look at closing the version project with the post-version review.


Discussion Questions

  1. A member of your team is a systems analyst from the old school and just cannot adjust to APF. Her problem is that the client has decision-making authority over the direction that your software development project is taking and the client is, shall we say, technically challenged. How would you handle this dilemma?

  2. You are the project manager over one of your company’s first APF projects. You are having trouble getting the client’s involvement. What would you do?


Chapter 18: Post-Version Review

Overview

The only thing we know about the future is that it is going to be different.

—Peter F. Drucker

Just as the traditionalist conducts a post-implementation audit at the end of the project, so also does the APFist conduct a post-version review at the end of the current version (see Figure 18.1). There are a number of similarities between a post-implementation audit and a post-version review, but there are differences, too. The traditionalist is looking for final closure on the project, while the APFist is looking for ways to further increase the business value of the solution. In other words, the APFist is never looking for final closure; instead, he or she is always looking for more business value. The version just completed is just another step toward increasing business value. In that sense, APF is quite like the production prototype because it consists of a never-ending cycle of repeated solution improvements. The only ending that is ever encountered is to retire the solution altogether.

Click To expand
Figure 18.1: Post-Version Review phase.
Start Sidebar
Chapter Learning Objectives

After reading this chapter, you will be able to:

  • Explain the significance of the post-version review

  • Describe the deliverables from a post-version review

  • Conduct a post-version review

  • Extract lessons learned from the version project

End Sidebar

Let’s look at the series of actions that take place in the APF post-version review.


Checking Explicit Business Outcomes

The project was justified on the basis of explicit business value as defined by specific business outcomes. The Post-Version Review phase is the time to check to see if the project has achieved these outcomes. Oftentimes, however, these outcomes cannot be measured until weeks, months, or even quarters have passed since the version was put into production status and the success criteria can be measured. This part of the review is no different than in the traditional approach. The project has finished, and the team will be disbanded for reassignment to other projects. Waiting on the validation of a business outcome is related to the business reason for doing the project and in no way affects the team. Depending on that business outcome, another project focused on the same application may be commissioned and a new team assembled to do that work.


Reviewing Lessons Learned for Next Version Functionality

We know that learning and discovery are very important parts of the Client Checkpoint phase because that phase leads the client and the team to adjust the cycle plans going forward. Similarly, in the Post-Version Review phase, the client and the team consider all discovery and learning experiences with a view toward the next version’s functionality, on the assumption that there will be a next version. This information is the major input to the Version Scope phase for the next version. The analysis of this information will be the major part of the business validation of that next version.


Assessing APF for Improvements

So far, the lessons learned have focused on the solution (that is, the product) of the just completed version. The other type of lessons learned focuses on the process that was followed to create the solution and asks such questions as “How well did APF work?” and “How well did the client and the team follow APF?” In answering these questions, the client and the team offer suggestions for improvement of the process and the practice of the process. As you can see, APF has a built-in continuous quality improvement process.


Putting It All Together

Clearly, the post-version review is focused on the business value of what was just completed and on the business value of any future versions that might follow, which is as it should be. A guiding principle of APF is to deliver maximum business value. We have shown how this applies to a critique of the solution just delivered and to a preparation for any version that might follow.

In the next chapter, the final chapter in Part II, we consider some variations that might be encountered and how APF can be adapted to fit.


Discussion Questions

  1. You have completed your first APF project. Compare and contrast the traditional and APF approaches when both of them reach this same point.

  2. What differences might you see if it were possible to do the same project twice—once using the traditional approach and once using APF? Be specific. How might project differences affect your comparison? Again, be specific.

  3. What situations might you envision in which APF would be a better choice than TPM for the Jack Neift Trucking Company (see the case study in the Introduction)? Be specific.


Chapter 19: Variations to APF

Overview

Clearly no group can as an entity create ideas. Only individuals can do this. A group of individuals may, however, stimulate one another in the creation of ideas.

—Estill I. Green, VP, Bell Telephone Laboratories

An eXtreme project is a complex, self-correcting venture in search of a desired result.

—Doug DeCarlo

As its name states, APF is adaptive. We have seen that in several ways:

  • Specifying the number of cycles.

  • Determining cycle length.

  • Changing functionality priorities at each client checkpoint.

  • Building in changes (add new, modify existing, or delete) in functionality at each client checkpoint.

Start Sidebar
Chapter Learning Objectives

After reading this chapter, you will be able to:

  • Use APF for proof of concept

  • Adapt APF to revise the version plan

  • Identify an extreme project

  • Describe the four phases of the extreme project management approach

  • Understand how extreme project management clarifies the goal and converges to a solution

End Sidebar

We have also seen how APF not only anticipates these adaptations but also expects them. However, APF is far more adaptable than even the situations in the preceding list indicate. There are three other adaptations that we want you to be aware of, and these are the topic of this short chapter. The first two are brief topics and demonstrate how APF can be used as a proof-of-concept tool and in revising the version plan. These are discussed first. Then we draw a comparison between APF and extreme project management (xPM). The two are closely related approaches to managing projects when the solution is not known (APF) and when neither the solution nor the goal is known (xPM).

Note

You will probably find other reasons to adapt APF. Feel free to do that. APF is not a rigid structure to be followed without question. For us, the bottom line has always been to do what is right for the client. If that flies in the face of some established process or procedure, you need to take a serious look at the process or procedure. It may not be serving your needs.


Proof-of-Concept Cycle

There will be situations where the business case has not been sufficiently made to get approval to build the first version. In much the same way we have used prototyping to help with client definition of functionality, we can use the same concept in the first cycle by making the first cycle of APF a proof-of-concept cycle. That proof of concept could entail any of the following:

  • The creation of a prototype

  • A feasibility study

  • The writing of use cases

  • Storyboarding

  • Any other activity to demonstrate business value

However, it is very important that you not drag this activity out too long. Client interest and the interest of the approving manager will wane. You need to strike quickly while the iron is hot.


Revising the Version Plan

There will be situations where the initial version scope misses the mark. You will see evidence of this via a significant number of discoveries and lessons learned coming in the first few cycles. These discoveries and lessons can create a big disconnect between the original direction of the project and the corrected one that is now indicated. In other words, continuing on the course suggested by the current version scope is a waste of time and money. Remember that you built a mid-level WBS and are making your cycle plans around that WBS. Too many changes brought on by learning and discovery may render much of the WBS out of sync. The need to revise the version plan is clearly a subjective decision. We would err on the side of revision rather than sticking with a plan that may be heading in the wrong direction. The APFist is hard-pressed to do anything that may be a waste of the client’s time or money. The APFist would conclude that the plan is off course and should be abandoned immediately. The correct action is to revise (or even replace) the current version plan and basically start over.

Note

At this early point in the project, do not be afraid to kill the plan. In almost every case we can think of, you will be making the correct decision.


Extreme Project Management

The third variation that we will discuss is extreme project management. xPM and APF both originated at about the same time, so it is difficult to say which is a variation of the other from a chronological point of view. In any case, xPM handles the situation where the goal is not clearly defined and therefore the solution cannot be defined either. On the continuum of project management approaches, the traditional approach occupies the structured end, where there is the most clarity with respect to both the goal and the solution. xPM is at the unstructured end, where there is the least clarity with respect to the goal and the solution. APF occupies the middle ground.

This section defines the extreme project and gives a high-level overview of the four phases that constitute the xPM approach. As such, it is a good starting point for the executive or manager who simply needs to become familiar with the xPM approach.

Defining an Extreme Project

The best way to define an extreme project is to consider its characteristics, which are discussed in the following list:

High speed. The types of projects that are suited to xPM are ground breaking, innovative, critical to an organization’s future, and otherwise very important to their sponsors. That means that the results are wanted ASAP. Fast is good, and you will be around tomorrow to talk about it. Slow is bad, and you will be looking for something else to do with the rest of your life. Time, or faster, to market is a critical success factor in every extreme project business endeavor.

High change. The uncertainty about the goal or the solution means that as the project is underway, learning and discovery, just as in APF projects, will happen. It will happen with more regularity and frequency in xPM than in APF projects. The APF changes can be thought of as minor in comparison. The changes in an extreme project may completely reverse the direction of the project. We can envision cases where the changes might be to cancel the current project and start two or more projects based on the learning and discovery to date with the now cancelled project. For example, R&D projects are extreme projects, and a discovery in one cycle may cause the team and the client to move in a totally different direction in the next and later cycles.

High uncertainty. Because an extreme project is innovative and research-oriented, no one really knows what lies ahead. The direction chosen by the client and the project team might be 180 degrees out of phase with what they should be doing, but no one knows that. Furthermore, the time to complete the extreme project is not known. The cost to complete an extreme project is not known either. There will be a lot of trial and error. There will be a lot of false starts and killed projects.

These characteristics will strike fear into the hearts of most, if not all, project managers. Make no mistake, extreme projects are extremely challenging. Their failure rate will be high. Many will be cancelled before they are completed. For those that are successful, what they deliver may not at all reflect what they thought they would deliver. In other words, the actual goal achieved may be quite different than the goal that was originally envisioned. That is the nature of extreme projects, and that is where we begin our investigation of how xPM applies to them.

Overview of Extreme Project Management

By its very nature, xPM is unstructured. xPM (see Figure 19.1) and APF are both variations of the same theme. The theme is that learning and discovery moves the project forward. The idea is an adaptation of the Flexible Project Model introduced in 2000 by Doug DeCarlo in his eXtreme Project Management Workshop. Recall that the difference between xPM and APF is that APF requires a clearly defined goal, whereas xPM does not. As Figure 19.1 illustrates, xPM consists of four phases that we are calling INitiate, SPeculate, Incubate, and REview (INSPIRE).

xPM is an iterative approach just as APF is an iterative approach. xPM iterates in an unspecified number of short cycles (1- to 4-week cycle lengths are typical) in search of the solution (in other words, the goal). It may find an acceptable solution, or it may be cancelled before any solution is reached. It is distinguished from APF in that the goal is unknown, or at most, someone has a vague, but unspecified, notion of what the goal consists. Such a client might say: “I’ll know it when I see it.” That isn’t a new revelation to the experienced project manager; they have heard that many times before. Nevertheless, it is their job to find the solution (with the client’s help, of course).

Click To expand
Figure 19.1: Extreme project management.

APF is further distinguished from xPM in that xPM requires the client to be more involved within and between cycles, whereas APF requires client involvement between cycles. Drug research provides a good example of the extreme project. Suppose, for example, that the goal is to find a natural food additive that will eliminate the common cold. This is a wide-open project. Constraining the project to a fixed budget or fixed time line makes no sense whatsoever. More than likely the project team will begin by choosing some investigative direction or directions and hope that intermediate findings and results will do two things:

  • That the just finished cycle will point to a more informed and productive direction for the next and future cycles. In other words, xPM includes learning and discovery experiences just as APF does.

  • Most important of all, that the funding agent will see this learning and discovery as potentially rewarding and will decide to continue the funding support.

There is no constrained scope triangle in xPM as there is in TPM and APF projects. Recall that those TPM and APF projects have time and funding constraints that were meaningful. “Put a man on the moon and return him safely by the end of the decade” is pretty specific. It has a built-in stopping rule. When the money or the time runs out, the project is over. xPM does have stopping rules, but they are very different. There are two stopping rules in xPM:

  • The first one says that the project is over when the solution is found. Success!

  • The second one says the project is over when the sponsor is not willing to continue the funding. The sponsor might withdraw the funding because the project is not making any meaningful progress. It is not converging on an acceptable solution. In other words, the project is killed. Failure!

The next sections take a high-level look at the four phases of xPM.

INitiate

The INitiate phase is a mixture of selling the idea, establishing the business value of the project, brainstorming possible approaches, forming the team, and getting everyone on board and excited about what they are about to undertake. It is definitely a time for team building and creating a strong working relationship with the client.

Someone has an idea for a product or service and is proposing that a project be commissioned to investigate and produce it. Before any project will be launched, management must be convinced that it is an idea worth pursuing. The burden of proof is on the requestor. He or she must document and demonstrate that there is business value in the undertaking. The Project Overview Statement (POS), which we used in both TPM and APF, is the documentation we are recommending to sell the idea. There are some differences in the xPM version of the POS.

Defining the Project Goal

Unlike the goal of an APF project, the goal of an extreme project is not much more than a vision of some future state. “I’ll know it when I see it” is about the only statement of the project goal that could be made, given the vague nature of the project goal as envisioned at this point in time. It has all the characteristics of an adventure where the destination is only vaguely defined. You have to understand that the goal of an extreme project unfolds along the journey. It is not something that you can plan to achieve; it is only something that you and the client discover along the way. That process of discovery is exciting. It will call upon all of the creative juices that the team and the client can muster. Contrast this to the project goal in an APF project. In APF, the goal is known; it’s the solution that evolves as the project unfolds. In general, the client is the more directive in xPM, while the team is more directive in APF.

At this early stage, any definition of the project goal should be that vision of the future. It would be good at this point to discuss how the user or customer of the deliverables will use the product or service. Don’t be too restrictive, either. Keep your options open—or keep your powder dry, as one of my colleagues would say. Forming a vision of the end state is as much a brainstorming exercise as it is anything else. Don’t close out any ideas that may prove useful later on.

xPM Project Overview Statement

An example will help ground some of these new ideas. Suppose the project is to find a cure for the common cold.

As discussed in earlier chapters of this book, the Project Overview Statement is a critical document in both the TPM and APF approaches, and so it is again in xPM projects. However, because the goal was known in both TPM and APF projects but is not known in xPM projects, there will be some differences in the POS. These differences are best illustrated by way of example. Figure 19.2 is the POS for the project to find a cure for the common cold.

Click To expand
Figure 19.2: POS for the project to find a cure for the common cold.

The following bulleted list looks at each of the elements of this xPM POS to illustrate the differences between this sort of POS and that used in a TPM or APF approach.

Problem or opportunity statement. Nothing unusual here. This is a very simple statement of a problem that has plagued health care providers and moms since the dawn of civilization.

Goal statement. This particular project is taking a calculated (or maybe wild a**) guess that they can establish a preventative barrier to the occurrence of the common cold. Unlike the goal statements in TPM and APF projects, there is no timeframe specified. That would make no sense for such a research project.

Objective statements. These objective statements identify broad directions that the research effort will take. Notice that the format does not fit the S.M.A.R.T. characteristics defined in Chapter 3. In most cases, these objective statements will provide some early guidance on the directions the team intends to pursue. Unlike TPM and APF projects, these objective statements are not a necessary and sufficient set of objectives. Their successful completion does not assure goal attainment. In fact, some of them may be discarded based on learning and discovery in early cycles. Think of them as guideposts only. They set an initial direction for the project. Because the goal is not clearly defined, you can’t expect the objective statements to play the role that they do in TPM and APF projects.

Success criteria. The goal statement might do just as well as any success criteria, and so this part of the POS could be left blank. In this case we have set bounds around the characteristics of an acceptable cure.

Assumptions, risks, and obstacles. There is no difference between xPM, TPM, and APF when it comes to this section. The statements given in the example lean heavily toward assumptions. Having to make such assumptions happens to be the nature of this project.

Establishing a Project Timebox and Cost

Contrary to an APF project, an extreme project is not constrained by a fixed timeframe or cost limit. It is best to think of the xPM time and cost parameters as something to give the project team guidance on what the client expectations are. It is much like having the client say: “I would like to see some results within X months, and I am willing to invest as much as $Y to have you deliver.” The reality is that at each REview phase, the decision to continue or abort is made. That decision isn’t necessarily tied to the time and cost parameters given earlier by the client. In fact, if there is exceptional progress toward a solution, the client may relax either or both of the time and cost parameters. Put another way, if the progress to date is promising, more time and/or money may be put at the team’s disposal.

Establishing the Number of Cycles and Cycle Length

In the beginning, short cycles are advisable. In the early cycles, new ideas are tested, and many will be rejected; proof of concept may be part of the first few cycles. The team should not be committing to complex activities and tasks early on. As the team gains a better sense of direction, cycle length may be increased. Specifying cycle length and the number of cycles up front merely sets expectations as to when and how frequently the REview phase will take place. At each occurrence of a REview phase, cycle length and perhaps the number of cycles remaining may be changed to suit the situation. In an exploratory project, it would be a mistake to bind the team and the client to cycles that do not relate to the realities of the project. Remember that flexibility is the key to a successful xPM project.

Trade-Offs in the Scope Triangle

Despite the fact that xPM is unstructured, it is important that the priorities of the variables in the scope triangle be set. As project work commences and problems arise, which variable or variables are the client and the team willing to compromise? As is discussed in Chapter 1, the five variables in a project are as follows:

  • Scope

  • Quality

  • Cost

  • Time

  • Resource availability

Which of these is least likely to be compromised? Which would you choose to compromise first, if the situation warranted it? It depends on the type of project. For example, if the project involved conducting research to find a cure for the common cold, quality is the least likely to be compromised and time might be the first to be compromised. But what if you knew that a competitor was working on the same project? Would time still be the first variable to compromise? Probably not. Cost might take its place because time to market is now a critical success factor.

Scope is an interesting variable in extreme projects. Consider the common cold cure example again. Hypothetically, what if you knew that the competition was also looking for a cure for the common cold and that being first to market would be very important. In an earlier cycle, the team discovered not a cure for the cold but a food additive that arrests the cold at whatever stage of development it happens to be. In other words, the cold will not get worse than it was at the time the additive was taken. The early discovery also holds great promise to morph into the cure that you are looking for, but you need time to explore it. You feel that getting the early result to market now may give you a strategic barrier to entry, give the competition reason to pause, and buy you some time to continue toward the original goal. And so, scope is reduced in the current project and the project brought to a successful completion. A new project is commissioned to continue on the path discovered in the earlier project.

SPeculate

This phase defines the beginning of a new cycle and will always start with a brainstorming session. The input will either be a blank slate or output from the previous SPeculate-Incubate-REview cycle. In any case, the project team, client, and final user of the product or service should participate in the brainstorming session. The objective of this session is to explore ideas and identify alternative directions for the next Incubate phase. Because an extreme project has a strong exploratory nature about it, no idea should be neglected. Several directions may eventually be pursued in parallel in the next cycle. Cycle length, deliverables, and other planning artifacts are defined in the SPeculate phase as well.

The word speculate conjures up deep thinking, carrying out due diligence on several alternatives, the choosing of one or more of those alternatives, and then simply taking your chances. You should hear yourself saying, “I wonder if this would work?” That is what the SPeculate phase of xPM is all about.

Defining How the Project Will Be Done

The initial sense of direction for the team to take in the first cycle of an extreme project can vary considerably. A good approach is to use the POS objective statements as a guide. The POS can continuously be updated to reflect the current view of the project, and its objective statements can serve as a guide to what will be done. In later cycles, the team and the client will have the benefit of learning and discovery from the prior cycles. For the sake of discussion, let’s treat those two situations separately. In this section of the chapter, assume you are planning the first cycle. In some of the following sections, you will look at the SPeculate phase for the second and subsequent cycles.

Conditions of Satisfaction

We discussed the Conditions of Satisfaction in detail in Chapter 3 and will not repeat that discussion here. While the COS is a tool that produces a required deliverable in TPM and APF, its use in xPM is optional. COS loses its value as the goal becomes more and more elusive. If the client has only a vague idea about the goal, no amount of discussion around needs and deliverables will clarify the situation for either party, and the other planning artifacts described in the text that follows may be more useful in the initial SPeculate phase.

If you choose to use the COS in your xPM project, think of it as more of a brainstorming process. The project team and the client can investigate ideas en route to putting a list of what will be done in this cycle.

Scenarios, Stories, and Use Cases

The technical perfectionist would probably define these terms as different from one another, but for our purposes, they are synonymous. All three can be defined as descriptions of how a person might use the application. Because the application may be feature-rich, there can be, and usually will be, several such descriptions. If done correctly, these descriptions will be exhaustive of how the application can be used. These descriptions can then be prioritized and assigned to the appropriate development cycles. There is no practical limit to the number of such situations that are documented. In the case of technology projects, like Web site development, the client may be more comfortable telling you how they envision someone using the deliverable and what they can do at the Web site than they would be in trying to help you write a functional specification. The advantage in using scenarios, stories, and use cases is that the view you are building is from the user side, not from the technology side.

Prioritizing Requirements

The collection of scenarios, stories, and use cases provides insight into the requirements that the deliverable should meet. For the client, it is far easier to prioritize the collection than it is to prioritize the requirements. Prioritization is the next step in the SPeculate phase. There are several ways to produce a prioritized list of the items in the collection. Chapter 14 discussed three such methods: forced ranking; must-haves, should-haves, nice-to-haves; and the Q-Sort. Refer to Chapter 14 for the details on those methods.

Here are other aspects of the prioritization that need to be considered:

  • First, there can be a great number of items in the collection; so many, in fact, that approaches like forced ranking are not practical. Forced ranking doesn’t scale very well. A compromise approach might involve grouping the items based on their relationship to specific functions and then prioritizing between and within the functions. The strategy here would be to assign all of the items that relate to a specific function to a subteam for their consideration and development. Several subteams could be active in any given cycle.

  • Second, depending on how well the goal is understood, it might be wise to plan the initial SPeculate phase so that as many options and alternatives as possible can be investigated. The strategy here is to eliminate those alternatives that show little promise earlier rather than later in the project. That allows more resources to be brought to bear on approaches that have a higher probability of success.

  • Finally, where appropriate, prototypes might be considered as part or all of the first-cycle deliverables. Here the strategy is to prioritize items in the collection or functions by not spending too much time developing the real deliverable. Getting the client familiar with the prototype may give sufficient information to allow not only a reduction in the number of items in the collection, but also a prioritization of those items or functions that show promise. A good example is a typical B2C application. The prototype will show the various ways that a customer can interact with the application. Upon examination, the client will add to that list or delete from that list as they experience what the customer would experience when interacting with the application.

Think of the first cycle or two as exploratory in nature. Their purpose is to discover the directions that show promise and focus later cycles on them.

Identifying the First Cycle Deliverables

Once the prioritization is done, it is time to decide how much of that prioritized list to bite off for the initial cycle. Remembering that you want shorter cycles in the early part of the project suggests that you limit the first cycle deliverables to what you can reasonably accomplish in a week or two.

Note

By taking this approach, you are keeping the client’s interest up. That is important. APF follows the same strategy. Once the client has been fully engaged in the project, later cycles can be lengthened.

Because your team resources are limited, you have to face the question of depth versus breadth of deliverables. In other words, might it be better to extend the breadth to accommodate more functions by not delving deep into any one function. Produce enough detail in each function in this initial cycle to get a sense of further direction for the function. You may learn from only a shallow look at a function that it isn’t going to be part of the final solution. This shallow look allows you to save labor that would have been spent on a function that will be discarded and to spend it on more important work.

Go/No Go Decision

Because the initial cycle can be exploratory, the sponsor must have an opportunity to judge the soundness of the initial cycle plan and decide whether it makes sense to proceed. It is entirely possible that the original idea of the client cannot be delivered with the approach taken in the first cycle, and the first cycle leads the client to the decision that the idea doesn’t make any sense after all. Some other approach needs to be taken, and that approach is not known at this time. The go/no go decision points will occur at the end of each cycle. Decisions to stop a project are more likely to occur in the early cycles than in the later cycles. One should expect later cycles to have the benefit of earlier results that suggest that the project direction is feasible and should be continued.

Planning for Later Cycles

Later cycles will have the benefit of output from a REview phase to inform the planning activities that will take place in the SPeculate phase that will follow. Each REview phase will produce a clearer vision and definition of the goal. That clearer vision translates into a redirection of the project and that translates into a new prioritized list of deliverables for the coming Incubate phase. The newly prioritized deliverables list may contain deliverables from previous cycles that were not completed, deliverables that have not yet been part of an Incubate phase, and deliverables that are new to the project as a result of learning and discovery that occurred in the most recently completed Incubate phase. In any case, the revised prioritized deliverables list is taken into consideration as the team plans what it will do in the coming Incubate phase. It is now in the same position as it was in the very first SPeculate phase. What follows then is the assignment of deliverables to subteams and the scheduling of the work that will be done and who will do it.

Incubate

The Incubate phase is the xPM version of the Cycle Build phase in APF. There are several similarities between the phases and some differences as well. Consider the following points:

  • Even though the Incubate phase has a prioritized list of deliverables that are to be produced in this cycle, xPM still must maintain the spirit of exploration. It is a learning and discovery experience that may result in mid-cycle corrections that arise from that exploration.

  • APF, on the other hand, does benefit from learning and discovery as it proceeds with the cycle plan but it does not vary from the plan. The learning and discovery are input to the client checkpoint and that is where plan revisions take place.

These points are an important distinction between xPM and APF.

Subteams, working in parallel, will execute the plan developed in the previous SPeculate phase. The environment has to be very open and collaborative for this phase to be successful. Teams should be sharing ideas and cross-fertilizing discoveries and learning moments with one another. This is not just a time to execute a plan; it is a time for exploration and dynamic interchange. Mid-phase corrections with the collaboration of the client are likely as the subteams learn and discover together. New ideas and a redirection or clarification of the goal is likely to come from these learning and discovery experiences as well.

Assigning Resources

The Incubate cycle begins with an assignment of team members to each of the deliverables that have been prioritized for this cycle. The assignment should take place as a team exercise. That team involvement is important because of the exploratory nature of xPM cycles. Team members need to express their interest in one or more deliverables and also share their ideas with their fellow team members. This assignment time can also be an opportunity for team members to recruit others who share their same interests and would like to develop the deliverable with them. The project manager should not pass up the opportunity to create a synergy among team members with similar interests, as well as between subteams that will be working in parallel on different deliverables. Any opportunity to create a collaborative work environment only increases the team’s chances of success.

Establishing Cycle Plan

With the subteams in place and with their assignments made, the sub-teams can plan how they will produce the deliverables assigned to them. Deciding how a team produces the deliverables is exactly the same as was discussed in Chapter 16. In fact, many of the same tools discussed in Chapter 16 can be used to help establish a cycle plan here with equal effectiveness. For example, Chapter 16 presents the cycle plan as a time-sequenced whiteboard diagram showing a day-by-day schedule of what is going to be done and who is going to do it.

Note

However, never forget that there are some differences to a cycle plan in xPM. In xPM the team has to be ready for changes at any time. Exploration will often bring the team to a point where a change of direction makes sense. When these situations arise, the team needs to collaborate with the client and decide how to go forward.
Collaboratively Producing Deliverables

Collaboration goes to the very essence of xPM. Collaboration among subteams must occur. The example given earlier is one such instance. We spoke earlier in the chapter about the exploratory nature of an xPM project. Because the project is exploratory, no one has a lock on the solution. Even the goal is somewhat elusive. That means that the goal and the solution can be attained only through a solid team effort—a collaborative effort. There is a great deal of similarity between xPM projects and brainstorming. One idea may not be of much value when taken individually. However, combine it with one or more other ideas and suddenly there is value. The quote from Estill I. Green, VP of Bell Telephone Laboratories, given in the beginning of the chapter is relevant here: “Clearly no group can as an entity create ideas. Only individuals can do this. A group of individuals may, however, stimulate one another in the creation of ideas.”

REview

The REview phase is very similar to the Client Checkpoint phase in APF. All of the learning and discovery from the just-completed Incubate phase are brought together in another brainstorming session. Answers to questions such as:

  • What did we learn?

  • What can we do to enhance goal attainment?

  • What new ideas arose and should be pursued?

  • What should we do in the next cycle?

will be shared. The most important decision is whether or not the project will continue. This is a client decision. Have the results to date met with their expectations? Is the project moving toward an acceptable solution? These answers will determine whether or not the project will continue to the next cycle or be cancelled. APF and xPM share this go/no go decision point at the completion of each cycle. APF is less likely to result in a cancellation because so much more is known about the solution. xPM, on the other hand, is so exploratory and research-based that cancellations are far more likely.

Each cycle of an xPM project ends with a review of the just-completed Incubate phase. It is a meeting attended by the client and the project team. The purpose of the REview phase is to reflect on what has just happened and what learning and discovery have taken place. The output is a definition of the next cycle activities.

Applying Learning and Discovery from the Previous Cycle

Early in the sequence of cycles, the client and the team should expect significant findings and major redirections of further efforts. As the project moves into later cycles, the changes should diminish in scope because the project team should be converging on a more clearly defined goal and an acceptable solution to reach it.

Note

This part of the xPM process differs from APF because in APF the goal has always been clearly defined; it is the solution that becomes clearer with each passing APF cycle.
Revising the Project Goal

The first order of business is for the client and the project team to revisit the previous goal statement from the prior REview phase. Ask the following questions:

  • What has happened in the just-completed Incubate phase?

  • What new information do we have?

  • What approaches have we eliminated?

  • What new discovery suggests a change in goal direction and definition?

  • Are we converging on a more clearly defined goal?

This revision of the project goal is an important step and must not be treated lightly. The client and the team need to come to a consensus on that new goal statement. Update the POS with the new goal statement.

Reprioritizing Requirements

The second order of business is for the client and the project team to revisit deliverables and requirements. The following questions should be asked here:

  • How does the new goal statement impact the deliverables list?

    • Should some items be removed?

    • Should new items be added?

  • How is the functionality embedded in the new goal statement impacted?

The answers to these questions allow the client and the project team to reprioritize the new requirements. Update the POS to reflect the changes in the objective statements.

Making the Go/No Go Decision for Next Cycle

Will there be a next SPeculate-Incubate-REview cycle? Equivalently, the question could be this: Are we converging at an acceptable rate on a clearly defined goal and acceptable solution? The client will consider this question in the face of the money and time already spent. Does it make business sense to continue this project? The updated POS is the input to this decision.


Comparing Project Approaches

Figure 19.3 summarizes much of what we have been discussing in the first two parts of this book. It is interesting to compare and contrast all three approaches. The first thing to note is that these three approaches span the entire project landscape. TPM covers those cases where the goal and how to reach it are clearly known. At the other end of the spectrum is xPM, which covers those projects whose goal is not clearly known and, therefore, whose solution is not known either. All other cases fall in between the two and are covered by APF. APF and xPM require multiple cycles in order to bring the solution into focus (APF) or to bring the goal and the solution into focus (xPM).

The scope triangle applies equally to both TPM and APF, but not xPM. The xPM budget and timeframe are variable, and hence, the scope triangle does not apply there. The scope and its accompanying WBS are different for all three. Because scope is known and fixed in TPM, a complete WBS can be built and a complete plan generated from it. In the case of APF, only a certain level of detail is known, so the mid-level WBS reflects that level of clarity. Within a cycle, however, a lower-level WBS can be built for APF projects and a plan generated to build that cycle’s functionality. In the case of xPM, the scope is unknown, and hence, no meaningful WBS can be generated. Only within an xPM cycle can a plan be generated for the functionality to be explored in that cycle.

Click To expand
Figure 19.3: Comparison of the three approaches.

The most important message we can offer you is this: “Do not force your project into an approach. Let the characteristics of the project suggest the approach to be taken.”


Putting It All Together

One noticeable difference between the traditional approach and the APF approach is that APF is a thinking person’s approach, whereas the traditionalist approach often tends to be the blind following of a recipe with the expectation that everything will be all right. For example, APF requires continuous and meaningful involvement on the part of the client. A clear joint ownership by the client and the team is built into APF. That is not the case with the traditionalist approach. The traditionalist approach can be followed with little or no involvement by the client.

This chapter ends our presentation on APF. It is an exciting and invigorating approach to those projects that don’t quite fit the mold of the traditional approach. We hope that this brief introduction to APF will encourage our colleagues to ponder what we have said here and add their own take on APF. It is an idea whose time has come, and it should be taken seriously by the project management community.

When it comes to starting an extreme project, you have learned that the good habits formed in TPM and APF carry over into xPM. There is no need to learn anything new in order to get an extreme project underway. The POS will be used here just as it is used in TPM and APF. You want to get approval to work on your project, and you have a selling job to do. You are armed with the POS as your best strategy regardless of the type of project to be undertaken.

Finally, the best advice we can give you when you are doing an extreme project is to be open-minded. The habits that you formed in traditional project management may have great application in extreme projects, but they might not. You will be called on to be adaptive. Keep the goal of your extreme project in mind, and use or adapt whatever you can from your earlier experiences with traditional or adaptive projects.

You should now have a better understanding of how this unstructured xPM approach can, in fact, converge on the goal. The learning and discovery that takes place in a cycle gives the client and the project team the information it needs to rethink how it will move forward at the next cycle. The decision to move forward is a collective decision made by the client with the advice of the project team.

The ability of the team and the client to decide how to move forward is heavily dependent upon their ability to reconsider the prioritization of functionality. The learning that has taken place is the major contributor to their ability to reprioritize. That learning brings clarity to the final goal specification, and that clarity helps the client and the team to eliminate functionality that is out of scope with that now clearer goal, as well as to identify functionality that is critical to the more clearly defined goal.


Discussion Questions

  1. Suppose a project should have used a traditional approach, but you used APF. Comment on what might be different. Would the traditional approach have given you a better outcome? Why or why not? Be specific.

  2. Referring to the case study in the Introduction, suppose you were unable to sell your idea as having sufficient business value. How might you construct an APF approach that begins with a proof of concept? How would you be able to show potential business value sufficient to sell the project to senior management? Be specific.

  3. How does xPM differ from APF? Discuss the differentiating characteristics of each.

  4. Can APF be used on an extreme project? Why? Why not? Be specific.

  5. In the formation stages of a project, are there any distinct advantages to using xPM over APF for an extreme project? If so, identify them.

  6. In the formation stages of a project, are there any distinct disadvantages to using APF over xPM for an extreme project? If so, identify them. In considering your answer, think about what is really known versus what may be only speculation and how that might create problems.

  7. As a class exercise, identify three xPM projects and write the POS for one of them.

  8. Is APF or xPM more likely to waste less of the client’s money and the team’s time if the project was killed prior to completion? To answer the question, you have to consider when the decision to kill the project is made in APF versus xPM projects and what is known at the time the decision is made. Defend your position with specifics.


Part Three: Organizational Considerations

Chapter List

Chapter 20: Project Portfolio Management
Chapter 21: Project Support Office
Epilogue: Putting It All Together Finally
Appendix A: What’s on the CD-ROM
Appendix B: Bibliography

We have completed our discussion of the three approaches to project management: TPM, APF, and xPM. In the previous two parts, we discussed when to use the traditional, adaptive, or extreme approaches and how to use each one. There are two remaining topics that we feel are critical to your understanding the place of projects in the organization:

  • The first is project portfolio management. Many organizations are changing their focus from the individual project to the collection of projects underway or proposed in the organization.

  • The second is the Project Support Office (PSO). If any of the three approaches are to succeed in the organization, it will be because the organization has an effective support function in place.

Part III consists of two chapters. In Chapter 20, we take a look at the project portfolio with specific focus on what it is, how it is formed, and how it is managed. Chapter 21 discusses how organizations can support the project effort. We discuss what the PSO is, what functions it performs, what roles and responsibilities it has, how it is organized, and how to form one.

Part III is intended to give you an awareness of these two contemporary aspects of the enterprise—the project portfolio and the Project Support Office. Both can contribute to the success of TPM, APF, and xPM. It is important that you understand the roles, responsibilities, and functions of each, because they will impact your ability to be successful with project execution.


Chapter 20: Project Portfolio Management

Overview

He who attempts too much seldom succeeds.

—Dutch proverb

A good way to outline a strategy is to ask yourself: “How and where am I going to commit my resources?” Your answer constitutes your strategy.

—R. Henry Miglione, Oral Roberts University, An MBO Approach to Long-Range Planning

Organizations that invest in information technology projects, whether hardware-, software-, or both hardware- and software-focused, must have a plan for investing in these projects. The dollars needed to fund these projects will almost always exceed the dollars available. So how should an organization decide which projects should be funded and which shouldn’t be funded? Is this a short-term decision that looks only at the coming budget cycle, or is there some long-term strategy that spans multiple budget cycles? How can the funding agency determine if an IT investment is a good investment? Are there some criteria that can be applied? The answers to these questions are simple in some cases and extremely difficult in others. In this chapter, we use a life-cycle approach that traces the life of a project through the portfolio management process.

Start Sidebar
Chapter Learning Objectives

After reading this chapter, you will be able to:

  • Understand current practices in corporate project portfolio management and how they are applied

  • Know how to deliver explicit business value through a strategically aligned project portfolio

  • Adapt the concepts and practices of project portfolio management

End Sidebar


Introduction to Project Portfolio Management

In this first section, we set the foundation for our study of project portfolio management. While everyone knows what a project is, everyone may not understand that not all projects will come under the purview of our portfolio management process. Just what types of projects will be candidates for the project portfolio is a very basic tenet for every portfolio. You need to have a clear understanding of what a portfolio is, and there will be situations where more than one portfolio is advised. We want to make sure everyone is on the same page before we launch into the depths of a portfolio management discussion. In this section, we present the portfolio management process that will follow and then discuss each part of the process in detail in later sections.

Portfolio Management Concepts

First, we want to take another look at the project. The definition of a project comes from earlier discussions in this book, but not all projects belong in the portfolio. The word portfolio probably conjures up several different ideas. We have a simple definition that will put everyone on the same page.

What Is a Portfolio Project?

In Chapter 1, we defined a project in the following way:

A project is a sequence of unique, complex, and connected activities having one goal or purpose that must be completed by a specific time, within budget, and according to specification.

This is a technical definition, and it tells you quite a bit about the type of work that can legitimately be called a project, but when you are dealing with a portfolio, it doesn’t tell the whole story. Because you are constructing a portfolio of projects, you need to define the types of projects that qualify for inclusion in the portfolio. Not all projects will be managed as part of a portfolio. What about small, routine projects that are done as part of normal business operations? Certainly they will not fall under the portfolio management process. They are already included in the operations budget of their respective business units. On the other hand, how big, complex, and expensive does the project have to be before we will consider it for the portfolio? No matter how specific you are in establishing the qualification criteria, there will always be a certain amount of subjectivity to deal with. For example, take a look at complexity in the case of the selection and purchase of a desktop computer. If you are technically savvy, the purchase of the computer is a simple task and would not be considered a project. On the other hand, if you are technically challenged, the purchase of a computer clearly is a project and a complex one at that.

That said, it seems clear that you would want to set a minimum effort, cost, and even value to those projects that will be considered for inclusion in the portfolio. These are certainly subjective calls on your part, but you must make them to really understand when you have a project that will be proposed for the portfolio and when you don’t.

Note

What about capital budget projects? Regardless of their dollar value, some organizations require that all capital budget projects be approved and be a line item in the capital budget. In effect, the capital budget is a portfolio of projects, where each project defines a piece of capital equipment that the requestor is asking to purchase.

What Is a Project Portfolio?

The simple definition of a project portfolio is as follows:

A project portfolio is a collection of projects that share some common link to one another.

The operative phrase here is “share some common link to one another.” We want to explore that idea in more detail. We already have given one example of projects that share a common link in the Note about capital budgets in the previous section. That link could take many forms. At the enterprise level, that link might be nothing more than the fact that the projects all belong to the same company. While that may be true, it is not too likely the kind of link you are looking for. Some more effective and specific links might be the following:

  • The projects may all originate in the same business unit or functional area—information technology, for example.

  • The projects may all be new product development projects.

  • The projects may all be funded out of the same budget or from the same resource pool.

Whichever way you choose to define the link, one thing is almost certain: Whatever resources you have available for those projects will not be enough to meet all project requests. Some choices have to be made, and that is where project portfolio management takes over.

To further complicate the situation, you might need to establish different types of portfolios. For example, all of the capital projects with a value above $500 could form a portfolio. More specifically, the portfolio could cover only technology capital projects above $500. Systems development projects longer than six months with a total cost above $500,000 might be another type of portfolio. At this point in the discussion you can see that whatever portfolios you choose to establish, they will consist of projects that share similar characteristics.

What Is Project Portfolio Management?

Credit for establishing the field of modern portfolio theory belongs to Henry Markowitz, an economist at the City University of New York. He first presented his theory in the Harvard Business Review in 1959. In later years he was awarded the Nobel Prize in Economics for his discoveries. It wasn’t until the 1990s that his theories were extended from the investment portfolio to the project portfolio. Many of the approaches we talk about later in this chapter have their conceptual roots in his earlier works.

Our working definition of project portfolio management is as follows:

Project portfolio management includes establishing the investment strategy of the portfolio, determining what types of projects can be incorporated in the portfolio, evaluating and prioritizing proposed projects, constructing a balanced portfolio that will achieve the investment objectives, monitoring the performance of the portfolio, and adjusting the contents of the portfolio in order to achieve the desired results.

The Major Phases of Project Portfolio Management

No matter how you slice and dice it, project portfolio management consists of five phases, as shown by the shaded boxes in Figure 20.1.

  1. Establish

  2. Evaluate

  3. Prioritize

  4. Select

  5. Manage

In the illustration, we have embedded a generic project in the phases to illustrate the principles involved and the possible courses of action that a project may take over the course of its life. All of the discussions that follow in the remaining sections of this chapter are based on this diagram.

Click To expand
Figure 20.1: Portfolio project life cycle.

Also shown in Figure 20.1 is the changing status of a project as it moves through this life cycle. Note that there are eight different stages that a project may be in during this life cycle. They are as follows:

Proposed. A proposed project is one that has been submitted to the portfolio with a request that it be evaluated regarding its alignment to the portfolio strategy. A project that does not meet the alignment criteria may either be rejected out of hand or returned to the proposing party for revision and resubmission. Projects that are returned for revision are generally only in minor noncompliance, and following the suggested revisions should meet the alignment criteria.

Aligned. A proposed project is aligned if it has been evaluated and determined to be in alignment with the portfolio strategy. Once it has been determined to be aligned, it will be placed in one or more funding categories for future consideration. At this stage, the proposing parties should begin preparing a detailed plan. The plan will contain information that will help the portfolio manager make a final determination to select the project for funding and, hence, for inclusion in the portfolio.

Prioritized. An aligned project is prioritized if it has been ranked along with other projects in its funding category. This is the final stage before the project is selected for the portfolio. If it is high enough in priority in its category, it will be funded and included in the portfolio.

Selected. A prioritized project has been selected if it is in the queue of other prioritized projects in its funding category and is awaiting funding authorization. This is a temporary stage, and funding is certain at this point.

Active. A selected project is active if it has received its funding authorization and is open for work. At this stage, the project manager is authorized to proceed with the recruiting and assignment of team members, scheduling of work, and other activities associated with launching the project.

Postponed. An active project is postponed if its funding authorization has been temporarily removed. Such projects must return to the pool of prioritized projects and be selected once again in order for its funding authorization to be restored. The resources allocated to a postponed project are returned to the funding category from where they originated. The resources may be reassigned to the postponed project at some later time or may be allocated to the next project in the queue of that funding category.

Cancelled. An active project is cancelled if it has failed to demonstrate regular progress toward its successful completion. Depending on the stage in which the project was cancelled, there may be unspent resources. If so, they are returned to the funding category from where they originated. Those funds then become available for the next project in the queue of that funding category.

Completed. A project is completed if it has met all of its objectives and delivered business value as proposed.

A project may find itself in any one of these eight stages as it proceeds through the five phases of the project portfolio management life cycle. In the next sections of this chapter, we deal with each one of the five phases in more detail.


Establishing a Portfolio Strategy

The first step in portfolio management is to decide the strategy for the portfolio. That strategy is an investment strategy. That is, how will the enterprise’s funding be spread across the portfolio? Once this investment strategy is in place, the enterprise will have a structure for selecting the investment opportunities that will be presented in the form of project proposals. This is really a type of strategic planning phase in which the portfolio manager or the portfolio

management team decides how it will allocate its project budget to various general categories of project investment.

Note

We will use the term portfolio manager to represent the decision-making body whether it is one individual or a team.

Several models are easily adapted to this phase. In this chapter we examine five popular models:

  • Strategic Alignment Model

  • Boston Consulting Group Products/Services Matrix

  • Project Distribution Matrix

  • Growth versus Survival Model

  • Project Investment Categories

Each model has desirable characteristics that meet the organization’s need for good investment strategies. The strategy itself is determined by the dollar or resource (people, machines, facilities, and so on) investment the company is willing to make in each of the funding categories defined by the various models. The final question to be answered once this strategy is in place is this: Which projects will be funded in each of these categories? The answer to that question is found in the next three phases of the model.

Prior to releasing the investment plan, two questions should be answered by the portfolio manager:

  • Will projects be partially funded in order to include more projects in the portfolio, or will projects be funded only at the level of their request?

  • If an investment category has excess resources after project funding decisions have been made, can those resources be reallocated to other investment categories without compromising the portfolio strategy, and if so, how will they be reallocated?

If possible, it is good to make these decisions before the situations arise. The rules need to be clear so that all parties are informed ahead of time.

Strategic Alignment Model

The first model we study is the Strategic Alignment Model. This model makes good sense because it attempts to align projects with the direction the enterprise has decided to follow. In other words, it aligns projects with those things that are important to the enterprise. Figure 20.2 graphically depicts that model.

Click To expand
Figure 20.2: Strategic Alignment Model.

Value/Mission

This value/mission is a very brief statement of why the enterprise exists. It could be stated in terms of an end state that the enterprise desires to achieve or simply be a statement of who the enterprise is. Whichever form is used, this statement is unlikely to change, at least not in the foreseeable future.

Goals

To achieve its end state or accomplish its mission, the enterprise has to engage in certain major efforts. These are likely to be multiperiod or multiyear efforts designed to accomplish major results. They might never be attainable (eliminating world hunger, for example), or they might be achievable over long periods of time (finding a cure for cancer or a preventative for the common cold, for example). Any of these are good examples of goal statements. The important thing to remember is that they must be stated in a fashion that links them directly to one or more of the corporate objectives.

Objectives

There will be many approaches to the realization of each goal. Each approach is called an objective, which could be a one-year effort but might also span several years. Again, take the example of the preventative for the common cold. Objectives might include investigating possible food additives or modifying the immune system or finding a drug that establishes immunity to the cold. All three of these objectives can launch a number of tactics.

Tactics

Tactics are the short-term efforts, usually less than one year in duration, and are designed to meet one or more objectives. These are the projects that will be proposed for the portfolio. A project that relates to only one objective will be less attractive to the portfolio manager than a project that relates to several objectives. Similarly, a project that relates to a lower-priority objective will be less attractive than a project that relates to a higher-priority objective. Later in the chapter, in the section titled Selecting a Balanced Portfolio Using the Prioritized Projects, we look at how this works out with some examples.

How Are You Going to Allocate Your Resources?

The application of this model is quite straightforward. The enterprise must decide what resources will be allocated to each goal and to the objectives that support that goal. With that decision made, the enterprise accepts project proposals from its various departments as to what projects they wish to undertake and how those projects relate to the goals and objectives of the enterprise. Obviously, there won’t be much interest in supporting projects that do not further the goals of the enterprise.

Boston Consulting Group Products/Services Matrix

The Boston Consulting Group (BCG) Product Matrix is a well-known model that has been used for several years. It defines four categories of products/services based on their growth rate and competitive position, as shown in Figure 20.3.

Cash Cows

These are well-established products/services that have a strong market share but limited growth potential. They are stable and profitable. Projects that relate to cash cows are important to the organization because they will want to protect that investment for as long as it maintains that market position.

Dogs

Because these products/services are not competitive and have little or no growth potential, any projects related to them should not be undertaken. The best thing that can happen to the dogs is that the organization phase them out as quickly and painlessly as possible. Don’t send good money after bad!

Click To expand
Figure 20.3: BCG Products/Services Matrix.

Stars

These are products/services that have strong market positions and clearly strong growth potential. Projects related to stars are good investment opportunities. Stars are the future cash cows.

?

The question mark represents the starting point of the model. Products/services that are untested in the market but appear to have strong growth potential are worthy of spending R&D dollars. Projects linked to those efforts are good investment opportunities. The objective is to turn them into stars and then cash cows.

How Are You Going to Allocate Your Resources?

It all depends on the current market position of the enterprise, what the business outlook is, and a variety of other considerations. Except for the dogs, the other three categories will have some level of investment. If the industry is stable, cement manufacturing, for example, more resources might be spent on the cash cows to make sure they maintain their market position, lesser resources on the stars because the enterprise will always want to keep some growth opportunities in the pipeline, and even lesser on the ? because the industry isn’t in the research and development mode. In a volatile, high-growth, high-tech industry the allocations might be very different. More resources will be spent on the stars and ? and fewer on the cash cows. Cash cows will have a very short useful life, and any investments in them will be risky.

Project Distribution Matrix

Simple, yet elegant in its simplicity, the Project Distribution Matrix model, shown in Figure 20.4, says that there must be a mix of projects in the portfolio. This mix will be dictated by the skill inventory of those who will work on projects, as well as the needs of the organization to attain and sustain market share. It can be used in conjunction with the models shown previously to ensure a healthy mix is present in the project portfolio. The Project Distribution Matrix is similar to the Strategic Alignment Model in that it defines a rule for classifying projects. The rule is a two-way classification, as shown in the figure.

New—Enhancement—Maintenance

The columns of the matrix classify projects according to whether they are New, Enhancement, or Maintenance.

Click To expand
Figure 20.4: Project Distribution Matrix.

New. A new project is one that proposes to develop a new application, process, or product.

Enhancement. An enhancement project is one that proposes to improve an existing process or product.

Maintenance. A maintenance project is one that simply proposes to conduct the normal care and feeding of an existing operation, which could include fixing errors that have been detected or otherwise updating some features that have become obsolete or are part of a process that has been changed.

Strategic—Tactical—Operational

The rows of the matrix classify projects based on their role in the enterprise:

Strategic. A strategic project is one that focuses on the strategic elements of the enterprise. Applications that extract basic data from businesses, society, and the economy and translate that data into policy formulation are examples of Strategic projects.

Tactical. Tactical projects are projects that look at existing processes and procedures and propose ways to make improvements by changing or replacing the process or procedure.

Operational. Operational projects are those that focus on existing processes and try to find ways to improve efficiency or reduce costs.

How Are You Going to Allocate Your Resources?

The application of this model is also quite straightforward. The enterprise that has defined a project classification rule must now decide what resources will be allocated to each of the nine categories. With that decision made, the enterprise accepts project proposals from its various departments as to what projects they wish to undertake. A feature of this model is that it can be tied to the resource pool of skilled employees. The required skills across each of these nine categories are different. To some extent that may dictate how much emphasis is placed on each category. The enterprise will want to use its available skills, so the relative priority of each category can help or hinder that effort.

Note

The Graham-Englund Selection Model (discussed later in this chapter) incorporates available staff capacity based on skills as part of its selection strategy.

Growth versus Survival Model

This way of categorizing projects is the simplest of all that we are presenting. Projects are either focused on growth or survival. Growth projects are those that propose to make something better in some way. Obviously, these are discretionary projects. Survival projects, on the other hand, are the “must-do” projects. These projects must be done, or the enterprise will suffer irreparable damage. Another way of looking at this model is that survival projects are projects that must be done, and all other projects are growth projects.

How Are You Going to Allocate Your Resources?

If the budget is in a contracting phase, you will probably allocate most of your resources to the survival category. On the other hand, if you are in an expansion phase, you will allocate most of your resources to the growth category.

Project Investment Categories

The Project Investment Categories Model is a close kin of the financial investment portfolio. It identifies categories of investments. These categories define types of projects just as a financial portfolio defines types of investment instruments. In the case of projects, you define the following categories:

Infrastructure. Projects that strengthen the hardware and software systems that support the business

Maintenance. Projects that update existing systems or products

New products. Projects that propose entirely new products or services

Research. Projects that investigate new products, services, or systems to support the business

Each type of project will receive some percentage of the resource pool.

How Are You Going to Allocate Your Resources?

This model operates just like the BCG Products/Services Matrix discussed earlier in the chapter. Both models require the portfolio manager to establish a distribution across existing and new products and services. The distribution will most likely be directly related to whether the enterprise is in a growth or maintenance posture with respect to its coming investment strategy.

Choosing Where to Apply These Models

Depending on the particular application that you have in mind, you will want to choose the most appropriate model. This section helps you consider some of the possibilities.

Corporate Level

If your organization has an enterprise-wide project management office that has management responsibility for the project portfolio, then your choice of model is limited to two. Both the BCG Products/Services Matrix and the Strategic Alignment Model are good candidates. Both focus on the strategic goals of the organization at the highest levels and can directly relate a single project to how well it aligns with defined strategies. That provides a basis for prioritizing a project.

Functional Level

At the corporate level, dollars are allocated to strategic initiatives that impact the entire organization, whereas at the functional level, the information technology department, for example, the situation can be quite different. Resources are allocated to operational- or tactical-level projects. Rather than allocating dollars, it is more likely that the resource to be allocated is professional staff. In that case, the Project Distribution Matrix, Growth versus Survival Model, or Project Investment Categories will do the job.

Note

Later in this chapter we discuss the Graham-Englund Selection Model. It doesn’t fit into the framework of the other models, so we treat it separately. In fact, the Graham-Englund Selection Model is built around the allocation of professional resources to prioritized projects as its basic operating rule. That would make the Graham-Englund Selection Model a good choice for functional-level projects.


Evaluating Project Alignment to the Portfolio Strategy

This evaluation is a very simple intake task that places a proposed project into one of several funding categories as defined in the model being used. The beginning of the project intake process involves determining whether the project is in alignment with the portfolio strategy and placing it in the appropriate “bucket.” These buckets are defined by the strategy that is used, and each bucket contains a planned dollar or resource amount. Once all of the projects have been placed in buckets, each bucket is passed to the next phase, where the projects that make up a bucket are prioritized.

There are two ways that this intake process can take place:

  • The person proposing the project does the evaluation.

  • The intake person does the evaluation.

It can work well both ways. If the person proposing the project does the evaluation, he or she will need a clear definition of each funding category in the portfolio strategy. The project proposal may be returned to the proposer for clarification or revision before being placed in a funding category. Some procedures may ask the proposer to classify the project, and then this intake process is nothing more than an administrative function. This does place the burden on the proposer and not on the portfolio manager. However, there is the possibility of biasing the evaluation in favor of the proposer. The bias arises when the proposer, having such intimate familiarity with the proposal, will subjectively evaluate it rather than objectively evaluate it. There is also the strong likelihood that these types of evaluations will not be consistent across all projects. Having an intake person conduct the evaluations ensures that all proposals will be evaluated using a consistent and objective criteria.

In other cases the process is more formal, and the project proposal is screened to specific criteria. This formal evaluation is now a more significant process and may involve the portfolio manager or a portfolio committee. Projects that do not match any funding category are returned to the proposer and rejected with no further action specified or requested. If the portfolio manager does the evaluation, the problem of bias largely disappears. In this scenario the proposer must follow a standard procedure for documenting the proposed project. We return to that topic at the end of this chapter in the section titled Preparing Your Project For Submission to the Portfolio Management Process.

The deliverable from this phase of the process is a simple categorization of projects into funding categories.


Prioritizing Projects and Holding Pending Funding Authorization

The first tactical step in every portfolio management model involves prioritizing the projects that have been shown to be aligned with the portfolio strategy. Recall that the alignment placed the project in a single funding category. It is those projects in a funding category that you prioritize. When you are finished, each funding category will have a list of prioritized projects. There are dozens of approaches that could be used to establish that prioritization. Some are nonnumeric; others are numeric. Some are very simple; others can be quite complex and involve multivariate analysis, goal programming, and other complex computer-based algorithms. Our approach here is to identify those methods that can easily be implemented in the public sector and do not require a computer system for support, although for some, a simple spreadsheet application can reduce some of the labor intensity of the process. We discuss six models:

  • Forced Ranking

  • Q-Sort

  • Must-Haves, Should-Haves, Nice-to-Haves

  • Criteria Weighting

  • Paired Comparisons

  • Risk/Benefit

See Chapter 14 for an additional discussion of these prioritization approaches.

Forced Ranking

This approach is best explained by way of an example. Suppose 10 projects have been proposed. Number them 1, 2, ... 10 so that we can refer to them later on. Suppose that the portfolio management team has six members (A, B, ... F), and they are each asked to rank the 10 projects from most important (1) to least important (10). They can use any criteria they wish, and they do not have to describe the criteria they used. The results of their rankings are shown in Table 20.1.

Table 20.1: Forced Ranking of 10 Projects
Project # | A | B | C | D | E | F | Rank Sum | Forced Rank
1 | 2 | 5 | 3 | 2 | 1 | 6 | 19 | 2
2 | 4 | 3 | 2 | 7 | 9 | 10 | 35 | 6
3 | 7 | 4 | 9 | 8 | 6 | 3 | 37 | 7
4 | 1 | 8 | 5 | 1 | 2 | 2 | 19 | 3
5 | 3 | 6 | 8 | 4 | 7 | 5 | 33 | 5
6 | 8 | 9 | 10 | 9 | 10 | 8 | 54 | 9
7 | 5 | 1 | 1 | 3 | 3 | 4 | 17 | 1
8 | 6 | 2 | 4 | 5 | 4 | 1 | 22 | 4
9 | 10 | 10 | 7 | 10 | 8 | 9 | 54 | 10
10 | 9 | 7 | 6 | 6 | 5 | 7 | 40 | 8

The individual rankings from each of the six members for a specific project are added to produce the rank sum for each project. Low values for the rank sum are indicative of projects that have been given high priority by the members. So, for example, Project 7 has the lowest rank sum and is therefore the highest-priority project. Ties are possible. In fact, the preceding example has two ties (1 and 4, 6 and 9). Ties can be broken in a number of ways. For example, we prefer to use the existing rankings to break ties. In this example, a tie is broken by taking the tied project with the lowest rank score and moving it to the next lowest forced rank. For example, the lowest rank for Project 1 is 6, and the lowest rank for Project 4 is 8. Therefore, the tie is broken by giving Project 1 a rank of 2 and Project 4 a rank of 3.

Forced ranking works well for small numbers of projects, but it does not scale very well.

Q-Sort

When you use Q-Sort (see Figure 20.5), projects are first divided into two groups: high priority and low priority. The high-priority group is then divided into two groups: high priority and medium priority. The low-priority group is also divided into two groups: low priority and medium priority. The next step is to divide the high-priority group into two groups: very high priority and high priority. The same is done for the low-priority group. The decomposition continues until all groups have eight or fewer members. As a last step, you could distribute the medium-priority projects to the other final groups.

Q-Sort is simple and quick. It works well for large numbers of projects. It also works well if done as a small group exercise using a consensus approach.

Must-Haves, Should-Haves, Nice-to-Haves

This approach, and variations of it, is probably the most commonly used way of ranking. As opposed to the forced rank where each individual project is ranked, this approach creates three categories. The person doing the ranking only has to decide which category the project belongs in. The agony of having to decide relative rankings between pairs of projects is spared by this approach. The number of categories is really arbitrary, and the names of the categories are also arbitrary.

Note

We prefer to use the naming convention “must-haves, should-haves, nice-to-haves,” rather than categories like high, medium, low or A, B C. The names avoid the need to define what each category means.

Click To expand
Figure 20.5: An example of the Q-Sort.

This method is even simpler than the Q-Sort. If the number of projects is large, you may need to prioritize the projects within each of the three groups in order to make funding decisions.

Criteria Weighting

There are literally hundreds of criteria weighting models. They are all quite similar, differing only in the minor details. We give one example of criteria weighting, but there are several that all apply the same principles. A number of characteristics are identified, and a numeric weighting is applied to each characteristic. Each characteristic has a scale attached to it. The scales usually range from 1 to 10. Each project is evaluated on each characteristic, and a scale value given to the project. Each scale value is multiplied by the characteristic weight, and these weighted scale values are added. The highest result is associated with the highest-priority project.

Click To expand
Figure 20.6: Criteria weighting.

Figure 20.6 shows a sample calculation for one of the proposed projects for the portfolio. The first column lists the criteria against which all proposed projects for this portfolio will be evaluated. The second column lists the weight of that criterion (higher weight indicates more importance to the scoring algorithm). The third through the seventh columns list the evaluation of the project against the given criteria. Note that the evaluation can be given to more than one level. The only restriction is that the evaluation must be totally spread across the levels. Note that each criteria level adds to one. The eighth column is the sum of the levels multiplied by the score for that level. This process is totally adaptable to the nature of the portfolio. The criteria and criteria weight columns can be defined to address the needs of the portfolio. All other columns are fixed. The last two columns are calculated based on the values in columns 2 through 7.

Paired Comparisons Model

The next scoring model is called the Paired Comparisons Model. In this model, every pair of projects is compared. The evaluator chooses which project in the pair is the higher priority. The matrix in Figure 20.7 is the commonly used method for conducting and recording the results of a paired comparisons exercise.

Click To expand
Figure 20.7: An example of a paired comparisons.

First note that all 10 projects are defined across the 10 columns and down the 10 rows. For 10 projects, there are 45 comparisons that you have to make. The 45 cells above the diagonal contain the comparisons you make. First, Project 1 is compared to Project 2. If Project 1 is given a higher priority than Project 2, a “1” is placed in cell (1, 2) and a “0” is placed in cell (2, 1). If Project 2 had been given a higher priority than Project 1, you would place a “0” in cell (1, 2) and a “1” in cell (2, 1). Next, Project 1 is compared to Project 3, and so on, until Project 1 has been compared to all other nine projects. Then Project 2 is compared to Project 3, and so on. Continuing in this fashion, the remaining cells are completed. The final step is to add all the entries in each of the 10 rows, producing the rank for each project. The higher the score, the higher the rank. The rightmost column reflects the results of those calculations. Note that Project 7 had the highest overall priority.

Note

This Paired Comparisons Model is a quick and simple method; unfortunately, it doesn’t scale very well. For example, 100 projects would require 4950 comparisons.

Click To expand
Figure 20.8: Risk/Benefit Matrix.

Risk/Benefit

The final scoring model is the Risk/Benefit Matrix. There are many ways to do risk analysis, from subjective to very sophisticated mathematical models. The one we are introducing is a very simple quasi-mathematical model. Risk is divided into five levels (1, 2,...5). Level 1 is a very low risk (or high probability of success), and level 5 is a very high risk (or very low probability of success). Actually, any number of levels will do the job. Defining three levels is also quite common. In this model we are going to assess two risks: the risk of technical success and the risk of business success. These are arranged in Figure 20.8.

Each project is assessed in terms of the probability of technical success and the probability of business success. The probability of project success is estimated as the product of the two separate probabilities. To simplify the calculation, the graph shows the results of the computation by placing the project in one of three areas:

  • Fund projects that fall in the lightly shaded cells.

  • Consider projects that fall in the cells with no shading.

  • Refer projects in the darkly shaded cells back to the proposing agency unless there is some compelling reason to fund them.

If there are a large number of projects, you will need to prioritize those that fall in the lightly shaded cells. A good start on that would be to prioritize the cells starting in the upper left corner and working toward the center of the matrix.


Selecting a Balanced Portfolio Using the Prioritized Projects

You might think that because you have a prioritized list in each funding category and you know the resources available for those projects, the selection process would be simple and straightforward, but it isn’t. Selection is a very challenging task for any portfolio management team. The problem stems from the apparent conflict between the results of evaluation, the ranking of projects from most valuable to least valuable, and the need to balance the portfolio with respect to one or more variables. These two notions are often in conflict. As a further complication, should partial funding of projects be allowed? You will see that conflict more clearly later in the section “Balancing the Portfolio.” There are several approaches to picking the project portfolio. As you have already seen, in this chapter we chose to deal with five portfolio strategies and six prioritization approaches. Those gave us 30 possible combinations for selection approaches, and there are many more that we could have discussed. From among the 30 that we could examine, we have picked three to focus on:

  • Strategic Alignment Model and Weighted Criteria

  • Project Distribution Matrix and Forced Ranking

  • Graham-Englund Selection Model with the Project Investment Categories and the Risk/Benefit Matrix

This section shows the results of combining the previous sections into an approach for selecting projects for the portfolio. By choosing the BCG Products/Services Matrix, Strategic Alignment Model, Project Distribution Matrix, Growth versus Survival Model, or the Project Investment Category Model, you make a statement about how your resources will be allocated. Each one of these models generates some number of “buckets” into which resources are distributed. Those buckets with more resources are valued more than those with fewer resources. These buckets represent the supply of resources available to the projects that are demanding those resources. It would be foolish to expect there to be a balance between the supply of resources and the demand for them. Some buckets will have more resources than have been requested, while others will not have enough resources to meet demand. This section explains how to resolve those differences to build a balanced portfolio.

Balancing the Portfolio

Unfortunately, there isn’t a perfect or best way to build a balanced portfolio. There are basically two approaches and neither one ensures an optimal solution:

  • The first approach is to make one master list of prioritized projects. However, if you simply use that prioritized list of projects using any of the models presented so far, you may end up with less than satisfactory results. For example, you could end up funding a number of short-term, low-risk projects with low organizational value. Alternatively, you could end up funding all long-term, high-risk projects with high organizational value. In either case the resulting portfolio would not be representative of the organization’s strategy. In other words, you could end up with a portfolio that was not at all in line with the corporate strategy.

  • The second approach, and the one that we have taken here, is to separate projects into buckets and prioritize the projects that have been placed in each bucket and do this for every bucket. While this certainly gives us a balanced portfolio, it may not give us the best portfolio. Why is that? Some buckets may have been very popular choices for proposed projects, and a very good project may not have reached high enough on the priority list to be funded. Yet that project may be a much better alternative than some project in another bucket that did receive funding. It’s basically the luck of the draw.

So which approach should you take? We recommend the second, and there are two reasons for our recommendation:

  • Prioritizing a single list, which may be long, is far more difficult than working with several shorter lists. The work can be divided among several persons or groups in the second case, but not in the first case. Furthermore, when you first align projects with funding categories and then prioritize within funding categories, you are not only working with a smaller number of projects but with a group of projects that are more homogeneous.

  • Once the projects have been aligned within funding categories, the portfolio manager may then allocate the resources across the funding categories. That avoids the situation where there could otherwise be a wide variance between the resources that are being requested and those that are being offered in each category. The caution here is that the portfolio manager may try to honor the requests and abandon any portfolio strategy. You can’t have it both ways.

The examples given in the sections that follow illustrate some of these ideas. These are but a few of the many examples we could give, but they are sufficient to illustrate some of the ways to mitigate against such outcomes and ensure a balanced portfolio that reflects the organization’s investment strategy.

Strategic Alignment Model and Weighted Criteria

In this section we use the Strategic Alignment Model to select projects for the portfolio. Figure 20.9 shows one variation that we might use.

Click To expand
Figure 20.9: Achieving balance with the Strategic Alignment Model.

Each objective is weighted with a number between 0 and 1. Note that the sum of the weights is 1. These weights show the relative importance of each objective compared against the others. Below each objective is the budget allocated to that objective. The total budget is $20M. Ten projects are being considered for this portfolio. The proposed budget for each is shown with the project number. The total request is for $25M. In this example, a project may be associated with more than one objective. We can do that by assigning to each project objective pair a weight that measures that strength of the relationship of that project to that objective. This weight was the result of evaluating the alignment of the projects to the objectives. The sum of the weights for any project is 1.0. To establish the priority order of the 10 projects, multiply the objective weight by the project weight and add the numbers. The result of that calculation is shown in the Score column for all 10 projects in the example we are using. The higher the project’s score, the higher the project should be on your list of projects to fund. So Project 7 is the top-priority project with a score of .300. Project 10 is the tenth priority with a score of .120.

The awards to the projects are made by starting with the highest-priority project, which in the example is Project 7. The request is for $3M. Of that amount, 80 percent will come from the budget for Strategy 2 and 20 percent will come from Strategy 4. That reduces the budget for Strategy 2 from $5M to $2.6M and for Strategy 4 from $4M to $3.4M. The process continues with the next-highest-priority project and continues until the budget for each strategy is allocated or there are no more requests for resources. There may be cases where a project receives only partial funding from a funding category. For example, Project 10 should have received $1.6M from Strategy 1 but when it came up for funding, there was only $0.3M left in that budget. Following the example to completion results in the allocations shown in Figure 20.9. The requests totaled $25M, the budget totaled $20M, and the allocations totaled $19.4M. The remaining $0.6M should not be redistributed to those projects that did not receive their requested support. These resources are held pending performance of the portfolio and the possible need to reallocate resources at some later date.

This section gives you but one example of applying an adaptation of criteria weighting to the Strategic Alignment Model to produce a portfolio selection approach. This model is probably the best of those discussed in this chapter because it allows the portfolio manager to express the enterprise strategy in a direct and clear fashion through the weights chosen for each objective. It also shows how the proposed projects relate to that prioritization through the weighted scores on each objective. The model provides management with a tool that can easily adapt to changing priorities and that can be shared with the organization.

Project Distribution Matrix and Forced Ranking Model

To further illustrate the process of creating a portfolio selection approach, next we combine the Project Distribution Matrix and the Forced Ranking Model. First, assume that the total dollars available for Major IT Projects is $20M and that the dollars have been allocated as shown in Figure 20.10. We’ll use the same 10 projects from the previous section with the same funding requests. The projects are listed in the order of their ranking within each funding category.

The first thing to note in this example is that the investment decisions do not line up very well with the funding requests from the 10 projects. There is a total of $9M in four funding categories with no projects aligned in those categories. Your priorities as portfolio manager were expressed by your allocation of funds to the various funding categories. However, the project proposals do not line up with that strategy. Are you willing to make any budget changes to better accommodate the requests? You should, but with the stipulation that you do not compromise your investment strategy. Legitimate changes would be to move resources to the left but in the same row or up but in the same column. If you agree that that is acceptable, then you end up with Figure 20.11. $3M was moved from the Strategic/Maintained category to the Strategic/Enhanced category, and $1M was moved from the Operational/New category to the Tactical/New category. Any other movement of monies would compromise the investment strategy.

Click To expand
Figure 20.10: Project Distribution Matrix with budget and funding requests.
Click To expand
Figure 20.11: Project Distribution Matrix with adjusted budget and funding requests.

After the allocations have been made, you are left with Figure 20.12. The balances remaining are also shown in Figure 20.12. These monies are to be held pending changes to project status as project work is undertaken.

Graham-Englund Selection Model and the Risk/Benefit Matrix

So far in the examples the only resource we have been working with is money. However, one of the most important resources, at least for information technology projects, is people. Staff resources are composed of professionals of varying skills and experiences. As you consider the portfolio of projects, you need to take into account the ability of the staff to deliver that portfolio. For example, if the portfolio were largely new or enhanced strategic applications, you would draw heavily on your most experienced and skilled professionals. What would you do with those who were lesser skilled or experienced? That is an important consideration, and the Graham-Englund Selection Model is one model that approaches project selection with that concern in mind. Basically it will work from a prioritized list of selected projects and staff them until certain sets of skilled and/or experienced professionals have been fully allocated. In other words, people, not money, become the constraint on the project portfolio. Several related problems arise as a result. We will briefly discuss some of the issues and staffing concerns that this approach raises.

Click To expand
Figure 20.12: Project Distribution Matrix with budget balances and funding decisions.

The Graham-Englund Selection Model is a close parallel to those previously discussed, but it has some interesting differences. We put it in here because of its simplicity and the fact that it has received some attention in practice. Figure 20.13 is an adaptation of the portfolio project life cycle to the Graham-Englund Selection Model.

What Should We Do?

The answer to this question is equivalent to establishing the portfolio strategy. In the case of the Graham-Englund Selection Model, we are referring to the IT strategy of the organization. The answer can be found in the organization’s values, mission, and objectives, and it is the general direction in which they should be headed consistent with who they are and what they want to be. It is IT’s role to support those goals and values. IT will do that by crafting a portfolio of projects consistent with those goals and values. Think of answering “What should we do?” as the demand side of the equation. You will use the project investment categories (infrastructure, maintenance, new products, and research) to identify the projects you should do. These categories loosely align with the skill sets of the technical staff and will give you a basis for assigning resources to projects. In fact, any categorization that allows a mapping of skills to projects will do the job. We have kept it simple for that sake of the example, but this approach can get very complex.

Click To expand
Figure 20.13: An adaptation of the Graham-Englund Selection Model.
Click To expand
Figure 20.14: Project staffing requirements.

Figure 20.14 is a list of the 10 projects and the skilled positions needed to staff them. The second column gives the number of staff in each position that is available for these 10 projects. Again, we have kept the data simple for the sake of the example.

What Can We Do?

The answer to this question is found by comparing project requirements with the organization’s resource capacity. Current commitments come into play here, as the organization must look at available capacity rather than just total capacity.

Note

Dealing with the issue of what your organization can do raises the important issue of having a good human resource-staffing model in place, one that considers future growth of the enterprise, current and projected skills inventories, training programs, career development programs, recruiting and hiring policies and plans, turnover, retirements, and so on.

Think of answering “What can we do?” as the supply side of the equation. Figure 20.14 lists the projects that can be done with the staff resources available. Under each project number is the type of project (I = infrastructure, M = maintenance, N = new product, and R = research). However, it does not say which projects will be done. Not all of them can be done simultaneously with the available staff resources, so the question as to which ones will be done is a fair question.

What Will We Do?

The list of projects given in Figure 20.14 is longer than the list of projects you will do. The creation of the “will-do” list implies that some prioritization has taken place. Various criteria such as return on investment, break-even analysis, internal rate of return, and cost/benefit analysis might be done to create this prioritized list. In this example we will use the list that results from the Risk/Benefit Matrix, as shown in Figure 20.15.

The priority ordering of the projects based on the probabilities of success is P#1, P#4, P#5, P#2, P#7, P#3, P#6, P#8, P#9, and P#10. If you staff the projects in that order, you will be able to staff Projects 1, 4, 5, 2, and 7. At that point you will have assigned all resources except one senior project manager. Projects 3, 6, and 8 did fall in the acceptable risk categories, but there are no resources left to staff them.

Click To expand
Figure 20.15: Projects prioritized using the Risk/Benefit Matrix.

However, the example is oversimplified. You have assumed that a person is staffed 100 percent to the project. That is unlikely. In reality, a scarce resource would be scheduled to work on projects concurrently so as to allow more projects to be active. In reality, you would sequence the projects rather than start them all at the same time. Projects have differing durations, and this difference frees up resources to be reassigned. In any case, the example has shown you how the process works.

How Will We Do It?

Answering this question is roughly equivalent to the selection phase in the portfolio project life cycle. In the case of resource management, “How will we do it?” is just a big staffing and scheduling problem. By scheduling scarce resources across the prioritized list, you are placing more projects on active status; that is, they will be placed in the portfolio. Detailed project plans are put in place, and the scheduling of scarce resources across the projects is coordinated. Performance against those plans is carefully monitored because the resource schedule has created a dependency between the projects. The critical chain approach to project management offers considerable detail on scheduling scarce resources across multiple projects. The interested reader should referred back to Chapter 12 of this book, where we discuss critical chain project management in more detail, as well as the book Critical Chain Project Management by Lawrence Leach.

Balancing Using Partial Funding or Staffing of Projects

Earlier in the chapter we asked the question about whether partial funding would be allowed. The tentative answer to the question of partial funding or partial staffing is yes, because it yields a couple of key benefits. The most obvious benefits are that it puts more projects into active status and gives us a chance to better control the risk in the portfolio. If one of those partially funded projects doesn’t meet muster, it can be postponed or cancelled and the remaining resources reallocated to other partially funded projects that are meeting muster. There is one major drawback that the portfolio manager must contend with: The delivery date of the partially funded projects will be extended into the next budget cycle. That may mean a delay in getting products or services into the market and hence delay the revenue stream. That has obvious business implications that must be taken into account.


Managing the Active Projects

In this last phase, you continuously compare the performance of the projects in the portfolio against your plan. Projects can be in one of three statuses: On Plan, Off Plan, or In Trouble. You will see how that status is determined and what action can be taken as a result. Here, the challenge is to find performance measures that can be applied equitably across all the projects. Two come to mind:

  • Cost schedule control

  • Milestone trend charts

The detailed discussion of these is given later in this section.

To bring closure to the final phase, projects can be postponed, cancelled, or, believe it or not, completed, and you will see exactly how these endings affect the portfolio going forward.

So, the project is underway. Regardless of the effort that was expended to put a very precise and complete plan in place, something will happen to thwart those efforts. In the 35 years that we have been managing projects, not a single project went according to plan. That wasn’t due to any shortcomings on our part. It is simply a fact of life that things will happen that could never have been foreseen, and the project will be impacted. Corrective actions will have to be taken. In this module you will see two reporting tools that allow an apples-to-apples comparison of the status of projects in the portfolio. The first tool is applied at the portfolio management level, while the second tool is applied at the project level.

Project Status

As mentioned, there are three categories for the status of active projects: On Plan, Off Plan, or In Trouble. The next sections take a look at each of these states and how that status might be determined.

On Plan

Even the best of plans will not result in a project that stays exactly on schedule. A certain amount of variance from the plan is expected and is not indicative of a project in jeopardy. The threshold between On Plan and Off Plan is a subjective call. We offer some guidelines for this variance later in the chapter, in the section titled SPI and CPI Trend Charts.

Off Plan

Once a project crosses that threshold value, it moves from On Plan to Off Plan. For a project to be Off Plan is not unexpected. But what is expected is to get back On Plan. If the project manager cannot show the corrective action that will be taken to get the project back On Plan and when that event is likely to occur, there is a problem and the project has now moved to In Trouble. The project can also move to In Trouble if it passes a second threshold value that separates Off Plan from In Trouble.

In Trouble

No matter in what way the project reaches the In Trouble condition, the implications are very serious. To be In Trouble means that there is not much chance that the project can be restored. Serious intervention is required because the problem is out of control and out of the range of the project manager’s abilities to correct. However, just because a project is In Trouble doesn’t necessarily mean that the project manager is at fault. There may be cases where freak occurrences and random acts of nature have put the project in this category. The project manager is unable to put a get-well plan in place and is asking for help that goes beyond his or her range of authority. The portfolio manager is considering canceling the project unless there is some compelling reason why that action should not be taken. So a new project manager will not necessarily rectify the problem.

The Role of the Project Manager

Obviously, one of the project manager’s key responsibilities is the status of the project. While there are many reasons that a project may drift out of plan, it is the responsibility of the project manager to institute corrective measures to restore the project to an On Plan status. The extent to which the project manager meets that responsibility will be obvious from the future status of an Off Plan project.

The project manager can also be a cause of an Off Plan status. That can happen in a number of ways. In our experience, one of the major contributing factors is the failure of the project manager to have a good system of cross-checking and validating the integrity of the task status being reported by the team. If the project manager does not have a visible process for validating task status, that is a good indication that scheduling problems are sure to occur. The second behavioral problem that we see is the failure of the project manager to establish a repeatable and effective communications process. The first place to look for that is in constant questioning from the team members about some aspect of the project that impacts their work for which they have little or no knowledge. There should be full disclosure by the project manager to the team. That process begins at planning time and extends through to the closure of the project.

Reporting Portfolio Performance

Two well-known reporting tools can be used to compare the projects across a portfolio and likewise the general performance of the portfolio as a whole: cost/schedule control (C/SC) and milestone trend charts. Both of these were discussed in detail in Chapter 10, and that discussion is not repeated here. What we will do is take those two reporting tools and show how they can be applied to measuring the performance of the portfolio.

Schedule Performance Index and Cost Performance Index

From C/SC we take the schedule performance index (SPI) and cost performance index (CPI).

Schedule performance index. The schedule performance index (SPI) is a measure of how close the project is to performing work as it was actually scheduled. If the project is ahead of schedule, its SPI will be greater than 1, and if it is behind schedule its SPI will be less than 1, which would indicate that the work performed was less than the work scheduled.

Cost performance index. The cost performance index (CPI) is a measure of how close the project is to spending on the work performed to what was planned to have been spent. If you are spending less on the work performed than was budgeted, the CPI will be greater than 1. If not, and you are spending more than was budgeted for the work performed, then the CPI will be less than 1.

These two indices are intuitive and are good yardsticks to compare the projects in a portfolio. Any value less than 1 is undesirable; any value over 1 is good. These indices are displayed graphically as trends compared against the baseline value of 1.

SPI and CPI Trend Charts

The milestone trend charts that we introduced in Chapter 10 are adapted here to fit the SPI and CPI trends. We will track the SPI and CPI over time using the criteria established in Chapter 10.

Some examples will help. Take a look at a milestone trend chart for a hypothetical project (see Figure 20.16). The trend chart plots the SPI and CPI for a single project at weekly reporting intervals. The heavy horizontal line has the value 1. That is the boundary value for each index. Values above 1 indicate an ahead-of-schedule or under-budget situation for that reporting period. Values below 1 indicate a behind-schedule or over-budget situation for that reporting period. Over time these indices tell us an interesting story of how the project is progressing or not progressing.

For example, Figure 20.16 shows that beginning with Week 5 the schedule for Project ALPHA began to slip. The slight improvement in the budget may be explained by work not being done, and hence the cost of that work that was scheduled but not done was not logged to the project. This type of relationship between schedule and cost is not unusual.

Spotting Out-of-Control Situations

Certain patterns signal an out-of-control situation. Some examples of these sorts of situations are shown in Figures 20.17 through 20.20 and are described in this section.

Figure 20.17 depicts a project schedule is slowly slipping out of control. Each report period shows additional slippage since the last report period. Four such successive occurrences, however minor they may seem, require special corrective action on the part of the project manager.

Click To expand
Figure 20.16: Example SPI and CPI trend chart.
Click To expand
Figure 20.17: A run up or down of four or more successive SPI or CPI values.
Click To expand
Figure 20.18: Seven or more successive SPI or CPI values above or below 1.

Figure 20.18, shows a minor over-budget situation. While this may not be significant by itself, that situation has persisted for the last seven report periods. The portfolio manager can fairly ask the project manager why he or she hasn’t corrected the situation. The situation isn’t serious, but it should have been fixed by now. There may be extenuating circumstances that occurred in the first few weeks of the project that have persisted without any possibility of correction. It is true that the CPI and SPI are fairly stable despite their negative performance.

Figure 20.19 shows both the SPI and CPI trending in the same direction. The fact that the trend is negative is very serious. Not only is the schedule slipping, but also there are consistent cost overruns at the same time. If the situation were reversed and the trend were positive, you would obviously have a much better situation. In that case not only would the project be ahead of schedule, but it would also be running under budget. Figure 20.20 illustrates that point.

Click To expand
Figure 20.19: SPI and CPI trending in the same direction.
Click To expand
Figure 20.20: SPI and CPI trending in the same direction.
Note

Don’t be too quick to congratulate the project manager, because it may not be his or her heroic efforts that created that situation. If the duration estimates were too generous and the labor needed to complete the activities was not what was estimated, then the project may be ahead of schedule and under budget through no special efforts of anyone on the team. Still, give the project manager some room here; he or she may have been heroic.

In either case, whether trending to the good or trending to the bad, a good portfolio manager investigates and finds out what has happened.

These same data plots can be used to show how the portfolio is performing both with respect to schedule and cost. Figure 20.21 is the hypothetical data for the BETA Program Portfolio. It consists of five projects that all began at the same time. The solid lines are the SPI values for the five projects over the seven-week report period. The heavy dotted line is the portfolio average. While the portfolio has been behind schedule for the entire seven weeks, it is trending upward and has nearly reached an on-schedule situation. The same type of plot can show budget performance for the portfolio as well.

Click To expand
Figure 20.21: SPI values for a hypothetical portfolio.


Closing Projects in the Portfolio

Best practices include acceptance criteria, agreed upon by the client and the project manager during project planning, that clearly state when the project is considered finished. This acceptance criteria usually takes the form of a checklist of scope items or requirements. When all items on the checklist have been checked off as completed, the project is deemed finished. The work of the project, however, is not yet complete. What remains is what we call a post-implementation audit. The topic of this section is to examine the activities and contents of a post-implementation audit and discuss why it is so important that one be done.

Attainment of Explicit Business Value

Each project was proposed based on the value it would return to the enterprise if it were funded and completed successfully. Was that value achieved? This is a question that may not be answerable until some time after the project is complete, but it is a question that deserves an answer. This proposed value was the basis for the business justification for the project and was a major factor in placing the project in the portfolio in the first place.

Lessons Learned

Following are several questions that might be asked about a project just completed:

  • Was the project goal/objectives achieved?

  • Was the project work done on time?

  • Was the client satisfied with the project results?

  • Was the explicit business value realized? (Check success criteria.)

  • What modules were learned about your project management methodology? What worked? What didn’t work?

  • How well did the team follow the methodology?

All of these questions are important and should be answered. In some cases the particular nature of the project may render some questions more important than others, but that does not excuse the project team from answers to all of them. Some of the most important information about the project management process can come from these answers, so the answers should be shared with all other project teams.


Preparing Your Project for Submission to the Portfolio Management Process

Now that you understand the portfolio management process, you should have a pretty good idea of what you need to do to prepare your project proposal for submission and consideration to be part of a portfolio. In the absence of your having to follow a prescribed procedure for proposing your project, we can suggest three ways to prepare your project proposal:

  • First, you might adapt the POS, which was discussed in detail in Chapter 3. The POS will work quite well but may need some additional information, like cost and time estimates, that are traditionally not part of the POS.

  • Second, you might try a two-step approach. Submit the POS first to determine the alignment of your project, and then prepare a detailed project plan in order to submit time and cost data to the prioritization and selection phases.

  • Finally, you might develop an entirely new submission process based on the five-phase portfolio management process.

The next three sections spend a few paragraphs on each one of these options.

A Revised Project Overview Statement

Chapter 3 already discusses the POS in great detail, so we won’t repeat that discussion here. Recall that the POS is a short document (ideally one page) that concisely states what is to be done in the project, why it is to be done, and what value it will provide to the organization when completed.

When it is used in the portfolio management process, the main purpose of the POS is to have the portfolio committee evaluate the project and determine that it is in alignment with the corporate strategy. Later it will be reviewed by the managers who are responsible for setting priorities and deciding what projects to support in the portfolio. For this reason, the POS cannot contain any technical jargon that generally would not be used across the enterprise. Once approved, the POS becomes the foundation for future planning and execution of the project. It becomes the reference document for questions or conflicts regarding project scope and purpose.

Parts of the POS

The POS has five component parts:

  • Problem/opportunity statement

  • Project goal

  • Project objectives

  • Success criteria

  • Assumptions, risks, and obstacles

Recall that its structure is designed to lead the reader from a statement of fact (problem/opportunity) to a statement of what this project will address (project goal). Given that senior management is interested in the project goal and that it addresses a concern of sufficiently high priority, they will read more detail on exactly what the project includes (project objectives). The organizational value is expressed as quantitative outcomes (success criteria). Finally, a summary of conditions that may hinder project success are identified (assumptions, risks, obstacles). The following list looks at each of these sections more closely as they apply to the project portfolio process:

Problem/opportunity statement. The first part of the POS is a statement of the strategic objective(s) that the project is addressing. If appropriate, the statement should come directly from the company’s strategic plan or be based on the portfolio strategy. This is critical because it provides a basis for the rest of the document. It also sets the priority with which the portfolio manager will view what follows. If you are addressing a high-priority area or high-value area, your idea will get more attention and the reader will read on.

Project goal. The second section of the POS states the goal of the project—what you intend to do to address the strategic objective(s) identified in the previous section. The purpose of the goal statement is to get senior management to value the idea enough to read on. In other words, they should think enough of your approach to the corporate strategy to conclude that it warrants further attention and consideration. Several other proposals will pertain to the same objective(s). Because yours will not be the only one submitted, you want it to stand out among the crowd.

The goal statement must not contain any language or terminology that might not be understandable to anyone having occasion to read it. In other words, no techie talk allowed. It is written in the language of the organization so that anyone who reads it will understand it without further explanation from the proposer. Under all circumstances, avoid jargon.

The goal statement is short and to the point. Keep in mind that the more you write, the more you increase the risk that someone will find fault with something you have said. The goal statement does not include any information that might commit the project to dates or deliverables that are not practical. Remember, you do not have much detail about the project at this point.

Project objectives. The third section of the POS is the project objectives. Here is your chance to show more breadth to your project and bind it even tighter to one or more of the strategic objectives.

Success criteria. The fourth section of the POS answers the question, “Why do we want to do this project?” It is the measurable explicit business outcome that will result from doing this project. It sells the project to the portfolio manager. This may be the most important part of the POS. The portfolio manager is trying to maximize the value that can be generated from the portfolio. Every project has to contribute to that value.

The question that you have to answer is this: What business value will result from successfully completing the project? The answer to this question will be a statement of the explicit business outcome to be realized. It is essential that the criteria be quantifiable and measurable, and if possible, expressed in terms of business value. Remember that you are trying to sell your idea to the portfolio manager.

As an added value statement, consider quantifiable statements about the impact your project will have on efficiency and effectiveness, error rates, reduced turnaround time to service a customer request, reduced cost of providing service, quality, or improved customer satisfaction. Management deals in deliverables, so always try to express success criteria in quantitative terms. By doing this you avoid any possibility of disagreement as to whether the success criteria were met and the project was successful. The portfolio manager will look at your success criteria and assign organizational value to your project. In the absence of other criteria, this success criteria will be the basis for his or her decision whether or not to place the project in the portfolio.

Assumptions, risks, and obstacles. The fifth section of the POS identifies any factors that can affect the outcome of the project and that you want to bring to the attention of the portfolio manager. These factors can affect deliverables, the realization of the success criteria, the ability of the project team to complete the project as planned, or any other environmental or organizational conditions that are relevant to the project. You want to record anything that can go wrong. Be careful, however, to put in the POS only those items that you want senior management to know about and in which they will be interested.

The project manager uses the assumptions, risks, and obstacles section to alert the portfolio manager to any factors that may interfere with the project work or compromise the contribution that the project can make to the organization. Do not assume that everyone knows what the risks and perils to the project will be. Document them and discuss them.

POS Attachments

The best way we have found to provide the important time and cost information with your POS is through one or more selected attachments. As part of their initial evaluation and prioritization of your project proposal, portfolio management may want some measure of the economic value of the proposed project. They recognize that many of the estimates are little more than a guess, but they will nevertheless ask for this information.

Note

We recommend giving range estimates rather than point estimates. You don’t have enough detail at this point to do any better.

In our experience, we recommend that you consider adding one of two types of analyses to your POS:

Risk analysis. Risk analysis is the most frequently used attachment to the POS in our experience. In some cases, this analysis is a very cursory treatment. In others, it is a mathematically rigorous exercise. Many business decision models depend on quantifying risks, expected loss if the risk materializes, and the probability that the risk will occur. All of these are quantified, and the resulting analyses guide the portfolio manager in decisions on project approval. Risk management was discussed in detail in Chapter 2 and briefly in Chapter 3.

Financial analyses. Some portfolio managers may require a preliminary financial analysis of the project. Although such analyses are very rough because not enough information is known about the project at this time, they will still be useful. In some instances, they also offer criteria for prioritizing all of the POSs the portfolio manager will be reviewing. Some of the possible analyses are feasibility studies, cost/benefit analyses, and break-even analyses. These were all discussed in Chapter 3.

A Two-Step Submission Process

The first step in the two-step submission process is to submit the POS much as is described in the previous section. Once the alignment decision has been made and the project is aligned with the portfolio strategy, the second step can be taken. The second step is to prepare and submit the detailed project plan. The plan can contain information that would be useful for later decisions, and the information is generally not provided unless it will be used. The strategy in the two-step process is to do the extensive planning work only if the project is deemed to be in alignment with the portfolio strategy. An added benefit to the two-step process is that how the project is aligned may also be useful information for the planning work. In our experience the planning effort can take a number of directions and to know specifically how the project relates to the portfolio strategy can produce better and more targeted business value.

A New Submission Process

If you are going to fashion a new submission process based on the five-phase portfolio management process, we advocate a single submission that contains all of the information needed to take the project up to the Selected stage of the project portfolio life cycle. What information is needed to reach that point? Here is a list for your consideration:

Project name. A name that will give some indication of what the project is all about. Don’t use coded names like XP.47.

Sponsor name. The name, position title, and business unit affiliation of the sponsoring individual.

Project manager name. If known.

Project funding category. This will attach the project to some part of the portfolio strategy. In some cases multiple categories may be given.

Project goal. This will be the same type of statement you would have used in the POS for this project.

Project objectives. This will be the same type of statements you would have used in the POS for this project.

Explicit business value. This is a very important piece of the submission. Here you have to establish the business value for this project. You need to make a quantitative statement about increased revenue, decreased cost, or improved service. It must be a measurable metric.

Risks. Risk combined with project cost and explicit business value will give financial analysts the grist for their mill. This is where the true business validation of the project is made or lost.

Estimated total project cost. You do not have a detailed project plan at this point, so all that you can give is a range estimate.

Estimated project duration. You do not know when the project will begin, and so you cannot give a completion date. The statement you want to make here is something like “This project will be completed eight months after the start date,” or better still, “This project can be completed in six to nine months following its start date.”


Putting It All Together

We have shown you a model for project portfolio management and several contemporary tools and processes that you might employ to implement it. In effect, we have given you a starter kit for building your own project portfolio management process. If you are a project manager and have to submit your project to a portfolio committee for approval, you now have a strategy for doing that and having some hope for success.


Discussion Questions

  1. In what ways, if any, would TPM, APF, and xPM projects affect your project portfolio management process? Be specific.

  2. What criteria (time, cost, value, and so on) must a sequence of activities meet in order to qualify as a project for the portfolio?

  3. What types of data will you need in order to evaluate, prioritize, and select projects for the portfolio?

  4. How might you combine the CSC approach with milestone trend charts to produce yet a third tracking method?


Chapter 21: Project Support Office

Overview

There is nothing more difficult to take in hand, more perilous to conduct, or more uncertain in its success, than to take the lead in the introduction of a new order of things.

—Machiavelli, The Prince

Your organization has put a project management methodology in place, and teams are beginning to use it. However, you are not satisfied. Your expectation is that everyone would be using a project management methodology and that a higher percentage of projects would be successfully completed. So far there has been no measurable impact on project success. What can you do?

Start Sidebar
Chapter Learning Objectives

After reading this chapter, you will be able to:

  • Describe a PSO

  • Understand the signs that you need a PSO

  • Know the missions, objectives, and structures of the PSO

  • Know the functions performed by the PSO

  • Know how to establish a PSO

  • Understand the challenges to establishing a PSO

  • Know how to grow and mature your PSO

End Sidebar

The latest advancement in project management is the Project Support Office (PSO). It is established to support project teams and to reduce the risk of project failure. The PSO has several different names and variations in terms of mission, objectives, functions, organizational structure, and organizational placement. These can become quite overwhelming for someone who is not familiar with the concept and its practice. In this chapter we intend to help you understand all aspects of the PSO and to recognize the signs that you should establish one.


Background of the Project Support Office

Early in the life cycle of any process, there are always the early adopters who stumble onto it and are eager to give it a chance. Their enthusiasm may prove to be contagious, and soon others begin using the process too. At some point management begins to take notice because the understanding of the process is creating problems. Not everyone understands the process the same way. And there are many levels of expertise with the tool; while some misuse it, others don’t take its use seriously.

If this sounds like the general topic of project management, it should. Senior management intuitively understood they needed to do something about the problem, and the first reaction was to send people away for some project management training. This by itself didn’t cause much improvement.

Next came the introduction of some standards and common metrics found in project management. A project management process was crafted and introduced with a lot of fanfare. All were expected to use it. Some did, some didn’t. Some still held on to their old ways and managed projects the way they had been doing it all along. While all of this was going on, projects continued to be executed. There were so many projects underway and so much confusion that management recognized the seriousness of the problem. There was no way to manage across projects within the organization because of redundancy, wasted resources, and the lack of managed standards, and there was no leadership in making project management an asset to the organization. Effective project management was a recognized need in the organization. Senior management held high expectations that by having a standardized project management methodology the success rate of projects would increase. Considerable effort was spent getting a methodology designed, documented, and installed, but somehow it had little impact on project success rates. In fact, it was a big disappointment. Senior management realized that having a methodology wasn’t sufficient. Something more was needed. And thus appeared the Project Support Office (PSO). The PSO was an opportunity to put an entity in place that would ensure compliance. Project success would surely follow. The PSO would be an insurance policy that would protect the adoption and spread of the methodology.

There are at least four reasons why an organization would choose to implement a PSO:

  • As the organization grows in the number and complexity of the projects in its portfolio, it must adopt formal procedures for managing the volume. To do this, the organization establishes the procedures that are followed for initiating, proposing, and approving projects.

  • With the increased volume comes a need for more qualified project managers. Those who would like to become project managers will need to be identified and trained. Those who already are project managers will need additional training to deal effectively with the increased complexity. The PSO is the depository of the organization’s skill inventory of current and developing project managers. Because managers using the PSO are aware of the types and complexity of current and forthcoming projects, the PSO is the entity best prepared to identify the training needs of project managers and their teams.

  • Lack of standards and policies leads to increased inefficiencies and a compromise on productivity. The increasing failure rate of projects is testimony to that fact. Through the establishment and enforcement of standards and practices, the PSO can have a positive impact on efficiency and productivity.

  • Finally, the increased complexity and number of projects places a greater demand on resources. It is no secret that the scarcity of information technology professionals has become a barrier to project success. By paying attention to the demand for skilled project teams and the inventory of skilled team members, the PSO can maintain the proper balance through training.


What Is a Project Support Office?

There are several varieties of PSOs in use in the contemporary organization. Each serves a different purpose. Before you can consider establishing a PSO in your organization, you have to understand these differences. The purpose of this section is to discuss those differences and ascertain what form is best suited for you organization. A good working definition of a Project Support Office is:

A Project Support Office is a temporary or permanent organizational unit that provides a portfolio of services to support project teams that are responsible for a specific portfolio of projects.

The next three sections look at each of the major components of the definition.

Temporary or Permanent Organizational Unit

Among the various forms of PSOs, some are temporary and some are permanent structures. That determination is made based on the types of projects that they support.

Temporary. PSOs that are temporary are usually called Program Offices, and they support the administrative needs of a group of projects that are related by purpose or goal. When those projects are completed, the Program Office is disbanded. Many government projects have Program Offices attached to them. They are generally long-term arrangements and involve millions or billions of dollars of funding.

Permanent. Those that are permanent are called by various names as discussed in the section Naming the Project Support Office later in the chapter. These PSOs provide a range of support services for projects that are grouped by organizational unit rather than goal or purpose.

Portfolio of Services

The fully functional PSO serves six major purposes. For now, we’ll briefly list and describe them. Further discussion of these functions occurs later in the chapter in more detail in the section Exploring PSO Functions.

Project support. This includes preparing proposals, gathering and reporting weekly status information, maintaining the project notebook, and assisting with the post-implementation audit.

Consulting and mentoring. Professional project consultants and trainers are available in the PSO to support the consulting and mentoring needs of the project teams. In this capacity, they are a safe harbor for the project manager and team members as well.

Methods and standards. This includes such areas as project initiation, project planning, project selection, project prioritization, Work Breakdown Structure templates, risk assessment, project documentation, reporting, software selection and training, post-implementation audits, and dissemination of best practices.

Software tools. The evaluation, selection, installation, support, and maintenance of all the software that supports project work is part of this function.

Training. Training curriculum development and training delivery may be assigned to the PSO, depending on whether the organization has a centralized training department and whether it has the expertise needed to develop and deliver the needed programs.

Project manager resources. Here the PSO provides a resource to project managers for advice, suggestions, and career guidance. Regardless of the organizational structure in which the PSO exists, the project manager does not have any other safe place to seek advice and counsel. The PSO is ideally suited to that role. A variety of human resource functions are provided. Some PSOs have project managers assigned to them. In these situations, these project managers are usually assigned to complex, large, or mission-critical projects.

Specific Portfolio of Projects

We have already identified one portfolio—those projects that have a link through their goals and purposes. In other words, collectively they represent a major initiative to accomplish some overall common purpose. A good example is the U.S. space program. Think of a single project as something that will accomplish a part of a greater overall mission. Together all of the projects represent a single focus and common purpose. As stated previously, these projects form a program and are administered under a Program Office. When the goal of the projects that are part of the program is accomplished, the Program Office is disbanded.

Another portfolio of projects that you can identify is one that organizes projects under a single organizational unit and is funded from the same budget, like IT. The IT department’s PSO will be a permanent structure that will support all IT projects now and into the future.

Still one more specific portfolio that deserves mention is made up of those projects that are funded out of the same budget. They may have no other relationship with one another other than they share a finite pool of money. These projects will often be linked through a PSO. Such a PSO will be primarily interested in ensuring the proper expenditure of the dollars in the budget that funds all of these projects. These PSOs will generally have a project portfolio management process in place to manage the budgets for their projects.


Naming the Project Support Office

So far we have casually used the label PSO. In our experiences there are many different names that have been used to identify the organizational unit that provides the functions we have identified, and you may have encountered some of these alternate terms for what we have discussed as the PSO. Some alternate names for a PSO are as follows:

  • Project Office

  • Program Office

  • Project Management Office

  • Project Control Office

  • Project Management Group

  • Project Management Center of Excellence

  • Enterprise PMO

  • Directorate of Project Management

  • Development Management Office

  • IT Project Support

  • Mission Central

Some of these names are clearly attached to an enterprise level unit, while others are more specific to the group they serve. An interesting one is the last one—Mission Central. A recent client for whom we designed and implemented a project management methodology and the accompanying project support office was troubled by the word management and, in fact, wasn’t too happy with the term project either. To that client, the term management suggested some type of oversight or control function that wasn’t the intention, and the term project had been overused in the company and had a lot of baggage that needed to be left behind. They needed a name for this new entity they were commissioning. A naming contest was initiated by the chairman, who also selected the winning entry. Mission Central won.

Despite the misgivings of the client we just discussed, we have nevertheless chosen to use the name PSO for a reason. In our experience the most successful project support units are those that are characterized as providing both proactive and reactive support services. They are ready to respond to requests for help in any way that the project manager or team members may need. These PSOs also have a responsibility of seeing that the organization practices effective project management. That happens through the provision of a standard methodology, the training and documentation to support its widespread use, and a review function to ensure its correct usage.

However, we have had experience with PSOs that send a very different message. These are the units that have more of a monitoring and enforcement mission. They are seldom called a PSO and are more likely to be named Project Management Office, or Project Control Office, or simply Project Office. Such units have a spylike air about them and are unlikely to produce the usage that the organization expects.


Establishing Your PSO's Mission

Team LiB

Establishing Your PSO’s Mission

If you have decided that a PSO will be established, the first order of business is to establish the mission of your PSO. The following list gives some examples of possible mission statements:

  • Provide overall management and administrative support to the ALPHA program.

  • Establish and monitor compliance to the project management methodology.

  • Provide a comprehensive portfolio of support services to all project managers on an as-requested basis.

The first statement is the typical mission statement of a Program Office. It provides administrative support for a program, which comprises a group of projects related to something called “ALPHA Program.” This type of mission statement will be very common in organizations that operate large programs that consist of many projects.

The second statement is a very limited mission statement. Often such a statement doesn’t find much favor with project managers. Even though this mission statement is not popular, it is necessary in any PSO that is worth the price. There must be a standard established and there must be compliance to that standard, but it doesn’t have to be couched in terms that suggest a Gestapo enforcement. Combining a strong statement of support in the mission statement will go a long way toward satisfying the project manager who is desperate for support and can live with it and with the standard.

The third statement is more to our liking. It seems to be more supportive of the things a project manager is looking for in a PSO. This is our pick, and it fits comfortably with a name like Project Support Office. A PSO will still have some of those Gestapo-like functions to perform, but the mission statement suggests that they are surrounded by a comprehensive list of support services. It seems to define a package that can be sold to project managers and to senior managers as well.


Framing PSO Objectives

Assume that you have adopted the third mission statement as the mission statement of your PSO. (We use the name PSO from this point forward in the discussion.) Because the PSO is a business unit, its objectives should be framed in business terms. See the following list for some examples.

  • Help project teams deliver value

  • Increase the success rates of projects to 75 percent

  • Reach PMMM Level 4

The first statement is a bit vague in that it passes the business reason for the PSO to the project teams. They have to define value and make it happen. If you want to hold the toes of the PSO to the fire, then either the second or third statement will do the job. They are very specific and can be easily measured.

Note

PMMM in the third statement stands for Project Management Maturity Model. It is discussed later in this chapter.


Exploring PSO Functions

The six functions mentioned earlier in the chapter and discussed in the following sections are fairly comprehensive of those that a PSO might offer. A word of caution is in order, however. It would be a mistake to implement all of the listed functions at once even if that is the ultimate goal of your PSO. Introducing a PSO into the organization is asking management to absorb quite a bit. You will have a much better chance of success if the functions are prioritized and introduced piecemeal. We have more to say about this later in the chapter when we discuss the challenges of implementing a PSO. For now we will simply define what each of these functions involves and leave implementation for a later conversation.

Project Support

This function encompasses all of the administrative support services that a PSO might offer to a project manager and project team. They are as follows:

  • Schedule updating and reporting

  • Time sheet recording and maintenance

  • Report production and distribution

  • Report archiving

  • Report consolidation and distribution

  • Project notebook maintenance

The PSO project support services are an attempt on the part of the PSO to remove as much non-value-added work from the project team as it can and place it in the PSO. Obviously, you would rather have the project team focused on the work of the project and not be burdened by so-called administrivia. More importantly, the PSO staff will be much more knowledgeable of how to provide these services because they will be very familiar with them and with the use of the tools and systems that support them. It is obvious that the cost of providing the service is much lower if done by the PSO than if done by the project team. Further to the point, the PSO staffs that will actually provide the service need minimal office skills, whereas the project team members’ skill set is not likely to include the skills appropriate to provide these services. Therefore, the service will be provided by a less costly employee who is appropriately positioned for the assignment.

Consulting and Mentoring

The PSO professional staff members are available to project teams and project managers on an as-requested basis. They stand ready to help with any specialized assistance. The following is a list of the consulting and mentoring services they can supply:

  • Proposal development support

  • Facilitation of project planning sessions

  • Risk assessment

  • Project interventions

  • Mentoring and coaching project managers

  • Mentoring senior management

The PSO professional consultants are the senior-most project managers in the company. Their experiences are broad and deep. They have heard and seen all situations. There will not be any surprises to them. They will be able to help the project manager even in the most complex of circumstances.

Note

One practice that we have seen in a few PSOs is to rotate these consultants through the PSO. Think of it as a sabbatical from the front lines. One of the benefits of this rotation is that it continually infuses new ideas and best practices into the PSO as well as back out into the field.

The PSO is uniquely positioned to gather and archive best practices from around the company. That makes them particularly valuable as a resource to project teams. Those resources are made available to teams through the PSO professional consultants.

One service that we believe is particularly valuable is the facilitation of project planning sessions. The PSO consultant is the ideal person to conduct a project planning session. That relieves the project manager from the facilitation responsibility and allows that manager to concentrate on the project plan itself. The PSO consultant can concentrate on running a smooth planning session. This PSO consultant will have better planning facilitation skills than the project manager by virtue of the fact that he or she has conducted far more planning sessions. It is a win-win situation.

One other practice that we have seen is that the PSO consultant is not actually attached to the PSO. They are the virtual PSO consultants. They are out in the field running projects but have particular areas of expertise that they are willing to make available to others as needed. The PSO simply becomes the clearinghouse for such services. With this setup, confidentiality is critical. Project managers are not likely to bare their soul to other project managers if what they say will be the topic of conversation in the lunch room the next day.

Methods and Standards

Methods and standards represent a service that every PSO must provide. A good ROI from a PSO will not happen in the absence of a standard methodology and a means of monitoring and enforcing it. The following list contains the services included in this function:

  • Establishing, monitoring, and enforcing standards

  • Project selection for the portfolio

  • Work Breakdown Structure construction

  • PERT/CPM Network development

  • Maintenance of tools/process library

  • Bid preparation

  • Risk assessment

  • Status reporting

  • Change management

  • Documentation

  • Change orders

The establishment, monitoring, and enforcement of standards are major undertakings for a newly formed PSO. Perhaps more than any other task the PSO will perform, this one affects the culture and operation of the organization. As we discuss later, a plan to put standards in place must involve as many stakeholders as possible. We are talking about a cultural change in every business unit that is involved with projects and project management. The affected parties must have an opportunity to be involved in establishing these standards or the whole effort will be for naught. We have a lot more to say on this point later in the chapter.

Software Tools

Every PSO should be looking for productivity improvements. As teams become dispersed, it is essential that they remain productive. In this technology-crazed business environment, you can’t let time and distance erect barriers to performance. The PSO is the only organizational unit that can provide the support needed in the ever-changing set of tools available on the market. They are responsible for soliciting, evaluating, selecting, and contracting with vendors of these tools. The following lists the services that the organization depends on the PSO to provide:

  • Software evaluation

  • Software selection

  • Vendor negotiations

  • Software training

  • Software management and maintenance

Training

Training in project management has probably been around longer than any other methodology an organization is likely to have. Senior managers incorrectly assumed that the solution to their high rate of project failure lies in giving everyone some training in project management. They were looking for that silver bullet, and there simply isn’t one to be found. What has happened in many organizations is that several different project management training courses have been taken by the professional staff. Accordingly, there is no central approach that they followed as a result of their training. In a sense everyone was still doing his or her own thing. Some followed the approach they had been taught, others did what they had always done, and yet others taught themselves. Under the PSO all of that needs to change.

Note

To have maximum impact on the practice of project management in the organization, a project management curriculum must be built around an established project management methodology. You simply can’t do it any other way.

There is a school of thought that says if you teach the concepts and principles effectively, project managers will be able to adapt them to whatever situation they encounter. That sounds good, but it doesn’t work. We have found that most project managers don’t want to think; they want to be told. “Just tell me what I am supposed to do. I’m not interested in the concepts and theory.” That is a truly unfortunate attitude, but that’s reality; you can’t change it very easily. With that in mind, the PSO, in collaboration with their organization’s training department, must jointly assume the responsibility of designing and implementing a curriculum that is aligned with the organization’s project management methodology. Furthermore, the PSO must assume whatever responsibility the training department is unwilling or unable to assume. Whatever the case, the job must be done. The following lists the training services provided by the PSO.

  • Project management basics

  • Advanced project management

  • PMP exam preparation

  • Specialized topics

  • Support of the training department

  • Development of courses and course content

  • Delivering courses

  • PM training vendor selection

When it comes to project management training, the relationship between the training department and the PSO must be a collaborative effort. The development of the project management curriculum should involve both the curriculum development experts from the training department and the subject matter experts from the PSO. The delivery of the curriculum can be done either by the PSO or by the training department. If it is to be done by the training department, then the curriculum design must have followed a facilitative design. That relieves the training department from having to find trainers who have project management practice expertise, which is difficult at best. In most cases we have seen, the trainers come from those who are project management subject matter experts, and this is really the preferred method. There is no good substitute for frontline experience by the trainer. No amount of book knowledge can replace it.

Project Manager Resources

The final function in our PSO includes a number of human resources services revolving around project managers. The list (which follows this paragraph) is quite comprehensive. It encompasses assessment, development, and deployment services.

  • Human resource development

  • Identification/assessment of skills

  • Selection of team members

  • Selection of project managers

  • Assessment of project teams

  • Professional development

  • Career guidance and development

This function is delivered in two ways:

  • In some cases project managers will be assigned to the PSO. They receive their project assignments from the PSO.

  • The more common arrangement is for the project managers to be assigned to a business or functional unit. Even in this case the PSO can still make project assignments and deliver the human resource services listed under this function.


Selecting PSO Organizational Structures

Different organizations have taken several approaches in the structure and placement of the PSO. In this section we comment on our experiences with each of the structures we have seen in practice. In the following section we consider the organizational placement of the PSO.

Virtual versus Real

A virtual PSO performs all of the functions of any other PSO except that its staff is allocated to the business units. These PSOs are mostly available when their services are needed. They do not perform any routine functions. Other than a director and perhaps an administrative support person, the virtual PSO does not have any other budgeted staff. Professional staffs from the business units that are involved with projects volunteer their services to the PSO. This is not a permanent volunteer position. These individuals, who are generally project managers themselves, agree to serve for some period of time and are then replaced. In many cases they volunteer to provide only a specified type of service or services.

The real PSO, on the other hand, does have a budgeted staff of professionals, which probably includes several project managers. They will perform several routine functions, such as project reviews and software evaluations. The project reviews are a good way to monitor the adoption of the methodology and uncover best practices as well. Their strength will probably be that they offer a healthy dose of project support services to project teams.

Proactive versus Reactive

The proactive PSO aligns very closely with the real PSO, and the reactive PSO aligns closely with the virtual PSO. The real PSO can be proactive because they have the staff to take leadership roles in a variety of projects to improve project management practices. The reactive PSO, on the other hand, does not have the staff and does well to just respond to requests for help.

Temporary versus Permanent

What we have called Program Offices in this chapter are the only temporary form of PSO that we know of. All other examples of PSOs are permanent and service an ever-changing list of projects.

Program versus Projects

We have already defined programs as collections of related projects. The related projects will always have some dependencies between them, and hence, there will be a need for oversight such as a Program Office. Significant resource management problems will arise because of the interproject dependencies, and only oversight from the vantage point of a Program Office can be effective.

Enterprise versus Functional

PSOs can be attached at the enterprise or at the functional level:

  • At the enterprise level, they must provide services to all disciplines. They are generally well funded and well staffed. They have visibility at the project portfolio level and may be involved in strategic roles.

  • At the functional level, they generally service the needs of a single discipline. They are generally not as well funded or staffed as their enterprise-level counterpart.

Hub—Hub and Spoke

In very large organizations the PSO may be organized in a hierarchical form. At the hub, or central office, if you will, is a high-level PSO that sets policy and standards for the enterprise. If only the hub form is in place, then all of the functions of the PSO will reside there. In time, as the organization grows in its maturity and dependence on the PSO, these functions may be carried out at the business unit or division level by regional PSOs (the spokes), who take their direction from the central PSO. The hub is typically staffed by high-level project executives whose focus is strategic. At the end of a spoke is a regional PSO, which has operational responsibilities for the unit they represent. Obviously, the hub-and-spoke configuration works best in those organizations that have a more mature approach to project management. It is not a structure for the organizations new to project management.


Organizational Placement of the PSO

There are three organizational placements for the PSO, as shown in Figure 21.1.

At the enterprise level they are usually called by some name like Enterprise PSO (EPSO) that suggests they serve the entire enterprise. There are two variations of EPSOs that we have seen—centralized or decentralized:

  • In the centralized version the EPSO provides all of the services to all project teams corporate-wide that any PSO would provide.

  • The decentralized version often has a policy and procedure responsibility with satellite PSOs providing the actual functions in accordance with the established policy and procedures.

    Click To expand
    Figure 21.1: Organizational placement of the PSO.

Both models can be effective. The size of the organization with respect to the number of projects needing support is the best determinant of structure, the decentralized structure favoring the larger organization. There really are no hard-and-fast rules here.

The PSO can also serve the needs of a significant part of the enterprise—such as at the division or business unit level. The most common example is the information technology division. Here the PSO serves the needs of all the IT professionals in the organization (IT PSO in Figure 21.1, for example). Because this PSO is discipline-specific, it will probably offer project support services tailored to the needs of the information technology project. It may also offer services specific to the needs of teams that are using various systems development processes. In other words, a division-level PSO may offer not only project management support services but also services specific to the discipline.

The PSO can also serve the needs of a single program. As shown in the Figure 21.1, there may be several of these programs even within a single division. This is a common occurrence in the information technology division. These PSOs are temporary. When the program that they support is completed, the PSO is disbanded.


How Do You Know You Need a PSO?

However you slice it, the PSO is established for the sole purpose of improving the practice of project management for the group of projects and project managers over whom it has stewardship. The PSO is an investment, and its ROI is measured in terms of cost avoidance. That cost avoidance is a direct result of a significant reduction in project failures for which the PSO is held directly responsible and accountable.

The Standish Group Report

The reasons for project failure have been investigated and reported in detail for several years. One of the most thorough research efforts into the reasons for project failure is the work of the Standish Group (we discussed this research in Chapter 2 as well). Their most recent report is “Chronicles 2000.” In the study reported there, they surveyed several hundred IT executives asking them why projects fail. The top 10 reasons why IT projects fail according to this study were as follows. IT projects fail due to a lack of:

  1. Executive management support

  2. User involvement

  3. Experienced project manager

  4. Clear business objectives

  5. Minimized scope

  6. Standard infrastructure

  7. Firm basic requirements

  8. Formal methodology

  9. Reliable estimates

  10. Skilled staff

After reviewing the major functions that the PSO provides, you can see that a PSO is uniquely positioned to mitigate each of these 10 reasons for project failure. In fact, it is the only organizational entity that is so positioned.

Spotting Symptoms That You Need a PSO

Several symptoms provide you with clues that you might need a PSO:

Project failure rates too high. The data is all too familiar to us. Reports show 70 percent and higher regardless of how you define failure. That is simply unacceptable. Many of the reasons for those high numbers are probably found in the list from the Standish Group. Those that relate to the project management approach that was used—namely, user involvement, clear business objectives, minimized scope, standard infrastructure, firm basic requirements, and formal methodology—can be addressed by choosing the correct approach (TPM, APF, or xPM). It is our contention that by choosing the appropriate approach, the organization can make a serious impact on failure rates.

Training not producing results. We are not aware of any systematic study of the root causes of training ineffectiveness. The possible causes are inappropriate materials, inappropriate delivery, no follow-through on behavioral changes after training, or no testing of skill acquisition. Training needs to be taken seriously by those who attend the training. They need to be held accountable for applying what they have learned, and there needs to be ways to measure that application. We are amazed at how many training professionals and curriculum designers are not familiar with Kirkpatrick’s model. The interested reader can consult Donald L. Kirkpatrick’s Evaluating Training Programs, Second Edition (Berrett-Koehler Publishers, Inc., 1998) In our experience, project reviews that are held at various milestones in the life of the project are excellent points at which to validate the application of training. If there is not clear evidence that training has been applied, some corrective action is certainly called for.

HR project staff planning not effective. Organizations need to do a better job of defining the inventory of project staff skills and the demand for those skills by project. There needs to be a concerted effort to match the supply to the demand and to make better staffing assignments to projects. The PSO is the best place for this responsibility to be carried out.

Can’t leverage best practices. The PSO is the best place to collect and distribute best practices. Project status meetings and project reviews are the place to identify best practices. The PSO, through some form of bulletin board service, is the best place to distribute that information. In the absence of that service, the collection and distribution of best practices isn’t going to happen.

Don’t have control of the project portfolio. Many senior managers don’t know the number of projects that are active. They haven’t made any effort to find out and to be selective of those projects that are active. That behavior has to stop if there is any hope of managing the project work that goes on in the organization. The PSO is the clear choice for stewardship of that portfolio. At least, it can be the unit that assembles project performance data and distributes it to the decision makers for their review and action.

No consistency in project reporting. Without a centralized unit responsible for the reporting process, consistent and useful reporting isn’t going to happen. Again, the PSO is the clear choice to establish the reporting structure and assist in its use.

Too many resource scheduling conflicts. Most organizations operate with some form of matrix structure. Resources are assigned from their functional unit to projects at the discretion of the functional unit manager. In such situations resource conflicts are unavoidable. The individuals that are assigned to projects are torn between doing work for their functional unit and doing work for the project to which they have been assigned. None of this is news to you. One solution to resource scheduling conflicts is to use the PSO as the filter through which project staffing requests and staffing decisions are made. The major benefit of this approach is that it takes the project manager off the hot seat and puts the responsibility in the PSO where it can be more equitably discharged.

Gap between process and practice. This is a major problem area for many organizations. They may have a well-documented process in place, but without any oversight and compliance function in place, they are at the mercy of the project manager to use or not use the process. The PSO is the only unit that can close this gap. The PSO puts the process in place with the help of those who will be held accountable for its use. The PSO, through project performance reviews, can determine the extent of that gap and can put remedial steps in place to close it.


Establishing a PSO

When you are planning for a PSO, three critical questions must be answered. One of them deals with defining a desired future for your organization’s PSO—the goal, so to speak. But to reach that goal, you have to assess where you currently are with respect to that goal. The answer to that question identifies a gap between the current state and the future state. That gap is removed through the implementation plan for your PSO. This is the definition of a standard gap analysis. The three major questions, then, arranged chronologically, are as follows:

  • Where are you?

  • Where are you going?

  • How will you get there?

Before you attempt to answer those questions, you need a foundation for answering them. The Software Engineering Institute (SEI) provides just the foundation you need. Their five-level model described in the next section also gives you a foundation on which you can plan for the further growth and maturation of our PSO.

PSO Stages of Growth

Over the past several years, the Software Engineering Institute at Carnegie Mellon University has developed a maturity model for software engineering. It has gained wide support and has become a standard of the software development profession. The model is called the Capability Maturity Model (CMM). It has recently been adapted to project management in the form of a Project Management Maturity Model (PMMM). We will use the five maturity levels of the PMMM to answer these questions: Where are you and where are you going?

Figure 21.2 offers a graphic depiction and brief description of each of the maturity levels of the PMMM.

Level 1: Initial

Level 1 is the level where everyone basically does as he or she pleases. There may be some processes and tools for project management, and some may be using them on an informal basis. Project management training is nonexistent, and help may be available on an informal basis at best. There doesn’t appear to be any signs of organization under project management.

Click To expand
Figure 21.2: Project management maturity levels.

Level 2: Repeatable

Level 2 is distinguished from Level 1 in that there is a documented project management process available. It is used at the discretion of the project manager. There is some training available for those who are interested. The only sign of a PSO is through some part-time support that will help a project team on an as-requested basis.

Level 3: Defined

The transition from Level 2 to Level 3 is dramatic. The project management processes are fully documented, and project management has been recognized as critical to business success by senior management. A formal PSO is established and staffed and given the responsibility of ensuring enterprise-wide usage of the methodology. Enforcement is taken seriously. A solid training curriculum is available. There is some sign that project management is being integrated into other business processes.

Level 4: Managed

Successful project management is viewed as a critical success factor by the organization. A complete training program and professional development program for project managers is in place. The PSO is looked upon as a business, and project portfolio management is of growing importance. The project portfolio is an integral part of all business planning activities.

Level 5: Optimized

The PSO is the critical component of a continuous quality improvement program for project management. Progress in the successful use of project management is visible, measured, and acted upon.

Planning a PSO

You can now put the pieces of a plan together. Based on what we have discussed so far, your plan to establish a PSO might look something like Figure 21.3.

Before you can begin the activities shown in Figure 21.3, however, you have to write the Project Overview Statement (POS) for the PSO.

Cross-Reference

For a more detailed discussion of the components of a POS and what goes into writing one, see Chapter 3.

The POS

Figure 21.4 is an example POS for a PSO implementation project submitted by Sal Vation.

Click To expand
Figure 21.3: A plan to establish a PSO.
Click To expand
Figure 21.4: An example Project Overview Statement for a PSO implementation project.

The next sections take a quick look at what Sal submitted.

Problem/Opportunity

First, note that the statement describes a business condition that needs no defense or further clarification. Anyone, especially the executive committee, who reads it will understand it and agree with it. The importance of this statement will determine whether or not the reader will continue to the goal statement. In this case, the situation is grave enough so their continued reading is a foregone conclusion.

Goal

The statement is clean and crisp. It states what will be done and by when. Note that it is phrased so that the project is expected to deliver results before the expected completion date. Sal recognizes the importance of early results to the executive committee and doesn’t want the stated time line to shock them and perhaps risk their approval.

Objectives

The objective statements expand and clarify the goal statement and suggest interim milestones and deliverables.

Success Criteria

Sal has expressed the success criteria in specific and measurable quantitative terms. This is very important. In this case the criteria will help the executive committee understand the business value of the project. It is the single most important criteria Sal can present to them at this time to help them decide whether the project is worth doing.

Assumptions, Risks, Obstacles

Sal has called to the attention of the executive committee anything that he feels can potentially compromise the success of the project. These statements serve two purposes:

  • They highlight for senior managers some of the potential problems that they might be able to mitigate for the project team.

  • They provide some risk data for the financial analysts to estimate the expected return on the investment in a PSO.

They will consider the success criteria versus risk to determine the expected business value that can result from this project. In case there were other projects vying for the same resources, the analysts would have a comparable statistic to use to decide where to spend their resources.

Planning Steps

Sal will eventually get approval to move into the details of planning the project in anticipation of getting executive committee approval of the plan so that he and his team can get to work. Sal might expect a few iterations of the POS before he gets that approval to proceed with planning. In our experience senior managers often question success criteria, especially with reference to its validity.

Forming the PSO Task Force

The PSO task force forms the strategy group for this project. They are to be considered members of the project team. Their membership should be managers of those business units that will be impacted by the PSO. The size of the enterprise determines how many members there will be. A task force of four to six should work quite well, but a task force of 15 would be counterproductive. Without the support and commitment of each task force member, the PSO it is unlikely to succeed. Because their operations are likely to be affected by the PSO, they must be a part of its mission and have an opportunity to be heard as decisions are made on the mission, functions, and services the PSO will provide.

Measuring Where You Are

Several metrics have been developed to quantitatively measure the maturity level of your project management processes. We have developed one that consists of over 800 yes/no questions. (The interested reader should consult us at rkw@eiicorp.com for details on this proprietary product.) These questions cover all five maturity levels for all 39 project management processes identified by PMI in their PMBOK. Figure 21.5 shows the results for a recent assessment for one of our clients. The data on each of the 39 processes have been aggregated to the knowledge area level.

Click To expand
Figure 21.5: Maturity level data for nine knowledge areas of PMBOK.

This one graphic conveys a lot of information about this organization’s project management maturity levels. First of all, the dashed line shows the maturity level of each knowledge area as documented in the organization’s project management methodology. The box and whisker plots are maturity-level data on how project management was practiced in several projects that were reviewed in the same quarter. The box and whisker plot is a summarized view of the data points for each project on a single knowledge area. Each box displays the middle 50 percent of the data. The endpoints of the whiskers denote the extreme data points. The color coding denotes the status of the knowledge area. A red box indicates a process whose practice is significantly below the maturity level of the baseline process. A yellow box indicates a process whose practice is significantly above the maturity level of the baseline process. For example, take a look at the Scope Management knowledge area. The projects that were reviewed demonstrated a maturity level range from a low of 1.2 to a high of 4.1. The middle half of the data points range from 1.8 to 2.9. The Scope Management knowledge area was assessed at a maturity level of 3.5. In all cases where there is a maturity level below target or above target, it is an area that needs further investigation. The investigation should look for answers to the less than nominal maturity and take the necessary corrective steps to raise the level of maturity of that knowledge area. In those cases where the knowledge area is found to be performing above nominal, the investigation should look for the reasons for that exemplary performance and for ways to share their findings with other project teams.

In determining where the organization is with respect to project management, there are two threads of investigation:

  • The first is the organizational environment that the PSO will function in. This involves assessing the opinions of the managers whose business units will be impacted. Oftentimes this can be done with face-to-face interviews of key managers.

  • The second is an attempt to assess the current relationship between project managers and the clients they serve. In this case the clients will be internal business units and external customers who buy their products.

An assessment tool that we have developed at Enterprise Information Insights, Inc., that has been quite successful in practice is the Project Manager Competency Assessment (PMCA). It is an assessment of a project manager’s project management competencies. (Contact us at rkw@eiicorp.com for information on how to acquire the tool.) Figure 21.6 is a report from that assessment tool.

Click To expand
Figure 21.6: An example project manager competency assessment.

This PMCA reports findings in four major areas (business competency, personal competency, interpersonal competency, and management competency) as they relate to the individual’s project management behaviors. There are a total of 18 competencies spread across these four areas. Each one uses the box and whisker plot to summarize the opinions of the assessors. In this case there were eight assessors. The endpoints of the box and whisker plots denote the extreme data points. The hollow rectangle is the middle half of the data. The filled rectangle is the average of all assessors. The bolded vertical line is the individual’s self-assessment. This individual has a higher self-assessment of herself than do the managers who provided the competency data. This is especially evident in business awareness, business partnership, initiative, conceptual thinking, resourceful use of influence, and motivating others. This person should be advised to take a close look at how she sees herself relative to how others see her. This self-inflated phenomenon is not unusual. We have seen it time and time again in many of these assessments. People are simply not aware of how they affect others. As a group, her interpersonal competencies are held in high regard by her fellow workers. Her personal competencies, especially initiative, conceptual thinking, and self-confidence, may be problematic.

If either of these two assessments, either the maturity level of your project management processes or the project manager competency assessment, uncovers problems, an intervention may be needed prior to any further PSO planning. For the purposes of our exercise, the assessments have shown us that the organization is ready to move forward and strongly supports the creation of a full-service PSO.

The next step is to take a look at the existing methodology. There are two areas of investigation:

  • The first is to assess the maturity level of the project management processes that are in place. This can be done by using commercially available tools (such as Project Management Maturity Assessment).

  • The second area of investigation is to assess how project teams are using that methodology. Again, there are commercially available tools for this assessment (Project Management Competency Assessment, for one). Please contact us at rkw@eiicorp.com for more information on these and other similar assessment tools.

For the purposes of this example, assume those assessments show that the organization is at Level 1 maturity both in terms of their project management processes and the practice of those processes.

Establishing Where You Want To Go

The future of the organization in the example seems to rest on its ability to restore market share. As expressed in the POS, Sal has as a long-term goal the achievement of level 5 maturity in the PSO. His strategy will be to achieve that in phases, with each phase providing business value to the organization. The PSO is expected to be a full-service PSO. Its mission, functions, and organization are given in Table 21.1.

Table 21.1: Example PSO Mission, Functions, and Organization

MISSION

To provide the project management services and support needed to establish a market leadership position for the organization in the customized furnishings business.

FUNCTIONS

All project administrative services

Project management processes to support all project types

Comprehensive software for all phases of product development

A customized and complete PM training curriculum

A revolving staff of consulting project managers

A professional development program for project managers

ORGANIZATION

An enterprise-wide unit attached to the president’s office

EPSO director will be a three-year renewable appointed position

Permanent staff consists of:

Project administrator to deliver support services

Manager of methods and tools

Senior project manager consultant

Project manager consultant

Curriculum development specialist

Senior trainer

Trainer

The long-term goal of the PSO is to ensure project success. It should be obvious that goal means at least the attainment of Level 3 maturity. Without a documented process in place and in use by all teams, it is unlikely that there will be any measurable increase in the rate of project success.

On the other hand, to casually state that Level 4 maturity is the goal of the PSO is not appropriate. That is clearly a business decision. To attain Level 4 maturity is a big step. It is very costly in terms of the extent of change in the organization. We would liken that change to the evolution of the enterprise to a projectized organizational structure. To move from Level 4 to Level 5 is a matter of implementing a continuous quality improvement process within the PSO. That is far less traumatic and usually involves not much more than putting teeth into a project review process and a concerted effort to capture and implement best practices from the organization’s projects, as well as projects external to the organization.

Referring for a moment back to the data in Figure 21.5, because the middle half of the data points all fall below the average of 3.5, Scope Management needs some improvement. This would be an area where a continuous quality improvement effort would focus. The results of a continuous quality improvement effort in Scope Management might look something like the hypothetical data displayed in Figure 21.7. Note that not only has the process baseline maturity level improved from 3.5 to 4.1 during the period from 3/2002 to 12/2002, but the mid-range of the maturity level of the practice has moved from (1.8–2.9) to (3.9–4.3). The maturity level of the practice of Scope Management has increased significantly, and its range has decreased. This is a marked improvement! If this organization had set as its goal to increase the Scope Management maturity level of its process and its practice to 4.0, it would have achieved that goal.

Click To expand
Figure 21.7: Continuous quality improvement of scope management.
Establishing How You Will Get There

It goes without saying that the lower your current project management maturity level is, the more challenging it will be to move to Level 3 or higher maturity. Level 3 is where the PSO can really begin to make an impact on the practice of project management. It is at this level that the organization is fully bought into project management. Teams must use it, and the PSO is monitoring that usage. Best practices are identified through project reviews and folded back into the methodology. All signs are positive. Figure 21.8 gives a brief description of what actions should be taken to move from one level to the next.

Click To expand
Figure 21.8: How to move to the next maturity level.

Sal’s plan consists of four phases. Each phase ends with a milestone that signifies the attainment of the next level of maturity. So Phase One is complete when the organization has reached maturity Level 2 in the PSO. Phases Two, Three, and Four are similarly defined. Within each phase there are a number of deliverables that add business value. These deliverables have been prioritized to add business value as soon as possible. Figure 21.9 describes the high-level plan through all four phases.

Click To expand
Figure 21.9: PSO plan overview.


Challenges to Implementing a PSO

Too many executives have the impression that a PSO is mostly a clerical function and that establishing one is not too difficult. Nothing could be further from the truth. J. Kent Crawford provides a compelling discussion of some of those challenges in The Strategic Project Office: A Guide to Improving Organizational Performance, published by Marcel Dekker in 2001. Crawford’s challenges are as follows:

  • Speed and patience

  • Leadership from the bottom up

  • A systems thinking perspective

  • Enterprise-wide systems

  • Knowledge management

  • Learning and learned project organizations

  • Open communications

Speed and Patience

Effectively deploying a PSO can require two to five years for full implementation. That is a long time. According to the Standish Group research, the longer the project, the higher the probability of project failure. The way out of this apparent dilemma is to plan the PSO deployment in stages. Each stage must deliver visible and measurable value to the organization. To do otherwise is to court disaster.

Leadership from the Bottom Up

A major strategy in putting a PSO in place is a bottom-up strategy. At the department or project level, you will have to demonstrate value by showing the results that a PSO can achieve. By way of example then, others in the organization will see that success and ask how they can do it in their own areas. This grassroots effort will be contagious and will be one of the keys to a successful PSO implementation over time.

A Systems Thinking Perspective

This point goes to the very heart of a PSO contributing at the corporate level. At some point in the implementation of the PSO, senior managers will begin to see how an effectively managed project portfolio can contribute to corporate goals. Senior managers begin to think about the portfolio and not just the projects that make it up. This transition from Level 3 to Level 4 maturity is the result of a major discovery by senior management. They begin to think in terms of a systems perspective.

Enterprise-wide Systems

This characteristic is clearly one of a Level 4 organization. The integration of the project data into the other corporate databases allows senior managers the tools they need to make enterprise-wide business decisions where projects are the strategic components of their business plans. Making this jump from single project focus to strategic portfolio focus is the sign of a Level 4 PSO.

Knowledge Management

To drive thinking to the enterprise-wide level requires sophisticated corporate databases, standardization of data capture, and the applications systems to extract knowledge from information. Even something as simple as a database of best practices and lessons learned has been implemented in only a few organizations. Part of the reason for the lack of those kinds of databases is because project management is in its infancy. There are standards at the project level but few standards at the portfolio level.

Learning and Learned Project Organizations

Most organizations have not taken the education and training of project managers very seriously. That fact has to change if the PSO is expected to make an impact on project success. A comprehensive curriculum with a variety of delivery approaches is needed. Career and professional development programs for project managers are few and far between. The PSO is positioned to deliver, but senior management must first make the commitment and provide the needed resources.

Open Communications

Communications between and among projects and from first-line managers through to executive levels must be open and free. The PSO can establish and maintain the channels of communications.


Putting It All Together

In this chapter we introduced the PSO, discussed its roles and responsibilities, and gave a plan for establishing one. The five-level Capability Maturity Model is a good way to measure the maturity of your current PSO, and it provides a sound basis for a continuous quality improvement program.


Discussion Questions

  1. Given that your PSO is going to support all three types of project management methodologies presented in this book, what advice would you offer as to organizational structure, staffing, and functions provided? Be specific and back up your statements with the reasons for your suggestions.

  2. Senior management will always ask what business value they will realize from the PSO. How would you measure the return on investment for your PSO?


Epilogue: Putting It All Together Finally

We want to take this opportunity to make a few closing remarks about what we have shared with you throughout the course of this book.

Closing Comments by Bob Wysocki

This third edition has been a true labor of love for me. Even before the second edition was published, I realized there was so much more that I really needed to say that I began making notes for the third edition. I am excited about APF. I think Rudd and I have given it a good start. There will surely be more to come as we continue to implement it with our clients and discuss it with our colleagues. I would value any input you care to pass on. Email me at rkw@eiicorp.com.

We are living and working in truly challenging and exciting times. Those in my generation can remember how times were before the computer became a social and business requirement. If someone had told me 20 years ago that within 25 years we would routinely talk to a computer and it would talk back, I would have thought he fell out of a tree and landed on his head. But here we are. The computer is pervasive. It has invaded every corner of our existence. There is no escaping it. And I doubt that anyone would want to escape it.

For the project manager it has been a boon, but it has also been a bust. Unfortunately, too many project managers have left the thinking to the software. I shudder when I hear a senior manager say that they need to get some project management training for their people and in the same breath say they are looking for a good course on MS Project to help their people learn how to be project managers. Wow! I find it hard to believe that anyone would associate knowledge of project management with how to run a software package. The two are very different. I know of no project management software package that can teach you the concepts and principles of project management. That is not what they are designed to do.

As the project mix moves from traditional to adaptive to extreme, the set of tools also moves from process-oriented to people-oriented and from high-tech to low-tech. I have never really been a slave to the technology. I have always seen it as an enabler. I remind all of my colleagues that what we are all about as project managers is to deliver to our clients the maximum in business value for the money and time they place under our stewardship. Nothing else really matters. The emergence of the agile methods vividly reminds us of that fact. The introduction of APF and its guiding principles is another reminder.

All of my degrees are in mathematics. I was told very early on in that education that mathematics is the queen of the sciences. It exists to serve and support scientific advancement. In much the same way, project management is the queen of the business management disciplines. It exists to serve and support the growth and success of our business community. In that sense we have an obligation—a responsibility—to do the very best that we can.


Closing Comments by Rudd McGary

As the pace of business increases and the use of project management becomes more and more integrated into the standard business, we need to find ways to help the organization get maximum benefits from its project management professionals. This isn’t the time to continue doing everything the way it used to be done; it is time to find new ways to think of the practice of project management and to fit these into useable models for the people practicing project management. We have tried to do that with this book.

Simply training won’t make an organization have good project managers. It has to be a mixture of training, relating to organizational needs, mentoring, and in some cases using outside resources to help the organization rethink the best ways to be effective in project management. This book is intended as a guide to help you work within your organization in order to get the best-possible results. It’s also intended to make you think and perhaps rethink what new practices can be done in project management that will keep your organization competing in the marketplace. If we have given you some areas to consider, we’ve done our job. Take what we suggest, make it work within your organization, and the outcome is going to help you run your organization and the specific area of project management.

The challenges for project management have never been greater. But such challenges also mean that the opportunities are there as well. By taking what you need from this text and using it to help you be a better project manager, you will be doing what is needed to stay competitive. We hope we’ve helped you do that.


Appendix A: What's on the CD-ROM

Team LiB

Appendix A: What’s on the CD-ROM

This appendix provides you with information on the contents of the CD that accompanies this book. For the latest and greatest information, please refer to the Read Me file located at the root of the CD.

System Requirements

Make sure that your computer meets the minimum system requirements listed in this section. If your computer doesn’t match up to most of these requirements, you may have a problem using the contents of the CD.

For Windows 9x, Windows 2000, Windows NT4 (with SP 4 or later), Windows Me, or Windows XP:

  • PC with a Pentium processor running at 120 MHz or faster

  • At least 32 MB of total RAM installed on your computer; for best performance, we recommend at least 64 MB

  • Ethernet network interface card (NIC) or modem with a speed of at least 28,800 bps

  • A CD-ROM drive

  • A copy of Microsoft Word (or some word-processing program) and a copy of Microsoft PowerPoint


Using the CD

To install the items from the CD to your hard drive, follow these steps:

  1. Insert the CD into your computer’s CD-ROM drive.

  2. The Autorun window appears with the following options: Install, Browse, and Exit.

    • Install: Gives you the option to install the supplied software and/or the author-created samples on the CD-ROM.

    • Browse: Enables you to view the contents of the CD-ROM in its directory structure.

    • Exit: Closes the Autorun window.

If you do not have Autorun enabled, or if the Autorun window does not appear, follow these steps to access the CD:

  1. Click Start, Run.

  2. In the dialog box that appears, type “d:\setup.exe”, where d is the letter of your CD-ROM drive. This brings up the Autorun window described in the preceding set of steps.

  3. Choose the Install, Browse, or Exit option from the menu. (See Step 2 in the preceding list for a description of these options.)


What's on the CD

Team LiB

What’s on the CD

The following sections provide a summary of the software and other materials you’ll find on the CD.

Author-Created Materials

All author-created materials from the book are on the CD in the folder named Author.

There are several files for your use that relate to the case study found in the introduction to the book. The first file is the case study itself, labeled “Case Study.” This file is an electronic copy of the printed text of the case study in the introduction and runs in MS Word.

You will also find two files in MS Project and another in MS Word that relate to the case study, particularly the case study questions included at the end of the chapters in Part I of the book.

  • The first file, named Highlevel WBS, is a high-level set of categories for any IT project. These categories are standard “waterfall” categories and are intended as a guide for you to start doing your WBS for the case study. You can view this file in MS Project.

  • The second file, labeled Systest, is a two-level WBS for testing. This file presents a general guide, simply as an example. Your organization may organize testing differently, but the breakdown you see here gives you one way in which you might start your WBS. You can view this file in MS Project.

  • The third file, named Scope Statement Example, offers a sample scope statement that can help you write your own scope statement when you get to the case study question at the end of Chapter 3.

In addition to these files that concern the case study, the CD contains PowerPoint versions of every figure and table in the book for use in class presentations and discussions. You need PowerPoint installed to access and display these slides. Please take note that the slides are protected by copyright and should not be altered in any way when presented. The filenames for the slides match the table and figure numbers in the book for ease of reference.

Further, in addition to the content on the CD, instructors using this book are encouraged to contact author Robert K. Wysocki at rkw@eiicorp.com if they are interested in receiving a file of helps and hints to the Discussion Questions listed at the end of each chapter. The author would appreciate hearing from you, and this file is full of useful suggestions about what constitutes effective answers to the book’s provocative questions.

Applications

The CD also contains a trial version of Microsoft Project 2002, a project management program with various tools for project collaboration, management, scheduling, analysis, and reporting.

Shareware programs are fully functional, trial versions of copyrighted programs. If you like particular programs, register with their authors for a nominal fee and receive licenses, enhanced versions, and technical support. Freeware programs are copyrighted games, applications, and utilities that are free for personal use. Unlike shareware, these programs do not require a fee or provide technical support. GNU software is governed by its own license, which is included inside the folder of the GNU product. See the GNU license for more details.

Trial, demo, or evaluation versions are usually limited either by time or functionality (such as being unable to save projects). Some trial versions are very sensitive to system date changes. If you alter your computer’s date, the programs will time out and will no longer be functional.


Troubleshooting

If you have difficulty installing or using any of the materials on the companion CD, try the following solutions:

Turn off any antivirus software that you have running. Installers sometimes mimic virus activity and can make your computer incorrectly believe that it is being infected by a virus. (Be sure to turn the antivirus software back on later.)

Close all running programs. The more programs you’re running, the less memory is available to other programs. Installers also typically update files and programs; if you keep other programs running, installation may not work properly.

Reference the Read Me. Please refer to the Read Me file located at the root of the CD-ROM for the latest product information at the time of publication.

If you still have trouble with the CD, please call the Customer Care phone number: (800) 762-2974. Outside the United States, call 1 (317) 572-3994. You can also contact Customer Service by e-mail at techsupdum@wiley.com. Wiley Publishing, Inc., will provide technical support only for installation and other general quality control items; for technical support on the applications themselves, consult the program’s vendor or author.


Appendix B: Bibliography

Overview

Ignorance never settles a question.

—Benjamin Disraeli, English Prime Minister

Those who have read of everything are thought to understand everything, too; but it is not always so—reading furnishes the mind only with materials of knowledge; it is thinking that makes what is read ours. We are of the ruminating kind, and it is not enough to cram ourselves with a great load of collections; unless we chew them over again, they will not give us strength and nourishment.

—John Locke

The following books are a collection of current publications from our project management libraries. Nearly all the books we included were published in the last 10 years. The few exceptions are titles that were written by leaders in our field or have a particularly valuable contribution to the literature. They are classics. All of these books will be of particular interest to professionals who have project management responsibilities, are members of project teams, or simply have a craving to learn about the basics of sound project management. The focus of many of the books is systems and software development because that is our primary interest, although several also treat the basic concepts and principles of project management. We also included books on closely related topics that we have found to be of value in researching and writing this book. You might find value in them, too.

For your ease in finding specific sources, we arranged the bibliography topically according to four of the major areas we deal with in the book.


Traditional Project Management

Baker, Sunny, and Kim Baker. 1998. The Complete Idiot’s Guide to Project Management. New York: Alpha Books. (ISBN 0-02-861745-2)

Barkley, Bruce T., and James H. Saylor. 1994. Customer-Driven Project Management: A New Paradigm in Total Quality Implementation. New York: McGraw-Hill, Inc. (ISBN 0-07-003739-6)

Bechtold, Richard. 1999. Essentials of Software Project Management. Vienna, Va.: Management Concepts. (ISBN 1-56726-085-3)

Belanger, Thomas C. 1995. How to Plan Any Project: A Guide for Teams (and Individuals). Sterling, Mass.: The Sterling Planning Group. (ISBN 0-9631465-1-3)

Bennatan, E. M. 1992. On Time, Within Budget: Software Project Management Practices and Techniques. Wellesley, Mass.: QED Publishing Group. (ISBN 0-89435-408-6)

Blaylock, Jim, and Rudd McGary. 2002. Project Management A to Z. Columbus, Ohio: PM Best Practices, Inc. (ISBN 0-9719121-0-6)

Block, Thomas R., and J. Davidson Frame. 1998. The Project Office. Menlo Park, Calif.: Crisp Publications. (ISBN 1-56052-443-X)

Burr, Adrian, and Mal Owen. 1996. Statistical Methods for Software Quality. London, England: International Thomson Computer Press. (ISBN 1-85032-171-X)

Cable, Dwayne P., and John R. Adams. 1997. Principles of Project Management. Upper Darby, Pa.: Project Management Institute. (ISBN 1-880410-30-3)

Capper, Richard. 1998. A Project-by-Project Approach to Quality. Hampshire, England: Gower Publishing Limited. (ISBN 0566079259)

Center for Project Management. 1995. Managing Advanced IT Projects. San Ramon, Calif.: Center for Project Management.

CH2Mhill. 1996. Project Delivery System: A System and Process for Benchmark Performance. Denver, Colo.: CH2Mhill. (ISBN 0-9652616-0-3)

Chang, Richard Y. 1994. Continuous Process Improvement. Irvine, Calif.: Richard Chang Associates. (ISBN 1-883553-06-7)

———. 1995. Process Reengineering in Action. Irvine, Calif.: Richard Chang Associates. (ISBN 1-883553-16-4)

Chang Richard Y., and P. Keith Kelly. 1994. Improving Through Benchmarking. Irvine, Calif.: Richard Chang Associates. (ISBN 1-883553-08-3)

Chang, Richard Y., and Matthew E. Niedzwiecki. 1993. Continuous Improvement Tools. Vol. I. Irvine, Calif.: Richard Chang Associates. (ISBN 1-883553-00-8)

———. 1993. Continuous Improvement Tools. Vol. II. Irvine, Calif: Richard Chang Associates. (ISBN 1-883553-01-6)

Chapman, Chris, and Stephen Ward. 1997. Project Risk Management: Processes, Techniques and Insights. New York: John Wiley & Sons. (ISBN 0-471-95804-2)

Cleland, David I., et al. 1998. Project Management Casebook. Upper Darby, Pa.: Project Management Institute. (ISBN 1-880410-45-1)

Cleland, David I., et al. 1998. Project Management Casebook: Instructor’s Manual. Upper Darby, Pa.: Project Management Institute. (ISBN 1-880410-45-1)

Cleland, David I., et al. 1998. Annotated Bibliography of Project and Team Management. Newtown Square, Pa.: Project Management Institute. (ISBN 1-880410-47-8)

Cleland, D. I., and W. R. King, eds. 1983. Project Management Handbook. New York: Van Nostrand Reinhold. (ISBN 0-442-22114-2)

Conway, Kieron. 2001. Software Project Management: From Concept to Deployment. Scottsdale, Ariz.: The Coriolis Group. (ISBN 1-57610-807-4)

Crawford, J. Kent. 2002. Project Management Maturity Model: Providing a Proven Path to Project Management Excellence. New York: Marcel Dekker, Inc. (ISBN 0-8247-0754-0)

Darnell, Russell W. 1996. The World’s Greatest Project: One Project Team on the Path to Quality. Newtown Square, Pa.: The Project Management Institute. (ISBN 1-880410-46-X)

Davidson, Jeff. 2000. 10 Minute Guide to Project Management. Indianapolis: Macmillan. (ISBN 0-02-863966-9)

DeGrace, Peter, and Leslie Hulet Stahl. 1990. Wicked Problems, Righteous Solutions. Englewood Cliffs, N.J.: Yourdon Press Computing Series. (ISBN 0-13-590126-X)

Dekom, Anton K. 1994. Practical Project Management. New York: Random House Business Division. (ISBN 0-394-55077-3)

DeMarco, T. 1982. Controlling Software Projects. New York: Yourdon Press.

DeMarco, Tom. 1997. The Deadline: A Novel About Project Management. New York: Dorsett House. (ISBN 0-932633-39-0)

DeMarco, T., and T. Lister. 1999. Peopleware, Productive Projects and Teams. 2d ed. New York: Dorsett House Publishing. (ISBN 0-932633-43-9)

Dettmer, H. William. 1997. Goldratt’s Theory of Constraints: A Systems Approach to Continuous Improvement. Milwaukee, Wis.: ASQ. (ISBN 0-87389-370-0)

Dobson, Michael S. 1999. The Juggler’s Guide to Managing Multiple Projects. Newtown Square, Pa.: The Project Management Institute. (ISBN 1-880410-65-6)

Dymond, Kenneth M. 1998. A Guide to the CMM: Understanding the Capability Maturity Model for Software. Annapolis, Md.: Process Transition International, Inc. (ISBN 0-9646008-0-3)

Eureka, William E., and Nancy E. Ryan. 1994. The Customer-Driven Company. Burr Ridge, Ill.: Irwin. (ISBN 0-7863-0141-4)

Fleming, Quentin W. 1992. Cost/Schedule Control Systems Criteria. Chicago: Probus Publishing Company. (ISBN 1-55738-289-1)

Fleming, Quentin W., John Bronn, and Gary C. Humphreys. 1987. Project and Production Scheduling. Chicago: Probus Publishing. (ISBN 0-917253-63-9)

Fleming, Quentin W., and Quentin J. Fleming. 1993. Subcontract Planning and Organization. Chicago: Probus Publishing Company. (ISBN 1-55738-463-0)

Fleming, Quentin W., and Loel M. Koppelman. 2000. Earned Value Project Management. 2d ed.. Newtown Square, Pa.: The Project Management Institute. (ISBN 1-880410-27-3)

Forsberg, Kevin, et al. 1996. Visualizing Project Management. New York: John Wiley & Sons, Inc. (ISBN0-471-57779-0)

Frame, J. Davidson. 1994. The New Project Management. San Francisco: Jossey-Bass Publishers. (ISBN 1-55542-662-X)

Friedlein, Ashley. 2001. Web Project Management: Delivering Successful Commercial Web Sites. San Francisco: Morgan Kaufmann Publishers. (ISBN 1-55860-678-5)

Fuller, Jim. 1997. Managing Performance Improvement Projects: Preparing, Planning, Implementing. San Francisco: Jossey-Bass Publishers. (ISBN0-7879-0959-9)

Goldberg, Adele, and Kenneth S. Rubin. 1995. Succeeding with Objects: Decision Frameworks for Project Management. Reading, Mass.: Addison-Wesley Publishing. (ISBN 0-201-62878-3)

Goldratt, Eliyahu M. 1997. Critical Chain. Great Barrington, Mass.: The North River Press. (ISBN 0-88427-153-6)

———. 1992. The Goal: A Process of Ongoing Improvement. Great Barrington, Mass.: The North River Press. (ISBN 0-88427-061-0)

Goodpasture, John C. 2002. Managing Projects for Value. Vienna, Va.: Management Concpets. (ISBN 1-56726-138-8)

Grady, Robert B. 1992. Practical Software Metrics for Project Management and Process Improvement. Englewood Cliffs, N.J.: Prentice Hall. (ISBN 0-13-720384-5)

Greer, Michael. 1996. The Project Manager’s Partner: A Step-by-Step Guide to Project Management. Amherst, Mass.: HRD Press, Inc. (ISBN 0-087425-397-7)

Grey, Stephen. 1995. Practical Risk Assessment for Project Management. Chichester, England: John Wiley & Sons, Ltd. (ISBN 0-471-93979-X)

Hackos, JoAnn T. 1994. Managing Your Documentation Projects. New York: John Wiley & Sons, Inc. (ISBN 0-471-59099-1)

Hallows, Jolyon. 1998. Information Systems Project Management: How to Deliver Function and Value in Information Technology Projects. New York: AMACOM. (ISBN0-8144-0368-9)

Harrington, F. L. 1992. Advanced Project Management: A Structured Approach. 3d ed. New York: Halsted Press. (ISBN 0-470-21970-X)

Harrington, H. James, et al. 2000. Project Change Management: Applying Change Management to Improvement Projects. New York: McGraw-Hill. (ISBN 0-07-027104-6)

Harvard Business Review. 1991. Project Management. Boston: Harvard Business School Press. (ISBN 0-87584-264-X)

Haugan, Gregory T. 2002. Project Planning and Scheduling. Vienna, Va.: Management Concepts. (ISBN 1-56726-136-1)

———. 2002. Effective Work Breakdown Structures. Vienna, Va.: Management Concepts. (ISBN 1-56726-135-3)

Hetzel, Bill. 1993. Making Software Measurement Work. New York: John Wiley & Sons, Inc. (ISBN 0-471-56568-7)

Hiebeler, Robert et al. 1998. Best Practices: Building Your Business with Customer-Focused Solutions. New York: Simon & Schuster. (ISBN 0-684-83453-7)

Hill, Peter R. 2001. Practical Project Estimation: A Toolkit for Estimating Software Development Effort and Duration. Warrandyte, Victoria, Australia: International Software Benchmarking Standards Group. (ISBN 0-9577201-1-4)

Hiltz, Mark J. 1994. Project Management Handbook of Checklists. Vol. 1, Conceptual/Definition and Project Initiation. Ontario, Canada: MarkCheck Publishing. (ISBN 0-9697202-2-X)

———. 1994. Project Management Handbook of Checklists. Vol. 2, Organizations/Communications/Management. Ontario, Canada: MarkCheck Publishing. (ISBN 0-9697202-3-8)

———. 1994. Project Management Handbook of Checklists. Vol. 3, Project Planning and Control. Ontario, Canada: MarkCheck Publishing (ISBN 0-9697202-4-6)

———. 1994. Project Management Handbook of Checklists. Vol. 4, Implementation/ Termination. Ontario, Canada: MarkCheck Publishing. (ISBN 0-9697202-5-4)

Humphrey, Watts S. 1997. Managing Technical People. Reading, Mass.: Addison-Wesley. (ISBN 0-201-54597-7)

Hunt, V. Daniel. 1996. Process Mapping: How to Reengineer Your Business Processes. New York: John Wiley & Sons, Inc. (ISBN 0-471-13281-0)

Huston, Charles L. 1996. Management of Project Procurement. New York: The McGraw-Hill Companies, Inc. (ISBN 0-07-030552-8)

Ibbs, C. William, and Young-Hoon Kwak. 1997. The Benefits of Project Management: Financial and Organizational Rewards to Corporations. Newtown Square, Pa.: The Project Management Institute. (ISBN 1-880410-32-X)

Ireland, Lewis R. 1991. Quality Management for Projects and Programs. Upper Darby, Pa.: Project Management Institute. (ISBN 1-880410-11-7)

Jalote, Pankaj. 2000. CMM in Practice: Processes for Executing Software Projects at Infosys. Reading, Mass.: Addison-Wesley. (ISBN0-210-61626-2)

Jensen, Bill. 2000. Simplicity: The New Competitive Advantage in A World of More, Better, Faster. Cambridge, Mass.: Perseus Books. (ISBN 0-7382-0210-X)

Johnson, James R. 1991. The Software Factory: Managing Software Development and Maintenance. Wellesley, Mass.: QED Information Sciences, Inc. (ISBN 0-89435-348-9)

Johnston, Andrew K. 1995. A Hacker’s Guide to Project Management. Oxford, England: Butterworth-Heinemann Ltd. (ISBN 0-7506-2230-X)

Kaydos, Will. 1999. Operational Performance Measurement: Increasing Total Productivity. Boca Raton, Fla.: St Lucie Press. (ISBN 1-57444-099-3)

Keen, Peter G. W., and Ellen M. Knapp. 1996. Business Processes: A Glossary of Key Terms & Concepts for Today’s Business Leader. Cambridge, Mass.: Harvard Business School Press. (ISBN 0-87584-575-4)

Kerzner, Harold. 1998. In Search of Excellence in Project Management. New York: Van Nostrand Reinhold. (ISBN 0-442-02706-0)

———. 2001. Project Management: A Systems Approach to Planning, Scheduling, and Controlling. 7th ed. New York: John Wiley & Sons, Inc. (ISBN0-471-39342-8)

King, David. 1992. Project Management Made Simple. Englewood Cliffs, N.J.: Yourdon Press Computing Series. (ISBN 0-13-717729-1)

Kirkpatrick, Donald L. 1998. Evaluating Training Programs, Second Edition. Berrett-Koehler Publishers, Inc. (ISBN 1-57675-042-6)

Kliem, Ralph L., and Irwin S. Ludin. 1997. Reducing Project Risk. Hampshire, England: Gower Publishing Limited. (ISBN 0-566-07799-X)

Kloppenborg, Timpothy J., and Joseph A. Petrick. 2002. Managing Project Quality. Vienna, Va.: Management Concepts. (ISBN 1-56726-141-8)

Kolluru, Steven, et al. 1996. Risk Assessment and Management Handbook For Environmental, Health, and Safety Professionals. New York: McGraw-Hill, Inc. (ISBN 0-07-035987-3)

Kopelman, Orion et al. 1998. Projects at Warp-Speed With QRPD: The Definitive Guidebook to Quality Rapid Product Development. Palo Alto, Calif.: Global Brain, Inc. (ISBN 1-885262-16-0)

Kyle, Mackenzie. 1998. Making It Happen: A Non-Technical Guide to Project Management. Toronto, Canada: John Wiley & Sons, Canada Ltds. (ISBN 0-471-64234-7)

Lambert, Lee R., and Erin Lambert. 2000. Project Management: The CommonSense Approach. Columbus, OH: LCG Publishing. (ISBN 0-9626397-8-8)

Laufer, Alexander. 1997. Simultaneous Management: Managing Projects in A Dynamic Environment. New York: AMACOM. (ISBN 0-8144-0312-3)

Laufer, Alexander, and Edward J. Hoffman. 2000. Project Management Success Stories: Lessons of Project Leaders. New York: John Wiley & Sons, Inc. (ISBN 0-471-36007-4)

Leach, Larry P. 1997. The Critical Chain Project Managers’ Fieldbook. Idaho Falls, Idaho: Quality Systems.

———. 2000. Critical Chain Project Management. Boston: Artech House. (ISBN 1-58053-074-5)

Levine, Harvey A. 2002. Practical Project Management: Tips, Tactics, and Tools. New York: John Wiley & Sons, Inc. (ISBN 0-471-20303-3)

Lewis, James P. 1995. Project Planning, Scheduling & Control. Chicago: Irwin. (ISBN 1-55738-869-5)

———. 1998. Mastering Project Management. New York: McGraw-Hill. (ISBN 0-7863-1188-6)

———. 2000. The Project Manager’s Desk Reference. 2d ed.. New York: McGraw-Hill. (ISBN 0-07-134750-X)

Lientz, Bennet P., and Kathryn P. Rea. 1995. Project Management for the 21st Century. New York: Academic Press. (ISBN 0-12-449965-5)

———. 2001. Dynamic E-Business Implementation Management: How to Effectively Manage E-Business Implementation. San Diego: Academic Press. (ISBN 0-12-449980-5)

———. 2001. Breakthrough Technology Project Management. 2d ed. San Diego: Academic Press. (ISBN 0-12-449968-6)

Maguire, Steve. 1994. Debugging the Development Process. Redmond, Wash.: Microsoft Press. (ISBN 1-55615-650-2)

Martin, Paula. 1995. Leading Project Management into the 21st Century: New Dimensions in Project Management and Accountability. Cincinnati, Ohio: MartinTate. (ISBN 0-943811-04-X)

McConnell, Steve. 1996. Rapid Development. Redmond, Wash.: Microsoft Press. (ISBN 1-55615-900-5)

———. 1998. Software Project Survival Guide. Redmond, Wash.: Microsoft Press. (ISBN 1-57231-621-7)

Meyer, Christopher. 1993. Fast Cycle Time: How to Align Purpose, Strategy, and Structure for Speed. New York: Free Press. (ISBN0-02-921181-6)

Michaels, Jack V. 1996. Technical Risk Management. Upper Saddle River, N.J.: Prentice Hall. (ISBN 0-13-155756-4)

Miller, Dennis. 1994. Visual Project Planning & Scheduling. Boca Raton, Fla.: The 15th Street Press. (ISBN 0-9640630-1-8)

Muller, Robert J. 1998. Productive Objects: An Applied Software Project Management Framework. San Francisco: Morgan Kaufmann Publishers, Inc. (ISBN 1-55860-437-5)

Muther, Richard. 2000. More Profitable Planning: Six Steps to Planning Anything. Kansas City, Mo.: Management and Industrial Research Publications. (ISBN 0-933684-193)

Neuendorf, Steve. 2002. Project Measurement. Vienna, Va.: Management Concepts. (ISBN 1-56726-140-X)

Newbold, Robert C.1998. Project Management in the Fast Lane: Applying the Theory of Constraints. Boca Raton, Fla.: St Lucie Press. (ISBN 1-57444-195-7)

Nielsen, Jakob. 2000. Designing Web Usability. Indianapolis: New Riders Publishing. (ISBN 1-56205-810-X)

Norris, Mark, Peter Rigby, and Malcolm Payne. 1993. The Healthy Software Project: A Guide to Successful Development and Management. Chichester, England: John Wiley & Sons, Ltd. (ISBN 0-471-94042-9)

Palisades Corp. 1994. Risk Analysis & Modeling @Risk. Newfield, N.Y.: Palisades Corporation.

Paulk, Mark C., et al. 1994. The Capability Maturity Model: Guidelines for Improving the Software Process. Reading, Mass.: Addison-Wesley. (ISBN 0-201-54664-7)

Phillips, Jack J. et al. 2002.The Project Management Scorecard: Measuring the Success of Project Management Solutions. Boston: Butterworth-Heinemann Ltd. (ISBN 0-7506-7449-0)

Pinto, Jeffrey K. 1998. Project Management Handbook. San Francisco: Jossey-Bass Publishers. (ISBN 0-7879-4013-5)

Pritchard, Carl L. 1998. How to Build A Work Breakdown Structure: The Cornerstone of Project Management. Arlington, Va.: ESI International. (ISBN 1-890367-12-5)

———. 2001. Risk Management: Concepts and Guidance. Arlington, Va.: ESI International. (ISBN 1-890367-30-3)

Pritchett, Price, and Brian Muirhead. 1998. The Mars Pathfinder: Approach to Faster-Better-Cheaper. Dallas, Tex.: Price Pritchett & Associates (ISBN 0-944002-74-9)

Project Management Institute. 1997. Principles of Project Management. Upper Darby, Pa.: Project Management Institute. (ISBN 1-880410-30-3)

———. 1997. The PMI Book of Project Management Forms. Upper Darby, Pa.: Project Management Institute. (ISBN: 1-880410-31-1)

———. 1999. Project Management Software Survey. Newton Square, Pa.: Project Management Institute. (ISBN 1-880410-52-4)

———. 1999. The Future of Project Management. Newtown Square, Pa.: Project Management Institute. (ISBN 1-880410-71-0)

———. 2000. A Guide to the Project Management Body of Knowledge. Newtown Square, Pa.: Project Management Institute. (ISBN: 1-880410-23-0)

———. 2000. Project Management Experience and Knowledge Self-Assessment Manual. Newtown Square, Pa.: Project Management Institute. (ISBN 1-880410-24-9)

———. 2001. Practice Standards for Work Breakdown Structures. Newtown Square, Pa.: Project Management Institute. (ISBN 1-880410-81-8)

Putnam, Lawrence H., and Ware Myers. 1992. Measures for Excellence: Reliable Software On Time, Within Budget. Englewood Cliffs, N.J.: Yourdon Press Computing Series. (ISBN 0-13-56794-3)

Rad, Parviz F. 2002. Project Estimating and Cost Management. Vienna, Pa.: Management Concepts. (ISBN 1-56726-144-2)

Raferty, John. 1994. Risk Analysis in Project Management. London, England: E&FN SPON. (ISBN 0-419-18420-1)

Raynus, Joseph. 1999. Software Process Improvement with CMM. Boston: Artech House. (ISBN 0-89006-644-2)

Royce, Walker. 1998. Software Project Management: A Unified Framework. Reading, Mass.: Addison-Wesley. (ISBN 0-201-30958-0)

Royer, Paul S. 2002. Project Risk Management: A Proactive Approach. Vienna, Va.: Management Concepts. (ISBN 1-56726-139-6)

Schuyler, John. 2001. Risk and Decision Analysis in Projects. 2d ed. Newtown Square, Pa.: The Project Management Institute. (ISBN 1-880410-28-1)

Schwalbe, Kathy. 2000. Information Technology Project Management. Boston: Course Technology. (ISBN 0-7600-1180-X)

Senge, Peter. 1994. The Fifth Discipline. New York. Currency/Doubleday. (ISBN: 0-385-26095-4)

Siegel, David. 1997. Secrets of Successful Web Sites: Project Management on the World Wide Web. Indianapolis: New Riders. (ISBN 1-56830-382-3)

Smith, Preston G., and Donald Reinertsen. 1991. Developing Products in Half the Time. New York: Van Nostrand Reinhold. (ISBN 0-442-00243-2)

Sodhi, Jag, and Prince Sodhi. 2001.IT Project Management Handbook. Vienna, Va.: Management Concepts. (ISBN 1-56726-098-5)

Stapleton, Jennifer. 1997. DSDM: Dynamic Systems Development Method. Harlow, England: Addison-Wesley. (ISBN 0-201-17889-3)

TechRepublic. 2001. IT Professional’s Guide to Project Management. Louisville, Ky.: TechRepublic. (ISBN 1-931490-16-3)

Thomsett, Michael C. 1990. The Little Black Book of Project Management. New York: Amacom. (ISBN 0-8144-7732-1)

Thomsett, R. 1993. Third Wave Project Management. Englewood Cliffs, N.J.: Yourdon Press Computing Series. (ISBN 0-13-915299-7)

———. 2002. Radical Project Management. Prentice Hall. (ISBN: 0-13-009486-2)

Toney, Frank, and Ray Powers. 1997. Best Practices of Project Management Groups in Large Functinal Organizations. Upper Darby, Pa.: Project Management Institute. (ISBN 1-880410-05-2)

Turtle, Quentin C. 1994. Implementing Concurrent Project Management. Englewood Cliffs, N.J.: Prentice Hall. (ISBN 0-13-302001-0)

Ulrich, Karl T., and Steven D. Eppinger. 1995. Product Design and Development. New York: McGraw-Hill. (ISBN 0-07-065811-0)

Verma, Vijay K. 1995. Organizing Projects for Success. Upper Darby, Pa.: Project Management Institute. (ISBN 1-880410-40-0)

Verzuh, Eric. 1999. The Fast Forward MBA in Project Management. New York: John Wiley & Sons, Inc. (ISBN 0-471-32546-5)

Ward, J. LeRoy. 2000. Project Management Terms: A Working Glossary. Arlington, Va.: ESI International. (ISBN 1-890367-25-7)

Weiss, Joseph W., and Robert K. Wysocki. 1992. 5-Phase Project Management: A Practical Planning and Implementation Guide. Reading, Mass.: Addison- Wesley. (ISBN 0-201-56316-9)

Westney, Richard E. 1992. Computerized Management of Multiple Small Projects. New York: Marcel Dekker. (ISBN 0-8247-8645-9)

Wheelwright, Steven C., and Kim B. Clark. 1992. Revolutionizing Product Development: Quantum Leaps in Speed, Efficiency, and Quality. New York: The Free Press. (ISBN 0-02-905515-6)

———. 1995. Leading Product Development: The Senior Manager’s Guide to Creating and Shaping the Enterprise. New York: The Free Press. (ISBN 0-02-934465-4)

Whitten, Neal. 1995. Managing Software Development Projects. 2d ed. New York: John Wiley & Sons. (ISBN 0-471-07683-X)

———. 2000. The EnterPrize Organization. Newtown Square, Pa.: The Project Management Institute. (ISBN 1-880410-79-6)

Wideman, R. Max. 1992. Project and Program Risk Management: A Guide to Managing Project Risks & Opportunities. Newton Square, Pa.: Project Management Institute. (ISBN 1-880410-06-0)

Wysocki, Robert K., Robert Beck, Jr, and David B. Crane. 2000. Effective Project Management. 2d ed. New York: John Wiley & Sons. (ISBN 0-471-36028-7)

Yourdon, Edward. 1999. Death March: The Complete Software Developer’s Guide to Surviving “Mission Impossible” Projects. Upper Saddle River, N.J.: Prentice Hall. (ISBN 0-13-014659-5)


Adaptive Project Framework

Because we introduced APF in this book, there really aren’t any other published references. However, here are two titles that are somewhat related.

Highsmith, James A. 2000. Adaptive Software Development: A Collaborative Approach to Managing Complex Systems. New York: Dorset House Publishing. (ISBN 0-932633-40-4)

Thomsett, Rob. 2002. Radical Project Management. Upper Saddle River, N.J.: Prentice Hall. (ISBN 0-13-009486-2)


Extreme Project Management

Extreme project management and more generally agile project management are products of the software development discipline. They remain there today. For that reason the references that follow are almost exclusively focused on software development.

Ajani, Shaun. 2002. Extreme Project Management: Unique Methodologies, Resolute Principles, Astounding Results. San Jose, Calif.: Writers Club Press. (ISBN 0-595-21335-9)

Ambler, Scott W. 2000. The Unified Process Elaboration Phase: Best Practices in Implementing the UP. Lawrence, Kans.: R&D Books. (ISBN1-929629-05-2

———. 2002. Agile Modeling: Effective Practices for Extreme Programming and the Unified Process. New York: John Wiley & Sons, Inc. (ISBN 0-471-20282-7)

Ambler, Scott W., and Larry L. Constantine. 2000. The Unified Process Inception Phase: Best Practices in Implementing the UP. Lawrence, Kans.: CMP Books. (ISBN 1-929629-10-9)

———. 2000. The Unified Process Construction Phase: Best Practices in Implementing the UP. Lawrence, Kans.: CMP Books. (ISBN 1-929629-01-X)

Beck, Kent, and Martin Fowler. 2001. Planning Extreme Programming. Reading, Mass.: Addison-Wesley. (ISBN 0-201-71091-9)

Cockburn, Alistair. 1998. Surviving Object-Oriented Projects. Boston, Mass.: Addison-Wesley. (ISBN 0-201-49834-0)

———. 2001. Writing Effective Use Cases. Boston, Mass.: Addison-Wesley. (ISBN 0-201-70225-8)

Fowler, Martin. 2000. Refactoring: Improving the Design of Existing Code. Boston: Addison-Wesley. (ISBN 0-201-48567-2)

Highsmith, James A. 2000. Adaptive Software Development: A Collaborative Approach to Managing Complex Systems. New York: Dorset House Publishing. (ISBN 0-932633-40-4)

Highsmith, Jim. 2002. Agile Software Development Ecosystems. Boston: Addison-Wesley. (ISBN 0-201-76043-6)

Jeffries, Ron, Ann Henderson, and Chet Hendrickson. 2001. Extreme Programming Installed. Boston: Addison-Wesley. (ISBN 0-201-70842-6)

Kruchten, Philippe. 2000. The Rational Unified Process: An Introduction. 2d ed. Boston, Mass.: Addison-Wesley. (ISBN 0-201-70710-1)

Newkirk, James, and Robert C. Martin. 2001. Extreme Programming in Practice. Boston: Addison-Wesley. (ISBN 0-201-70937-6)

Succi, Giancarlo, and Michele Marchesi. 2001. Extreme Programming Examined. Boston: Addison-Wesley. (ISBN 0-201-71040-4)

Wake, William C. 2002. Extreme Programming Explored. Boston: Addison- Wesley. (ISBN 0-201-73397-8)


Organizational Considerations

Block, Thomas R., and J. Davidson Frame. 1998. The Project Office. Upper Darby, Pa.: Project Management Institute. (ISBN 1-56052-443-X)

Cooper, Robert G., Scott J. Edgett, and Elko J. Kleinschmidt. 1998. Portfolio Management for New Products. Reading, Mass.: Perseus Books. (ISBN 0-201-32814-3)

Crawford, J. Kent. 2002. The Strategic Project Office: A Guide to Improving Organizational Performance. New York: Marcel Dekker, Inc. (ISBN 0-8247-0750-8)

Dinsmore, Paul C. 1999. Winning in Business with Enterprise Project Management. New York: AMACOM. (ISBN 0-8144-0420-0)

Dye, Lowell D., and James S. Pennypacker, (editors). 1999. Project Portfolio Management: Selecting and Prioritizing Projects for Competitive Advantage. West Chester, Pa.: Center for Business Practices. (ISBN 1-929576-00-5)

Graham, Robert J., and Randall L. Englund. 1997. Creating an Environment for Successful Projects. San Francisco: Jossey-Bass Publishers. (ISBN 0-7879-0359-0)

Hallows, Jolyon. 2002. The Project Management Office Toolkit: A Step-by-Step Guide to Setting Up a Project Management Office. New York: AMACOM. (ISBN0-8144-0663-7)

Kerzner, Harold. 2001. Strategic Planning for Project Management Using a Project Management Maturity Model. New York: John Wiley & Sons, Inc. (ISBN 0-471-40039-4)

Rad, Parviz F., and Ginger Levin. 2002. The Advanced Project Management Office: A Comprehensive Look at Function and Implementation. Boca Raton, Fla.: St Lucie Press. (ISBN 1-57444-340-2)


Index

Symbols and Numerics

? (question mark), portfolio management, 360
5-Phase Project Management: A Practical Planning and Implementation Guide (Robert K. Wysocki), 22, 24, 84, 209
10 Minute Guide to Project Management (Jeff Davidson), 441


Index_A

Team LiB

Index

A

ABT Workbench software package, 27
AC (actual cost), cost schedule control, 225–226
accommodators, team balance, 186–187
achievement, motivation, 172
action to be taken lists, 36
active projects. See also projects
managing, 382–389
Off Plan status, 383
On Plan status, 383
out-of-control situations, recognizing, 385–389
portfolio life cycle, 356
project manager’s roles in, 384
In Trouble status, 383–384
activities
back-end, 114
bottleneck, 137
complex, 4
connected, 5
crashpoints, 100
defined, 4, 76
dependencies, 123–125
duration of, estimating, 99–105
front-end, 114
management reserve, 137–139
sequence of activities, 4
stretching, resource leveling, 149–150
unconnected, 5
unique, 4
activity managers, 153
activity-on-the-arrow (AOA) method, network diagrams, 121
actual cost (AC), cost schedule control, 225–226
Adaptive Project Framework (APF)
core values, 276–277
overview, 267–269
proof-of-cycle concept, 330
resources for, 448
administration, contracts, 184
administrative practices, hygiene factors, 172
advancement, motivation, 172
agendas, for JPP (Joint Project Planning) sessions, 164–165
Agile Software Development Ecosystems (Jim Highsmith), 448
agreements
conversation and negotiation, 52
PDS (Project Definition Statement), 71–72, 161
aligned projects, portfolio life cycle, 355
AOA (activity-on-the-arrow) method, network diagrams, 121
APF. See Adaptive Project Framework
appendices, data support, 167
application systems, development of, 15
approval process, Project Overview Statement, 67–71
architectural design tools, 78
assessment, risks, 35, 37–38
assignment sheets, work packages, 154–155
assimilators, team balance, 186
audits, post-implementation, 27, 246–248
authority, project team members, 185
avoidance, conflict resolution, 196


Index_B

Team LiB

Index

B

back-end activities, 114
backward pass calculation, critical path, 132
balanced portfolios, 373–374
best-practices constraints, 126
Boston Consulting Group (BCG) Product Matrix model, portfolio management, 359–361
bottleneck activities, 137
bottom-up approach, Work Breakdown Structure, 81–82
brainstorming process, 198
break-even analysis, financial analysis, 65–66
budgets. See also costs
fixed, 285–286
management reserve, 138
project definition, 5–6
quality management, 29
buffers
capacity constrained, 259
cost, 259
drum, 259
feeding, 258–259
managing, 260–262
overview, 257–258
project, 258
resource, 258–259
schedules with, 259–260
Building Effective Project Teams (Robert K. Wysocki), 187, 196
business approach, WBS, 91
butcher paper, 79


Index_C

Team LiB

Index

C

canceled projects, portfolio life cycle, 356
canceling contracts, conditions of, 185
Capability Maturity Model (CMM), 415
capacity constrained buffers, 259
cash cows, portfolio management, 359
CCPM. See critical chain project management
CD components, 435–438
ceremonial acceptance, project closure, 244
challenges, motivation, 173–174
change management
documenting, 234–236
market opportunities, 10–11
project change requests, 234
project impact statements, 234
Chart of Accounts (CoA), 89
charts
flip-charts, 79
Gantt, 119–120, 218–219
milestone trend, 219, 221–222
checklists, project closure, 244
clarification, conversation and negotiation, 52
classifications, projects, 13–16
Client Checkpoint phase, project framework
inputs to, 319
overview, 273–274
questions to be answered during, 319–321
Scope Bank, 319
clients
acceptance, project closure, 244
expectations, communications management, 50
closure, project closure
checklists, 244
client acceptance, 244
contracts, 43, 185
deliverables, installing, 27, 245
documentation, 245–246
final reports, 249
formal acceptance, 244
portfolio management, 390
post-implementation audit, 27, 246–248
project management, 21–22
recognition, 249
CMM (Capability Maturity Model), 415
CoA (Chart of Accounts), 89
collaboration, conflict resolution, 197
common cause variation, 252
communications management
client expectations, 50
communication flow, choosing effective channels, 201–202
content information, 201
email, 201–202
phone use, 202
with sponsors, 204
with stakeholders, 205
timing of information, 200
upward communication filtering, 204–205
video conferences, 201
written materials, 202
competency reports, 421–422
completed projects, portfolio life cycle, 356
completion dates, project definition, 5
complex activities, project definition, 4
Computerized Management of Multiple Small Projects (Richard E. Westney), 447
Conditions of Satisfaction (COS)
business outcomes, specifying, 54
clarity of purpose, establishing, 53–54
defined, 50
developing good, 51–53, 281–283
provider-driven conversation, 282
requestor-driven conversation, 282
reviews, conducting, 54
wants versus needs, 51
conferences, video, 201
conflict resolution management
avoidance, 196
collaboration, 197
confrontation, 196–197
overview, 188
resource resolution, 256–257
team operating rules, 189
confrontation, conflict resolution, 196–197
connected activities, project definition, 5
connected networks, 123
consensus building processes
overview, 197–198
team operating rules, 189
constraints, types of, 125–128
consultation
JPP (Joint Project Planning) sessions, 162
project support, 400, 405–406
content information, communications management, 201
continuous quality management, 30–31
contracted team members, recruiting, 181–185
contracts
administration of, 184
cancellation, 185
closing, 43, 185
fixed bid, 184
managing, 42
procurement management, 42–43
retainer, 184
time and materials, 184
controlling. See monitoring
controls. See also reports; status reports
balance between, 210
high control, 209
low control, 209–210
purpose of, 208–209
quality versus, 211
risks versus, 207–208
conversation
negotiation and, 52
provider-driven, 282
requestor-driven, 282
corporate initiatives, 58
corporate level portfolio management, 364
corrective action, 214
COS. See Conditions of Satisfaction
cost performance index (CPI), 227–228, 384–385
cost variance (CV), cost schedule control, 225
costs. See also budgets
buffers, 259
estimating, 111–114
financial analysis, Project Overview Statement, 65–66
project definition, 8
reduction of, success criteria, 62
cost/schedule control (C/SC), 225, 384
Cost/Schedule Control Systems Criteria (Quentin W. Fleming), 441
CPI (cost performance index), 227–228, 384–385
crashpoints, defined, 100
Creative Problem Solving and Opportunity Finding (J. Daniel Couger), 190
criteria weighting models, portfolio management, 368–369
Critical Chain (Eliyahu Goldratt), 262, 442
critical chain project management (CCPM)
common cause variation, 252
history of, 262–263
management approach to, 255–257
overview, 251–252
special cause variation, 253
statistical validation, 253–255
Critical Chain Project Management (Lawrence P. Leach), 251, 382, 444
critical path
backward pass calculations, 132
defined, 130
EF (earliest finish) time, 131
ES (earliest start) time, 130
LF (latest finish) time, 131
LS (latest start) time, 131
near-critical path, 134–135
slack time, computing, 133–134, 147
critical success factors (CSF), 30
C/SC (cost/schedule control), 384
cultural factors, risk assumption, 64
cumulative reports, 212
current period reports, 211–212
customer-based strategies, problem management, 238
CV (cost variance), cost schedule control, 225
Cycle Build phase, project framework
cycle functionality, building, 310
Issues Log, 312–313
overview, 273
schedules, micro-level, creating, 306–309
Scope Back, maintaining, 311–312
status reports, 314
task sequencing, 303–304
team meetings, 313–314
work packages, writing, 309–310
Cycle Plan phase, project framework
overview, 272–273
resource requirements, estimating, 302–303
task duration estimation, 301


Index_D

Team LiB

Index

D

data support, appendices, 167
date constraints, 128–129
deadlines, project definition, 8
Death March: The Complete Software Developer’s Guide to Surviving “Mission Impossible” Projects (Edward Yourdon), 447
Debugging the Development Process (Steve Maguire), 444
decision making processes, 189, 192–196
decomposition, defined, 77
defining phase, project management, 18–19
deliverables
documentation, 245
JPP (Joint Project Planning) sessions, 165–166
project closure, 27, 245
Delphi technique, duration method, 103
departmental approach, WBS, 91
dependencies
defined, 123
FF (finish-to-finish), 125
FS (finish-to-start), 124
SF (start-to-finish), 124–125
SS (start-to-start), 124
version functionality, prioritizing, 288
deployment strategies, developing, 187–188
description reports, work packages, 155–157
design-build-test-implement verb-type approach, WBS, 90
Designing Web Usability (Jakob Nielson), 445
diagrams. See network diagrams
discretionary constraints, 126
documentation
change management, 234–236
deliverables, 245
project closure, 245–246
system, 85
dogs, portfolio management, 359
drum buffers, 259
DSDM: Dynamic Systems Development Method (Jennifer Stapleton), 446
duration
activity duration, 99–105
Delphi technique, 103
optimistic estimates, 105
overview, 97–99
pessimistic estimates, 105
as resource availability function, 109–111
of tasks, estimating, 301
version functionality, prioritizing, 288
work effort versus, 97–99
dynamic project plans, 19
The Dynamics of Conflict Resolution: A Practitioner’s Guide (Bernard S. Mayer), 197


Index_E

Team LiB

Index

E

earliest finish (EF) time, 131
earliest start (ES) time, 130
earned value (EV), cost schedule control, 225–226
efficiency, planning improvements, 20
effort creep, defined, 11
email, communications management, 201–202
enhancement projects, Project Distribution Matrix model, 362
Enterprise PSO (EPSO), 410–411
environmental factors, risk assumption, 64
equipment, JPP (Joint Project Planning) sessions, 164
ES (earliest start) time, 130
escalation strategies, problem management, 238
Essentials of Software Project Management (Richard Bechtold), 440
establish phase, portfolio management, 354
estimations
activity duration, 99–105
costs, 111–114
duration, 97–99
EV (earned value), cost schedule control, 225–226
Evaluating Training Programs, Second Edition (Donald L. Kirkpatrick), 413
evaluation
decision making processes, 194
portfolio management, 354
exception reports, 212
execution phase, project management, 20–21
explicit business outcomes. See success criteria
Extreme Programming Explored (William Wake), 449
Extreme Project Management: Unique Methodologies, Resolute Principles, Astounding Results (Shaun Ajani), 448
extreme project management (xPM)
defined, 332
go/no go decision, 341–342
Incubate phase, 342–344
Initiate phase, 334–338
overview, 331, 333
POS (Project Overview Statement), 335–336
project approach comparisons, 346–347
resources, 448–449
Review phase, 344–345
Speculate phase, 339–342


Index_F

Team LiB

Index

F

face-to-face meetings, 201
facilitators, JPP (Joint Project Planning) sessions, 161–162
facilities, as resource requirement, 106, 302
feasibility studies, financial analysis, 65–66
The Fast Forward MBA in Project Management (Eric Verzuh), 447
feature creep, defined, 12
feedback, motivation, 175
feedback loops, continuous quality management, 30
feeding buffers, 258–259
final reports, project closure, 249
financial analysis, 65–66
finish-to-finish (FF) dependency, 125
finish-to-start (FS) dependency, 124
5-Phase Project Management: A Practical Planning and Implementation Guide (Robert K. Wysocki), 22, 24, 84, 209
fixed bid contracts, 184
fixed budgets, 285–286
flip-charts, 79
forced ranking
defined, 288–289
portfolio management, 366–367, 376–377
formal acceptance, project closure, 244
free slack time, computing, 133
freeware programs, 437
front-end activities, 114
FS (finish-to-start) dependency, 124
functional level portfolio management, 364
functional managers, project managers versus, 170–171
functional specification, defined, 7
functional support, 410
futures-oriented information, updating, 215


Index_G

Team LiB

Index

G

Gantt charts, 119–120, 218–219
gap analysis, 30
geographic approach, WBS, 91
goals
establishing, 59–60
need for, 5
portfolio management, 358
go/no go decision, extreme project management, 341–342
Graham-Englund Selection model, portfolio management, 377–379
growth projects, portfolio management, 363
A Guide to the CMM: Understanding the Capability Maturity Model for Software (Kenneth M. Dymond), 441


Index_H

Team LiB

Index

H

A Hacker’s Guide to Project Management (Andrew K. Johnston), 443
The Handbook of Industrial and Organizational Psychology (Kenneth Thomas), 197
hardware installation project type, 15
Harvard Business Review (Henry Markowitz), 354
high change projects, 332
high speed projects, 332
high uncertainty projects, 332
hiring, project type classification, 15
historical data, activity duration method, 103–104
hope creep, defined, 11
How to Plan Any Project: A Guide for Teams (Thomas C. Belanger), 440
human resource services, support, 408–409
hygiene factors, 172


Index_I

Team LiB

Index

I

ideas, Project Definition Statement, 71
identification, risk management, 34
implementation
network diagrams, 120
PSO (Project Support Office), 427–429
Implementing Concurrent Project Management (Quentin C. Turtle), 447
In Search of Excellence in Project Management (Harold, Kerzner), 443
In Trouble status, active projects, 383–384
increased revenue, success criteria, 61
Incubate phase, extreme project management, 342–344
infrastructure projects, 363
inherited projects, 55
Initiate phase, extreme project management, 334–338
Initiate, Speculate, Incubate, Review (INSPIRE), 333
initiatives
corporate, 58
unsolicited, 55–56
interpersonal factors
hygiene, 172
risk assumption, 64
interproject constraints, 128
investment categories, portfolio management, 363
Issues Log, maintaining, 312–313


Index_J

Team LiB

Index

J

job security, hygiene factors, 172
Joint Project Planning (JPP) sessions, 67, 161–167
The Juggler’s Guide to Managing Multiple Projects (Michael S. Dobson), 441


Index_L

Team LiB

Index

L

lag variables, 129
large projects, Work Breakdown Structure for, 83–84
latest finish (LF) time, 131
latest start (LS) time, 131
Learning Styles Inventory (LSI), 186–187
leveling resources, 144–151
LF (latest finish) time, 131
listening skills, developing good, 51
lists, action to be taken, 36
The Little Black Book of Project Management (Michael C. Thomsett), 447
logical constraints, 126–127
LS (latest start) time, 131
LSI (Learning Styles Inventory), 186–187


Index_M

Team LiB

Index

M

maintenance projects, Project Distribution Matrix model, 362
Making Software Measurement Work (Bill Hetzel), 442
management constraints, 127
Management of Project Procurement (Charles L. Huston), 443
management reserve activities, 137–139
management reserve budgets, 138
Managing Performance Improvement Projects: Preparing, Planning, Implementing (Jim Fuller), 442
Managing Projects for Value (John C. Goodpasture), 442
Managing Software Development Projects (Neal Whitten), 447
Managing Technical People (Watts S. Humphrey), 443
Managing the Project Team: The Human Aspects of Project Management (Vijay K. Verma), 189
Managing Your Documentation Projects (JoAnn T. Hackos), 442
market opportunities, change management, 10–11
masked behavior, defined, 188
materials
as resource requirement, 107, 302
time contracts and, 184
meetings
Cycle Build phase, APF, 313–314
face-to-face, 201
sidebar, 232
status, 231–233
team meetings, reasons for, 199
mentoring, project support, 400, 405–406
methods, Project Support Office, 406–407
micro-level planning, 151–152
micro-level schedules, 306–309
Microsoft Project 2002 software package, 27
milestones
reviewal process, 54
trend charts, 219, 221–222
The Mind Map Book (Tony Buzan), 82
Mindmapping (Joyce Wycoff), 82
mission statements, 358, 403
mistakes, activity duration variation, 102
money, as resource requirement, 107, 302
monitoring
progress, 28
risk assessment, 36–37
motivation techniques, 172–175


Index_N

Team LiB

Index

N

near-critical path, 134–135
needs versus wants, Conditions of Satisfaction, 51
negative variance reports, 217–218
negotiation and conversation, 52
network diagrams
AOA (activity-on-the-arrow) method, 121
defined, 118–119
implementation, 120
network-based scheduling, 119–120
PDM (precedence diagramming method), 121–122
planning, 120
schedules, creating, 129–135
unit of analysis in, 122
network-based scheduling, 119–120
networks, connected, 123
The New Project Management (J. Davidson, Frame), 441
new projects, Project Distribution Matrix model, 362
notebooks, project notebooks, 21
noun-type approaches, Work Breakdown Structure, 89–90


Index_O

Team LiB

Index

O

objectives
portfolio management, 358–359
POS (Project Overview Statement), 60–61
obstacles, listing, 63–64
Off Plan status, active projects, 383
On Plan status, active reports, 383
On Time, Within Budget: Software Project Management Practices and Techniques (E. M. Bennatan), 440
Open Plan software package, 27
operation rules, situations requiring, 189
operational projects, Project Distribution Matrix model, 362
optimistic estimates, activity duration, 105
organizational approaches
project management, 28
Project Support Office, 409–411
Work Breakdown Structure, 91
Organizational Behavior in Action: Skill Building Experiences (William C. Morris), 194
Organizing Projects for Success (Vijay K. Verma), 447
outcomes, specification, 54


Index_P

Team LiB

Index

P

pain curve, project management, 44–47
Paired Comparisons model, portfolio management, 369–371
PDM (precedence diagramming method), network diagrams, 121–122
PDS (Project Definition Statement), 71–72, 161
people, as resource requirements, 106, 302
permanent support, 410
pessimistic estimates, activity duration, 105
phone use, communications management, 202
planned value (PV), cost schedule control, 225–226
planning
efficiency, improving, 20
JPP (Joint Project Planning) sessions, 67, 160–161
micro-level, 151–152
network diagrams, 120
procurement management, 39–40
project management, 19–20, 28
project proposal, 26–27
resources, as cost estimation, 111
risk management, 35–36
team development, 27–28, 188
tools for, 78
uncertainty, overcoming, 20
PMBOK (Project Management Body of Knowledge), 22
PMCA (Project Manager Competency Assessment), 421–422
PMMM (Project Management Maturity Model), 415
PMs. See project managers
point estimates, defined, 254
policies, hygiene factors, 172
portfolio management
balanced portfolios, 373–374
BCG (Boston Consulting Group) Product Matrix model, 359–361
corporate level, 364
criteria weighting models, 368–369
dogs, 359
establish phase, 354
evaluation, 354
forced ranking, 366–367, 376–377
functional level, 364
goals, 358
Graham-Englund Selection model, 377–379
growth projects, 363
investment categories, 363
management concepts, 352–354
objectives, 358–359
overview, 352
Paired Comparisons model, 369–371
project closure, 390
Project Distribution Matrix model, 361–362, 376–377
project life cycle, 355–356
project submission, 391–395
Q-Sort, 290, 367
Risk/Benefit Matrix model, 371–372, 377–378
Strategic Alignment model, 357–359, 374–375
survival projects, 363
POS. See Project Overview Statement
positive variance reports, 217
post-implementation audits, 27, 246–248
Post-It notes, 79, 140, 164
postponed projects, portfolio life cycle, 356
Post-Version Review phase, project framework, 274–275, 325–327
power failures, unique activities and, 4
Practical Project Management (Anton K. Dekom), 441
Practical Risk Assessment for Project Management (Stephen Grey), 442
Practical Software Metrics for Project Management and Process Improvement (Robert B. Grady), 442
precedence diagramming method (PDM), network diagrams, 121–122
prioritized projects, portfolio life cycle, 356
proactive support, 410
problem management
customer-based strategies, 238
escalation of, managing, 237–240
POS (Project Overview Statement), 58–59, 392
project manager-based strategies, 238
resource manager-based strategies, 238
team operating rules, situations requiring, 189
team organization, 190–192
procedures, updating, 15
Process Mapping: How to Register Reengineer Your Business Processes (V. Daniel Hunt), 443
process owners, JPP (Joint Project Planning) sessions, 162
process quality management, 8, 30, 32–33
procurement management
contract management, 42–43
overview, 38
planning phase, 39–40
RFPs (Requests for Proposals), 40–41, 183
vendor selection, 41–42
products
development, project management, 44
quality, 8
Program Offices, Project Support Office, 400
programs, defined, 6
progression, monitoring, 28
Project and Program Risk Management: A Guide to Managing Project Risks & Opportunities (R. Max Wideman), 447
project change requests, change management, 234
project definition, 3–6, 9–12
Project Definition Statement (PDS), 71–72, 161
Project Distribution Matrix model, portfolio management, 361–362, 376–377
Project Estimating and Cost Management (Parviz F. Rad), 446
project impact statements, change management, 234
project management
closing phase, 21–22
defining phase, 18–19
execution phase, 20–21
levels of, 28–29
methodology comparisons, 43–44
organizational approaches, 28
pain curve, 44–47
phases of, 23–28
planning phase, 19–20
PMBOK (Project Management Body of Knowledge), 22
procurement management, 38–43
product development, 44
project approval process, 69
quality management, 29–33
resources for, 439–447
risk management, 33–38
scheduling processes, 21
system development and, 45
Project Management: A Systems Approach to Planning, Scheduling and Controlling (Harold Kerzner), 176
Project Management Body of Knowledge (PMBOK), 22
Project Management Handbook (Jeffrey K. Pinto), 445
Project Management Handbook of Checklists (Mark J. Hiltz), 443
Project Management Made Simple (David King), 443
Project Management Maturity Model (PMMM), 415
Project Management Terms: A Working Glossary (J. Leroy Ward), 447
Project Manager Competency Assessment (PMCA), 421–422
project manager-based strategies, problem management, 238
project managers (PMs)
approval processes, 69
authority and responsibilities of, 185
functional managers versus, 170–171
JPP (Joint Project Planning) sessions, 162
recruiting, 175–178
resource utilization and work schedule control, 11
roles of, 384
Project Measurement (Steve Neuendorf), 445
project notebooks, 21
Project Overview Statement (POS)
approval process, 67–71
attachments to, 64–66
example of, 57
financial analysis, 65–66
goals, establishing, 59–60
objectives statement, 60–61
overview, 25–26
problems/opportunities, stating, 58–59, 392
purpose of, 55–56
risks, listing, 63–64
success criteria, identifying, 61–63
writing, 283–285
xPM (extreme project management), 335–336
Project Planning and Scheduling (Gregory T. Haugan), 442
Project Planning, Scheduling & Control (James P. Lewis), 444
Project Selection and Economic Appraisal (William E. Souder), 290
Project Support Office (PSO)
alternate names for, 401–402
consultation, 400, 405–406
defined, 399
ESPO (Enterprise PSO), 410–411
growth stages, 415–417
history of, 398–399
human resource services, 408–409
implementation challenges, 427–429
mentoring, 400, 405–406
methods and standards, 406–407
mission statements, establishing, 403
need for, 412–414
organizational approaches to, 409–412
permanent structures, 400
proactive versus reactive support, 410
Program Offices, 400
program versus projects, 410
service portfolios, 400–401
software tools, 400, 407
task force, forming, 420
temporary structures, 400
training, 400, 407–408
virtual versus real support, 409–410
A Project-by-Project Approach to Quality (Richard Capper), 440
projects. See also active projects
buffers, 258–259
classifications of, 13–16
constraints, 7–9
defined, 3
high change, 332
high speed, 332
high uncertainty, 332
infrastructure, 363
inherited, 55
large, Work Breakdown Structure for, 83–84
maintenance, 362
as motivation and development tools, 171–175
new, 362
operational, 362
portfolio life cycle, 355–356
postponed, 356
prioritized, 356
Project Distribution Matrix model, 361–362
repeats of, 15
selected, 356
subprojects, 5
survival, 363
time-to-market, 148
Type A, 13
Type B, 13
Type C, 14
Type D, 14
proof-of-concept cycle, APF, 330
provider-driven conversation, 282
PSO. See Project Support Office
PV (planned value), cost schedule control, 225–226


Index_Q

Team LiB

Index

Q

Q-Sort prioritization, 290, 367
quality management
budgets, maintaining, 29
continuous, 30–31
controls versus, 211
gap analysis, 30
overview, 29
process, 8, 30, 32–33
product, 8
Quality Management for Projects and Programs (Lewis R. Ireland), 443
quantifiable statements, 62
question mark (?), portfolio management, 360


Index_R

Team LiB

Index

R

Radical Project Management (Rob Thomsett), 292, 448
range estimates, defined, 254
Rapid Development (Steve McConnell), 445
The Rational Unified Process: An Introduction (Philippe Krutchen), 449
reactive support, 410
real versus virtual support, 409–410
recognition
as motivation, 172, 174
for project closure, 249
success criteria, 245
recruiting
contracted team members, 181–185
core team members, 178–181
project managers, 175–178
project type classification, 15
reduction of costs, success criteria, 62
Refactoring: Improving the Design of Existing Code (Martin Fowler), 448
reports. See also controls; status reports
competency, 421–422
cost schedule control, 222–228
cumulative, 212
current period, 211–212
description, work packages, 155–157
detail levels of, 229–230
exception, 212
Gantt charts, 119–120, 218–219
how and what to report, 215–216
milestone trend charts, 219, 221–222
negative variance, 217–218
positive variance, 217
project closure, 249
Standish Group, 412–413
stoplight, 212–213
variance, 213–214, 217–218
Request for Information (RFI), 183
Request for Proposals (RFPs), 40–41, 183
Request for Quote (RFQ), 183
request stage, conversation and negotiation, 52
requestor-driven conversation, 282
requirements gathering, defined, 40
Resource Breakdown Structure, 108–109
resource manager-based strategies, problem management, 238
resources
AFP (Adaptive Project Framework), 448
buffers, 258–259
conflict resolution management, 256–257
defined, 9
leveling, 144–151
limits, project definition, 5–6
planning, as cost estimation, 111
requirements, estimating, 106–111, 302–303
Resource Breakdown Structure, 108–109
shortage of, 181
traditional project management, 439–447
xPM (extreme project management), 448–449
responses, conversation and negotiation, 52
responsibility, as motivation, 172
retainer contracts, 184
revenue, success criteria, 61
Review phase, extreme project management, 344–345
reviews, project milestones, 54
RFI (Request for Information), 183
RFPs (Requests for Proposals), 40–41, 183
RFQ (Request for Quote), 183
Risk Analysis in Project Management (John Raferty), 446
risk management
analysis and management process, 33, 65
assessment, 35–38
controls versus, 207–208
environmental factors, 64
identifying, 34
interpersonal factors, 64
listing, Project Overview Statement, 63–64
monitoring and control, 36–37
planned responses, 35–36
project classification, 13–15
risk analysis worksheet, 39
version functionality, prioritizing, 287–288
Risk/Benefit Matrix model, portfolio management, 371–372, 377–378


Index_S

Team LiB

Index

S

salary, hygiene factors, 172
schedule performance index (SPI), 227–228, 384–385
schedule variance (SV), cost schedule control, 225
schedules
buffers, 259–260
compressing, 135–137
micro-level, 306–309
network diagrams, 129–135
network-based, 119–120
project management, 21
variances in, 214
scope
defined, 7
functional specification, 7
project management life cycle, 24–26
statement of work, 7
Scope Bank
Client Checkpoint phase, APF, 319
Cycle Build phase, APF, 311–312
scope creep, 11, 19
scope triangle
project definition, 9–12
Version Scope phase, APF, 290–294
selected projects, portfolio life cycle, 356
senior management, project approval process, 70
sequence of activities, project definition, 4
SF (start-to-finish) dependency, 124–125
shareware programs, 437
shortage of staff, 181
sidebar meetings, 232
situation definition, decision making processes, 194
skill levels
activity duration variation, 101
resource estimation, 107–108
slack time
computing, 133–134
utilizing available, 147
S.M.A.R.T. (specific, measurable, assignable, realistic, time-related), 60
smoothing, resource leveling, 148
software
installation project type, 15
procurement management, 39–40
tools, project support, 400, 407
Software Project Management: From Concept to Deployment (Kieron Conway), 441
Software Project Management (Walker Royce), 446
special cause variation, 253
specific, measurable, assignable, realistic, time-related (S.M.A.R.T.), 60
specifications
functional, 7
outcomes, 54
project definition, 6
Speculate phase, extreme project management, 339–342
SPI (schedule performance index), 227–228, 384–385
sponsors, communications with, 204
SS (start-to-start) dependency, 124
staffing. See resources
stakeholders, communications with, 205
standards, Project Support Office, 406–407
Standish Group reports, 412–413
start-to-finish (SF) dependency, 124–125
start-to-start (SS) dependency, 124
statement of work, defined, 7
statistical validation, CCPM, 253–255
status meetings, 231–233
status reports. See also controls; reports
Cycle Build phase, APF, 314
types of, 211–214
WBS (Work Breakdown Structure), 78
stoplight reports, 212–213
Strategic Alignment model, portfolio management, 357–359, 374–375
The Strategic Project Office: A Guide to Improving Organizational Performance (J. Kent Crawford), 427, 449
strategic projects, Project Distribution Matrix model, 362
subprojects, project definition, 5
subteam approach, Work Breakdown Structure, 80–81
success criteria
celebration tips, 249
cost reduction, 62
defined, 53
identifying, 61–63
increased revenue, 61
recognition, 245
success sliders, 292–293
supervision, hygiene factors, 172
support. See Project Support Office
survival projects, portfolio management, 363
Surviving Object-Oriented Projects (Alistair Cockburn), 448
SV (schedule variance), cost schedule control, 225
system documentation, 85
system requirements, 435
systems development, project management and, 45


Index_T

Team LiB

Index

T

tactical projects, Project Distribution Matrix model, 362
tactics, portfolio management, 359
task forces, forming, 420
tasks
duration of, estimating, 301
identity of, motivation factors, 174–175
sequencing, 303–304
teams
approval processes, 69
authority and responsibilities of, 185
balancing, 186–187
communications, managing, 200–205
contracted, recruiting, 181–185
core team members, recruiting, 178–181
decision making process, 192–196
deployment strategies, developing, 187–188
learning styles, 186–187
meetings, reasons for, 199
operating rules, situations requiring, 189
planning phase, 27–28, 188
problem solving techniques, 190–192
project approval process, 69
technical constraints, 125–127
Technical Risk Management (Jack V. Michaels), 445
technical supervision, hygiene factors, 172
technographers, JPP (Joint Project Planning) sessions, 162
technological factors, risk assumption, 64
temporary support, 410
10 Minute Guide to Project Management (Jeff Davidson), 441
Theory of Constraints (TOC), 251
Third Wave Project Management (R. Thomsett), 447
thought process tools, Work Breakdown Structure, 78
three-point technique, activity duration method, 103
time and materials contracts, 184
timebox, defined, 285–286
time-to-market projects, 148
TOC (Theory of Constraints), 251
top-down approach, Work Breakdown Structure, 79–80
total slack time, computing, 134
traditional project management. See project management
training
documentation, 245
project support, 400, 407–408
troubleshooting CD installation, 438
Type A projects, 13
Type B projects, 13
Type C projects, 14
Type D projects, 14


Index_U

Team LiB

Index

U

uncertainty, project planning, 20
unconnected activities, 5
The Unified Process Elaboration Phase: Best Practices in Implementing the UP (Scott W. Ambler), 448
unique activities, project definition, 4
unit of analysis, network diagrams, 122
unsolicited initiatives, 55–56
upward communication filtering, 204–205


Index_V

Team LiB

Index

V

value statements, 358
variance reports, 213–214, 217–218
vendors, selecting good, 41–42
verb-type approaches, Work Breakdown Structure, 90
Version Scope phase, project framework
components of, 279–280
COS (Conditions of Satisfaction), developing, 281–283
forced ranking, 288–289
overview, 269–272
POS (Project Overview Statement), writing, 283–285
Q-Sort, 290, 367
scope triangle, 290–294
version functionality, prioritizing, 287–288
video conferences, communications management, 201
virtual versus real support, 409–410
Visual Project Planning & Scheduling (Dennis Miller), 445


Index_W

Team LiB

Index

W

wants versus needs, Conditions of Satisfaction, 51
waterfall systems development methodology, WBS, 95
WBS. See Work Breakdown Structure
Web Project Management: Delivering Successful Commercial Web Sites (Ashley Friedlein), 442
whiteboard space, 79, 140
Winning in Business with Enterprise Project Management (Paul C. Dinsmore), 449
Work Breakdown Structure (WBS)
bottom-up approach, 81–82
building, approaches to, 88–91
business approach to, 91
completeness, testing criteria, 84–88
departmental approach to, 91
example of, 76, 91–95
geographic approach to, 91
hierarchical visualization, 76
for large projects, 83–84
low-level, 299–300
mid-level, 286–287
noun-type approaches, 89–90
organizational approaches to, 91
overview, 75–77
reporting with, 228–229
representation of, 91–95
for small projects, 82–83
subteam approach, 80–81
system documentation, 85
team approach, 80
top-down approach, 79–80
uses for, 78–79
verb-type approaches, 90
waterfall systems development methodology of, 95
work effort versus duration, 97–99
work packages
assignment sheets, 154–155
defined, 77
description reports, 155–157
managers for, 153
purpose of, 153–154
writing, 309–310
working conditions, hygiene factors, 172
The World’s Greatest Project: One Project Team on the Path to Quality (Russell W. Darnell), 441
written materials, communications management, 202


Index_X

Team LiB

Index

X

xPM. See extreme project management


List of Figures

Introduction to Effective Project Management

Figure I.1: Approaches to managing a project.
Figure I.2: Plan-to-goal comparison.

Chapter 1: What Is a Project?

Figure 1.1: The scope triangle.
Figure 1.2: The use of required and optional parts of the methodology by type of project.

Chapter 2: What Is Traditional Project Management?

Figure 2.1: The TPM life cycle.
Figure 2.2: Continuous Quality Management Model.
Figure 2.3: The process quality management matrix.
Figure 2.4: Candidate list of risk drivers.
Figure 2.5: Risk analysis worksheet.
Figure 2.6: Traditional project management and systems development.
Figure 2.7: Product development life cycle and TPM.
Figure 2.8: The project management life cycle pain curve.

Chapter 3: Scoping the Project

Figure 3.1: Establishing the Conditions of Satisfaction.
Figure 3.2: An example POS.

Chapter 4: Identifying Project Activities

Figure 4.1: Hierarchical visualization of the Work Breakdown Structure.
Figure 4.2: A typical mindmap generated by MindManager.
Figure 4.3: WBS for a house.
Figure 4.4: Indented outline WBS for a house.
Figure 4.5: WBS for a waterfall systems development methodology.

Chapter 5: Estimating Duration, Resource Requirements, and Cost

Figure 5.1: Elapsed time versus work time.
Figure 5.2: The Delphi technique.
Figure 5.3: The three-point method.
Figure 5.4: Assigning staff to activities.
Figure 5.5: An example of a Resource Breakdown Structure.

Chapter 6: Constructing and Analyzing the Project Network Diagram

Figure 6.1: The activity-on-the-arrow method.
Figure 6.2: PDM format of a project network diagram.
Figure 6.3: Activity node.
Figure 6.4: Diagramming conventions.
Figure 6.5: Dependency relationships.
Figure 6.6: Forward pass calculations.
Figure 6.7: Backward pass calculations.
Figure 6.8: Critical path.
Figure 6.9: ES to LF window of an activity.
Figure 6.10: Schedule compression iterations.

Chapter 7: Finalizing the Schedule and Cost Based on Resource Availability

Figure 7.1: The resource scheduling problem.
Figure 7.2: An example of a task dependency diagram and time-scaled resource schedule.
Figure 7.3: Work package assignment sheet.
Figure 7.4: Work package description report.

Chapter 9: Recruiting, Organizing, and Managing the Project Team

Figure 9.1: Couger’s Creative Problem Solving (CPS) Model.

Chapter 10: Monitoring and Controlling Progress

Figure 10.1: The total cost of control and risk.
Figure 10.2: Gantt chart project status report.
Figure 10.3: A run up or down of four or more successive data points.
Figure 10.4: A change of more than three standard deviations.
Figure 10.5: Seven or more successive data points above or below the planned milestone date.
Figure 10.6: Two successive data points outside three standard deviations from the planned milestone date.
Figure 10.7: The standard S curve.
Figure 10.8: Baseline versus actual cost curve illustrating cost variance.
Figure 10.9: Baseline versus actual cost illustrating schedule variance.
Figure 10.10: Cost/performance indicators.
Figure 10.11: The full story.
Figure 10.12: PV, EV, and AC curves.
Figure 10.13: Status reporting with the WBS.
Figure 10.14: A typical change control process.
Figure 10.15: Change control form.

Chapter 12: Critical Chain Project Management

Figure 12.1: Using contingency can reduce project time.
Figure 12.2: The early schedule.
Figure 12.3: The late schedule with resource assignments.
Figure 12.4: One way to resolve the resource conflict.
Figure 12.5: Another way to resolve the resource conflict.
Figure 12.6: Project schedule with buffers added.
Figure 12.7: Buffer penetration and action decisions.

Chapter 13: Introduction to the Adaptive Project Framework

Figure 13.1: The Adaptive Project Framework.

Chapter 14: Version Scope

Figure 14.1: Version Scope phase.
Figure 14.2: Establishing Conditions of Satisfaction.
Figure 14.3: An example of the Q-Sort.
Figure 14.4: The scope triangle.
Figure 14.5: Success sliders for the scope triangle.

Chapter 15: Cycle Plan

Figure 15.1: Cycle Plan phase.
Figure 15.2: Mid-level WBS.

Chapter 16: Cycle Build

Figure 16.1: Cycle Build phase.
Figure 16.2: An example micro-level schedule.

Chapter 17: Client Checkpoint

Figure 17.1: Client Checkpoint phase.

Chapter 18: Post-Version Review

Figure 18.1: Post-Version Review phase.

Chapter 19: Variations to APF

Figure 19.1: Extreme project management.
Figure 19.2: POS for the project to find a cure for the common cold.
Figure 19.3: Comparison of the three approaches.

Chapter 20: Project Portfolio Management

Figure 20.1: Portfolio project life cycle.
Figure 20.2: Strategic Alignment Model.
Figure 20.3: BCG Products/Services Matrix.
Figure 20.4: Project Distribution Matrix.
Figure 20.5: An example of the Q-Sort.
Figure 20.6: Criteria weighting.
Figure 20.7: An example of a paired comparisons.
Figure 20.8: Risk/Benefit Matrix.
Figure 20.9: Achieving balance with the Strategic Alignment Model.
Figure 20.10: Project Distribution Matrix with budget and funding requests.
Figure 20.11: Project Distribution Matrix with adjusted budget and funding requests.
Figure 20.12: Project Distribution Matrix with budget balances and funding decisions.
Figure 20.13: An adaptation of the Graham-Englund Selection Model.
Figure 20.14: Project staffing requirements.
Figure 20.15: Projects prioritized using the Risk/Benefit Matrix.
Figure 20.16: Example SPI and CPI trend chart.
Figure 20.17: A run up or down of four or more successive SPI or CPI values.
Figure 20.18: Seven or more successive SPI or CPI values above or below 1.
Figure 20.19: SPI and CPI trending in the same direction.
Figure 20.20: SPI and CPI trending in the same direction.
Figure 20.21: SPI values for a hypothetical portfolio.

Chapter 21: Project Support Office

Figure 21.1: Organizational placement of the PSO.
Figure 21.2: Project management maturity levels.
Figure 21.3: A plan to establish a PSO.
Figure 21.4: An example Project Overview Statement for a PSO implementation project.
Figure 21.5: Maturity level data for nine knowledge areas of PMBOK.
Figure 21.6: An example project manager competency assessment.
Figure 21.7: Continuous quality improvement of scope management.
Figure 21.8: How to move to the next maturity level.
Figure 21.9: PSO plan overview.


List of Tables

Chapter 1: What Is a Project?

Table 1.1: Example Project Classes and Definitions

Chapter 2: What Is Traditional Project Management?

Table 2.1: Risk Log Example

Chapter 9: Recruiting, Organizing, and Managing the Project Team

Table 9.1: The Six Phases of the Decision-Making Process

Chapter 14: Version Scope

Table 14.1: Force Ranking of 10 Pieces of Functionality

Chapter 20: Project Portfolio Management

Table 20.1: Forced Ranking of 10 Projects

Chapter 21: Project Support Office

Table 21.1: Example PSO Mission, Functions, and Organization


List of Sidebars

Chapter 1: What Is a Project?

Chapter Learning Objectives

Chapter 2: What Is Traditional Project Management?

Chapter Learning Objectives
Case Study

Chapter 3: Scoping the Project

Chapter Learning Objectives
Case Study

Chapter 4: Identifying Project Activities

Chapter Learning Objectives
Case Study

Chapter 5: Estimating Duration, Resource Requirements, and Cost

Chapter Learning Objectives
What If the Specific Resource Is Known?
Case Study

Chapter 6: Constructing and Analyzing the Project Network Diagram

Chapter Learning Objectives
Case Study

Chapter 7: Finalizing the Schedule and Cost Based on Resource Availability

Chapter Learning Objectives
Case Study

Chapter 8: Organizing and Conducting the Joint Project Planning Session

Chapter Learning Objectives
Case Study

Chapter 9: Recruiting, Organizing, and Managing the Project Team

Chapter Learning Objectives
Case Study

Chapter 10: Monitoring and Controlling Progress

Chapter Learning Objectives
Cost/Schedule Control Terminology
Case Study

Chapter 11: Closing Out the Projects

Chapter Learning Objectives
Case Study

Chapter 12: Critical Chain Project Management

Chapter Learning Objectives

Chapter 13: Introduction to the Adaptive Project Framework

Chapter Learning Objectives

Chapter 14: Version Scope

Chapter Learning Objectives

Chapter 15: Cycle Plan

Chapter Learning Objectives

Chapter 16: Cycle Build

Chapter Learning Objectives

Chapter 17: Client Checkpoint

Chapter Learning Objectives

Chapter 18: Post-Version Review

Chapter Learning Objectives

Chapter 19: Variations to APF

Chapter Learning Objectives

Chapter 20: Project Portfolio Management

Chapter Learning Objectives

Chapter 21: Project Support Office

Chapter Learning Objectives

Team LiB
Previous Section